•   
  • 1
  • 66
  • 67
  • 68(current)
  • 69
  • 70
  • 111
  •   
OpenELEC Testbuilds for RaspberryPi (Kodi 15.0) Part 1
(2015-03-10, 06:59)allan87 Wrote: This TV28.db-journal is not restricted to these builds or to the Pi. I saw it on last nights OS X build as well. That build, by the way, is also missing several PVR add ons, so that also, is a general issue.

If you've still got your TV27* db files, you should attach them to PR6621 for further investigation.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
I got stuck on the isengard screen with #307 but was able to access the Pi v2 over SMB nonetheless, so copied the #308b tar to the Update folder. I tried twice but both times it gave an error about either SYSTEM or KERNEL md5 being missing/wrong so wouldn't update.

So I copied the files manually after putting the uSD in my PC but I'm still stuck on the bootscreen with #308b installed.

My TV26, TV27 and TV28.db files are all 36KB and TV28.db-journal is 17KB.

Here's my debug Kodi.log: http://pastebin.com/acTrp5xj
Another stuck TV27 to TV28 upgrade - please upload your TV27 details to PR6621 (ie. upload the TV27 database(s) to dropbox etc., add the download link to PR6621).
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2015-03-10, 08:43)Milhouse Wrote: Another stuck TV27 to TV28 upgrade - please upload your TV27 details to PR6621 (ie. upload the TV27 database(s) to dropbox etc., add the download link to PR6621).

Done, thanks.
@doveman2: thanks, although unfortunately your "debug" log doesn't actually have debug enabled. You can enable debug while booting an earlier build (#0304) then upgrading to #0309, or add <loglevel>2</loglevel> to advancedsettings.xml then try booting #0309 again (remove any TV28.db* files first).
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2015-03-10, 02:58)rbmaster Wrote: Edit 2: So basically deleting the previous TV database files makes it work again, but it still sometimes auto reboots while scanning for IPTV channels (building the TV28.db file maybe?). Maybe this is related to the IPTV PVR addon, but I'm reporting it to you anyway because it may not be an addon issue too.

debug log and kodi_crashlog required (uploaded to pastebin, of course Wink).
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2015-03-10, 09:10)Milhouse Wrote: @doveman2: thanks, although unfortunately your "debug" log doesn't actually have debug enabled. You can enable debug while booting an earlier build (#0304) then upgrading to #0309, or add <loglevel>2</loglevel> to advancedsettings.xml then try booting #0309 again (remove any TV28.db* files first).

Oops! There I was thinking I was so clever that I edited guisettings.xml to <extralogging default="true">true</extralogging> Smile

EDIT: Right, got it this time! I've updated the link in my github post: http://pastebin.com/VWpLMdaB
(2015-03-10, 07:13)Milhouse Wrote:
(2015-03-10, 00:35)afremont Wrote: Currently, nothing seems to be happening at all when I try to select a recording. I don't think Kodi is even attempting to connect to the windos machine this time around.

Did you enable debug logging?

(2015-03-10, 00:35)afremont Wrote: I can't check anything right now because I switched back to 5.0.5 Official for the evening. My wife lets me get away with testing some stuff "in production so to speak", but not being able to play recordings is a deal breaker for her. I only have one Pi 2 so I'll have to wait until bed time to switch back to #308b.

Appreciate the testing, but contacting the pvr.wmc addon author is going to be the most effective route to a solution.

I updated to #309 this morning, but no magic happened. Wink

I enabled logging and also enabled specific logging for samba (I think I did anyway, it's orange now), after that I rebooted.
Here is the log file:

http://sprunge.us/QKUP

At 42.154xxx seconds I pressed OK on Recordings.
The page loaded with my series listings

At 46.236xxx seconds I pressed OK on the first listed entry (series)
Nothing happens but whoosh sound

At 49.xxxxxx seconds the PVR addon is called again to refresh channels, timers and recordings (this happens every 10 seconds apparently)

From my interpretation, the PVR addon doesn't seem to receive anything when a series is selected, nor does samba spit anything out. I don't get the list of individual shows within the series which seems kind of odd.

Everything else done with the addon seems to work just like it always did. I will go ahead an post into the WMC forum to see if they know anything. Thanks again for your help, it's greatly appreciated.

BTW, I don't get any hangs when I change the workgroup from WORKGROUP to N5QMG, but even though the gui shows the change (and I rebooted as well), the samba log file still says that it is becoming the master browser for WORKGROUP. I'm not sure what to do about that.

EDIT: I learned that I needed to edit /storage/.config/samba.conf (after copying samba.conf.example to a new file named samba.conf) to make change the workgroup from WORKGROUP to MYWORKGROUPNAME. Sorry to have bothered anyone with this, I'm still trying to adjust to the system layout and methodology.
Experience: It's what you get when you were expecting something else.
I opened this thread about the issue with not being able to select/view recording with the pvr.mythtv plugin:

http://forum.kodi.tv/showthread.php?tid=220888

Looks like one of the plugin maintainers thinks this is an issue with Kodi itself. I posted in the Kodi application forum, so hopefully someone replies and the issue is resolved so that fix can be included in the RPi/RPi2 builds.
(2015-03-10, 19:28)zaphod24 Wrote: I posted in the Kodi application forum, so hopefully someone replies and the issue is resolved so that fix can be included in the RPi/RPi2 builds.

Thanks, ping me (or post here) if something turns up although I try and keep on top of the Kodi pull requests and include anything that looks interesting, useful or needs testing.

By the way, trac is here and is the current place to create a "ticket" for Kodi bugs. Have a search of it first in case a ticket for the same bug already exists.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Thanks! I didn't find anything describing my issue so I opened up ticket 15848.
New OpenELEC Isengard build #0310: RPi / RPi2
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 3.19.1 #1 Tue Mar 10 21:22:11 GMT 2015 armv6l GNU/Linux

# vcgencmd version
Mar 10 2015 15:33:55
Copyright (c) 2012 Broadcom
version 015c58030bfa095c209a59c0c19e02d6705a2c24 (clean) (release)

# lsb_release
OpenELEC (Milhouse) - Version: devel-20150310212120-#0310-gfc745b6 [Build #0310]

# vcdbg log msg 2>&1 | grep DTOK
001544.610: Kernel trailer DTOK property says yes

# Kernel device tree status: Enabled

Based on tip of OpenELEC master (fc745b66, changelog) and tip of XBMC master (6d6d797c, changelog) with the following modifications: Build Highlights:
  1. New firmware
  2. Experimental MVC 3D support - needs testing:
    popcornmix Wrote:I've added a gui option (in video/acceleration settings) "Support MVC video (full frame 3D)". For testing purposes this will default to on.
    Note: This is experimental. It will affect all H.264 video content, although should be harmless when the video is not MVC.

    Start with your 3D BluRay ISO file. Run makemkv on it and be sure to enable the "MVC-3D" stream (this is currently required as ffmpeg doesn't support MVC in ISO).

    The mkv video file needs to be marked as 3D, so either name it as 3D.SBS, or use video OSD settings to mark it as SBS (or TAB).
    Now the video file should be played in a half-SBS (or half-TAB) mode.

    If anyone has any MVC files, I'd be interested in the results of your testing.

    This is stage one. It is possible to output a full resolution frame packed 3D mode over HDMI (I have this working with command line omxplayer),
    and having this working will be the next stage. However getting the GUI to do something sensible in this mode will require more work.

    More details: PR:323
Build Details:
  1. Firmware (Mar 10):
    • Add overlays: hy28a, hy28b, mz61581, piscreen, pitft28-resistive, rpi-display, tinylcd35
    • firmware: Adding support for frame packed 3D modes
    • firmware: video codec: preparatory change to handling of userdata for CFP2
    • firmware: video codec: refactor categoriser new_picture code
    • firmware: video codec: allow MBLoop to handle both dnri slots
    • firmware: arm_loader: Add support for the HAT setgpio and gpio_drive directives
    • firmware: dispmanx/hvs: Clear EOF callback state when the display is destroyed
  2. XBMC:
    • [gui] fix for textbox vertical centering (PR:6632, 1 commit, 1 file changed)
    • Add short/long date formats, time formats, temperature and speed unit settings (PR:6629, 9 commits, 33 files changed)
    • [win32file] use LastWriteTime instead of ChangeTime (fixes #15590) (PR:6670, 1 commit, 1 file changed)
    • [fonts] ability to capitalize the first letter of each word (PR:6599, 1 commit, 6 files changed)
    • keyboard layout improvements (PR:6655, 4 commits, 32 files changed)
    • Cleanup context menus in addon window (PR:6602, 1 commit, 5 files changed)
    • [reorder] initialize members in the order they were declared (PR:6674, 3 commits, 3 files changed)
    • [gui] Fix/cleanup osd dialogs to close PVR related if media is stopped (PR:6546, 3 commits, 3 files changed)
    • Disable desktop compositing for KDE, when Kodi is in full-screen mode (PR:6672, 1 commit, 1 file changed)
    • [Fix][LangCodes] Fixes subs service can't write correct language suffix in subtitle filename (PR:6677, 2 commits, 1 file changed)
    • [droid/depends] - bump default API version to 17 (was missed during sdk bump) (c667724c)
    • [cosmetic] rebrand pydocs template (9eba3a94)
  3. libcec:
    • Fix compilation on Raspberry Pi (PR:57, 2 commits, 1 file changed)
  4. pvr.filmon:
    • fix build for Win32 (PR:5, 1 commit, 2 files changed)
  5. pvr.mediaportal.tvserver:
    • Addon update to v1.10.3 (PR:2, 6 commits, 43 files changed)
  6. newclock4:
    • New commits in this build:
      • [players] Add settings option to enable MVC support (21d5a029)
    • Commits no longer in build:
      • Revert "rbp: Use new dispmanx function for vsync callbacks" (10516aa9)
      • changed: don't show a kaitoast when the configuration has been updated by libCEC (48e92d5a)
      • changed: ask if the user wants to disable libCEC if no TV couldn't be found for 30 seconds (dee9d7be)
      • Fixed remote initialization (bc39cab4)
      • Fixed disconnect (46938c18)
      • Changed sleep call to AbortableWait (7fa4885c)
      • squash: ffmpeg hevc remove upstreamed patches (77e808a1)
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
I've noticed something odd today. (using RPi1 B+)

Using #0309, i cannot select subtitle add-ons from the system-settings-video-subtitles section.
When i try to add them using system-settings-add-ons, they will install, but cannot be selected in system-settings-video-subtitles.
Reverting to #0304 resolved all problems.

Also, i still cannot use the VU+/Enigma2 PVR add-on, the add-on will not start, because of dll errors.
Note that with the next build, PR6306 will no longer be reverted as subsequent commits (ie. PR6675) have made this impossible/impractical in which case some PVRs will most likely be broken again (ie. crashing). This issue is awaiting a fix - please contact the addons maintainer for further details.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2015-03-11, 00:46)FabianE Wrote: Using #0309, i cannot select subtitle add-ons from the system-settings-video-subtitles section.
When i try to add them using system-settings-add-ons, they will install, but cannot be selected in system-settings-video-subtitles.
Reverting to #0304 resolved all problems.

Seems to be working for me (#0310).

I installed the Subscene.com subtitle addon, and could then select this addon in System->Settings->Video->Subtitles for Movies.

I also added OpenSubtitles.org as a second subtitle addon, and could select either subtitle addon in System->Settings->Video->Subtitles for Movies.

I would suggest trying with a fresh .kodi in case this is a settings/addon issue.

One annoying behaviour is that having selected a subtitle addon, it's not possible to revert the selection back to "None" without disabling/uninstalling the currently selected subtitle addon, although this is probably more a case of bad UI design than outright bug.

(2015-03-11, 00:46)FabianE Wrote: Also, i still cannot use the VU+/Enigma2 PVR add-on, the add-on will not start, because of dll errors.

debug log (wiki)?

I'd say contact the addon author but the Enigma2 sub-forum looks like a total wasteland - is this addon being actively supported?
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
  •   
  • 1
  • 66
  • 67
  • 68(current)
  • 69
  • 70
  • 111
  •   



Logout Mark Read Team Forum Stats Members Help
OpenELEC Testbuilds for RaspberryPi (Kodi 15.0) Part 112
This forum uses Lukasz Tkacz MyBB addons.