[HELP] tvheadend and epg grabber
#1
Hi everyone,I have raspbmc with a dvb-t usb and work fine, but in my stupid country (Italy) I can view in EPG only current program and the next.How can i do expand my EPG?I tried to install XMLTV with tv_grab_file ,in my xml that I have download I can see the programs,but can't read to tvheadend..HOw can solve?thanks
Reply
#2
You configure it on the tvheadend backend - via the web interface once you've installed/enabled XMLTV and the grabber via the command line. How you configure tvh depends on what version you're running. but it's fairly straightforward - it's important that you run the grabber configuration *as the hts user* (or whomever you're running tvh as) and then enable it in the webUI.
Reply
#3
I have simple enable service from raspbmc settings.This in my EPG GRABBER configuration.Image Thanks
Reply
#4
I beleive You need to periodically (ie. cron) send XML file to TVH backend with something like this perhaps:
./tv_grab_file1 | socat - UNIX-CONNECT:/home/hts/.hts/tvheadend/epggrab/xmltv.sock

I just copied it from post in TVH forum.
Reply
#5
Well, I don't know what the previous two guys are doing but I do NOT use that xmltv.sock thing - never could get it to work. Here are the settings I use:

Image

The uncommented setting in Cron mulit-line tells TVHeadEnd to reread the XML file at 5:55 each morning. There is no sense at all in doing it any more often than you actually obtain new listings. My shell script that creates the tv_grab_file.xmltv file runs at 5:45 each morning (via a cron job) and never takes more than a minute or two to complete, so having TVHeadEnd read it once a day at 5:55 is sufficient. I cannot fathom why anyone would want to reread this file every minute; that is a complete waste of system resources!

I will note that after you download tv_grab_file and put it in the /usr/bin directory you should open it in a text editor and note the line that begins with "cat" near the top of that file. That line show the path and filename where TVHeadEnd expects to find your XMLTV format file. So after you create the file it needs to be moved to that location, or alternately you can edit tv_grab_file (as root - use sudo) to change the path and filename to match your XML file (just make sure your file is readable by the hts user). If you do decide to edit it you might want to fix that stupid spelling error (change grag to grab in the line that begins with "printf") but that's entirely optional, but I did because it bugged me! Smile

In any case if you are using an Internal Grabber then you don't check one of the External Interfaces and vise versa. If you want to use the sock thing and can figure out how, that's fine, but that is not an internal grabber. If you want to simply read an XMLTV format file created by another program such as mc2xml or zap2xml then that's fine too, but then you probably want to use the Internal Grabber and not one of the External Interfaces. Anyway, what I am showing you above works for me.

Note: To force TVHeadEnd to reread the XML file (after you've done an extra creation run to fix some problem, perhaps) temporarily set the Internal Grabber to "disabled", click Save Configuration, then set it back to using tv_grab_file and Save Configuration again. Then after doing that, reload the web page before you try to find any new channels in the dropdowns on the Channels page. Otherwise you probably won't see the newly-added channels!

Note (another one): tv_grab_file is a bash script so make sure your have the bash shell on your system - if you don't, then it needs to be modified for whatever shell you have.
Reply
#6
Been there, done that.   Done all of this.  I'm not on an RPI, though I love my RPI, but this post had the best screenshots of TVH I've seen so I'm resurrecting this old thread because of all the information here that was relevant to my predicament.

I cannot get the EPG stuff to work.  I presume success means I will see something in the "Electronic Program Guide" tab, right?

I'm running Kodi and Kodi sees the channels tvheadend is feeding it.  But there is no Program Guide.

I ... just ... want ... to ... get ... an Episode Program Guide ... to display in Kodi for the OTA channels coming in from my antenna, soon to be two.  I've been running Linux for almost 25 years.  This is now the most intractable problem I've ever run into.  It just shouldn't be this hard.  I have spent days upon days on this!  This whole experience makes me think the Myth of Sisyphus was not a myth but an historical fact!

I have the xmltv utilities installed.

I have an account with Schedule Direct because I believe in supporting open source projects and it's properly set up for my zipcode.

I'm running Tvheadend v. 4.0.9-16~g63c1034~trusty.  I'm running this version on my Linux Mint box because the *third* tv adapter I bought that I could be sure was compatible with Linux demands a library that is not available after that version of Mint.  That was almost 2 years ago when I fought that beast.  Maybe things have changed since then but that's what I have now.  It shouldn't matter because it's bringing in the TV stations from my antenna.

As far as I understand it, this version is prior to the version that utilizes sockets so I'm trying to follow the dozens of blog posts that explain how to do it the "old way".

tvheadend is running as the hts user:
Quote:$ ps ax | grep tvheadend
 3634 ?        Ssl    0:03 tvheadend -f -u hts -g video
 I run the tv_grab_na_dd as the "hts" user like so:
Quote:   tv_grab_na_dd --config-file /home/hts/.hts/tv_grab_na.conf --dd-data /home/hts/.xmltv/tv_grab_file.xmltv
 I have confirmed tv_grab_file.xmltv is a valid xml file which contains the listings from the SD account.

I got my "tv_grab_file" from https://github.com/Rigolo/tv-grab-file.

The relevant line in the tv_grab_file that points to tv_grab_file.xmltv reads:
Quote: cat /home/hts/.xmltv/tv_grab_file.xmltv
I have run that command from the command line and it works.
 
I modified the "printf" line further down to read:
Quote:   printf "tv_grab_file: North America: NC, MYZIPCODE\n"
And that's what I see in the drop-down list.  So I know tvheadend is seeing it.

I've clicked "Save Configuration" a dozen times as well as "Trigger OTA EPG grabber" everytime I make some kind of subtle change trying to get this blasted thing to work.

I've restarted tvheadend from the command line countless times as well as closed down and re-opened the browser interface.  I've rebooted the machine as well.

I'm not pointing to a socket file in the EPG/Grabber menu for "External interfaces". 

I've read all the lines in every blog post that addresses the EPG guide in tvheadend and Kodi.  I've read between the lines of all those posts.  I've extrapolated from descriptions of what old/newer versions of tvheadend look like to what I'm seeing on my version.

Again.  This just shouldn't be this hard.  What the holy hell am I missing?
Reply
#7
This would probably be better in the TVheadend section - I'll move it there.

Although a new thread rather than resurrecting a 4 year old one might have been better as the TVheadend feature set has changed a bit over that time.
|Banned add-ons (wiki)|Forum rules (wiki)|VPN policy (wiki)|First time user (wiki)|FAQs (wiki) Troubleshooting (wiki)|Add-ons (wiki)|Free content (wiki)|Debug Log (wiki)|

My Blog Posts
Reply



Logout Mark Read Team Forum Stats Members Help
[HELP] tvheadend and epg grabber1
This forum uses Lukasz Tkacz MyBB addons.