Export Video Library : Unable to write to folder
Hi all,

As preperation for upgrading from v13.2 to v14.0, I wanted to export my video library.

However, about 1 out of 10 folders (so far I only tried about 30ish) comes back with the error "unable to write to folder".

So far, all these 30 folders are located in "D:\Videos\Moviez\720p\ok" (so they are not on a different (network) drive then the folders that do work).
I already tried comparing the security permissions between them and working folders, but found no difference.

Does anyone know how to get to the bottom of this?


Although all folders (also the ones were it works) have the read only attribute partly enabled, explicitly disabling that flag does help to get xbmc to export to the folder.
Immediatly after doing so, that attribute is already partly enabled again (as they all are).

So it does have something to do with file / folder permissions, but I do not understand yet how...
Couple of questions,

Is the folder write protected?

Is there enough space for the files to be written, same size or slightly larger than your Thumbnails folder?

Do you have kodi using a userid / password combo that is missing write access to the folder in question? I ask because I did this inadvertently at one point while also trying to do an export.

Is D:\ a mapped network drive? (probably not, but just double checking)
Hi spchtr,

D: is a normal NTFS partition in Windows without any password (behind is an internal RAID5 disc set, but Windows applications do not notice / see this)
I didn't do anything special to the permissions / attributes of those folders in MS Windows. All is default... (perhaps they got inherited during a download?)

There is about 3TB of free space, so also that should not be an issue.

Somehow something did go wrong with some movie folders, because some folders apparently had something different with the read-only attribute.
When I check the read-only attribute in Explorer though, it was exactly the same for
1) the parent folder : D:\Videos\Moviez\720p\ok
2) a movie folder that XBMC could not export to : D:\Videos\Moviez\720p\ok\nonexportablemovie
3) a movie folder that XBMC could export to : D:\Videos\Moviez\720p\ok\exportablemovie
The check box was not empty, it was not checked, but it was filled with a square (meaning partly enabled i suppose)

When changing the checkbox of the D:\Videos\Moviez\720p\ok\nonexportablemovie from partly enabled to empty, XBMC was able to export to it (but the check box immediately changed back to partly enabled from itself)
To completely solve the above issue, I changed the read-only attribute from the whole D:\Videos\Moviez from partly enabled to empty.
I have exactly the same problem, about 10% of my folder is unable to write to.

I confirm my HDD have enough space, and the folder is not write protected, and there is no other program accessing or locking the folder.

Logout Mark Read Team Forum Stats Members Help
Export Video Library : Unable to write to folder0
This forum uses Lukasz Tkacz MyBB addons.