Kodi (OpenELEC) freezing on Intel J1900 based computer during movie playback
#1
Hello,

I'm using XBMC-KODI OpenELEC build on Intel J1900 based computer (x86 desktop). It is a mini pc, but it has 2 GB RAM and 16 GB SSD drive. I play movies on XBMC-KODI from my RaspberryPi local NAS storage using SAMBA protocol (wired network connection between NAS and XBMC-KODI) and I control the media center using the official Android application on my smartphone.

When I was on 4.2.1 OpenELEC version the XBMC-KODI started freezing occasionally during movie playback. It froze about once a week and there was nothing to do about it than manually restart the media center and play the movie again (I don't have any other means of control as the Android application which is not responding when the media center is frozen). A few days ago I updated to OpenELEC 5.0 (always using the x64 version) and now it's freezing every 60 minutes or so. Now I'm unable to play a movie without at least one hard restart.

I've tried clearing the movie database, soft reset and even deleting the whole media center 16 GB harddrive, installing a fresh OpenELEC 5.0 version and setting everything up again (without using the backup), but it still freezes.

I also tried tweaking the advancedsettings.xml file, so my latest version is:
Code:
<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<advancedsettings>
  <musicthumbs>
    <remove>folder.jpg</remove>
    <add>albumart.jpg</add>
  </musicthumbs>
  <loglevel>1</loglevel>
  <network>
    <buffermode>1</buffermode>
      <cachemembuffersize>104857600</cachemembuffersize>
  </network>
</advancedsettings>

When looking to the logs: \\xbmc\logfiles -> 01_KODI.log there is nothing there:

Code:
23:47:32 T:139701184882432   DEBUG: GetMovieId (smb://RASPBERRYPI/movies$/movie1.mp4), query = select idMovie from movie where idFile=34
23:47:32 T:139701184882432   DEBUG: webserver: request received for /jsonrpc
23:47:43 T:139701184882432   DEBUG: Previous line repeats 4 times.
23:47:43 T:139701184882432   DEBUG: GetMovieId (smb://RASPBERRYPI/movies$/movie1.mp4), query = select idMovie from movie where idFile=34
// and now a blank line and afterwards a new startup a few minutes later

What can I do about that?
Reply
#2
Freezes are known and won't be fixed until https://bugs.freedesktop.org/show_bug.cgi?id=88012 is fixed.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#3
Corresponding OpenELEC bugreport: https://github.com/OpenELEC/OpenELEC.tv/issues/3726
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#4
(2015-01-13, 16:03)fritsch Wrote: Corresponding OpenELEC bugreport: https://github.com/OpenELEC/OpenELEC.tv/issues/3726

Thank you for the link! I don't know how to change the Linux kernel, so I've changed CPU C-State to C1 for now:

Code:
BIOS -> Advanced -> PPM Configuration -> set Max CPU C-State to C1 (was C7)

By the way what cache settings (HOW-TO:Modify_the_video_cache (wiki)) would you recommend for my hardware setup?
I was surprised, that after a vanilla OpenELEC 5.0 installation there was cache: 0 - not using cache - when hitting info on movie screen while playing a movie from SAMBA. But Kodi's default buffermode settings is buffermode: 0 which should buffer all internet filesystems - including SAMBA, yes?
Reply
#5
Cache is not my part of kodi I am interested. I only use local content via wired network on a NFS server and default kodi settings are good enough.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#6
I'm on the same boat Sad
J1900 hangs every few minutes if I have HW acceleration enabled. Even without HW acc, I have hangs (kernel ones) from time to time.

What do you recommend me guys: downgrading to 3.16 kernel or sticking to C1 at BIOS level?
If the answer is downgrading, any guidance about how to replace it without losing data?

Thanks in advance!
Reply
#7
Didn't you ask exactly the same in the bugreport?

Use the 3.16 version I referenced on the bugreport. Disabling C7 is a shitty solution which only cause more warmth.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#8
Yes, I did. Hope it's not a problem but my apologies if it is Wink

How do I update the kernel? Can I ssh, remount /flash and copy SYSTEM and KERNEL files?
On the other hand, if I use USB disk, will I lose my current config?

danke schön!
Reply
#9
Well, took the risk of updating using the USB and I updated to development release without losing my config Wink
I'm new to Openelec and it's the first time I have done so.

I can't still tell you about the results of the new kernel, because as soon as I enabled VAAPI acceleration and rebooted, I faced a different problem!
Kodi hanged just after the loading screen, before showing the skin main screen!

I'm not using default Confluence but a custom skin called "XBMCMania Aeon Knox". I installed it using XBMCMania repository (https://repository-xbmcmania.googlecode.....helix.zip)
*BUT* I can still access using SSH or SFTP, it's not a kernel hang, just Kodi blocks.

Maybe this helps finding the root of the problem with J1900 and other Intel machines due to the fact this does not hang kernel and maybe we can gather more info.

Resuming:

* VAAPI disabled
- Kodi boots OK with default skin configured
- Kodi boots OK with XBMCMania Aeon skin configured

* VAAPI enabled
- Kodi boots OK with default skin configured
- Kodi HANGES just after showing main screen with XBMCMania Aeon skin configured

I've checked kodi.log and found nothing special when it hanges (no errors, etc...). Should I enable specific components log?

Regards

PS: BTW forgot to mention this happens with both the official 5.0.2 kernel and the development "downgraded" kernel
Reply
 
Thread Rating:
  • 1 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
Kodi (OpenELEC) freezing on Intel J1900 based computer during movie playback51