Problems installing driver for skystar 2
Hi im having a problem trying to install the driver for my skystar 2 s/2 card on ubuntu. When I go to compile after I haver patched I get this error below

File not found: /lib/modules/3.3.0-32-generic/build/.config at ./scripts/ line 32, <IN> line 4.

I understand that its because my kernel driver is newer as confirmed by doing a
as 3.13.0-32-generic.

Does anyone know how I can fix this issue?

Also when I run lspci -v I can see my

card00:0b.0 Network controller: Techsan Electronics Co Ltd B2C2 FlexCopII DVB chip / Technisat SkyStar2 DVB card (rev 02)
Subsystem: Techsan Electronics Co Ltd B2C2 FlexCopII DVB chip / Technisat SkyStar2 DVB card
Flags: slow devsel, IRQ 17
Memory at d4100000 (32-bit, non-prefetchable) [size=64K]
I/O ports at 1080 [size=32]
Looking at my system (which doesn't have a Skystar but what the hell...), that directory seems to be a list of links to the linux headers.

So.... have you installed them? I'm presuming it's looking for /lib/modules/'uname -r'/build... and that you've made a typo with 3.3.0-32? Or is this hard-coded into a build script for some bizarre reason?

My guess: sudo apt-get install linux-headers-`uname -r` linux-source
I just ran the above command sudo apt-get install linux-headers-`uname -r` linux-source and it added the latest linux header which is 3.13.0-44-generic. So I tried to use this command below:

sudo apt-get install linux-headers-`3.3.0-32-generic` linux-source

But it won't let me add a lower kernel as it gives me this error below

3.13.0-32-generic: command not found
Reading package lists... Done
Building dependency tree
Reading state information... Done
Virtual packages like 'linux-headers' can't be removed
linux-source is already the newest version.
0 to upgrade, 0 to newly install, 0 to remove and 6 not to upgrade.

I think it may be hard coded into the MakeFile script but in a linux newbie so not sure how to change it. Is there any other way of installing a old kernel
Lose the quotes - you could have run it as I typed, so uname would expand.

sudo apt-get install linux-headers-3.13.0-32-generic linux-source

You've again got 3.3.0... versus the 3.13.0... you're using, so that's starting to concern me. I see no reason you need stuff from an old kernel unless there's something (a) hard-coded and (b) very weird about the driver files (or ( c ) you're made another typo).
Been messing about with it and don;t know what i've done but seem a step further going to make a new thread for support on new issue

Logout Mark Read Team Forum Stats Members Help
Problems installing driver for skystar 20
This forum uses Lukasz Tkacz MyBB addons.