•   
  • 1
  • 10
  • 11
  • 12(current)
  • 13
  • 14
  • 32
  •   
[RELEASE] Amazon Prime Instant Video (US/UK/DE)
(2015-04-06, 18:57)capfuturo Wrote:
(2015-04-06, 18:51)drew_351 Wrote:
(2015-04-03, 06:50)cyked Wrote: If you are doing this via SSH, type 'locate default.py' and find the folder with prime.instant. Replace that file. Out of curiousity, what issues are you having? As I understand it, this won't "fix" an issue. Its to allow support of 1080p playback.

When I try to use this addon some videos play for me, but many, infact most that I have tried do not. I can see the video options just fine, but when I click to play them nothing happens. I was hoping this would fix it, since some videos play just fine.
It could depend on so many factors such as where you are located geographically, the speed of your connection, your Amazon prime localisation and account settings, etc...

Wish I knew what some of those factors would need to be. I am in the US, maybe that matters. Do you know of any way to determine/narrow down so I could get this resolved?
Reply
@drew_351: at this point and solely by having a quick reading to this thread you should know US Amazon prime streaming presents challenges. However, and only for the purpose of isolating your specific issue in case it differs, try this:

1. Connect via a fast VPN to a UK server
2. Get a trial UK Amazon Prime (UK AP) subscription (you can log in with your usual US credentials). Configure your UK Amazon account settings via website to work with Adobe Flash and not Microsoft Silverlight (Kodi is only Flash-compatible).
3. Connect via AP app for Kodi. Try 720p or less depending on your connection speed; don't do 1080p unless you've got over 10Mbps inbound through the VPN, which I doubt, otherwise the stream will buffer/stutter a lot.

Conclusions: If your streaming issues have vanished then the culprit is the add-on handling of US-bound Amazon Prime, as described earlier in this thread by your fellow United Statians.
Best,

capfuturo


"The world must learn to work together, or finally it will not work at all" - General Eisenhower
Reply
THANK YOU SO MUCH!

Although I'm having problems with some media, Aaahh!!! Real Monsters and X files for example produce script errors.

Amazon UK user. If there's any way I can help provide logs/tests etc happy to help.

EDIT UPDATE!

Think I figured it out, somehow settings had reset to US account and I'd saved the seasons to my tv shows, X-files aren't available in the UK unless you buy it.
Reply
Hi,

as of today, I am no longer able to play any Movie or TV Series with the Add-On.

What I found out so far is that the div with id: "player_container_wrapper" is not loaded and therefore some Values cannot be found - namely:
  • the productTitle
  • the productImage
  • the playserSwf
  • the deviceTypeID

I also wondered whether this Add-On can be found in a public Git repository?
Reply
@Baertierchen: just to let you know Amazon Prime Add-on (UK) is working perfectly for me as I write.
Best,

capfuturo


"The world must learn to work together, or finally it will not work at all" - General Eisenhower
Reply
Its not in git, but in googlecode: https://code.google.com/p/addonscriptord...me_instant

Addonscripters Beta Repository
Backend: Asrock N3150 with Ubuntu 18.04 Server with TvHeadend and many QEMU VMs
Living Room: MiBOX  with Kodi
Other Kodi Clients: 4 Windows 10, 1 Android
Reply
Same here, it stopped working since yesterday. Amazon uk, failed script error.
Reply
And here... Amazon UK not working :0(
Reply
Amazon DE, same thing.
Reply
able to search but script failed on playback Sad
Reply
Hi,

same here, Amazon DE.

Based on Baertierchen post I took a quick look into the code. It seems that Amazon changed something in their site which causes the plugin to fail.

The parsing of the relevant information from the HTML source happens on lines 613-620 in default.py:

Code:
matchCID=re.compile('"customerID":"(.+?)"').findall(content)
    if matchCID:
        matchTitle=re.compile('"product":.+?"title":"(.+?)"', re.DOTALL).findall(content)
        matchThumb=re.compile('"product":.+?"image":"(.+?)"', re.DOTALL).findall(content)
        matchToken=re.compile('"csrfToken":"(.+?)"', re.DOTALL).findall(content)
        matchSWF=re.compile('"playerSwf":"(.+?)"').findall(content)
        matchMID=re.compile('"marketplaceID":"(.+?)"').findall(content)
        matchDID=re.compile('"deviceTypeId":"(.+?)"').findall(content)

As no information is found, the subsequent call on line 628 fails with an index out of bound exception when trying to access information from empty/null arrays:

Code:
content = opener.open('https://'+apiMain+'.amazon.com/cdp/catalog/GetStreamingUrlSets?version=1&format=json&firmware=WIN%2011,7,700,224%20PlugIn&marketplaceID='+urllib.quote_plus(matchMID[0])+'&token='+urllib.quote_plus(matchToken[0])+'&deviceTypeID='+urllib.quote_plus(matchDID[0])+'&asin='+videoID+'&customerID='+urllib.quote_plus(matchCID[0])+'&deviceID='+urllib.quote_plus(matchCID[0])+str(int(time.time()*1000))+videoID).read()

Does anybody know if this plugin is still under active development?

[EDIT]
I'm a regular user of this plugin, not a developer nor in any way affiliated with it.
[/EDIT]

Best,
therapy
Reply
Looks like the guys at http://www.kodinerds.net/index.php/Threa...?pageNo=30 fixed this User infabo annexed the default.py and fixed it for now i have attached his script at http://skywurz.com/misc/default.zip
Reply
Has anyone gotten this to work with Kodi 15 (OpenELEC) builds on Raspberry Pi 2?
[H]i-[d]eft [M]edia [K]een [V]ideosaurus
My Family Room Theater
Reply
works fine on xbian for rasp pi 2 for me
Reply
How do we install that file for openelec? Help would be appreciated.
Reply
  •   
  • 1
  • 10
  • 11
  • 12(current)
  • 13
  • 14
  • 32
  •   



Logout Mark Read Team Forum Stats Members Help
[RELEASE] Amazon Prime Instant Video (US/UK/DE)6
This forum uses Lukasz Tkacz MyBB addons.