• 1(current)
  • 2
  • 3
  • 4
  • 5
  • 14
  •   
Kodi doesn't pickup new tv episodes
#1
Hello. I've been fighting this issue for a while now, it starting on XBMC on my windows machine and i was hoping it will be remedied now that i moved to Kodi on ubuntu.

Unfortunately it does still happen.

Here's the problem - on occasion, new shows won't get picked up by kodi. their folder is created, the episode name is 100% ok but kodi won't pick it up even if i update library or clean library and then update library.

I did find a workaround.

I think it'll be easier with an example that have happened lately.

When banshee's third season started a few weeks ago, the episode downloaded automatically into
Code:
/media/tv/Banshee
so i had
Code:
/media/tv/Banshee/Banshee/Season 03/Banshee.S03E01.mkv

sitting there.

Howerver, as mentioned, kodi wouldn't pick up that episode even after library refresh / clean refresh.

The workaround that i found to work is to rename the top folder

Code:
mv /media/tv/Banshee /media/tv/BanshXX
mv /media/tv/BanshXX /media/tv/Banshee/
refresh library

That would trigger a full shows refresh and at the end of the refresh the episode would appear.

This is how i was dealing with the issue until now.

Today however, i am at loss as my workaround doesn't work =)

12 Monkeys started and it was downloaded.

I have

Code:
/media/tv/12 Monkeys/12 Monkeys/Season 01/12.Monkeys.S01E01.mkv
/media/tv/12 Monkeys/12 Monkeys/Season 01/12.Monkeys.S01E02.mkv

But no amount of refreshing library, renaming the folders or anything else i've tried helps.

Please help me diagnose this issue once and for all.

Here's the kodi.log but as you can see it absolutely and totally ignores 12 monkeys. Only mention of it is when i play it via Video / Files.
Reply
#2
Why do you have your folders doubled, such as '/Banshee/Banshee/' or '/12 Monkeys/12 Monkeys/'? I think that might be the root of your issue.
Reply
#3
It's like that as the default renaming pattern from sickbeard which is
Code:
%SN\Season %0S/%S.N.S%0SE%0E

it was just set up like that since the beginning, it does work for 98% of the shows.

Should i change it to :
Code:
Season %0S/%S.N.S%0SE%0E
?
Reply
#4
It's unusual to have this duplication so yes, try getting rid of that.

I don't know what scraper you're using, but you might have a caching/propagation delay - if it's a new series or episode, and someone's only just added it, then it may show on the web site but not yet be available through an API query. Wait some time and try again, might help (this would normally just be minutes, though, not hours or days).

I just added TV/12 Monkeys/12.Monkeys.S01.E01.mkv as a stub and it scraped fine from thetvdb.
Reply
#5
I have this same issue, actually, and I've been racking my brain to figure out what's going on. Unfortunately I don't have a solution for you yet. I've trying deleted the database and restoring it, cleaning the database, removing and re-adding sources... I don't know where to go next.
Reply
#6
Sdbarker, do you have the same directory structure as I do?

I removed showname and season name from the renaming pattern and at least in the case of 12 monkeys it did help. I'll keep an eye on the shows and see if this solved my problem.
@Prof yaffle, thanks for checking it out for me. I do use thetvdb as you, and I believe 12 monkey was added long ago so probably not my issue.
Reply
#7
It's not quite the same. Media\TV Shows\[showname\[season no]\[filename.ext].
Reply
#8
(2015-01-18, 02:02)sdbarker Wrote: It's not quite the same. Media\TV Shows\[showname\[season no]\[filename.ext].


Hum, ok and you're saying thing happens to you..

Could you try my work around and see if it helps you?
Reply
#9
Done.

I renamed Workholics to Workaholixx and scanned.

Code:
15:45:39 T:7408 WARNING: No information found for item 'smb://Gozer/Media/TV Shows/Workaholxx/', it won't be added to the library.
15:45:40 T:7408 WARNING: No information found for item 'smb://Gozer/Media/TV Shows/It's Always Sunny in Philadelphia - Extras/', it won't be added to the library.
15:45:44 T:7408 WARNING: VIDEO::CVideoInfoScanner::Process directory 'smb://Gozer/Media/TV Shows/Workaholics/' does not exist - skipping scan.
15:45:44 T:7408 WARNING: VIDEO::CVideoInfoScanner::Process directory 'smb://Gozer/Media/TV Shows/Workaholics/Season 01/' does not exist - skipping scan.
15:45:44 T:7408 WARNING: VIDEO::CVideoInfoScanner::Process directory 'smb://Gozer/Media/TV Shows/Workaholics/Season 02/' does not exist - skipping scan.
15:45:44 T:7408 WARNING: VIDEO::CVideoInfoScanner::Process directory 'smb://Gozer/Media/TV Shows/Workaholics/Season 03/' does not exist - skipping scan.
15:45:44 T:7408 WARNING: VIDEO::CVideoInfoScanner::Process directory 'smb://Gozer/Media/TV Shows/Workaholics/Season 04/' does not exist - skipping scan.

It should be noted that there's a Season 05 folder in there as well that's *completely* ignored.
Reply
#10
No, you should rename it back to the correct name and then scan.
Reply
#11
Sorry, I did rename it back, and then scanned again. Same outcome -- nothing.
Reply
#12
I am having a similar/same problem with Kodi-Helix.

My folder structure is:

TV Shows
|
|__ Show Name 1
| |__ File (<show name> SxxExx.mkv)
| |__ File (<show name> SxxExx.mkv)
| |__ File (<show name> SxxExx.mkv)
|__Show Name 2
| |
| |__ File (<show name> SxxExx.mkv)
| |__File (<show name> SxxExx.mkv)
| |__File (<show name> SxxExx.mkv)
.

Up until Kodi (ie, Frodo, Gotham), I could "Scan for New Content" on the "TV Shows" folder, and it would find all new episodes, as well as new shows (and their episodes). Now it does nothing. I have to go to each TV Show and do the scan for that show. And, for new shows, I have to select "Show Info" on the new folder, and then the scraper will look up the new show.

I thought it might be the skin, since I saw that Quartz (which I had been using) was still broken with Helix. But I get the same results with Confluence.

What's up?

ken
Reply
#13
(2015-01-19, 02:43)daytooner Wrote: I am having a similar/same problem with Kodi-Helix.

My folder structure is:

TV Shows
|
|__ Show Name 1
| |__ File (<show name> SxxExx.mkv)
| |__ File (<show name> SxxExx.mkv)
| |__ File (<show name> SxxExx.mkv)
|__Show Name 2
| |
| |__ File (<show name> SxxExx.mkv)
| |__File (<show name> SxxExx.mkv)
| |__File (<show name> SxxExx.mkv)
.

Up until Kodi (ie, Frodo, Gotham), I could "Scan for New Content" on the "TV Shows" folder, and it would find all new episodes, as well as new shows (and their episodes). Now it does nothing. I have to go to each TV Show and do the scan for that show. And, for new shows, I have to select "Show Info" on the new folder, and then the scraper will look up the new show.

I thought it might be the skin, since I saw that Quartz (which I had been using) was still broken with Helix. But I get the same results with Confluence.

What's up?

ken

I haven't even had with the individual scanning or the show info method. I've also tried "refresh for all episodes", and that hasn't worked either.
Reply
#14
Hey there, i have the exact same problem running openelec 5.0. Some tv shows are scanned but not every episode or season are detected and it's NOT a naming issue. Had the same issue with openelec 4.2.0, probably happened when the default scraper got updated at some point. At the moment the faulty tv shows are Forever (not every episode gets scanned) and Banshee where seasons 2 and 3 are completely ignored.
Reply
#15
(2015-01-21, 18:27)Glasofruix Wrote: Hey there, i have the exact same problem running openelec 5.0. Some tv shows are scanned but not every episode or season are detected and it's NOT a naming issue. Had the same issue with openelec 4.2.0, probably happened when the default scraper got updated at some point. At the moment the faulty tv shows are Forever (not every episode gets scanned) and Banshee where seasons 2 and 3 are completely ignored.


Your media hard drive is formatted with ntfs?
Reply
  • 1(current)
  • 2
  • 3
  • 4
  • 5
  • 14
  •   



Logout Mark Read Team Forum Stats Members Help
Kodi doesn't pickup new tv episodes0
This forum uses Lukasz Tkacz MyBB addons.