Kodi 14.1 Crashes HDMI
#46
Right. Unsubscribing.
Reply
#47
I am about 1/2 way through a potential hack to the gbox that could fix this problem. Cross your fingers.
Reply
#48
OK - hack didn't fix the problem but perhaps it will give some insight on where to look. I read in another forum on the Matricom MX2 that superuser permissions were not being granted and thus causing the issue with Kodi 14.1. The Matricom Gbox Q is not rooted. So I was able to boot to TWRP recovery and apply a root fix to give me root. I was then able to see that Kodi 14.1 requests a number of root permissions. I am not sure if this could potentially have anything to do with the fact that the video goes black. Unfortunately, granting the permissions did not prevent it from going black after starting or exiting Kodi. I tried various uninstall and reinstall as well as clearing data and cache and re-starting. The SU requests are below (FYI all requests use chmod 666 but I only included that on the first line. My next step is to uninstall 14.1 and reinstall 14 to see if it requests the same permissions. A

chmod 666 /dev/anvideo
/dev/abstream_mpps /dev/amstreatm_mpts /dev/anstream_rm /dev/amstream_sub /dev/amstream_sub_read /dev/amstream_vbuf
/sys/class/video/axis
/sys/class/video/screen_mode
/sys/class/video/disable_video
/sys/class/tsync/pts_pcrscr
/sys/class/audiodsp/digital_raw
/sys/class/ppmgr/ppmgr_3d_mode
/sys/devices/system/cpu/cpu0/cpufreq/scaling_min_freq
/sys/devices/system/cpu/cpu0/cpufreq/scaling_max_freq
/sys/devices/system/cpu/cpu0/cpufreq/scaling_governor
Reply
#49
I have gone back to kodi 14.0 and found that it will still ask for the superuser permissions. Since I did not have the box rooted previously I am not sure if this means that it has nothing to with the HDMI issue.

I did do a bit more research on HDMI handshake and reasons why a handshake can be lost. One proposed solution was to use an HDMI switch that can determine when a handshake is lost and try to restore it automatically since most TVs will not try to restore the handshake. What is odd though is that my TV does not indicate that the signal is lost, it only goes dark as if it is receiving a signal but no data is being transmitted to render an image. Rather than unplugging the HDMI this time I just cycled through the HDMI inputs on my TV and that restored the screen.

So still no solution but I am hoping all this extra information gets some else closer to the solution. In the meantime, my next step will be to upgrade the firmware on my TV....something else I read was worth giving a shot.
Reply
#50
Firmware upgrade didn't do anything. I have a better TV on the 3rd floor that I also have a Gbox for. I will fiddle with that one if I have time tonight to see if the same problems occur. The problem may be a combination of the Gbox and the TV itself. Would be interesting if anyone having this issue can post the model number and maker of their TV.
Reply
#51
I have a amlogic s812 chipset and have the same issue helix 14 runs fine but as all I get on kodi 14.1 is a first run then black screen, then that's it, it wont run.
Reply
#52
I bet this is due to https://github.com/xbmc/xbmc/commit/de5e...903d9ce066

Please ask Matricom what they are doing (wrong) when "android.intent.action.REALVIDEO_ON" is sent to Android.
The intent can be handled by the FW or not, but cannot kill your display. I bet there is an unblanking ("echo 0 > /sys/class/graphics/fb0/blank") missing in their FW.
Reply
#53
(2015-02-09, 14:00)Koying Wrote: I bet this is due to https://github.com/xbmc/xbmc/commit/de5e...903d9ce066

Please ask Matricom what they are doing (wrong) when "android.intent.action.REALVIDEO_ON" is sent to Android.
The intent can be handled by the FW or not, but cannot kill your display. I bet there is an unblanking ("echo 0 > /sys/class/graphics/fb0/blank") missing in their FW.
Thanks for giving us a path to go down koying. We appreciate the insight!
Reply
#54
MY question is this what is the difference between 14.0 and 14.1, 14.0 works great on my q box while 14.1 causes the screen to go black when accessing kodi. I am not a tech guy I am not one of the entitled I appreciate all the work people do for the love of a product and no money. I would even join the development team if I had some sort of background in android or kodi but I have not. Thanks to all that look at my post and try and answer it
Reply
#55
You probably should abstain to ask questions whose answer can only be technical if you are not "a tech guy", especially if the possible answer is 2 posts above yours Wink
Reply
#56
So what your saying is there is a code in 14.1 that was not in 14.0 that the q box firmware has a problem with?
Reply
#57
(2015-02-09, 18:01)cpgallant Wrote: So what your saying is there is a code in 14.1 that was not in 14.0 that the q box firmware has a problem with?

indeed
Read/follow the forum rules.
For troubleshooting and bug reporting, read this first
Interested in seeing some YouTube videos about Kodi? Go here and subscribe
Reply
#58
https://www.facebook.com/matricom.net/posts_to_page

You will find my post on Matricom's facebook page. Hopefully it will gain some attention. Feel free to go and add your own comments and like the comment to further get their attention.
Reply
#59
As the details on this issue progress, I wanted to provide a few links to sync up how it is being tracked. As of now, and as expected, Matricom staff has not given any responses to the issue. (Hats off to Rock/CC)

Matricom FB: https://www.facebook.com/matricom.net/posts_to_page

Matricom Forum: https://forums.matricom.net/viewtopic.ph...4&start=15

Thank you KDT for the effort you have put into it (for those equally appreciative, please take note of the Donate button, as they are doing this for free vs. Matricom being a commercial business).
Reply
#60
Hi All - Just FYI that I had a conversation with Matricom Support. Below is a transcript. Looks like we have to wait for a newer firmware version...but this at least validates what Kodi devs were saying in the first place. Thanks to Mandrake for the hats off as well as posting the links in both forums to try to keep things in sync.

| 09.02.2015 13:13:30 | Nick W.: Hello Chris, my name is Nick W., how may I help you?
| 09.02.2015 13:13:46 | Chris: Have you read the topic I posted
| 09.02.2015 13:14:15 | Nick W.: We are and the new firmware should resolve the issue. I don't have a release date for you
| 09.02.2015 13:14:23 | Nick W.: I am sorry to say.
| 09.02.2015 13:14:39 | Chris: Is that firmware 1.2.2
| 09.02.2015 13:14:43 | Chris: I am currently running that beta version
| 09.02.2015 13:15:32 | Nick W.: the new will be 1.2.3 or a revision of 1.2.2.x
| 09.02.2015 13:16:03 | Chris: gotcha - will there be a beta release - I understand not giving a date as I work in software development myself
| 09.02.2015 13:17:15 | Nick W.: I don't know if they plan to release a beta or full when they do move forward with it, all I've been given is that it's in the works and some of the issues that are being address, which yours happens to be one of.
| 09.02.2015 13:18:40 | Chris: Ok - I appreciate your candor. Can you provide any insight onto why it appears Matricom staff does not respond to posts within the message boards. There has been back and forth discussion in two separate threads but there doesn't appear to be any indication from Matricom that this was being worked on
| 09.02.2015 13:18:50 | Chris: just knowing that it is known and being addressed goes a long way
| 09.02.2015 13:19:30 | Nick W.: We are in the process of reworking forum structure and are restaffing as well. During this time, the forums have noticeably suffered and we apologize about that.
| 09.02.2015 13:20:34 | Chris: Again - I appreciate your candor. We will anxiously await the next firmware release.....
Reply
 
Thread Rating:
  • 1 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
Kodi 14.1 Crashes HDMI51