•   
  • 1
  • 2
  • 3(current)
  • 4
  • 5
  • 11
  •   
Overclocking Pi 2
#31
The default gpu_mem (when NOT set in config.txt) is 64MB. The default in OpenELEC for the Pi2 is 256MB.

I've found that when running the GUI at 1080 with high colour depth and higher quality fanart/imageres settings in advancedsettings.xml, gpu_mem=320 is necessary to eliminate resource issues.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
#32
(2015-02-07, 19:56)invisable Wrote: Yes, think so, it is in the default openelec config.txt anyway. Only put it down as some people like to increase..

Yeah of course mate. Wasn't having a go, was just trying to confirm my understanding was correct Smile

I've had mine running for around 3 days too now @ 1000 and no issues as of yet. Nice and snappy. Im running a usb 3.0 / sd card setup but I would be interested to see if indeed the usb is still necessary.

Might try the SD only tomorrow and see if there are any significant differences.
Reply
#33
(2015-02-07, 21:48)jimmymcmahon Wrote:
(2015-02-07, 19:56)invisable Wrote: Yes, think so, it is in the default openelec config.txt anyway. Only put it down as some people like to increase..

Yeah of course mate. Wasn't having a go, was just trying to confirm my understanding was correct Smile

I've had mine running for around 3 days too now @ 1000 and no issues as of yet. Nice and snappy. Im running a usb 3.0 / sd card setup but I would be interested to see if indeed the usb is still necessary.

Might try the SD only tomorrow and see if there are any significant differences.

Haha didn't think you were buddy !!
I personally don't think Usb is needed, see how you get on when you test it out. I'm running off a class 4 sd card at the moment and it's running just fine, I did intend to get a better card but it seems the pi 2 reads it quicker then 4MBps

Millhouse thanks for the info I'll increase the value of gpu_mem to your figure.
Reply
#34
23:11:39 12.299986 T:3041406976 NOTICE: Raspberry PI firmware version: Jan 30 2015 18:25:11
Copyright © 2012 Broadcom
version d6e004c61a7a749897c482c860d0b2c28196437e (clean) (release)
23:11:39 12.300172 T:3041406976 NOTICE: ARM mem: 688MB GPU mem: 320MB MPG2:1 WVC1:0
23:11:39 12.300236 T:3041406976 NOTICE: cacheMemBufferSize: 20MB
23:11:39 12.300577 T:3041406976 NOTICE: Config:
arm_freq=1100
core_freq=520
sdram_freq=520
over_voltage=6
over_voltage_sdram=4
over_voltage_avs=0x1b774
hdmi_drive=2
hdmi_force_hotplug=1
hdmi_channel_map=8
disable_overscan=1
disable_l2cache=1
program_serial_random=1
config_hdmi_boost=2
disable_commandline_tags=2
emmc_pll_core=1
hdmi_force_cec_address=65535
ignore_lcd=1
framebuffer_ignore_alpha=1
framebuffer_swap=1
arm_control=0xa5800010
force_turbo=1
temp_limit=85
force_pwm_open=1
pause_burst_frames=1
avoid_fix_ts=1

Is this normal with Openelec?
Shouldn´t it be "disable_l2cache=0"?

This is the Explanation in the Raspberry Pi Config.txt explained from the Wiki:

## disable_l2cache
## Disable arm access to GPU's L2 cache. Needs corresponding L2 disabled
## kernel.
##
## Value Description
## -------------------------------------------------------------------------
## 0 Enable L2 Cache (Default)
## 1 Disable L2 cache
##
#disable_l2cache=0
backpowered RaspberryPi Model B, Kodi15, Boblight-Ambilight,
arm_freq=1040 core_freq=520 gpu_freq=510 isp_freq=510 sdram_freq=600
over_voltage_sdram=6 over_voltage=8 current_limit_override=1 force_turbo=1
gpu_mem=256 force_turbo=1 avoid_pwm_pll=1 current_limit_override=1
Reply
#35
It seems to be normal for all operating systems - same with Raspbian.

Enabling l2cache (disable_l2cache=0) will hang kodi.bin on startup. vcgencmd will also hang.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
#36
Ok, i just wondered because of the official explanation from the config.txt
Also added your gpu_mem value, thanks for this tip.
backpowered RaspberryPi Model B, Kodi15, Boblight-Ambilight,
arm_freq=1040 core_freq=520 gpu_freq=510 isp_freq=510 sdram_freq=600
over_voltage_sdram=6 over_voltage=8 current_limit_override=1 force_turbo=1
gpu_mem=256 force_turbo=1 avoid_pwm_pll=1 current_limit_override=1
Reply
#37
what is over_voltage_avs=0x1b774, program_serial_random=1, config_hdmi_boost=2, arm_control=0xa5800010 and ignore_lcd=1?
Reply
#38
(2015-02-08, 17:20)Warez Wrote: what is over_voltage_avs=0x1b774, program_serial_random=1, config_hdmi_boost=2, arm_control=0xa5800010 and ignore_lcd=1?

They are added internally (if not otherwise specified) by the firmware. They are all normal.
Reply
#39
Reading this thread, it appears that "arm_freq=1000, core_freq=500, sdram_freq=500, over_voltage=2" has the standard mentioned by the experts. Two questions:

1) Can I still use Leo's old config tool to make this setting or better to do manually?

2) It appears that my RPi2 cannot handle the over-voltage=2 as my powersupply cannot supply enough voltage to make it work (I am using the USB from the Bravia). This is unfortunate as it used to work with the RPi and also worked with RPi2 without OC. What's the best I can try without over_voltage or with overvoltage=1?


Thanks!!!
Server: Asus Sabertooth Z77 | Intel Core i5 3.4 GHz | 16 GB DDR3 | 128 GB SSD, 82 TB (9 x 6 TB, 7 x 4 TB)
HTPC 1: Raspberry Pi 2 | HTPC 2: Raspberry Pi 2 | HTPC 3: Raspberry Pi
Reply
#40
Well, the best you can try is actually to do yourself a favour and get a decent 5.0V 2A power supply for you PI 2. It isn't meant to be powered by the USB out of your Bravia. If overvoltage 2 is already a problem my guess would be that even without overclocking you are already running on the limit.
Reply
#41
(2015-02-15, 15:47)steve1977 Wrote: Reading this thread, it appears that "arm_freq=1000, core_freq=500, sdram_freq=500, over_voltage=2" has the standard mentioned by the experts. Two questions:

1) Can I still use Leo's old config tool to make this setting or better to do manually?

2) It appears that my RPi2 cannot handle the over-voltage=2 as my powersupply cannot supply enough voltage to make it work (I am using the USB from the Bravia). This is unfortunate as it used to work with the RPi and also worked with RPi2 without OC. What's the best I can try without over_voltage or with overvoltage=1?


Thanks!!!

1)
Yes, Leopold has updated his configuration tool and repo to support the RPi2
Here's a link to the post/thread...
http://openelec.tv/forum/124-raspberry-p...=45#130837
I'm using the Turbo (Preset) with force_turbo=0 (I want to see what my new RPi2 can do "out of the box", before I push it any further).
2)
Also, Leopold has added the max_usb_current switch to address USB power settings (I don't use USB devices, so I just left it off).
I did however, purchase a new power supply (recommended for the RPi2) that is different from the RPi (as mentioned by FlowT)

Thanks
Reply
#42
One of the main reasons for using a RPi is that I don't need an extra powersupply (I really dislike cables), so I would love to find a way to get things working powered by the Bravia. It worked perfectly with the RPi1 and I do not have any USB devices attached.

Are you suggesting that I can save some power by turning off max_usb_current?

Let me try Leopold's new update of the config tool. Can it be installed from his old repo?
Server: Asus Sabertooth Z77 | Intel Core i5 3.4 GHz | 16 GB DDR3 | 128 GB SSD, 82 TB (9 x 6 TB, 7 x 4 TB)
HTPC 1: Raspberry Pi 2 | HTPC 2: Raspberry Pi 2 | HTPC 3: Raspberry Pi
Reply
#43
(2015-02-16, 01:03)steve1977 Wrote: One of the main reasons for using a RPi is that I don't need an extra powersupply (I really dislike cables), so I would love to find a way to get things working powered by the Bravia. It worked perfectly with the RPi1 and I do not have any USB devices attached.

Are you suggesting that I can save some power by turning off max_usb_current?

Let me try Leopold's new update of the config tool. Can it be installed from his old repo?

steve, I can only confirm that Leo updated his (old/current) repo and config tool to support the configuration of both the RPi and RPi2 and provides a link to it in his announcement post here: http://openelec.tv/forum/124-raspberry-p...=45#130837

It is my understanding that the max_usb_current=1 will configure the RPi 2 (B+) to direct more curent to the USB ports (from the new power supply, recommended for the newer Pi models, to direct some of the increased current, to power USB devices, like external HDD for example).

I appologize for the confusion, as I now understand your "no power supply" configuration, but only meant to confirm that I used Leo's config to configure (overclock) both my old RPi and new RPi2.

Thanks.
Reply
#44
(2015-02-16, 01:03)steve1977 Wrote: One of the main reasons for using a RPi is that I don't need an extra powersupply (I really dislike cables), so I would love to find a way to get things working powered by the Bravia. It worked perfectly with the RPi1 and I do not have any USB devices attached.

Do you have a second USB port available on the Bravia? If so it might be worth trying a USB Y-cable to power the Pi2.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
#45
arm_freq=1000
sdram_freq=500
core_freq=500
over_voltage=1
gpu_mem=320
force_turbo=1

Without any issues for 5 days.
Reply
  •   
  • 1
  • 2
  • 3(current)
  • 4
  • 5
  • 11
  •   



Logout Mark Read Team Forum Stats Members Help
Overclocking Pi 22
This forum uses Lukasz Tkacz MyBB addons.