Win Subtitles display incorrect characters
#1
Hello guys. Just installed Kodi on my computer. I speak English not good so I want to learn it. So I watch the movies in English and reading subtitles in my language (Russian). I installed Opensubtitles.org. And the problem is that the English subtitles displayed correct, but when I chose Russian it shows some weird characters. looks like Kodi don't understand Russian fonts. Can I fix it or no. thanks for your help
Reply
#2
Yeah I have the same problem but no solution so far. Well I have one that's kind of awkward: you can use your own subtitle that you've downloaded of the internet (not through kodi) then if needed fix it to display correct characters using this guide and then load it to your movie while it's playing through the audio button (which it's kind of counterintuitive but it's there) where you'll find the option browse for subtitle and then locate your corrected subtitle file and you're good to go.

Needles to mention this procedure is cumbersome and should be needless if we could just choose subtitle encoding for ourselves during movie playback just like in an internet browser if programing Kodi to read the right encoding proves such an impossible task. I do realise I'm being bitter here but this IS nonsense and I can't believe that this is still a problem today!
Reply
#3
(2015-02-08, 09:41)Riko23 Wrote: Hello guys. Just installed Kodi on my computer. I speak English not good so I want to learn it. So I watch the movies in English and reading subtitles in my language (Russian). I installed Opensubtitles.org. And the problem is that the English subtitles displayed correct, but when I chose Russian it shows some weird characters. looks like Kodi don't understand Russian fonts. Can I fix it or no. thanks for your help

I may have a solution for you that's Russian cyrillic specific. You should change the general encoding for Kodi.

Go to: System > Video > Subtitles > Character Set

There choose Cyrillic Windows and then restart your movie or Kodi for that matter. It should work. Hopefully.
Reply
#4
Update:

Ok thanks to Amet I finally have this figured out. It's not a completely satisfying solution, but it's better than nothing.

Here is the solution step by step to make Cyrillic subtitles display correctly:

1. First create the folder in which we will place the cyrillic supporting font. Use this guide (I've tested it on windows only):

OS X

~/Library/Application Support/Kodi/Media/Fonts (If the fonts folder doesn't exist create it)

Android

Android/data/org.xbmc.kodi/files/.kodi/Fonts/ (If the fonts folder doesn't exist create it)

Windows

Start - type %APPDATA%\kodi\media\Fonts - press Enter (If the fonts folder doesn't exist create it)

Linux

~/.kodi/Fonts (If the fonts folder doesn't exist create it)

OpenElec

/storage/.kodi/Fonts (If the fonts folder doesn't exist create it)

2. Next you need to get a font with Cyrillic support in it. I repeat not a Cyrillic font but one with cyrillic support in it (like the kind you write with in Word when you switch the language button in the windows taskbar). You can search for one online, or if on windows you can navigate to the Windows Fonts folder (C:\Windows\Fonts) and there I recommend taking Arial Unicode MS Regular, just copy it and paste it into Kodi's Fonts folder. It will its display filename as ARIALUNI.TTF and that's how you'll see it in Kodi's settings menu.

3. Open Kodi and go to: System > Video > Subtitles > Character Set

There choose Cyrillic Windows. While you're there go to Font to use for text subtitles and change the font to ARIALUNI.TTF using the arrows on the right.

Finally close and restart Kodi and the next time you play a movie your Cyrillic subtitles should playback correctly.

The downside is that other latin based eastern european font characters won't so you have to change back to Central European (Windows). It's a bummer but for now at least it works somehow.
Reply
#5
(2015-04-12, 12:32)svetiev Wrote: It's now Setting/player/Language/Character set/   choose language(windows)
Reply
#6
(2020-06-07, 15:32)msamynaeem Wrote: It's now Setting/player/Language/Character set/   choose language(windows)

Please don't bother replying to 5-yr old forum threads.
Technology and software moves on quicker than that.
Got a Kodi problem? Provide a full Debug log (wiki) | Usefull pages: First time user (wiki) | Troubleshooting (wiki) | Free content (wiki) | Forum rules (wiki) | VPN policy (wiki)
Reply



Logout Mark Read Team Forum Stats Members Help
Subtitles display incorrect characters1
This forum uses Lukasz Tkacz MyBB addons.