•   
  • 1
  • 8
  • 9
  • 10(current)
  • 11
  • 12
  • 56
  •   
WIP Windows DirectX 11 upgrade test thread
Hey!
Here you go. The setting was enabled by default, here are the files with it enabled: https://dl.dropboxusercontent.com/u/1732...window.zip (i get a notice from windows "Kodi does not work anymore..."
Here with it disabled https://dl.dropboxusercontent.com/u/1732...screen.zip (no notice just a crash)
Here with windowed mode, no fullscreen at all https://dl.dropboxusercontent.com/u/1732...ndowed.zip

In all three cases I hear the sound from the notification before it crashes. I hope it hels Smile
Reply
Thanks. Your logs are helpfull. I'll try to fix an issue.
Reply
Awesome Smile
Reply
New build:

Fixed:
  • Fixed hardware based Stereoscopic 3D mode.

Download link in the first post.

Thank Mettbrot for helping identify issue.
Reply
Hey
I tried two more. Appearantly you have to make the 3D screen the main screen in multi monitor setups for it to be recognized as 3D Display in resolution settings... (spent an hour on this including nvidias useless 3DTV Play Utility <- this is bullshit ^^)
I ended up with the TV as the only monitor:
First setup with "use fullscreen window rather..." enabled http://pastebin.com/PqGu1Thv
When I start the movie, the sound plays, but the screen freezes (including the top left log info) I managed to shut Kodi down gracefully by using keys X - Esc Esc - S - Enter (As a remote user I'm glad I knew this combo ^^)

second try with the option disabled, using true fullscreen: http://sprunge.us/YLAR
Until setting current 3D mode to hardware based I had every text on the screen cut of at the beginning: https://dl.dropboxusercontent.com/u/17326625/kodi.jpg
Other than that:
It works! Smile The screen resolution in 3D mode was fucked up though - but I think I have to blame the false set reslution flag in mkv header for that Tongue

I hope this helps
Reply
Thank you Mettbrot.

Firstly, I think what requirements 3D screen as the main screen depends on hardware. I've tested on my desktop where 3DTV was as second monitor. It worked fine in true fullscreen mode, windowed and small window. But I've tested with Intel GPU, it doesn't require 3D screen as a main.

Secondly, I don't know exactly but I certain what any vendor's 3D utilities are not needed because we use DirectX stereoscopic feature and it depends only on drivers implementation. So any 3DTV Play and similar is bullshit as you said.

I have a couple quiestions:
1. In the first setup, has TV switched to 3D mode?
2. In the true fullscreen what is wrong with 3D resolution?

At the end. If I remember correctly when I was trying implement hardware based 3D in dx9 implementation, nVidia hardware requires true fullscreen mode whereas Intel hardware requires windowed mode. But I think in dx11 should supports both modes, who knows.
Reply
1.The TV switches to 3D mode when I select the 3D resolution in the NVIDIA control panel. (there is one for 1080p 24Hz and another entry in a 3D category 1080p 3D 24Hz BUT the 3D category only shows when the TV is main screen) Then when I open Kodi and select Current mode hardware based it switches to "3D mode off" shortly and then back to "put your glasses on blabla".

2. resolution was wrong because the FullSBS movie had wrong display width set. Nothing wrong with Kodi Wink
Reply
@Mettbrot
Please do not select 3D resoultion in control panel. Launch Kodi in windowed fullscreen and then select hardware based 3D mode in settings or when movie starts playing. Also try this with 3DTV as second display.
Reply
ok. 3 Monitor Setup, TV set to normal 1080p resolution and not main screen.
Turning on kodi it is rendered in red/cyan (this is with fake fullscreen enabled): https://dl.dropboxusercontent.com/u/1732...screen.jpg
I think the driver does this for all 3D programs (seen it in a game before) when "Enable Stereo 3D settings for all supported Displays" in Windows is enabled.
Disabling the fake fullscreen option sets its back to normal (except the text cut off I mentioned before this time at the end of the textareas)

If I now select current 3D mode to hardware based (with fake fullscreen or not - doesnt matter) I get a strange picture with a redish color defect and artefacts in the background: https://dl.dropboxusercontent.com/u/1732...ware3D.jpg
Kodi remains usable though.

Setting "current 3D" back to disabled depends on fake fullscreen setting:
-removes the red blur and everything back to normal (with fake fullscreen disabled)
-freezes display like I told before where I can hear sounds and leave kodi with keyboard ( with fake fullscreen enabled)


Here is a log of all this: http://pastebin.com/24kvAV3w
Reply
Thanks Mettbrot.

The first picture is a nVidia's stupid "feature" and can be disabled through nVidia Control panel. At the tab Set Up Stereoscopic 3D need to enable checkbox Hide Stereoscopic 3D effect when game starts. Also need to set up stereoscopic 3D correctly at the same tab to resolve an issue on second picture.

I can confirm an issue with fake fullscreen enabled and exiting out stereo mode.
Reply
As I did not find this option on my control panel I did some reading on this and it seems that nvidia removed almost all settings from the stereoscopic 3D setup tab. It used to look like this
Image

but it seems they removed the "hide 3D when game starts" and also the "select when display is in 3D mode" options according to https://forums.geforce.com/default/topic...is-gone/1/
Fortunately, I could use the registry to disable the option (page 2 in the thread) and will try again later.

edit:
so I tried it and everything is normal with default fake fullscreen enabled. Setting current mode to hardware based, the screen turns back and comes back on, i get the xbmc notification but the TV does not turn to 3D. Playing a Movie gives me just a normal picture for one eye (as if watching in monoscopic mode) disabling once more freezes kodi: http://pastebin.com/xb9AuqHv

If I disable fake fullscreen and set current mode to hardware based I am back with the blurry red picture and the "actifacts" in the background. Playing the movie renders it correctly (without the "artifacts" as far as I can see) in red/cyan. http://sprunge.us/OLiW
The second time i tried with diabled fake fullscreen I stopped the video, 3D was turned back off and I had the screen flicker all the time until I closed kodi: http://sprunge.us/fXGU

I think red/cyan is what I set the driver to in the nvidia control pannel. I don't know where I can set it to the TV hardware mode since the switch for it is gone in this driver. It just says "3D vision discover" greyed out.
In the setup utility I can choose between
USB-IR-Emitter and Glasses
Cableglasses
ProHub and Glasses
Discover-Glasses (<--- this is red/cyan)

since the last option is the only option where you dont need sepcial hardware I chose this.

Any more tips on what to try?!
Reply
Now when I select the TV as first display I get the option how to use the 3D display. https://dl.dropboxusercontent.com/u/1732...etting.jpg
With HDMI Checkerboard I have to set the TV as it does not recognize the 3D picture.
It seems the only way to get frame packing from nvidia is in deed with 3DTV Play (which as you can see I have 13 days trial left Tongue )
If I select this, it works in Kodi, the TV recognizes it and everything is fine. But only if the tv is the first display. Hope this helps
Reply
nVidia still wants money for 3DTV Play?! lol. Other vendors provide this feature out of box!

So, your nvidia hardware (or drivers) requires 3D-capable screen as main screen and also 3DTV Play installed. I have nothing to say anymore. But, you can try with your integrated Intel HD GPU which also supports frame packing stereo. It doesn't require any utility.

Thank you anyway!
Reply
pretty ridiculous right? Tongue And I thought I was doing something wrong Wink
Now that we got this sorted out, if you want me to test anything else - I would be glad^^
Reply
New build:

Fixed:
  • Fixed "freeze" GUI after switching off hardware based stereoscopic 3D mode in windowed mode. But there is a possibility what a display does not switch to 2D.
  • Fixed screen flickering in true full-screen mode during changing stereo mode.
  • A few little fixes.
  • Rebased to current master in order to include latest features and fixes.

Download link in the first post.

@Mettbrot
can you test new build?
Thanks
Reply
  •   
  • 1
  • 8
  • 9
  • 10(current)
  • 11
  • 12
  • 56
  •   
 
Thread Rating:
  • 6 Vote(s) - 3.5 Average



Logout Mark Read Team Forum Stats Members Help
Windows DirectX 11 upgrade test thread3.56
This forum uses Lukasz Tkacz MyBB addons.