Linux XBMC minimum API version = '1.9.4', add-on API version (but I'm on latest)
#1
Just did an apt-get update/upgrade to update Kodi from early Feb build to the latest (21st Feb)
Getting "unknown error has occured" when addon loads.

Output of log is below, however I'm a bit confused as I'm using the latest 2.05 (have checked by apt-get remove/purge then apt-get install etc)

20:48:10 T:140262751856384 ERROR: PVR - Add-on 'Tvheadend HTSP Client' is using an incompatible API version. XBMC minimum API version = '1.9.4', add-on API version '1.9.3'
20:48:10 T:140262751856384 WARNING: UpdateAndInitialiseClients - failed to create add-on Tvheadend HTSP Client, status = 6
20:48:10 T:140262751856384 WARNING: UpdateAndInitialiseClients - failed to load the dll for add-on Tvheadend HTSP Client, disabling it
20:48:10 T:140262349203200 NOTICE: Thread BackgroundLoader start, auto delete: false

Any ideas?
Thanks
Reply
#2
Oops, seems I need to build from source...

Ahhhh never seems to work from me :/
Reply
#3
Latest Kodi from source (git-master) + latest pvr addons from source (git-master), all is ok.
Reply
#4
(2015-02-23, 12:10)giaur Wrote: Latest Kodi from source (git-master) + latest pvr addons from source (git-master), all is ok.

It's ok realized as soon as posted needed to get from git, all sorted, thanks for posting Smile
Reply
#5
I updated my machine today. Used the ordinary system update function in Ubuntu Mate. And after this the graphics didn't work, just got a black screen after reboot. Pressed Ctrl+Alt+F2 and reinstalled the NVIDIA graphics driver. Didn't replaced the xorg conf during the reinstallation. And it worked, now Kodi started. But... TVHeadEnd couldn't start. Got this in my log:

NOTICE: Starting Kodi (15.0-ALPHA1 Git:68a1dda). Platform: Linux x86 64-bit
NOTICE: Using Release Kodi x64 build
NOTICE: Kodi compiled Feb 28 2015 by GCC 4.9.1 for Linux x86 64-bit version 3.16.7 (200711)
NOTICE: Running on Ubuntu 14.10, kernel: Linux x86 64-bit version 3.16.0-31-generic
...
ERROR: PVR - Add-on 'Tvheadend HTSP Client' is using an incompatible API version. XBMC minimum API version = '1.9.4', add-on API version '1.9.2'
WARNING: UpdateAndInitialiseClients - failed to create add-on Tvheadend HTSP Client, status = 6
WARNING: UpdateAndInitialiseClients - failed to load the dll for add-on Tvheadend HTSP Client, disabling it
...

ok, so now I must download both the source for Kodi and for TvHeadEnd add-on? Does anyone has links to the correct versions of the source code? Would be great! Smile

And also a bit scary that the ordinary Ubuntu system update can cause such great disaster... Not good for Linux newbies...
Reply
#6
https://github.com/opdenkamp/xbmc-pvr-addons
Reply
#7
Thanks robo989! I'll try to compile the PVR add-on!
Reply
#8
ok, so I've compiled and installed the latest kodi source and pvr.hts-linux-x86_64.zip. But when I try to configure the PVR add-on, it won't start (the start and activate buttons are greyed out).

I can't see any hints in the kodi log to what the problem could be. I've turned on debugging log in the PVR add-on configuration.

I wonder if I need to upgrade my backend running HTS Tvheadend 3.4.28~geb79aee~trusty? Huh
Reply
#9
Smile 
I've solved the problem now.

The solution for me was to go back to kodi 14.1. Otherwise I think I would have to get the beta source for the TvHeadend 4.x and compile it on my backend which wasn't an option for me.

I (and other users running TvHeadend) must learn to not accept all upgrades offered through Ubuntu's ordinary system update...

Thank you robo989 for your help and effort trying to solve my issue.
Reply
#10
(2015-03-03, 23:00)hd789 Wrote: I've solved the problem now.

The solution for me was to go back to kodi 14.1. Otherwise I think I would have to get the beta source for the TvHeadend 4.x and compile it on my backend which wasn't an option for me.

I (and other users running TvHeadend) must learn to not accept all upgrades offered through Ubuntu's ordinary system update...

Thank you robo989 for your help and effort trying to solve my issue.

There's some decent 3.9.xxx builds around Smile
Most are trouble free to be honest, a bit of learning the webgui again mind you.
Reply



Logout Mark Read Team Forum Stats Members Help
XBMC minimum API version = '1.9.4', add-on API version (but I'm on latest)0
This forum uses Lukasz Tkacz MyBB addons.