•  Previous
  • 1
  • 90
  • 91
  • 92
  • 93
  • 94(current)
 
Thread Rating:
  • 4 Vote(s) - 5 Average
Trakt.tv v3
(2017-11-04, 15:55)steve1977 Wrote:
(2017-09-25, 23:26)dekes1 Wrote: Hi Razze, I'm trying to diagnose why a few movies in my Kodi collection are not being added to my Trakt collection. I've confirmed the rows for the movies in question are correct in the MyVideos db, but thy're not being found by the Trakt addon.

Same issue for me. I have a few thousands movies and they all sync nicely. However, there is a handful of movies, which for some reasons do not sync with Trakt and as a result do not show up in my Trakt collection. These movies have proper NFO files with IMDB ID and TMDB ID (created with EMM). Please let me know what info I can provide to help trouble-shooting. Or any experience how to get these few movies into my Trakt collection (synced by Kodi and not manual). Thanks in advance!

Are you able to check if your kodi database shows the correct ids (the ones from the nfo)? If that's the case I will need a debug log (see first post) either in this topic or via PM.
Reply
I just installed Kodi on my jailbroken iPad Air. Immediately after the Trakt installed succesfully notification I get another notification saying there was an error, see log for details. I also tried installing from zip (from the Github page). This is the log:

Code:
11:25:46.621 T:6141702144   ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                             - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                            Error Type: <type 'exceptions.IOError'>
                                            Error Contents: (10, 'No child processes')
                                            Traceback (most recent call last):
                                              File "/var/mobile/Library/Preferences/Kodi/addons/script.trakt/default.py", line 6, in <module>
                                                from resources.lib.service import traktService
                                              File "/var/mobile/Library/Preferences/Kodi/addons/script.trakt/resources/lib/service.py", line 19, in <module>
                                                from resources.lib.traktapi import traktAPI
                                              File "/var/mobile/Library/Preferences/Kodi/addons/script.trakt/resources/lib/traktapi.py", line 8, in <module>
                                                from trakt import Trakt
                                              File "/var/mobile/Library/Preferences/Kodi/addons/script.module.trakt/lib/trakt/__init__.py", line 3, in <module>
                                                from trakt.client import TraktClient
                                              File "/var/mobile/Library/Preferences/Kodi/addons/script.module.trakt/lib/trakt/client.py", line 5, in <module>
                                                from trakt.core.http import HttpClient
                                              File "/var/mobile/Library/Preferences/Kodi/addons/script.module.trakt/lib/trakt/core/http.py", line 8, in <module>
                                                from trakt.core.request import TraktRequest
                                              File "/var/mobile/Library/Preferences/Kodi/addons/script.module.trakt/lib/trakt/core/request.py", line 3, in <module>
                                                from requests import Request
                                              File "/var/mobile/Library/Preferences/Kodi/addons/script.module.requests/lib/requests/__init__.py", line 97, in <module>
                                                from . import utils
                                              File "/var/mobile/Library/Preferences/Kodi/addons/script.module.requests/lib/requests/utils.py", line 42, in <module>
                                                if platform.system() == 'Windows':
                                              File "/Users/Shared/jenkins/workspace/IOS-ARM64/tools/depends/xbmc-depends/iphoneos8.1_arm64-target/lib/python2.7/platform.py", line 1263, in system
                                              File "/Users/Shared/jenkins/workspace/IOS-ARM64/tools/depends/xbmc-depends/iphoneos8.1_arm64-target/lib/python2.7/platform.py", line 1230, in uname
                                              File "/Users/Shared/jenkins/workspace/IOS-ARM64/tools/depends/xbmc-depends/iphoneos8.1_arm64-target/lib/python2.7/platform.py", line 965, in _syscmd_uname
                                            IOError: (10, 'No child processes')
                                            -->End of Python script error report<--
11:25:46.672 T:6145716224   DEBUG: CurlFile::Open(0x16e4ff788) https://carlovandinther4.stackstorage.co...%20Castle/
11:25:46.853 T:6141702144    INFO: Python script stopped
11:25:46.853 T:6141702144   DEBUG: Thread LanguageInvoker 6141702144 terminating
11:25:46.856 T:6142275584   ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                             - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                            Error Type: <type 'exceptions.IOError'>
                                            Error Contents: (10, 'No child processes')
                                            Traceback (most recent call last):
                                              File "/var/mobile/Library/Preferences/Kodi/addons/script.trakt/default.py", line 6, in <module>
                                                from resources.lib.service import traktService
                                              File "/var/mobile/Library/Preferences/Kodi/addons/script.trakt/resources/lib/service.py", line 19, in <module>
                                                from resources.lib.traktapi import traktAPI
                                              File "/var/mobile/Library/Preferences/Kodi/addons/script.trakt/resources/lib/traktapi.py", line 8, in <module>
                                                from trakt import Trakt
                                              File "/var/mobile/Library/Preferences/Kodi/addons/script.module.trakt/lib/trakt/__init__.py", line 3, in <module>
                                                from trakt.client import TraktClient
                                              File "/var/mobile/Library/Preferences/Kodi/addons/script.module.trakt/lib/trakt/client.py", line 5, in <module>
                                                from trakt.core.http import HttpClient
                                              File "/var/mobile/Library/Preferences/Kodi/addons/script.module.trakt/lib/trakt/core/http.py", line 8, in <module>
                                                from trakt.core.request import TraktRequest
                                              File "/var/mobile/Library/Preferences/Kodi/addons/script.module.trakt/lib/trakt/core/request.py", line 3, in <module>
                                                from requests import Request
                                              File "/var/mobile/Library/Preferences/Kodi/addons/script.module.requests/lib/requests/__init__.py", line 97, in <module>
                                                from . import utils
                                              File "/var/mobile/Library/Preferences/Kodi/addons/script.module.requests/lib/requests/utils.py", line 42, in <module>
                                                if platform.system() == 'Windows':
                                              File "/Users/Shared/jenkins/workspace/IOS-ARM64/tools/depends/xbmc-depends/iphoneos8.1_arm64-target/lib/python2.7/platform.py", line 1263, in system
                                              File "/Users/Shared/jenkins/workspace/IOS-ARM64/tools/depends/xbmc-depends/iphoneos8.1_arm64-target/lib/python2.7/platform.py", line 1230, in uname
                                              File "/Users/Shared/jenkins/workspace/IOS-ARM64/tools/depends/xbmc-depends/iphoneos8.1_arm64-target/lib/python2.7/platform.py", line 965, in _syscmd_uname
                                            IOError: (10, 'No child processes')
                                            -->End of Python script error report<--
Any idea's?
Running Kodi on:
Linux, Windows, iOS and OSX
Image
Streaming 16TB from 4 NAS servers (4 x 4TB) over 5GHz WiFi-AC + gigabit ethernet.
Image
Reply
I think something has changed in the API, because I keep getting errors in debug mode:


Code:

10:43:30.441 T:11224   DEBUG: [script.trakt] resources.lib.syncEpisodes: [Episodes Sync] Getting episode collection/watched/rated from Trakt.tv
10:43:30.442 T:11224   DEBUG: [script.trakt] requests.packages.urllib3.connectionpool: Starting new HTTPS connection (1167): api.trakt.tv
10:43:30.638 T:11224   DEBUG: [script.trakt] resources.lib.syncEpisodes: [Episodes Sync] Invalid Trakt.tv show list, possible error getting data from Trakt, aborting Trakt.tv collection/watched/rated update.
10:43:30.638 T:11224   DEBUG: [script.trakt] resources.lib.syncEpisodes: [Episodes Sync] Error getting Trakt.tv collected show list, aborting tv show sync.

Same error goes for Movie collections.
Reply
I'm probably missing something...
The addon is a two way sync (Trakt.tv<->Kodi), but if I add a movie to the trakt collection via the web site it is delete after sometime and not getting to my kodi library, but if I add the same movie via kodi library it is updated in my trakt.tv collection, also, if I erase from trakt collection via web it keeps returning but if I delete from kodi library it is being removed from trakt collection.
This is not a two way sync, it a kodi library master sync. 
What am I doing wrong and how to fix this?

TIA
Reply
(2017-11-14, 10:16)ubarnoy Wrote: I'm probably missing something...
The addon is a two way sync (Trakt.tv<->Kodi), but if I add a movie to the trakt collection via the web site it is delete after sometime and not getting to my kodi library, but if I add the same movie via kodi library it is updated in my trakt.tv collection, also, if I erase from trakt collection via web it keeps returning but if I delete from kodi library it is being removed from trakt collection.
This is not a two way sync, it a kodi library master sync. 
What am I doing wrong and how to fix this?

TIA
Don't you think it would be very confusing for most users to have a move created in their library which they can't playback?
Reply
(2017-11-15, 12:46)Razze Wrote:
(2017-11-14, 10:16)ubarnoy Wrote: I'm probably missing something...
The addon is a two way sync (Trakt.tv<->Kodi), but if I add a movie to the trakt collection via the web site it is delete after sometime and not getting to my kodi library, but if I add the same movie via kodi library it is updated in my trakt.tv collection, also, if I erase from trakt collection via web it keeps returning but if I delete from kodi library it is being removed from trakt collection.
This is not a two way sync, it a kodi library master sync. 
What am I doing wrong and how to fix this?

TIA
Don't you think it would be very confusing for most users to have a move created in their library which they can't playback? 
Dear Razze,

thank you for this very helpful addon.

Your logic is basically right, but I have different needs in my system, and if I'm able to add a movie/show to Trakt collection via the web site (regardless of kodi), I don't see the necessity of erasing it from kodi collection, and yes, as not logic as it sounds, I would prefer adding it to my kodi library upon sync and it will be my responsibility to know not to play it (I might have it on different non connected device for future use...as example). To make a long story short, I would like to know if a complete sync (not just kodi to Trakt) is possible and/or you would consider it?

tnx
Reply
(2017-11-04, 23:31)Razze Wrote:
(2017-11-04, 15:55)steve1977 Wrote:
(2017-09-25, 23:26)dekes1 Wrote: Hi Razze, I'm trying to diagnose why a few movies in my Kodi collection are not being added to my Trakt collection. I've confirmed the rows for the movies in question are correct in the MyVideos db, but thy're not being found by the Trakt addon.

Same issue for me. I have a few thousands movies and they all sync nicely. However, there is a handful of movies, which for some reasons do not sync with Trakt and as a result do not show up in my Trakt collection. These movies have proper NFO files with IMDB ID and TMDB ID (created with EMM). Please let me know what info I can provide to help trouble-shooting. Or any experience how to get these few movies into my Trakt collection (synced by Kodi and not manual). Thanks in advance! 

Are you able to check if your kodi database shows the correct ids (the ones from the nfo)? If that's the case I will need a debug log (see first post) either in this topic or via PM. 

Thanks for your help. Please see the log file below. I tried everything, but cannot get the a handful of movies incl. "Wonder Woman (2017)" and "Rings (2017)" to sync with Trakt.

http://sprunge.us/AXbQ
http://sprunge.us/eMMa
Server: Asus Sabertooth Z77 | Intel Core i5 3.4 GHz | 16 GB DDR3 | 128 GB SSD, 82 TB (9 x 6 TB, 7 x 4 TB)
HTPC 1: Raspberry Pi 2 | HTPC 2: Raspberry Pi 2 | HTPC 3: Raspberry Pi
Reply
Hey Razze, just wondering was it ever considered to be able to view your lists with this addon so that I could go to my watchlist and then pick that movie or tv show to play from the library?
Reply
(2017-11-15, 15:22)ubarnoy Wrote:
(2017-11-15, 12:46)Razze Wrote:
(2017-11-14, 10:16)ubarnoy Wrote: I'm probably missing something...
The addon is a two way sync (Trakt.tv<->Kodi), but if I add a movie to the trakt collection via the web site it is delete after sometime and not getting to my kodi library, but if I add the same movie via kodi library it is updated in my trakt.tv collection, also, if I erase from trakt collection via web it keeps returning but if I delete from kodi library it is being removed from trakt collection.
This is not a two way sync, it a kodi library master sync. 
What am I doing wrong and how to fix this?

TIA
Don't you think it would be very confusing for most users to have a move created in their library which they can't playback?  
Dear Razze,

thank you for this very helpful addon.

Your logic is basically right, but I have different needs in my system, and if I'm able to add a movie/show to Trakt collection via the web site (regardless of kodi), I don't see the necessity of erasing it from kodi collection, and yes, as not logic as it sounds, I would prefer adding it to my kodi library upon sync and it will be my responsibility to know not to play it (I might have it on different non connected device for future use...as example). To make a long story short, I would like to know if a complete sync (not just kodi to Trakt) is possible and/or you would consider it?

tnx 
It should be possible, but I will not work on it. If you can, feel free to send a PR.
(2017-11-15, 17:28)steve1977 Wrote:
(2017-11-04, 23:31)Razze Wrote:
(2017-11-04, 15:55)steve1977 Wrote: Same issue for me. I have a few thousands movies and they all sync nicely. However, there is a handful of movies, which for some reasons do not sync with Trakt and as a result do not show up in my Trakt collection. These movies have proper NFO files with IMDB ID and TMDB ID (created with EMM). Please let me know what info I can provide to help trouble-shooting. Or any experience how to get these few movies into my Trakt collection (synced by Kodi and not manual). Thanks in advance! 

Are you able to check if your kodi database shows the correct ids (the ones from the nfo)? If that's the case I will need a debug log (see first post) either in this topic or via PM.  

Thanks for your help. Please see the log file below. I tried everything, but cannot get the a handful of movies incl. "Wonder Woman (2017)" and "Rings (2017)" to sync with Trakt.

http://sprunge.us/AXbQ
http://sprunge.us/eMMa 
I'm sorry, but are those movies even added to your library? Can't see anything in the logfile.
(2017-11-16, 03:12)Supersilver Wrote: Hey Razze, just wondering was it ever considered to be able to view your lists with this addon so that I could go to my watchlist and then pick that movie or tv show to play from the library?
Considered yes, there is also a old branch where some work was done. But there hasn't been enough time to work on it, so if you want to, please send a PR.
Reply
(Yesterday, 17:14)Razze Wrote:
(2017-11-15, 17:28)steve1977 Wrote:
(2017-11-04, 23:31)Razze Wrote: Are you able to check if your kodi database shows the correct ids (the ones from the nfo)? If that's the case I will need a debug log (see first post) either in this topic or via PM.  

Thanks for your help. Please see the log file below. I tried everything, but cannot get the a handful of movies incl. "Wonder Woman (2017)" and "Rings (2017)" to sync with Trakt.

http://sprunge.us/AXbQ
http://sprunge.us/eMMa  
I'm sorry, but are those movies even added to your library? Can't see anything in the logfile.
Yes they are part of the library. The library has thousands of movies and these two are added (and can be played), but are not synced with trakt. The issue can be replicated as I have removed the movies and re-added them. It is not only these two. Not sure how many, but should just be a 10-20 movies. Don't know how to identify the missing ones. Let me add the NFO files below. Maybe you can try to add a movie with this NFO (set content - local) and see whether it adds it for you?

https://pastebin.com/VRvWCqUD
Server: Asus Sabertooth Z77 | Intel Core i5 3.4 GHz | 16 GB DDR3 | 128 GB SSD, 82 TB (9 x 6 TB, 7 x 4 TB)
HTPC 1: Raspberry Pi 2 | HTPC 2: Raspberry Pi 2 | HTPC 3: Raspberry Pi
Reply
  •  Previous
  • 1
  • 90
  • 91
  • 92
  • 93
  • 94(current)



Trakt.tv v354