Thread Rating:
  • 0 Vote(s) - 0 Average
Incorrect EPG on some channels
#1
Everything used to work but I just noticed today that some channels have wrong EPG info. The shows are correct, but it seems it is "stuck" on EPG info from the day before. For example, "Sleepy Hollow" was showing on the EPG for Fox when it was 10 am that morning (where the news should be). I checked the MySQL
backend and it contains the RIGHT information. On the front-end, reset EPG and PVR data through Kodi and while it reloaded EPG data, it reloaded the bad information again (Sleepy Hollow). Where is it getting this bad EPG data from when the Mythtv database on the backend has correct EPG info for the channel? Seems like it's pulling cached data.

I checked the same listing on my android app to make sure it wasn't an issue with the backend and confirmed the EPG data displayed correctly on my android app (connects to same backend) ... So it seems to be a bug with the mythtv plug in on Kodi.
Reply
#2
I think you have to restart Kodi because propably day light saving has passed ...

Else you could request your backend API from your browser like:
Code:
http://backend:6544/Guide/GetProgramGuide?StartChanId=1003&NumChannels=1&StartTime=2015-02-09T00:44:07Z&EndTime=2015-02-16T00:44:07Z&Details=false
Replacing backend with your backend ip, 1003 with the chanid and period of time using UTC time.
Reply
#3
I having the same issue. Sleepy Hollow is stuck on fox for last couple days. still trying to figure it out.

John
Reply
#4
Thabks Janbar. I already rebooted many times and the Web service call to the backend pulls the right info. It's the epg in kodi that is showing stale data for some channels. Also I notice the channels with the stale program show an air date of 1969.

[q NJ uote='janbar' pid='1948739' dateline='1425731743']
I think you have to restart Kodi because propably day light saving has passed ...

Else you could request your backend API from your browser like:
Code:
http://backend:6544/Guide/GetProgramGuide?StartChanId=1003&NumChannels=1&StartTime=2015-02-09T00:44:07Z&EndTime=2015-02-16T00:44:07Z&Details=false
Replacing backend with your backend ip, 1003 with the chanid and period of time using UTC time.
[/quote]
Reply
#5
i think i'm going to wait till tomorrow after 2 am in my timezone and see what happens. because daylight savings changes at 2am est.
Reply
#6
waiting seemed to solve the issue. when daylights savings changed.

John
Reply
#7
Same here. I guess there's a bug in the app that makes the EPG crap out around DST.
Reply
#8
It has always paid to restart your mythbackend at DST switchover.
If I have helped you or increased your knowledge, click the 'thank user' button to give thanks :) (People with less than 20 posts won't see the "Thank you" button.)
Reply
#9
I had the same issue after DST. I SSHed into the mythbackend and just used mythfilldatabase. Rebooted the frontends and everthing was fine again.
Reply
#10
Rebooting/mythfill/reset EPG are all things I would normally do to resolve the problem. My issue was that the EPG was dysfunctional a day or two leading up to DST and none of those things worked. Wife was very unhappy. After the DST switch over, it appeared to clear out all the crap and worked just fine, without me resetting anything. This is the first DST switch over that's occurred since I installed Kodi and MythTv, so i'll just keep this in mind in the fall when we do it again :-)
Reply
#11
Sorry to bring up a year old post but....Is it possible this problem still exists? Today my EPG (now called "Guide") is doing the same thing. It's worked nearly flawlessly for as long as I've had it setup, now today it shows nothing but Zoolander on Comedy Central as well as many other channels showing just single shows that seem to air forever.

I've tried running mythfilldatabase, restarting kodi, restarting mythtv backend but nothing helps.

I can look at listings in mythweb and they are correct so it seems like it's an add on issue.

Is this a DST issue that just needs to be waited out?

(2015-03-09, 21:57)Moto79 Wrote: Rebooting/mythfill/reset EPG are all things I would normally do to resolve the problem. My issue was that the EPG was dysfunctional a day or two leading up to DST and none of those things worked. Wife was very unhappy. After the DST switch over, it appeared to clear out all the crap and worked just fine, without me resetting anything. This is the first DST switch over that's occurred since I installed Kodi and MythTv, so i'll just keep this in mind in the fall when we do it again :-)
Reply
#12
(2016-03-11, 06:01)waverz Wrote: Sorry to bring up a year old post but....Is it possible this problem still exists? Today my EPG (now called "Guide") is doing the same thing. It's worked nearly flawlessly for as long as I've had it setup, now today it shows nothing but Zoolander on Comedy Central as well as many other channels showing just single shows that seem to air forever.

I've tried running mythfilldatabase, restarting kodi, restarting mythtv backend but nothing helps.

I can look at listings in mythweb and they are correct so it seems like it's an add on issue.

Is this a DST issue that just needs to be waited out?

(2015-03-09, 21:57)Moto79 Wrote: Rebooting/mythfill/reset EPG are all things I would normally do to resolve the problem. My issue was that the EPG was dysfunctional a day or two leading up to DST and none of those things worked. Wife was very unhappy. After the DST switch over, it appeared to clear out all the crap and worked just fine, without me resetting anything. This is the first DST switch over that's occurred since I installed Kodi and MythTv, so i'll just keep this in mind in the fall when we do it again :-)


You know i had that issue in the last week. Not sure exactly what caused it. But i think its on the Kodi - mythtv addon side.

To solve it for now. i changed in kodi under tv. Just to pull 1 day. Then hit reset on the listings. Then it aligned properly.

I had the show lucifer for days and days on the same channel.

hope this helps.

John
Reply
#13
(2016-03-11, 16:05)jpreville Wrote:
(2016-03-11, 06:01)waverz Wrote: Sorry to bring up a year old post but....Is it possible this problem still exists? Today my EPG (now called "Guide") is doing the same thing. It's worked nearly flawlessly for as long as I've had it setup, now today it shows nothing but Zoolander on Comedy Central as well as many other channels showing just single shows that seem to air forever.

I've tried running mythfilldatabase, restarting kodi, restarting mythtv backend but nothing helps.

I can look at listings in mythweb and they are correct so it seems like it's an add on issue.

Is this a DST issue that just needs to be waited out?

(2015-03-09, 21:57)Moto79 Wrote: Rebooting/mythfill/reset EPG are all things I would normally do to resolve the problem. My issue was that the EPG was dysfunctional a day or two leading up to DST and none of those things worked. Wife was very unhappy. After the DST switch over, it appeared to clear out all the crap and worked just fine, without me resetting anything. This is the first DST switch over that's occurred since I installed Kodi and MythTv, so i'll just keep this in mind in the fall when we do it again :-)


You know i had that issue in the last week. Not sure exactly what caused it. But i think its on the Kodi - mythtv addon side.

To solve it for now. i changed in kodi under tv. Just to pull 1 day. Then hit reset on the listings. Then it aligned properly.

I had the show lucifer for days and days on the same channel.

hope this helps.

John
Someone in another post mentioned that. I tried it and my guide data is still out of whack. Mythweb listings are fine though.
Reply
#14
Hello,

I'm sorry to reopen this issue. I am using Kodi on a Mi box with PVR IPTV Simple.

Everything was working fine until this saturday. EPG is stuck on some channels and others work fine. I deleted, factory rested the device and Kodi and the problem keeps coming back.

I did the same setup on my MacBook Air (installing Kodi with my iptv service and it works just fine.

Any idea how to resolve my issue on the Mi Box?

Thanks for advice or input, it's greatly appreciated.

Daniel
Reply



Incorrect EPG on some channels00