download link says FORBIDDEN 403
When I download for windows from

I get an empty page with FORBIDDEN 403.
when you click the link, you'll be redirected to one of our mirrors.
please let us know the url of that mirror.
Do not PM or e-mail Team-Kodi members directly asking for support.
Always read the Forum rules, Kodi online-manual, FAQ, Help and Search the forum before posting.
I already posted the URL: <-- that is what is inside my address bar in FireFox.

Nothing else happens, like a change of url. It just stays there.

What more information can I provide to help you fix this issue?

If you want to see it for yourself, do the following:
1) Launch Firefox (I am on Win7, 32 bit)
2) Go to
3) Click the File: Windows, where Windows is hyperlinked to:
4) See an empty page with 403 error
ok, thanx for the details!

check if you can access this page:

it's a list of all our mirrors where you can download kodi-14.2-Helix_beta1
Do not PM or e-mail Team-Kodi members directly asking for support.
Always read the Forum rules, Kodi online-manual, FAQ, Help and Search the forum before posting.
The thing is: that is not what happens for us.
When we download that link we get a different mirror assigned to us, which actually works.

I can download that link no problem. I'm suspecting you hit one mirror which is broken, but I've not been able to find it yet.
Mirrors are assigned based on location / geo-ip. Where are you located ?
I am located in Holland, Europe. I just checked, it is still broken, so I downloaded from another mirror from the list Ronie posted.

By the way, they ALL are responsive and offer the download, I tried all 7 suggested, these ones:
Found 7 mirrors which handle this country (NL) (nl, prio 40) (nl, prio 30) (nl, prio 30) (nl, prio 20) (nl, prio 10) (nl, prio 10) (nl, prio 10)

So something must be wrong with the redirection-logic on but I have no clue what.

I couldn't successfully ping

I tried tracert for you, maybe it helps:


Tracing route to []
over a maximum of 30 hops:

1 <1 ms <1 ms <1 ms []
2 24 ms 20 ms 20 ms []
3 20 ms 20 ms 20 ms []
4 19 ms 19 ms 19 ms []
5 20 ms 19 ms 68 ms []
6 32 ms 32 ms 32 ms []
7 31 ms 32 ms 31 ms []
8 34 ms 47 ms 32 ms []
9 48 ms 33 ms 33 ms []
10 34 ms 33 ms 34 ms []
11 33 ms 33 ms 33 ms []
12 32 ms 33 ms 35 ms []
13 * * * Request timed out.
14 * * * Request timed out.
15 * * * Request timed out.

OK, thanks for your help.
If I can help you by providing more info, I will gladly do so.
The redirection logic is working as it is supposed to: you just listed the mirrors it selected and they seem correct for your location.
It is able to see your IP, find it in GeoIP database and give you a list of mirrors. If that page had shown you none or did not know your country, we had a problem.

The only thing I can think of is that your system / browser doesn't handle the redirection reply properly.
Which OS and browser do you use. Is it possible that you use anonimyzers or download assistants or anything ?
Could you try it with a bare browser (safe mode, plugins disabled).

It is normal that you can't ping by the way. The important part is that you can resolve it (which you can) and reach the webserver (which you can).

To further troubleshoot it, if you have a linux box around, the output of
curl -iS
would be interesting.

I am almost in the same ip-block as you are (also Dutch, also XS4ALL) and all is working for me.
Hi- Im getting the same error message for the windows download rc1 14.2

The arm apk was successful, but the windows links for both 14.1 and 14.2 are returning with an error message 403.

I tried the links above, but they didnt return with the correct version- 14.2 rc1

I tried with chrome, IE, and with AV off.

For those still beaten by this...

I found the rc1 here..
The mirrorlist posted by Ronie worked just OK for me:

I think the team needs to solve this strange issue with the failing mirror-redirection.
All mirrors listed there gave me the download (I checked them all) but the issue remains with the mainpage of Kodi.
I just think it isn't good advertisement if the main link fails.

@Kib, I tried Curl in a VMware Debian install, and it simply gave the same information: 403. (And some basic HTML)
Would it help if I posted the exact output? (I didn't yet because I couldn't copy/paste because the VM-ware tools isn't working on my free VMware Player yet)
Just tested every single mirror and all working fine as far as I can tell.
please post the full output:
curl -iS | pastebinit

This will give you an URL to post here. Install pastebinit before, if you don't already have it.
Debian now proceeds to download (in iceweasel browser).
Of course, it is a nonsense win32 download, but it works.
(I am not sure I tested it before in Iceweasel in WMWare VM)

I also added the curl output (but it is of little use because it works in Debian from here)

Still, in Win7/32bit I still have the same problem.
I turned off F-secure (everything) but that doesn't help.

I also installed a CURL for Win32: from here:
It gave this response:

C:\utils\curl>curl -iS
HTTP/1.0 403 Forbidden
Content-type: text/html;charset=UTF-8
Pragma: no-cache, no-store
Expires: -1
Content-Length: 135

<HTML><HEAD><meta http-equiv="content-type" content="text/html;charset=utf-8">
<TITLE>403 Forbidden</TITLE></HEAD><BODY></BODY></HTML>
This was run without F-secure anti-virus running.
I doubt this helps. Undecided

@ZAG: I also did that test. All mirrors give me a download. There seems only to be a problem with the redirection logic.
Maybe it is just me on my comp (and DanRob too it seems)

Can I assist with any other tests? Feel free to ask!
it has to be something in your windows install. Antivirus/firewall stuff being the most probable
I've been getting the same response the last couple of days from IP address, on two different Windows boxes (one laptop, one desktop).

Systems: Both Windows 8.1, 64-bit, fully updated
Browser: Firefox 39.0 and IE 11
Location: Brockton, Massachusetts, USA
My external IP: (IPv4), 2601:183:c500:1537::2 (IPv6)

Luckily, wget on my Linux box was able to collect it (from a different mirror) with no trouble.

Logout Mark Read Team Forum Stats Members Help
download link says FORBIDDEN 4030
This forum uses Lukasz Tkacz MyBB addons.