XBMC Update Library NOT picking up correctly labeled movie
#1
Chenobyl Diaries (2012) is not being picked up by my scanner AT-ALL. No matter how many times I rename it. When I go into files > movies directory > movie information over the folder Chernobyl Diaries (2012), or just Chernobyl Diares or even a more messed up name Chenobyl2012Diares - it works just fine.

Why does manual movie info scan work perfect yet the auto-scan completely skips over this movie ? Other than it being a crappy movie?
Reply
#2
Kodi has that problem with series too, many items are not detected, we are not alone in this matter.
I went back to XBMC 13 and my problems are gone.
Regards,
XBMCLuver.
Reply
#3
(2015-03-12, 20:58)XBMCLuver Wrote: Kodi has that problem with series too, many items are not detected, we are not alone in this matter.
I went back to XBMC 13 and my problems are gone.

That is completely unrelated since the OPs issue is most likely somewhat API and spelling related. You´ve reported the issues? Otherwise they won´t get fixed.
Always read the online manual (wiki), FAQ (wiki) and search the forum before posting.
Do not PM or e-mail Team-Kodi members directly asking for support. Read/follow the forum rules (wiki).
Please read the pages on troubleshooting (wiki) and bug reporting (wiki) before reporting issues.
Reply
#4
(2015-03-12, 06:53)TheLastOfUs Wrote: Chenobyl Diaries (2012) is not being picked up by my scanner AT-ALL. No matter how many times I rename it. When I go into files > movies directory > movie information over the folder Chernobyl Diaries (2012), or just Chernobyl Diares or even a more messed up name Chenobyl2012Diares - it works just fine.

Why does manual movie info scan work perfect yet the auto-scan completely skips over this movie ? Other than it being a crappy movie?

Hard to tell without a debug log. But i guess it´s a mixture of API nonsense and spelling issues. Please enable debug logging in system settings, scrape for new content and provide the entire kodi.log.
Always read the online manual (wiki), FAQ (wiki) and search the forum before posting.
Do not PM or e-mail Team-Kodi members directly asking for support. Read/follow the forum rules (wiki).
Please read the pages on troubleshooting (wiki) and bug reporting (wiki) before reporting issues.
Reply
#5
(2015-03-12, 21:17)mkortstiege Wrote:
(2015-03-12, 20:58)XBMCLuver Wrote: Kodi has that problem with series too, many items are not detected, we are not alone in this matter.
I went back to XBMC 13 and my problems are gone.

That is completely unrelated since the OPs issue is most likely somewhat API and spelling related. You´ve reported the issues? Otherwise they won´t get fixed.

You say unrelated, I say it's exactly the same.

Yes, I reported it and it was said this was fixed in 14.2 beta 2 but it isn't.
Regards,
XBMCLuver.
Reply
#6
Thread link please.
Always read the online manual (wiki), FAQ (wiki) and search the forum before posting.
Do not PM or e-mail Team-Kodi members directly asking for support. Read/follow the forum rules (wiki).
Please read the pages on troubleshooting (wiki) and bug reporting (wiki) before reporting issues.
Reply
#7
http://forum.kodi.tv/showthread.php?tid=218899
Regards,
XBMCLuver.
Reply
#8
heres the ONLY USEFUL thing even related to the movie in the log....mind telling me what the deal is? Again....auto-scan doesn't pick up said film....but movie info on said folder with two TIMES the weirdest names = INSTANT FIND! It's not normal - IM ON GOTHAM ....not kodi. I tried on Kodi = same deal


T:19068 DEBUG: [service.watchdog] [event] <created> <u'smb://THEM/Movies/Chernobyl Diaries/Chernobyl Diaries.mkv'>
01:17:29 T:19068 DEBUG: [service.watchdog] [event] <deleted> <u'smb://THEM/Movies/Chernobyl.Diaries.2012/Chernobyl Diaries.mkv'>
01:17:29 T:19068 DEBUG: JSONRPC: Incoming request: {"jsonrpc": "2.0", "method": "VideoLibrary.GetMovies", "params": {"filter": {"and": [{"operator": "is", "field": "path", "value": "smb://THEMOVIETHEATER/Movies/Chernobyl.Diaries.2012/"}, {"operator": "is", "field": "filename", "value": "Chernobyl Diaries.mkv"}]}, "properties": ["file"]}, "id": 1}
01:17:29 T:19068 DEBUG: CVideoDatabase::RunQuery took 2 ms for 0 items query: select * from movieview WHERE ((movieview.strPath LIKE 'smb://THEMOVIETHEATER/Movies/Chernobyl.Diaries.2012/')) AND ((movieview.strFilename LIKE 'Chernobyl Diaries.mkv'))
01:17:29 T:19068 DEBUG: JSONRPC: Incoming request: {"jsonrpc": "2.0", "method": "VideoLibrary.GetEpisodes", "params": {"filter": {"and": [{"operator": "is", "field": "path", "value": "smb://THEMOVIETHEATER/Movies/Chernobyl.Diaries.2012/"}, {"operator": "is", "field": "filename", "value": "Chernobyl Diaries.mkv"}]}, "properties": ["file"]}, "id": 1}
01:17:29 T:19068 DEBUG: CVideoDatabase::RunQuery took 1 ms for 0 items query: select * from episodeview WHERE ((episodeview.strPath LIKE 'smb://THEMOVIETHEATER/Movies/Chernobyl.Diaries.2012/')) AND ((episodeview.strFilename LIKE 'Chernobyl Diaries.mkv'))
01:17:29 T:19068 DEBUG: [service.watchdog] [videolibrary] No media with path 'u'smb://THEMOVIETHEATER/Movies/Chernobyl.Diaries.2012/'' and name 'u'Chernobyl Diaries.mkv'' in database
Reply
#9
@TheLastOfUs. Please disable the watchdog service and hit "update library". We need the entire log since it contains additional information. The snippet you posted contains no log line created by the VideoInfoScanner.
Always read the online manual (wiki), FAQ (wiki) and search the forum before posting.
Do not PM or e-mail Team-Kodi members directly asking for support. Read/follow the forum rules (wiki).
Please read the pages on troubleshooting (wiki) and bug reporting (wiki) before reporting issues.
Reply
#10
While at it, what filesystem is used on the smb side? Btw, just noticed THEM vs THEMOVIETHEATER. Might be a manual edit before posting that snippet though.
Always read the online manual (wiki), FAQ (wiki) and search the forum before posting.
Do not PM or e-mail Team-Kodi members directly asking for support. Read/follow the forum rules (wiki).
Please read the pages on troubleshooting (wiki) and bug reporting (wiki) before reporting issues.
Reply
#11
Apparently I had to do "Scan Recursively"....why?
Reply
#12
The movies are in a folder "/Movies" and then in their own folder..I noticed that Watch Dog was not picking up anything and neither was UPDATE LIBRARY until I did "Scan Recursively"....:/
Reply
#13
Not entirely sure but it sounds to me as if the content settings were kinda broken and the re-configure fixed it. Glad it's working now.
Always read the online manual (wiki), FAQ (wiki) and search the forum before posting.
Do not PM or e-mail Team-Kodi members directly asking for support. Read/follow the forum rules (wiki).
Please read the pages on troubleshooting (wiki) and bug reporting (wiki) before reporting issues.
Reply
#14
So I'm a bit confused. Is Scanning Recursively not recommended? That's the thing that fixed it. Otherwise unchecking that results in the same issues...
Reply
#15
@TheLastOfUs, hard to tell without knowing the underlying file and folder structure. There's nothing wrong with recursive scanning.
Always read the online manual (wiki), FAQ (wiki) and search the forum before posting.
Do not PM or e-mail Team-Kodi members directly asking for support. Read/follow the forum rules (wiki).
Please read the pages on troubleshooting (wiki) and bug reporting (wiki) before reporting issues.
Reply



Logout Mark Read Team Forum Stats Members Help
XBMC Update Library NOT picking up correctly labeled movie0
This forum uses Lukasz Tkacz MyBB addons.