v14 Mouse wheel?
#1
Hello

I'm using an archlinux with kodi 14.1 installed (on raspberri pi2)

The wheel of mouse doesn't works to do pageup/pagedown.

I tried to create a mouse.xml file but no changes.

Same problem with openelec distribution.

Any way to correct this problem ?


Thanks
Reply
#2
Can you post a debug log (wiki)? Just make sure to use the mouse wheel when the log is recording. That will tell us if Kodi is receiving any input command. That will tell us where to start looking for the issue.
Reply
#3
Thanks for your response.

Here are the line from kodi.log when I enable debug, and move the schroll to see if something is shown :

Code:
18:10:55 T:1953809168  NOTICE: Log level changed to "LOG_LEVEL_DEBUG_FREEMEM"
18:10:55 T:1953809168  NOTICE: Enabled debug logging due to GUI setting. Level 2.
18:10:55 T:1953809168   DEBUG: ------ Window Init () ------
18:11:02 T:1734341664   DEBUG: Thread JobWorker 1734341664 terminating (autodelete)
18:11:02 T:1817842720   DEBUG: Thread JobWorker 1817842720 terminating (autodelete)
18:11:02 T:1798493216   DEBUG: Thread JobWorker 1798493216 terminating (autodelete)
18:11:02 T:1953809168   DEBUG: ------ Window Deinit (Pointer.xml) ------
18:11:02 T:1708389408   DEBUG: Thread JobWorker 1708389408 terminating (autodelete)
18:11:07 T:1953809168   DEBUG: ------ Window Init (Pointer.xml) ------
18:11:07 T:1953809168 WARNING: CLinuxInputDevice::RelEvent: Unknown rel event code: 8
18:11:10 T:1953809168 WARNING: Previous line repeats 9 times.
18:11:10 T:1953809168   DEBUG: ProcessMouse: trying mouse action leftclick
18:11:11 T:1953809168   DEBUG: Previous line repeats 1 times.
18:11:11 T:1953809168   DEBUG: ------ Window Init (DialogSelect.xml) ------
18:11:11 T:1953809168    INFO: Loading skin file: DialogSelect.xml, load type: KEEP_IN_MEMORY
18:11:15 T:1953809168   DEBUG: ProcessMouse: trying mouse action mousedrag
18:11:19 T:1953809168   DEBUG: Previous line repeats 160 times.
18:11:19 T:1953809168 WARNING: CLinuxInputDevice::RelEvent: Unknown rel event code: 8
18:11:22 T:1953809168 WARNING: Previous line repeats 8 times.
18:11:22 T:1953809168   DEBUG: ProcessMouse: trying mouse action mousedrag
18:11:23 T:1953809168   DEBUG: Previous line repeats 1 times.
18:11:23 T:1953809168   DEBUG: ProcessMouse: trying mouse action leftclick
18:11:24 T:1953809168   DEBUG: ------ Window Deinit (DialogSelect.xml) ------
18:11:25 T:1953809168   DEBUG: ProcessMouse: trying mouse action mousedrag
18:11:26 T:1953809168   DEBUG: Previous line repeats 11 times.
18:11:26 T:1953809168   DEBUG: ProcessMouse: trying mouse action leftclick
18:11:29 T:1953809168   DEBUG: Previous line repeats 2 times.
18:11:29 T:1953809168 WARNING: CLinuxInputDevice::RelEvent: Unknown rel event code: 8
18:11:32 T:1953809168 WARNING: Previous line repeats 25 times.
18:11:32 T:1953809168   DEBUG: ProcessMouse: trying mouse action leftclick
18:11:34 T:1953809168   DEBUG: Previous line repeats 1 times.
18:11:34 T:1953809168  NOTICE: Disabled debug logging due to GUI setting. Level 0.
18:11:34 T:1953809168  NOTICE: Log level changed to "LOG_LEVEL_NORMAL"
18:11:35 T:1708389408  NOTICE: Thread JobWorker start, auto delete: true
Reply
#4
The unknown event code 8 seems to be the schroll :
http://openelec.tv/forum/134-usage/63203...roll-wheel

I'm using raspberry pi 2. It seems I'm not the only one with this problem
Reply
#5
No one ? Big Grin

Do I need to create a bug for kodi ?
Reply
#6
Not sure. As far as I can tell, everyone seems to be having this problem on the Pi, which is weird. However, I'm not a dev, so I can't do much more than basic troubleshooting with my knowledge.
Reply
#7
Not a dev either, but from what I can see it's not handled in the code.
https://github.com/xbmc/xbmc/blob/master...s.cpp#L573
It's plain simple: there is no code to handle the wheel.

There are a lot of references in google to this error, it seems pi specific because on other systems input is handled by Xorg (or whatever other non linux platforms have).
I have not enough c++ skills and kodi codebase knowledge to implement this and send a patch.
Help from a seasoned dev needed.
Reply
#8
Sad 
I have exactly the same problem on Pi & Pi2 from very old versions of XBMC up to the most recent KODI (OpenELC, OSMC).
It's too embarrassing behavior and I don't understand why still happens.Sad
No one can make a patch solution yet?Huh
Reply
#9
Strange that this isn't handled. I've had a look and I can see the mouse wheel events (rel event code 8), but Kodi doesn't handle them.
I'lll have a go at returning XBMC_MOUSEBUTTONDOWN / XBMC_MOUSEBUTTONUP for these. Should be in tonight's Milhouse test build.
Reply
#10
Latest Milhouse build has support for mouse wheel events.
Please test (note it is a nightly build).
If reports are positive I'll try to get it included in stable Isengard OE/OSMC builds.
Reply
#11
@popcornmix: I briefly tested the mousewheel support in #0708 and now things go a little crazy if you use the wheel then subsequently hover the mouse over a spinner control (eg. Settings -> System -> Audio output -> Boost centre channel when downmixing) - the spinner value starts changing automatically (and rapidly).

To reproduce:

1. Boot Kodi #0708
2. On Home menu, scroll the mouse wheel (one click should be sufficient)
3. Go to settings and hover over a spinner control

This is new behaviour in #0708, and didn't happen in #0707, so presumably this is a consequence of the new wheel support.

Be careful though, once you've changed a setting in #0708 Kodi may not start again - it looks like the settings are unreadable (probably because of PR7359) so take a backup of guisettings.xml before changing any settings!
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
#12
(2015-07-09, 00:18)Milhouse Wrote: Be careful though, once you've changed a setting in #0708 Kodi may not start again - it looks like the settings are unreadable (probably because of PR7359) so take a backup of guisettings.xml before changing any settings!

Yes, my debug build is hosed by one of today's merges (presumably the CVariant one):

Code:
#0  0x00bdf16c in __exchange_and_add (__val=-1, __mem=0xfffffffc) at /home/dc4/tools/arm-bcm2708/gcc-linaro-arm-linux-gnueabihf-raspbian-x64/arm-linux-gnueabihf/include/c++/4.8.3/ext/atomicity.h:49
#1  __exchange_and_add_dispatch (__val=-1, __mem=0xfffffffc) at /home/dc4/tools/arm-bcm2708/gcc-linaro-arm-linux-gnueabihf-raspbian-x64/arm-linux-gnueabihf/include/c++/4.8.3/ext/atomicity.h:82
#2  _M_dispose (__a=..., this=0xfffffff4) at /home/dc4/tools/arm-bcm2708/gcc-linaro-arm-linux-gnueabihf-raspbian-x64/arm-linux-gnueabihf/include/c++/4.8.3/bits/basic_string.h:246
#3  ~basic_string (this=0x3f19408, __in_chrg=<optimised out>) at /home/dc4/tools/arm-bcm2708/gcc-linaro-arm-linux-gnueabihf-raspbian-x64/arm-linux-gnueabihf/include/c++/4.8.3/bits/basic_string.h:539
#4  CVariant::cleanup ([email protected]=0x7eee4138) at Variant.cpp:303
#5  0x00bdf1dc in CVariant::~CVariant (this=0x7eee4138, __in_chrg=<optimised out>) at Variant.cpp:297
#6  0x009c2350 in PLAYLIST::CPlayListPlayer::SetRepeat ([email protected]=0x2868f18 <g_playlistPlayer>, [email protected]=0, state=<optimised out>, [email protected]=false)
    at PlayListPlayer.cpp:556
#7  0x0041020c in CMediaSettings::OnSettingsLoaded (this=0x2862400 <CMediaSettings::Get()::sMediaSettings>) at MediaSettings.cpp:178
#8  0x008e8170 in CSettingsManager::OnSettingsLoaded (this=0x3e69718) at SettingsManager.cpp:924
#9  0x008eab30 in CSettingsManager::Load ([email protected]=0x3e69718, root=Reading in symbols for tinyxml.cpp...done.
0x3efb778, [email protected]: false, [email protected]=true, [email protected]=0x0) at SettingsManager.cpp:109
#10 0x00403568 in CSettings::Load ([email protected]=0x28621b0 <CSettings::Get()::sSettings>, file=...) at Settings.cpp:150
#11 0x004035e8 in CSettings::Load (this=0x28621b0 <CSettings::Get()::sSettings>) at Settings.cpp:142
#12 0x0094d3a0 in CApplication::Create (this=0x3e0eeb8) at Application.cpp:624
#13 0x009ede68 in XBMC_Run (renderGUI=<optimised out>) at xbmc.cpp:49
#14 0x003926e8 in main (argc=3, argv=0x7eee4724) at main.cpp:77
Reply
#13
The guisettings.xml problem is due to PR7359, I've tested without this PR and there is no problem. Just building on Ubuntu with this PR and it crashes at startup, trying to build without and then will update on github.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
#14
If I revert CVariant commit I get this in log:
Code:
02:13:17 3198.419434 T:1979265024   ERROR: CSettings: unable to load settings from special://masterprofile/guisettings.xml, creating new default settings
with an infinite recursion here:
http://pastebin.com/eAgiyhss

which does look most likely to be settings commit related. This line does look like recursion:
https://github.com/xbmc/xbmc/blob/master...s.cpp#L156
Reply
#15
Yep, the infinite loop is due to PR7359, remove that and all is fine.

And yes, I'm getting the same problem with cvariants (this is with PR7359): http://sprunge.us/bGbX
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Mouse wheel?00