TVDB are updating their site. Their site currently has a number of bugs that have broken the TVDB scraper and any add-on that relies on TVDB data. TVDB are working to rectify the problems.

  •   
  • 1
  • 13
  • 14
  • 15(current)
  • 16
  • 17
  • 19
  •   
Hellowlol HTPC-Manager fork support thread
I hadn't updated the app in quite some time. I did so this evening. I also changed my port number as I am making some changes to my server. Since making both of these changes I am getting image errors (no images are showing) on the following:

KODI Server module
PLEX module
KODI Recent Episodes, Albums and Movies on the dashboard

Headphones and Mylar images are fine.

My log has this error for hundreds of images: cherrypy.error.53034672

I have reinstalled cherrypy, rebooted Windows, restart HTPC Manager.

Thanks in advance for any help.
Reply
(2015-11-30, 03:35)VMCosco Wrote: I hadn't updated the app in quite some time. I did so this evening. I also changed my port number as I am making some changes to my server. Since making both of these changes I am getting image errors (no images are showing) on the following:

KODI Server module
PLEX module
KODI Recent Episodes, Albums and Movies on the dashboard

Headphones and Mylar images are fine.

My log has this error for hundreds of images: cherrypy.error.53034672

I have reinstalled cherrypy, rebooted Windows, restart HTPC Manager.

Thanks in advance for any help.

Here is some additional info from the log

Code:
2015-11-29 21:10:07 :: cherrypy.error.50453808 :: ERROR :: [29/Nov/2015:21:10:07] HTTP
Traceback (most recent call last):
  File "C:\HTPCManager\libs\cherrypy\_cprequest.py", line 670, in respond
    response.body = self.handler()
  File "C:\HTPCManager\libs\cherrypy\lib\encoding.py", line 217, in __call__
    self.body = self.oldhandler(*args, **kwargs)
  File "C:\HTPCManager\libs\cherrypy\_cpdispatch.py", line 61, in __call__
    return self.callable(*self.args, **self.kwargs)
  File "C:\HTPCManager\modules\kodi.py", line 326, in GetThumb
    return get_image(url, h, w, o, mode, self.auth())
  File "C:\HTPCManager\htpc\helpers.py", line 87, in get_image
    image = resize_image(image, height, width, opacity, mode, resized)
  File "C:\HTPCManager\htpc\helpers.py", line 260, in resize_image
    im = im.resize(size, Image.ANTIALIAS)
  File "C:\Python27\lib\site-packages\PIL\Image.py", line 1290, in resize
    self.load()
  File "C:\Python27\lib\site-packages\PIL\ImageFile.py", line 164, in load
    self.load_prepare()
  File "C:\Python27\lib\site-packages\PIL\ImageFile.py", line 231, in load_prepare
    self.im = Image.core.new(self.mode, self.size)
  File "C:\Python27\lib\site-packages\PIL\Image.py", line 39, in __getattr__
    raise ImportError("The _imaging C module is not installed")
ImportError: The _imaging C module is not installed[/code]
Reply
(2015-11-30, 04:12)VMCosco Wrote:
(2015-11-30, 03:35)VMCosco Wrote: I hadn't updated the app in quite some time. I did so this evening. I also changed my port number as I am making some changes to my server. Since making both of these changes I am getting image errors (no images are showing) on the following:

KODI Server module
PLEX module
KODI Recent Episodes, Albums and Movies on the dashboard

Headphones and Mylar images are fine.

My log has this error for hundreds of images: cherrypy.error.53034672

I have reinstalled cherrypy, rebooted Windows, restart HTPC Manager.

Thanks in advance for any help.

Here is some additional info from the log

Code:
2015-11-29 21:10:07 :: cherrypy.error.50453808 :: ERROR :: [29/Nov/2015:21:10:07] HTTP
Traceback (most recent call last):
  File "C:\HTPCManager\libs\cherrypy\_cprequest.py", line 670, in respond
    response.body = self.handler()
  File "C:\HTPCManager\libs\cherrypy\lib\encoding.py", line 217, in __call__
    self.body = self.oldhandler(*args, **kwargs)
  File "C:\HTPCManager\libs\cherrypy\_cpdispatch.py", line 61, in __call__
    return self.callable(*self.args, **self.kwargs)
  File "C:\HTPCManager\modules\kodi.py", line 326, in GetThumb
    return get_image(url, h, w, o, mode, self.auth())
  File "C:\HTPCManager\htpc\helpers.py", line 87, in get_image
    image = resize_image(image, height, width, opacity, mode, resized)
  File "C:\HTPCManager\htpc\helpers.py", line 260, in resize_image
    im = im.resize(size, Image.ANTIALIAS)
  File "C:\Python27\lib\site-packages\PIL\Image.py", line 1290, in resize
    self.load()
  File "C:\Python27\lib\site-packages\PIL\ImageFile.py", line 164, in load
    self.load_prepare()
  File "C:\Python27\lib\site-packages\PIL\ImageFile.py", line 231, in load_prepare
    self.im = Image.core.new(self.mode, self.size)
  File "C:\Python27\lib\site-packages\PIL\Image.py", line 39, in __getattr__
    raise ImportError("The _imaging C module is not installed")
ImportError: The _imaging C module is not installed[/code]

Your pil install is broken. Uninstall it and install pillow
Reply
Quote:Your pil install is broken. Uninstall it and install pillow

Thanks. I uninstalled PIL, at least I think I did. Running "pip uninstall PIL" worked and now if I run it, it says PIL cannot be found. The are still PIL instances showinf in the python directory though. I installed Pillow using the windows installer. I restarted Windows. There is no change in behavior.

EDIT: I resolved it. There were some lingering PIL files that I needed to manually delete. All is working well now
Reply
Synology users can now pick this fork in the community package instead of the hack we used before.
Reply
A new auth level has been added.

A restricted user can add and see stuff but not change anything.
Reply
Hi hellow!

First of all i would like to say thanks for this awesome work you are doing!

Now to the "problem" :/

First problem i have is that when im going to Settings > Plugin/module > Enable (and fill in the rest of the info) and hit Save button, it saves, creates the menu button and all that, but after the "refresh" the plugin is Disabled BUT works?

Also if i trying to enable "robots.txt" or any other settings it saves, but gets "disabled" after the refresh. how come?

next problem is, or i think it with psutil cause i get this error/info message in the log.

Code:
"modules.stats    ERROR    Python should be executed as an administrator to smartmontools to work properly. Please, try to run python with elevated credentials."

My system is:

Code:
FreeNAS 9.3 nightlies
HTPC-Manager installed via plugin and then updated with your fork
Python 2.7.11
py27-sqlite3
py27-openssl
psutil Latest version
pip
smartctl 6.4 2015-06-04 r4109 [FreeBSD 9.3-RELEASE-p31 amd64] (local build)


I have tryed to installed from a "fresh" jail but i get the same problem, what im i doing wrong?

Im going nuts! Big Grin
Reply
Hi hellowlol,

I've finally managed to get HTPC-Manager to run without any of the error showing for PIL on my NAS and now get no errors at all and it detects pil installed but it doesn't display any of the background art on the Kodi Now Playing window?

Is there anyway I can make it show this art?
Reply
(2015-12-27, 22:54)bootdisk Wrote: Hi hellow!

First of all i would like to say thanks for this awesome work you are doing!

Now to the "problem" :/

First problem i have is that when im going to Settings > Plugin/module > Enable (and fill in the rest of the info) and hit Save button, it saves, creates the menu button and all that, but after the "refresh" the plugin is Disabled BUT works?

Also if i trying to enable "robots.txt" or any other settings it saves, but gets "disabled" after the refresh. how come?

next problem is, or i think it with psutil cause i get this error/info message in the log.

Code:
"modules.stats    ERROR    Python should be executed as an administrator to smartmontools to work properly. Please, try to run python with elevated credentials."

My system is:

Code:
FreeNAS 9.3 nightlies
HTPC-Manager installed via plugin and then updated with your fork
Python 2.7.11
py27-sqlite3
py27-openssl
psutil Latest version
pip
smartctl 6.4 2015-06-04 r4109 [FreeBSD 9.3-RELEASE-p31 amd64] (local build)


I have tryed to installed from a "fresh" jail but i get the same problem, what im i doing wrong?

Im going nuts! Big Grin

Let me by saying I'm sorry for the late response. I haven't gotten any notifications regarding this thread like I normally do.

1. Your first issue should be fixed
2. The error message is pretty clear but the wrapping I'm using for smartmoontool isn't compatible with freenas. I know the freenas guys have made changes to that wrapper but I do t think they have sent it upstream.
Reply
Its okey fork. It was me who posted on github about the first problem. But My server crashed.
Reply
I installed HTPC in my FREENAS server recently and it seems to be working quite well.
I use Couchpotato as well and connected it to HTPC.

it loads as it should but I noticed something that I'm hoping to get explained here.
each movie poster has a little circle with an arrow in the lower right corner, when I hover the mouse over it, i get a fly out that says 'download'. When I click on it I get a meta data window about the movie but i don't see a button or option to download.

What am I missing?
How can I enable this feature?

thanks

Updater Source
BRANCH master2
Current commit 6a78741eb94aa9cf74fb404a2da68336f119a73a
Reply
Hi.
Can someone point me to documentation covering 'Kodi Servers' setting page (or any other configuration-related docs for that matter)?
Running HTPC-Manager on same device as Kodi, but it fails to detect Kodi server. The port should be of JSON-RPC, right?
Running on Raspberry Pi model B (first generation) + DietPie, if that is of any importance.
Reply
(2016-01-21, 04:56)bkagan Wrote: I installed HTPC in my FREENAS server recently and it seems to be working quite well.
I use Couchpotato as well and connected it to HTPC.

it loads as it should but I noticed something that I'm hoping to get explained here.
each movie poster has a little circle with an arrow in the lower right corner, when I hover the mouse over it, i get a fly out that says 'download'. When I click on it I get a meta data window about the movie but i don't see a button or option to download.

What am I missing?
How can I enable this feature?

thanks

Updater Source
BRANCH master2
Current commit 6a78741eb94aa9cf74fb404a2da68336f119a73a

It just means that is download, it that tag i missing in the library tab you can click releases in the modal and choose a download. Sorry for the late replay
Reply
(2016-01-29, 00:01)tuxbass Wrote: Hi.
Can someone point me to documentation covering 'Kodi Servers' setting page (or any other configuration-related docs for that matter)?
Running HTPC-Manager on same device as Kodi, but it fails to detect Kodi server. The port should be of JSON-RPC, right?
Running on Raspberry Pi model B (first generation) + DietPie, if that is of any importance.

It should be the port of the webserver.
Reply
is there any way to filter HDD items in the dashboard? for some reason i'm seeing a bunch of /sys/fs/cgroup/ folders...
Reply
  •   
  • 1
  • 13
  • 14
  • 15(current)
  • 16
  • 17
  • 19
  •   
 
Thread Rating:
  • 2 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
Hellowlol HTPC-Manager fork support thread52