20 Nov 2019 - TVDB Scraper v3.2.0 is now available which reinstates scraping. TVDB are still in the process of fixing a number of bugs so there may still be further breakages. See this post. 2901570 (post)

v17 Kodi not remembering subtitle settings
#16
Still a problem. I have had it since 14. Reported.
Reply
#17
(2017-09-27, 12:45)Schiznit Wrote: Still a problem. I have had it since 14. Reported.

Worked on xbox, but now its hard to fix.
Reply
#18
(2017-04-29, 15:15)AlexMorris Wrote:
(2016-05-06, 12:05)AlexMorris Wrote:
(2016-03-05, 21:12)AlexMorris Wrote: And the behaviour still exists in 16.0.

And the behaviour still exists in 16.1.  

And the behaviour still exists in 17.1.  
And the behaviour still exists in 17.6.
Reply
#19
Same here. Very annoying. I have made sure my movie files do not have the default or forced flag set. I use the OSD to disable subs and set to default for all media but it does not stick. Subs are on by default when I play any movie.

UPDATE: I went back to Kodi 18 and no longer have this issue.
Reply
#20
Issue still exists in Kodi v18.1
Its pretty annoying to be honest to have to select every time the right subtitle language. Should be easy to fix, come on guys.
Reply
#21
(2019-03-27, 09:45)rudxai Wrote: Issue still exists in Kodi v18.1
Its pretty annoying to be honest to have to select every time the right subtitle language. Should be easy to fix, come on guys.
I'm on Kodi 18.1 on Android. I haven't experienced this issue since v.17.x. Did you check the video files and ensure they were not encoded with default subtitle settings? They will override Kodi settings.
Reply
#22
(2018-03-31, 03:09)AlexMorris Wrote:
(2017-04-29, 15:15)AlexMorris Wrote:
(2016-05-06, 12:05)AlexMorris Wrote: And the behaviour still exists in 16.1.  

And the behaviour still exists in 17.1.   
And the behaviour still exists in 17.6. 
And the behaviour still exists in 18.1.
Reply
#23
(2019-04-17, 13:20)AlexMorris Wrote:
(2018-03-31, 03:09)AlexMorris Wrote:
(2017-04-29, 15:15)AlexMorris Wrote: And the behaviour still exists in 17.1.   
And the behaviour still exists in 17.6. 
And the behaviour still exists in 18.1.
Try 18.2. You never know. 🙂
Got a Kodi problem? Provide us with a full Debug log (wiki) || Usefull pages: First time user (wiki) || Troubleshooting (wiki) || Free content (wiki) || Forum rules (wiki) || VPN policy (wiki)
Reply
#24
(2019-04-17, 13:44)Klojum Wrote:
(2019-04-17, 13:20)AlexMorris Wrote:
(2018-03-31, 03:09)AlexMorris Wrote: And the behaviour still exists in 17.6. 
And the behaviour still exists in 18.1. 
Try 18.2. You never know. 🙂 

As soon as it passes QA and gets released, sure. I'll give it a go.
Reply
#25
Oh... In Ubuntu 18.2 is already present. Hence my suggestion. Blush
Got a Kodi problem? Provide us with a full Debug log (wiki) || Usefull pages: First time user (wiki) || Troubleshooting (wiki) || Free content (wiki) || Forum rules (wiki) || VPN policy (wiki)
Reply
#26
(2019-04-17, 13:20)AlexMorris Wrote:
(2018-03-31, 03:09)AlexMorris Wrote:
(2017-04-29, 15:15)AlexMorris Wrote: And the behaviour still exists in 17.1.   
And the behaviour still exists in 17.6.  
And the behaviour still exists in 18.1. 

And the behaviour still exists in 18.2.
Reply
#27
So I was suddenly facing this exact issue on Kodi 18.3 where the show subtitles settings had been set to default true and would not change the default back to false for all media files. I was having to turn it off subtitles each time I started playing the video.

After a bit of digging around I found this corresponded to a corrupted MyVideos database so I tested with a new profile and the subtitles defaulted to off. Therefore there must be a subtitle setting stored in MyVideos database so I deleted it from the main profile and this fixed my issue.
Reply
#28
(2015-04-01, 21:40)AlexMorris Wrote: I'm using Kodi 14.2 on both Windows 8 and a Raspberry Pi (OpenELEC 5.0.8) and neither installation remembers my preference of always having subtitles turned on. I often watch video files with embedded subtitles (not separate .sub/.srt files), and I want the subtitles always displayed.

A search of this forum and of Google suggests that lots of people want to know how to turn off subtitles. It seems I'm the only person who wants subtitles always turned on.

The wiki page at http://kodi.wiki/view/Subtitles#Changing...g_playback indicates that subtitles are always on by default, but experience shows that this is not the case.

This thread - 87791 (thread) - indicates that the subtitle preference is held in guisettings.xml

guisettings.xml on both systems contains <showsubtitles>true</showsubtitles> but that setting seems to have no effect.

If I go into the audio options, enable subtitles, select "Set as default for all videos", answer "Yes" to the "Are you sure?" prompt, the preference is not remembered. Whenever I play a video with included subtitles, the subtitles are not shown and I need to enable them manually every time.

What do I need to do to have subtitles always displayed by default?

Assuming your file contains it's own subtitles, the only way I could do it was, when compressing the mkv file in handbrake I used the subtitle settings (*which ever line was for foreign language in my case I set line 2 first * ) check boxes " forced only " and " default ". Then in kodi I had to go to " Settings/Player/Accessibility " and turn on " prefer subtitles for the hearing impared ". This will enable subtitles by default on all files, so if you are watching something you don't want subtitles for, turn this option off.
Reply
#29
(2019-10-19, 23:32)BL0930 Wrote: turn this option off.

You're a bit late with your reaction here. In fact, you're 4.5 years too late with your reaction.
Your other reaction was to a thread post already a year old.

What gives?
Got a Kodi problem? Provide us with a full Debug log (wiki) || Usefull pages: First time user (wiki) || Troubleshooting (wiki) || Free content (wiki) || Forum rules (wiki) || VPN policy (wiki)
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Kodi not remembering subtitle settings00