•   
  • 1
  • 125
  • 126
  • 127(current)
  • 128
  • 129
  • 509
  •   
Kodi DSPlayer – DirectShow Player for Windows
@gotham_x

Make sure that vsync setting in reclock advanved setting is unchecked and try again. Then play a video with madVR overlaying its stats showing, Then double click the green reclock icon while video is playing and take a screenshot of that window next to madVR settings on video.

BTW you could also try enabling reclocks use AC3 encoding and only with multi-channel sources options. That may play better with your receiver.
Reply
(2015-10-24, 16:13)Razoola Wrote: Reclock can be set to work with both bitstreaming and PCM resampling without changing settings. It all depends on what it receives from the audio decoder. The problem is reclocks user interface makes it harder than it needs to be.

If you are wanting to slow down 25p to 24p you want LAV set up so bitstreaming is disabled. As Warner306 says you do not loose audio quality, slysoft would argue you gain quality. In 95% of cases I would say this is the correct setup for reclock (don't use bitstreaming).

Bitstreaming however is a great option in reclock and I'm very thankful its there. You have to understand when to use it though because using it incorrectly causes issues (like you have discovered) or the loss of audio quality. Because reclock does not resample audio when bitstreaming however it is appealing to some because you save many CPU cycles which is great if your using CPU for decoding video

You only want reclock doing bitstreaming if you can match your panels refresh rate to a very close multiple of the video refresh rate. For example, I could get an old 295GTX gfx card to a refresh rate of 23.972 or 23.978 adding a custom refresh rate in the NVidia control panel. This is the correct time to consider having bitstreaming enabled for use with reclock. Then its just a case of that final 'disable media speed correction with bitstream audio' setting and if you should use it or not. Using it means video will correct itself (drop/repeat frames) to keep sync with audio. Disabling it will mean bitstream audio packets will drop/repeat so video remains smooth always. Because refresh rates are so close these corrections will be few and far between no matter which option you choose for this setting.

Some people will also use bitstreaming when going 23.976 to 24.000 or visa versa. For some that's too much audio packets dropping, some however may see that as an acceptable trade off for the extra CPU cycles to use on video.
Even with Nvidias custom refresh rate, it's still "dynamic" in that it jumps around, only CRU can force a fixed refresh rate that's perfect.

It's all up to Nvidia/AMD, if any of those listens they got my money Confused.

Bitstreaming perfectly can work, but there's no program available except VideoClock that can decode, correct clocks, and then repack it to make audio match refresh rate with bitstream. This also only works with DTS-HD, there's no program as fair as i'm aware that can do this to TrueHD.

Standard Kodi can do this with DTS-HD as far as i'm aware. But if you play a TrueHD movie with "Sync playback to display" on + passthrough on, you'll notice that the audio will have "skips".

I'm unsure why this method doesn't work with DD Audio.
Reply
(2015-10-24, 16:20)Razoola Wrote: @gotham_x

Make sure that vsync setting in reclock advanved setting is unchecked and try again. Then play a video with madVR overlaying its stats showing, Then double click the green reclock icon while video is playing and take a screenshot of that window next to madVR settings on video.

BTW you could also try enabling reclocks use AC3 encoding and only with multi-channel sources options. That may play better with your receiver.


I have no idea how to capture screenshots from TV, I only have a remote control multidirectional, I can do this by phone, the quality is not as screenschot.

He takes some eyes

Image
Reply
(2015-10-24, 17:48)gotham_x Wrote:
(2015-10-24, 16:20)Razoola Wrote: @gotham_x

Make sure that vsync setting in reclock advanved setting is unchecked and try again. Then play a video with madVR overlaying its stats showing, Then double click the green reclock icon while video is playing and take a screenshot of that window next to madVR settings on video.

BTW you could also try enabling reclocks use AC3 encoding and only with multi-channel sources options. That may play better with your receiver.


I have no idea how to capture screenshots from TV, I only have a remote control multidirectional, I can do this by phone, the quality is not as screenschot.

He takes some eyes

Image

Change 23.976 to 25.000, you don't need to set 25->24 on MadVR settings.
Reply
(2015-10-24, 12:08)XTrojan Wrote:
(2015-10-24, 06:40)Warner306 Wrote:
(2015-10-24, 00:18)XTrojan Wrote: Hmm...Is it only me or is GTX 970 really this weak or underperforming?

The best settings i could get before framedrops were

1080 -> 2160P

Chroma: super-xbr150 + AR + Superres
Image: Jinc3 + AR
Luma Doubling: 2x or greater - NNEDI3 16
Chroma Doubling: Disabled
Upscaling Refinement: SuperRes + LL
Artifact Removal - Debanding: Medium/High
Image Enhancements: Off
Dithering: Error Diffusion 2

I was hoping for NNEDI3 32 doubling or atleast NNEDI3 for standard chroma upscaling, is it only me?

Not sure what i should change...

Definately go with super-xbr plus SuperRes - it is just about as good but much cheaper. And turn off linear light when using SuperRes. It is not recommended to scale in linear light when image upscaling, only downscaling.

You could reduce ED2 to Ordered Dithering, too. This won't make much of a difference. And turn off SuperRes for chroma upscaling, which also won't do much for image quality. Those changes might make it possible to use NNEDI3 32, which is marginally better.

Thanks, it looks awesome, is there any difference at the setting "Apply SuperRes First"? and "Refine image after every 2upscaling step"?

The first setting is applicable when multiple sharpening shaders are used. The second is only useful if the image is quadrupled.
Reply
@gotham_x, XTrojan is correct. In the window you brought up (clicking reclock twice) change the 23.976 to 25 in the top right corner, or you can probably change it to automatic also if your going to be using many different refresh rates with reclock.

You may want to have the pal Speed down option also selected but I can't remember off the top of my head exactly how that works but its related to the situation your trying to achieve.

you still also need to disable the 2nd vsync option in reclock mentioned before (2nd option from top of reclocks advanced settings page)

Raz
Reply
Hi gotham_x,

I was finally able to get it working without dropping frames. I had it working in bit-streaming too, but the audio was unacceptable, as predicted by Razoola.

For testing and screenshot purposes I used MPC-HC, but the settings are the same. After you input the settings, make sure to clear the timings and frame rate databases. I highlighted that in red. I hope the image isn't too big, looked fine in my preview post.

Thanks Warner306 and Razoola for the tip on bit-streaming, disabling that in LAV Audio was the final piece of the puzzle. I forgot about LAV, was too focused on Reclock.

Consequently, by disabling bit-streaming I no longer needed the audio latency entry in advancedsettings.xml, to correct for 24p

Image
Reply
Good day.
In new versions (where DX 11 enable and EVR disabled) my HTPC with integrated VideoCard cannot plays video normally (slideshow instead of video). Now the only choice is madVR which is very heavy for my card. Any settings with madVR and LAV are already checked, when madVR are used, I cannot see video. Rollback to version 15.0 with EVR support and all is fine. Can You enable EVR again, if it possible?
I'll be very thankfull.
Reply
Very good guys, for the mutual cooperation is working well with Reclocking, now, thanks to the image related to screenshots posted by hu1kamania with 1280px720p drop frame have fallen sharply, only downsides I can raise concerns (Treat 25p movies as 24p) if this setting in the Display Modes madVR is disabled you have an output display 50.00024Hz for content at 25fps.
Good Sunday.
Reply
one little question i have, the inverse telecine option in nvidia settings, any advice if leaving enabled (default) or rather turn it off using dsplayer version ?
Reply
There badly just needs to be a method to get proper refresh rates without modding, ReClock wouldn't even be needed and all movies would playback perfectly with no speedup or dropped frames.

Is there anyone that can hijack the timings the Haswell GPUs use, since they got perfect 23.976.
Reply
One thing I will point out to reclockers.

While you are using it you cannot read anything into the predicted frame drops/repeats reported in the madVR stats. Reclock will be constantly working and as a result the madVR stat will constantly be changing. If everything is working correctly you will never get a framedrop even though madVR prediction might say otherwise.
Reply
@XTrojan, in my view reclock is always needed even if you are ableto create a 100% matching refresh rate. This is because the video and audio clocks are different. Even if the refresh rates match with the video clock the audio clock may cause drift.

What is really needed in my view is a reclock replacement, probably something in LAV that madVR can tap into, or something in madVR that LAV can tap into. Or a new program that can sit between both (like reclock currently does).
Reply
(2015-10-25, 15:22)Razoola Wrote: @XTrojan, in my view reclock is always needed even if you are ableto create a 100% matching refresh rate. This is because the video and audio clocks are different. Even if the refresh rates match with the video clock the audio clock may cause drift.

What is really needed in my view is a reclock replacement, probably something in LAV that madVR can tap into, or something in madVR that LAV can tap into. Or a new program that can sit between both (like reclock currently does).

Audio has no "frames" as far as i'm aware, DD Audio however can't have the audio portions split up as well as DTS does, not sure why.

The solution to this mess is just a advanced reclock that instead of changing the audio clock instantly does something similar as VideoClock does.
Decode->Change audio clock to refresh rate->Pack->Bitstream

Since AMD/Nvidia hasn't given a shit for years, i doubt they'll do now, the only one who gave a fuck was Intel, but their GPUs aren't on the same league :/.
Reply
Yup, audio does not have frames, but there are audio packets. These are sent based on the audio clock as I understand it. To be honest this side of it is a little over my head as for me personally I will choose video quality over audio quality because video stutter ruins a movie more than a audio pop would.
Reply
  •   
  • 1
  • 125
  • 126
  • 127(current)
  • 128
  • 129
  • 509
  •   
 
Thread Rating:
  • 47 Vote(s) - 4.43 Average



Logout Mark Read Team Forum Stats Members Help
Kodi DSPlayer – DirectShow Player for Windows4.4347
This forum uses Lukasz Tkacz MyBB addons.