•   
  • 1
  • 174
  • 175
  • 176(current)
  • 177
  • 178
  • 509
  •   
Kodi DSPlayer – DirectShow Player for Windows
So far so good , no more dropped frames
But now i see something different

Watching a video with 29.970 fps , i can read at Ctrl+J
display 59.9389 Hz
Composition rate 59.94 Hz
Movie 29.97 fps (says source filter)
No dropped frames
No presentation glitches

I stop this video and i watch another with 23.976 fps , then i read
display 23.9755 Hz
Composition rate 29.97 Hz (it keeps the previous video fps)
movie 23.976 fps (says source filter)
No dropped frames
But a lot presentation glitches
The video stutters ( if i use the correct word because the english is not my native language)

i have to close the Kodi and to run it again
But i have the same problem if i use videos with different fps

Do i need to add something in the display modes?
I use only these ones
1080p60, 1080p59, 1080p50, 1080p23

Thanks again for your attention
Reply
Kodi Jarvis RC1 + dsplayer with all update until now (01/18/2016) - ffmpeg 2.8.5 (fixed exploid 2.8.4).

link for download:

https://dl.dropboxusercontent.com/u/7799...5.dx11.exe

Warnings:
- This is an unofficial Kodi build not from Team Kodi.
- This build comes with no warranties, explicit or implied, and you use it at your own risk.
- This build was compiled by Wanilton, for use only in Windows OS, and have same functions official Kodi Jarvis build Nightlie + dsplayer support.

git:

https://github.com/mediaBrasil/xbmc/tree...r_dsplayer

Have PVR fix* by @*Roma*, thanks.

* [Fix] PVR Channel switching functions
MediaBrazil forum Website - Youtube Channel
Aeon MQ9-0.3.0 & Ace2 Skin Team
MarcosQui Website Donate and support us.
Reply
So, I just switched to this version of Kodi, because the normal DVDPlayer version was giving me issues with HEVC playback.(Video was lagging behind the audio)
Anyway, the playback seems to have improved, but the DSPlayer settings page inside Kodi GUI has a lot of text missing for me.

Image

Log : http://pastebin.com/yBxT3U5y
Reply
@saarth,

Try here with clean install, and work fine

Image
MediaBrazil forum Website - Youtube Channel
Aeon MQ9-0.3.0 & Ace2 Skin Team
MarcosQui Website Donate and support us.
Reply
Hi there !

Thanks for your work, everything work fine !

I'm using Jarvis RC1 DSPlayer on Windows 10 with my little AM1 5350 who can't decode HEVC. With your player, he is able to decode it without lag and dropped frame !
Ok, he goes to 99%, but no matter Smile

Why DSPlayer will stop on Kodi 17 ?
Reply
(2016-01-19, 21:34)blepharocyte Wrote: Hi there !

Thanks for your work, everything work fine !

I'm using Jarvis RC1 DSPlayer on Windows 10 with my little AM1 5350 who can't decode HEVC. With your player, he is able to decode it without lag and dropped frame !
Ok, he goes to 99%, but no matter Smile

Why DSPlayer will stop on Kodi 17 ?

Dev left I think.
Mac Mini (2.7GHz, Late 2012, Windows 10, Kodi DSPlayer) | SATV 16GB | Panasonic TX-P50GT50B | Yamaha RX-V675 | Q Acoustics 2010i (FL, FR, Left S, Right S), Q2000ci Center, Q2070si Sub
Reply
(2016-01-19, 21:34)blepharocyte Wrote: Hi there !

Thanks for your work, everything work fine !

I'm using Jarvis RC1 DSPlayer on Windows 10 with my little AM1 5350 who can't decode HEVC. With your player, he is able to decode it without lag and dropped frame !
Ok, he goes to 99%, but no matter Smile

Why DSPlayer will stop on Kodi 17 ?

The developer left because he didn't want to maintain it anymore. He was hoping it would be merged into the main branch, but it won't.

Hope remains some developer will pick up this project in the future, as it works pretty well as is.

There is some hope madVR support might be added to the new VideoPlayer for v17, but that is unknown. That would not allow for the use of custom DirectShow filters, so DSPlayer would remain superior to most.
Reply
Hi I need some help. I have a problem when playing Live TV it looses focus so I have to press ALT + TAB to get it back in focus. The problem only occurs in Live TV. I have madVR exlusive mode enabled.

More information on this. I only have this problem because I have something called acamd/mdapiplus stealing focus which I'm using.

How can I fix this so it doesn't steal focus from Kodi/madVR?


EDIT: Got it working now!
Reply
(2016-01-17, 17:11)djoole Wrote: Once again, I made a clean install ;-)
I never do upgrades.

First thing after installing/windows updating W10 was install Nvidia drivers.
I don't think they are buggy... maybe they don't handle some stuff FFDSHOW/AVISYNTH want from them..
I have to wait a few more videos in order to say it was coming from that, but since i deactivated FFDSHOW in DSPlayer I don't have BSOD.
ok try it: DDU
Reply
Does anyone else here run this version of Kodi with a GTX 960?? If so, what are your settings at? I keep tweaking mine because I just can't seem to get everything the way I had hoped it would be after adding the 960. Before that I was just using a Radeon 6550 and the image quality doesn't seem to be too much better. It could just be me being picky though.
Reply
Does this build\branch work with Broadcom Crystal HD decoders? I am stuck on XBMC and would like to change, but I need CHD support. I can see it in the "filters configuration" but all I get is a black blinking screen. I really dont know how to set this up.
Reply
may start with mpc-hc first and get it working there than you can still try to make it work in kodi dsplayer.

it is way harder to change filter in kodi dsplayer than in mpc-hc
Reply
(2016-01-20, 21:40)Skinny_T Wrote: Does anyone else here run this version of Kodi with a GTX 960?? If so, what are your settings at? I keep tweaking mine because I just can't seem to get everything the way I had hoped it would be after adding the 960. Before that I was just using a Radeon 6550 and the image quality doesn't seem to be too much better. It could just be me being picky though.

I still think these profiles are a good starting point: 1966593 (post).

I would swap every super-xbr for NNEDI3 if your card can handle it. If the display is 4K, I've been told NNEDI3 is too much if you want to use image sharpening and other post-processing. Some people think super-xbr rings too much, but I don't find it all that offensive at 100 sharpness if used with SuperRes. With a 1080p display, NNEDI3 and even Reconstruction (soft) chroma upscaling would be possible.
Reply
(2016-01-21, 02:46)Warner306 Wrote:
(2016-01-20, 21:40)Skinny_T Wrote: Does anyone else here run this version of Kodi with a GTX 960?? If so, what are your settings at? I keep tweaking mine because I just can't seem to get everything the way I had hoped it would be after adding the 960. Before that I was just using a Radeon 6550 and the image quality doesn't seem to be too much better. It could just be me being picky though.

I still think these profiles are a good starting point: 1966593 (post).

I would swap every super-xbr for NNEDI3 if your card can handle it. If the display is 4K, I've been told NNEDI3 is too much if you want to use image sharpening and other post-processing. Some people think super-xbr rings too much, but I don't find it all that offensive at 100 sharpness if used with SuperRes. With a 1080p display, NNEDI3 and even Reconstruction (soft) chroma upscaling would be possible.

Thanks for the advice. I've actually followed your posts to a "T". Sometimes I think I expect too much, but then I've seen other systems that blow me away with similar specs and videos in the same format. I haven't tried NNEDI3 though. What would the difference be between 16,32,64,128 Neurons?

I don't have a 4k tv yet so I'll try out the Chroma Upscaling too.
Reply
(2016-01-21, 05:00)Skinny_T Wrote:
(2016-01-21, 02:46)Warner306 Wrote:
(2016-01-20, 21:40)Skinny_T Wrote: Does anyone else here run this version of Kodi with a GTX 960?? If so, what are your settings at? I keep tweaking mine because I just can't seem to get everything the way I had hoped it would be after adding the 960. Before that I was just using a Radeon 6550 and the image quality doesn't seem to be too much better. It could just be me being picky though.

I still think these profiles are a good starting point: 1966593 (post).

I would swap every super-xbr for NNEDI3 if your card can handle it. If the display is 4K, I've been told NNEDI3 is too much if you want to use image sharpening and other post-processing. Some people think super-xbr rings too much, but I don't find it all that offensive at 100 sharpness if used with SuperRes. With a 1080p display, NNEDI3 and even Reconstruction (soft) chroma upscaling would be possible.

Thanks for the advice. I've actually followed your posts to a "T". Sometimes I think I expect too much, but then I've seen other systems that blow me away with similar specs and videos in the same format. I haven't tried NNEDI3 though. What would the difference be between 16,32,64,128 Neurons?

I don't have a 4k tv yet so I'll try out the Chroma Upscaling too.

I'm in the same boat.

If I use Super-xbr +AR +Super-res, and all of the other recommended settings in the above guide, everything works with a 12-14ms render time. I tried switching settings to FSE and D3D11 to see if render times would improve, but they are consistently the same (windowed, FSE, D3D9, D3D11 net the same render time). Not that the picture is terrible or anything, but when I setup my neighbors' low end AMD system (AMD processor with on-board graphics) and enabled NNEDI3 128 Neurons, the sharpness was almost surreal! What else didn't make sense is that this was possible on such a low end machine, with 20-24ms render times (albeit they are running Windows 10, and I am on Windows 7x64).

When I tried the same on my machine, the renders are 45-90ms depending if I use 32, 64, or 128 neurons (with no change whether D3D9, D3D11, FSE, windowed, etc.). That being said, any content, whether 720p, 1080p, is unwatchable as the frame rate is really choppy.

I did setup my (and my neighbors') system to DXVA copy-back, as I was under the impression (after reading pages upon pages on here) that CUVID doesn't make any render time difference, and actually hurts quality. Please correct me if this is wrong.

If anyone has any suggestions or insight on what settings would work (whether in MadVR, LAV, Nvidia control panel, etc) so I could get NNEDI3 to work, it would be appreciated.

System Specs are:
Operating System: Windows 7 Ultimate 64-bit (6.1, Build 7601) Service Pack 1
Motherboard: Gigabyte Z87X-UD3H
BIOS: F9
Processor: Intel® Core™ i5-4670K CPU @ 3.60GHz (4 CPUs), ~3.6GHz
Memory: 16gb RAM
Display driver: 361.43
Card name: MSI NVIDIA GeForce GTX 660 OC 1033/1098MHZ 2GB 6GHZ GDDR5
Display Memory: 4036 MB ( Dedicated Memory: 1988 MB, Shared Memory: 2048 MB)
Resolution: 1920 x 1080 (32 bit)
Monitor Model: SONY 52XBR5 with XV Color (12-bit panel)
Output Type: HDMI
HDD: Crucial_CT480M500 SSD
HDD2: WDC Black 1.5tb
HDD3: WDC Black 2tb
HDD4: WDC Black 4tb
BD/HD-DVD: LG: HL-DT-ST BDDVDRW GGC-H20L
Reply
  •   
  • 1
  • 174
  • 175
  • 176(current)
  • 177
  • 178
  • 509
  •   
 
Thread Rating:
  • 47 Vote(s) - 4.43 Average



Logout Mark Read Team Forum Stats Members Help
Kodi DSPlayer – DirectShow Player for Windows4.4347