•   
  • 1
  • 20
  • 21
  • 22(current)
  • 23
  • 24
  • 509
  •   
Kodi DSPlayer – DirectShow Player for Windows
Spears & Munsil HD Benchmark Chroma Upsampling and YCbCr to RGB Conversion Evaluation

The Spears & Munsil HD Benchmark Color Space Evaluation is designed to test the ability of a media player and display to render an RGB image from a Y’CbCr 4:2:0 source video. This simple test pattern can be used to evaluate chroma upsampling quality and Y’CbCr -> R’G’B’ conversions of any DVD, Blu-ray or streaming media player and display panel. This primarily involves a test of the quality of the components Y’CbCr to RGB conversion: (Source) Y’CbCr 4:2:0 -> Y’CbCr 4:2:2 -> Y’CbCr 4:4:4 -> (Display Output) R’G’B’.

For a HTPC user, all video output is typically RGB as this is the working color space of a PC. Most display processors will convert this RGB input into a Y’CbCr format for video processing, either 4:2:2, 4:2:0 or 4:4:4, before converting back to RGB through chroma upsampling or simple chroma interpolation. Selecting a display’s specialized PC mode could possibly lead to video processing in RGB, and some 4:4:4 video modes out there might also handle an RGB input natively. The High Frequency Horizontal Resolution Burst pattern shown in the video will be a different color than the other nearby High Frequency Detail patterns if RGB is converted at any point to another color format.

HD Benchmark Color Space Evaluation Test Pattern
Image

As stated, PC users are evaluating the performance of Windows media players and the end display video processing when converting Y'CbCr to R'G'B' with RGB output to the display. This test is also helpful in determining if a display uses different internal processing steps with any potential visual errors in chroma processing when provided with an RGB full (0-255) vs. RGB limited (16-235) input.

Because most users will be displaying RGB levels in full range (0-255), there are some caveats to be aware of when interpreting the results of some of these tests.

Clipping
The clipping test shows whether the display is clamping any of the Y’CbCr or RGB channels above the 16-235 reference range. RGB full range does deliberately clip 0-15 (BtB) and 236-235 (WtW) when converting Y’CbCr to RGB, so this test will be invalid with PC RGB output and should not show any visible colored squares in any of the clipping boxes.

To test for channel clipping with RGB output, you must set madVR and the display to output video levels (16-235) with the GPU set to RGB full (0-255).

BT.709
The BT.709 color space test also appears not to be compatible with RGB full (0-255) output. I am not sure of the technical reasons, but neither the BT.601 or BT.709 squares are likely to be illuminated as the displayed color space. Again, to pass the test, set madVR and the display to output video levels (16-235) rather than PC levels (0-255).

4:2:2 vs. 4:4:4
The majority of flat panel TVs in the consumer display market render RGB color with some subsampling of the (CbCr) color channels. The practical reality is that most common display image processing chips limit processing of chroma data to 4:2:2 or 4:2:0 while carrying out any necessary internal video processing calculations. If a display has a PC mode, it may permit 4:4:4 chroma processing and display, but this often still leads to lower video quality due to a reduction in the quality of video processing calculations and/or an inability to enable certain video processing settings when PC mode is selected. Some of the few displays that can maintain intact 4:4:4 chroma resolution for the primary video modes with most video enhancements enabled — all the way from display input to processed output — include PC monitors and some high-end projectors.

Despite the reduction in quality caused by chroma subsampling, it is still possible to see a difference on chroma upsampling tests at 4:2:2 chroma resolution between a lower-quality chroma upscaling algorithm such as Bicubic60 and a high-quality chroma upscaling algorithm such as NGU. The added conversion steps from 4:4:4 -> 4:2:2 -> 4:4:4 -> RGB reduce chroma quality, but don't completely destroy it. Playing the upsampling pattern on a large PC monitor that is almost guaranteed to render RGB at 4:4:4 can demonstrate any visual loss in chroma detail from 4:4:4 to 4:2:2 compared to the typical TV video mode.

A quick method to determine if a display renders RGB with 4:4:4, 4:2:2 or 4:2:0 chroma resolution is to take the image below and view it fullscreen in Media Player Classic.

Chroma 4:4:4 Display Support Test Image — Must Be Viewed 1:1

Drag image into MPC window. If you can perfectly read the last two lines (with red and blue background, as well as some other lines like the blue and pink ones), then the display chroma subsampling is 4:4:4. Otherwise, the chroma is being rendered in 4:2:2 or 4:2:0 (likely it's using 4:2:2). To test chroma 4:4:4 support at 24p, first set the GPU refresh rate to 23 Hz.

Download Spears & Munsil HD Benchmark Color Space Evaluation

Spears & Munsil HD Benchmark Color Space Evaluation Download Link

Instructions on how to score the test with some background information on chroma subsampling and display video processing is found in the link below:

Introduction to Spears & Munsil Choosing a Color Space

Note: If the display resolution is higher than 1920 x 1080p (e.g., 4K UHD), double scaling of the chroma layer will occur from the setting in image upscaling to upscale the chroma and luma resolutions to match the display resolution (e.g., 4:2:0 CbCr = 960 x 540p -> 1920 x 1080p -> 3840 x 2160p).
Reply
(2015-04-25, 11:47)XTrojan Wrote:
(2015-04-24, 20:36)Warner306 Wrote:
(2015-04-24, 11:29)XTrojan Wrote: That's what i did, but the GUI of kodi + the subtitle service makes it superior if it'd work.
Didn't bother though as you need to choose "Intel Stereo Driver" as 3D renderer(not MadVR) which i can't find on Kodi.

I seem to have Judder or Tearing, can't tell but it's not a frame drop or repeat as that doesn't happen once in the movie, i should say this happens rarely though (maybe 5 times per movie)?

I tried using exclusive fullscreen + kodi fullscreen but as soon i close Kodi it freezes/crashes, i can once one of them fullscreen though, which one is to go to enable V-Sync?

Setup Is Intel HD 4600 With MadVR/Reclock/LAV Filters.

I bet you are going over the rendering queue, which is causing the frame dip. ReClock should eliminate frame repeats, but this sounds different. You have to be careful with your settings when using a low-powered GPU like the HD 4600. Make sure your rendering queues are in the 32-35 ms range.

fullscreen exclusive mode is not compatible with every graphics card. The best set-up for you might be to set Kodi to a true fullscreen and madVR to windowed mode. That could also eliminate the tearing.

Possibly, it's tearing that happens randomly, i'm running Bicubic 100.
Also, i got major artifacts frequently happening, i assume it's just Bicubic as it's common for it to cause artifacts?

Edit: I just noticed my AV has Video-processing on, could this be the cause?

Tearing and artifacts are not common to Bicubic image scaling or madVR. I would turn off any video processing that is not done by madVR or Kodi. This includes any processing done by the graphics card from its control panel. I would also try turning off hardware acceleration in LAV Video to see if that fixes the tearing.

Did you try setting Kodi to a true fullscreen and madVR to windowed mode? Also, are you looking at your rendering stats during playback (Cntrl+J)? Those stats will count presentation glitches and dropped frames as they happen. If these counters are not increasing during playback, then madVR is not at fault.
Reply
(2015-04-25, 21:53)Warner306 Wrote:
(2015-04-25, 11:47)XTrojan Wrote:
(2015-04-24, 20:36)Warner306 Wrote: I bet you are going over the rendering queue, which is causing the frame dip. ReClock should eliminate frame repeats, but this sounds different. You have to be careful with your settings when using a low-powered GPU like the HD 4600. Make sure your rendering queues are in the 32-35 ms range.

fullscreen exclusive mode is not compatible with every graphics card. The best set-up for you might be to set Kodi to a true fullscreen and madVR to windowed mode. That could also eliminate the tearing.

Possibly, it's tearing that happens randomly, i'm running Bicubic 100.
Also, i got major artifacts frequently happening, i assume it's just Bicubic as it's common for it to cause artifacts?

Edit: I just noticed my AV has Video-processing on, could this be the cause?

Tearing and artifacts are not common to Bicubic image scaling or madVR. I would turn off any video processing that is not done by madVR or Kodi. This includes any processing done by the graphics card from its control panel. I would also try turning off hardware acceleration in LAV Video to see if that fixes the tearing.

Did you try setting Kodi to a true fullscreen and madVR to windowed mode? Also, are you looking at your rendering stats during playback (Cntrl+J)? Those stats will count presentation glitches and dropped frames as they happen. If these counters are not increasing during playback, then madVR is not at fault.
To clarify, i don't use reclöck.It isn't caused by MadVR, It feels like an microstutter or frame drop(even though there's no frames dropped). Could it be that MadVR is not flushing the RAM/Refreshing the RAM or something similar?

I'm using Lanczos 4 and the artifacts only happen on very small places with two colors next to each other like this.

Image

I tried all of what you listed, but one thing i noticed was that Intel graphics was set to "Performance", i changed it to "Quality" and got some improvements but the issues still remain.

MadVR doesn't report anything wrong, i've tried Fullscreen with no effect, i've turned off video processing on both Kodi and the AVR. Software acceleration is on, hardware off.

Edit: I noticed that my audio output is the name of my TV and not my AVR? I'm currently using PC->AVR->TV.
Reply
(2015-04-25, 22:35)XTrojan Wrote:
(2015-04-25, 21:53)Warner306 Wrote:
(2015-04-25, 11:47)XTrojan Wrote: Possibly, it's tearing that happens randomly, i'm running Bicubic 100.
Also, i got major artifacts frequently happening, i assume it's just Bicubic as it's common for it to cause artifacts?

Edit: I just noticed my AV has Video-processing on, could this be the cause?

Tearing and artifacts are not common to Bicubic image scaling or madVR. I would turn off any video processing that is not done by madVR or Kodi. This includes any processing done by the graphics card from its control panel. I would also try turning off hardware acceleration in LAV Video to see if that fixes the tearing.

Did you try setting Kodi to a true fullscreen and madVR to windowed mode? Also, are you looking at your rendering stats during playback (Cntrl+J)? Those stats will count presentation glitches and dropped frames as they happen. If these counters are not increasing during playback, then madVR is not at fault.
To clarify, i don't use reclöck.It isn't caused by MadVR, It feels like an microstutter or frame drop(even though there's no frames dropped). Could it be that MadVR is not flushing the RAM/Refreshing the RAM or something similar?

I'm using Lanczos 4 and the artifacts only happen on very small places with two colors next to each other like this.

Image

I tried all of what you listed, but one thing i noticed was that Intel graphics was set to "Performance", i changed it to "Quality" and got some improvements but the issues still remain.

MadVR doesn't report anything wrong, i've tried Fullscreen with no effect, i've turned off video processing on both Kodi and the AVR. Software acceleration is on, hardware off.

Edit: I noticed that my audio output is the name of my TV and not my AVR? I'm currently using PC->AVR->TV.

It is difficult to tell what your problem might be. Lanczos4 is a very aggressive scaling algorithm. I would try Lanczos3 instead and see if the artifacts remain. What you are describing might be ringing from over-aggressive scaling. You shouldn't be scaling in linear light either, if that is checked. I would also uncheck all of the trade quality for performance checkboxes except for the one dealing with subtitles.

Try a different refresh rate and see if that is the issue. madVR's version of 3/2 pulldown is not that great, but it hasn't really bothered me. I've heard one person complain about 60hz playback before. Adding ReClock might make the problem better, but I doubt it. Outside of that, I don't know where to direct you. It sounds like you are going over the rendering queue a few times a movie. This has happened to me when 1080p movies don't match the target rectangle. I created a special profile in madVR to address these files as they would dip over 41 ms occasionally. Going over 41 ms will cause a stutter, but madVR will report the dropped frames.

Edit: I noticed you posted in another thread about using LumaSharpen. I would dump LumaSharpen and see if that improves matters. In my experience, artifacts will appear when using sharpening shaders.
Reply
(2015-04-26, 01:12)Warner306 Wrote:
(2015-04-25, 22:35)XTrojan Wrote:
(2015-04-25, 21:53)Warner306 Wrote: Tearing and artifacts are not common to Bicubic image scaling or madVR. I would turn off any video processing that is not done by madVR or Kodi. This includes any processing done by the graphics card from its control panel. I would also try turning off hardware acceleration in LAV Video to see if that fixes the tearing.

Did you try setting Kodi to a true fullscreen and madVR to windowed mode? Also, are you looking at your rendering stats during playback (Cntrl+J)? Those stats will count presentation glitches and dropped frames as they happen. If these counters are not increasing during playback, then madVR is not at fault.
To clarify, i don't use reclöck.It isn't caused by MadVR, It feels like an microstutter or frame drop(even though there's no frames dropped). Could it be that MadVR is not flushing the RAM/Refreshing the RAM or something similar?

I'm using Lanczos 4 and the artifacts only happen on very small places with two colors next to each other like this.

Image

I tried all of what you listed, but one thing i noticed was that Intel graphics was set to "Performance", i changed it to "Quality" and got some improvements but the issues still remain.

MadVR doesn't report anything wrong, i've tried Fullscreen with no effect, i've turned off video processing on both Kodi and the AVR. Software acceleration is on, hardware off.

Edit: I noticed that my audio output is the name of my TV and not my AVR? I'm currently using PC->AVR->TV.

It is difficult to tell what your problem might be. Lanczos4 is a very aggressive scaling algorithm. I would try Lanczos3 instead and see if the artifacts remain. What you are describing might be ringing from over-aggressive scaling. You shouldn't be scaling in linear light either, if that is checked. I would also uncheck all of the trade quality for performance checkboxes except for the one dealing with subtitles.

Try a different refresh rate and see if that is the issue. madVR's version of 3/2 pulldown is not that great, but it hasn't really bothered me. I've heard one person complain about 60hz playback before. Adding ReClock might make the problem better, but I doubt it. Outside of that, I don't know where to direct you. It sounds like you are going over the rendering queue a few times a movie. This has happened to me when 1080p movies don't match the target rectangle. I created a special profile in madVR to address these files as they would dip over 41 ms occasionally. Going over 41 ms will cause a stutter, but madVR will report the dropped frames.

Edit: I noticed you posted in another thread about using LumaSharpen. I would dump LumaSharpen and see if that improves matters. In my experience, artifacts will appear when using sharpening shaders.
I'll try disabling most "trade quality for performance" boxes and change to Lanczos 3.
Rendering isn't an issue as no frames get dropped.

Now that you mentioned 3/2 pulldown, if i always use 60Hz playback won't several frames get dropped since all my movies are 23.976Hz format?
Reply
(2015-04-26, 02:31)XTrojan Wrote:
(2015-04-26, 01:12)Warner306 Wrote:
(2015-04-25, 22:35)XTrojan Wrote: To clarify, i don't use reclöck.It isn't caused by MadVR, It feels like an microstutter or frame drop(even though there's no frames dropped). Could it be that MadVR is not flushing the RAM/Refreshing the RAM or something similar?

I'm using Lanczos 4 and the artifacts only happen on very small places with two colors next to each other like this.

Image

I tried all of what you listed, but one thing i noticed was that Intel graphics was set to "Performance", i changed it to "Quality" and got some improvements but the issues still remain.

MadVR doesn't report anything wrong, i've tried Fullscreen with no effect, i've turned off video processing on both Kodi and the AVR. Software acceleration is on, hardware off.

Edit: I noticed that my audio output is the name of my TV and not my AVR? I'm currently using PC->AVR->TV.

It is difficult to tell what your problem might be. Lanczos4 is a very aggressive scaling algorithm. I would try Lanczos3 instead and see if the artifacts remain. What you are describing might be ringing from over-aggressive scaling. You shouldn't be scaling in linear light either, if that is checked. I would also uncheck all of the trade quality for performance checkboxes except for the one dealing with subtitles.

Try a different refresh rate and see if that is the issue. madVR's version of 3/2 pulldown is not that great, but it hasn't really bothered me. I've heard one person complain about 60hz playback before. Adding ReClock might make the problem better, but I doubt it. Outside of that, I don't know where to direct you. It sounds like you are going over the rendering queue a few times a movie. This has happened to me when 1080p movies don't match the target rectangle. I created a special profile in madVR to address these files as they would dip over 41 ms occasionally. Going over 41 ms will cause a stutter, but madVR will report the dropped frames.

Edit: I noticed you posted in another thread about using LumaSharpen. I would dump LumaSharpen and see if that improves matters. In my experience, artifacts will appear when using sharpening shaders.
I'll try disabling most "trade quality for performance" boxes and change to Lanczos 3.
Rendering isn't an issue as no frames get dropped.

Now that you mentioned 3/2 pulldown, if i always use 60Hz playback won't several frames get dropped since all my movies are 23.976Hz format?

I thought you might be playing back in 60 hz already. I was suggesting changing the refresh rate to see if that was the problem.
Reply
Has anyone tried this with a N2820 Intel NUC or onwards models? Would love to read some results if anyone has tried!
Reply
(2015-04-26, 03:12)Warner306 Wrote:
(2015-04-26, 02:31)XTrojan Wrote:
(2015-04-26, 01:12)Warner306 Wrote: It is difficult to tell what your problem might be. Lanczos4 is a very aggressive scaling algorithm. I would try Lanczos3 instead and see if the artifacts remain. What you are describing might be ringing from over-aggressive scaling. You shouldn't be scaling in linear light either, if that is checked. I would also uncheck all of the trade quality for performance checkboxes except for the one dealing with subtitles.

Try a different refresh rate and see if that is the issue. madVR's version of 3/2 pulldown is not that great, but it hasn't really bothered me. I've heard one person complain about 60hz playback before. Adding ReClock might make the problem better, but I doubt it. Outside of that, I don't know where to direct you. It sounds like you are going over the rendering queue a few times a movie. This has happened to me when 1080p movies don't match the target rectangle. I created a special profile in madVR to address these files as they would dip over 41 ms occasionally. Going over 41 ms will cause a stutter, but madVR will report the dropped frames.

Edit: I noticed you posted in another thread about using LumaSharpen. I would dump LumaSharpen and see if that improves matters. In my experience, artifacts will appear when using sharpening shaders.
I'll try disabling most "trade quality for performance" boxes and change to Lanczos 3.
Rendering isn't an issue as no frames get dropped.

Now that you mentioned 3/2 pulldown, if i always use 60Hz playback won't several frames get dropped since all my movies are 23.976Hz format?

I thought you might be playing back in 60 hz already. I was suggesting changing the refresh rate to see if that was the problem.
Artifacts seem fixed, the stutter isn't Sad. The stutter happens randomly (usually once per 5min and on quick movements). Is 23.976 playback supposed to be like this since when i play 3D on Stereoscopic player everything feels smooth(it plays on 24P mode though and not 23P).

This issue for some reason doesn't appear on Stereoscopic player (Which uses CoreAVC 3D Decoder).

Edit: It's not max stats going over VSync limit either, da heck >_>. Lumasharpen isn't on.

Could it be audio related? I'm bitstreaming and have to put 275ms delay, otherwise lipsync will be out of order(this issue doesn't happen on Stereoscopic player, it plays them both perfectly synced together).

Edit2: This judder can't be MadVR or Intel HD, i'm gonna try to speed up the video to 25Hz and set refresh rate to 50 or 25.
Reply
(2015-04-26, 14:07)XTrojan Wrote:
(2015-04-26, 03:12)Warner306 Wrote:
(2015-04-26, 02:31)XTrojan Wrote: I'll try disabling most "trade quality for performance" boxes and change to Lanczos 3.
Rendering isn't an issue as no frames get dropped.

Now that you mentioned 3/2 pulldown, if i always use 60Hz playback won't several frames get dropped since all my movies are 23.976Hz format?

I thought you might be playing back in 60 hz already. I was suggesting changing the refresh rate to see if that was the problem.
Artifacts seem fixed, the stutter isn't Sad. The stutter happens randomly (usually once per 5min and on quick movements). Is 23.976 playback supposed to be like this since when i play 3D on Stereoscopic player everything feels smooth(it plays on 24P mode though and not 23P).

This issue for some reason doesn't appear on Stereoscopic player (Which uses CoreAVC 3D Decoder).

Edit: It's not max stats going over VSync limit either, da heck >_>. Lumasharpen isn't on.

Could it be audio related? I'm bitstreaming and have to put 275ms delay, otherwise lipsync will be out of order(this issue doesn't happen on Stereoscopic player, it plays them both perfectly synced together).

Edit2: This judder can't be MadVR or Intel HD, i'm gonna try to speed up the video to 25Hz and set refresh rate to 50 or 25.

I'm not sure. 24hz judder is always going to be present much like 3/2 pulldown. It is a myth that it is completely smooth because the framerate is quite low. But you may be describing something more serious. Try DVDPlayer (Context Menu -> Play Using). That would tell the story.

That audio delay makes it sound like your TV has a poor implementation of 24p playback. It is possible to have a delay but says bad things about the video lag created by your TV. I hope you are using Kodi to handle refresh rate changes and not madVR. I would try ReClock in this case, as it might improve the lip-sync issue in either bitstream or PCM playback. I have also discovered with my Samsung LED that 24p playback can be disappointing.

Sorry, I couldn't help wow you with the perfect A/V set-up. But, even with the best technology, compromises still exist and nothing is perfect. This is especially true with 24p playback.
Reply
(2015-04-26, 03:48)noonzascript Wrote: Has anyone tried this with a N2820 Intel NUC or onwards models? Would love to read some results if anyone has tried!

I have an Intel HD 3000 as a secondary computer. I use Chroma: Bicubic100 + AR, Luma: Lanczos3 + AR. All trade quality for performance checkboxes are left unchecked save the one relating to subtitles. The picture quality is superior to DVDPlayer but only by a small margin. Any upgrade in picture quality is welcome. I would install DSPlayer as there are few drawbacks. All upgrades are worth adding to your set-up.
Reply
(2015-04-26, 16:21)Warner306 Wrote:
(2015-04-26, 14:07)XTrojan Wrote:
(2015-04-26, 03:12)Warner306 Wrote: I thought you might be playing back in 60 hz already. I was suggesting changing the refresh rate to see if that was the problem.
Artifacts seem fixed, the stutter isn't Sad. The stutter happens randomly (usually once per 5min and on quick movements). Is 23.976 playback supposed to be like this since when i play 3D on Stereoscopic player everything feels smooth(it plays on 24P mode though and not 23P).

This issue for some reason doesn't appear on Stereoscopic player (Which uses CoreAVC 3D Decoder).

Edit: It's not max stats going over VSync limit either, da heck >_>. Lumasharpen isn't on.

Could it be audio related? I'm bitstreaming and have to put 275ms delay, otherwise lipsync will be out of order(this issue doesn't happen on Stereoscopic player, it plays them both perfectly synced together).

Edit2: This judder can't be MadVR or Intel HD, i'm gonna try to speed up the video to 25Hz and set refresh rate to 50 or 25.

I'm not sure. 24hz judder is always going to be present much like 3/2 pulldown. It is a myth that it is completely smooth because the framerate is quite low. But you may be describing something more serious. Try DVDPlayer (Context Menu -> Play Using). That would tell the story.

That audio delay makes it sound like your TV has a poor implementation of 24p playback. It is possible to have a delay but says bad things about the video lag created by your TV. I hope you are using Kodi to handle refresh rate changes and not madVR. I would try ReClock in this case, as it might improve the lip-sync issue in either bitstream or PCM playback. I have also discovered with my Samsung LED that 24p playback can be disappointing.

Sorry, I couldn't help wow you with the perfect A/V set-up. But, even with the best technology, compromises still exist and nothing is perfect. This is especially true with 24p playback.
I had same issue on DVDPlayer, it might be me being a perfectionist but i can notice it once per 5min or similar, what pisses me off is that Stereoscopic player doesn't have this issue at all.

I just tried reclock bitstreaming but with media correction on and playing at 24Hz, weirdly enough it seemed to fix some of the random judders without messing the audio up.

I have yet to watch a movie with this setup, but hoping it works.

Movie 23.976->24.000
Display->24.000
Lav Audio->A/V Sync on, bitstream on.

If this doesn't fix it then fuck it.
Reply
I must be doing something horribly wrong. I can't even get dsplayer to open. dvdplayer opens but not dsplayer. Tried on 2 different operating systems (both 8.1 x64). What am I doing wrong here. (I'm a newbie with Kodi btw)
Reply
(2015-04-26, 16:40)XTrojan Wrote:
(2015-04-26, 16:21)Warner306 Wrote:
(2015-04-26, 14:07)XTrojan Wrote: Artifacts seem fixed, the stutter isn't Sad. The stutter happens randomly (usually once per 5min and on quick movements). Is 23.976 playback supposed to be like this since when i play 3D on Stereoscopic player everything feels smooth(it plays on 24P mode though and not 23P).

This issue for some reason doesn't appear on Stereoscopic player (Which uses CoreAVC 3D Decoder).

Edit: It's not max stats going over VSync limit either, da heck >_>. Lumasharpen isn't on.

Could it be audio related? I'm bitstreaming and have to put 275ms delay, otherwise lipsync will be out of order(this issue doesn't happen on Stereoscopic player, it plays them both perfectly synced together).

Edit2: This judder can't be MadVR or Intel HD, i'm gonna try to speed up the video to 25Hz and set refresh rate to 50 or 25.

I'm not sure. 24hz judder is always going to be present much like 3/2 pulldown. It is a myth that it is completely smooth because the framerate is quite low. But you may be describing something more serious. Try DVDPlayer (Context Menu -> Play Using). That would tell the story.

That audio delay makes it sound like your TV has a poor implementation of 24p playback. It is possible to have a delay but says bad things about the video lag created by your TV. I hope you are using Kodi to handle refresh rate changes and not madVR. I would try ReClock in this case, as it might improve the lip-sync issue in either bitstream or PCM playback. I have also discovered with my Samsung LED that 24p playback can be disappointing.

Sorry, I couldn't help wow you with the perfect A/V set-up. But, even with the best technology, compromises still exist and nothing is perfect. This is especially true with 24p playback.
I had same issue on DVDPlayer, it might be me being a perfectionist but i can notice it once per 5min or similar, what pisses me off is that Stereoscopic player doesn't have this issue at all.

I just tried reclock bitstreaming but with media correction on and playing at 24Hz, weirdly enough it seemed to fix some of the random judders without messing the audio up.

I have yet to watch a movie with this setup, but hoping it works.

Movie 23.976->24.000
Display->24.000
Lav Audio->A/V Sync on, bitstream on.

If this doesn't fix it then fuck it.

Well, I'm glad you made it to the end. The only upgrade that could be recommended is a TV with a superior implementation of 24hz playback. I have some judder as well but I don't find it that annoying.

In the movie theatres, the projector has a shutter that opens and closes at high speeds, which creates the illusion that the video is moving at a framerate close to 48hz than 24hz. On a fixed display like a television, there is no shutter.
Reply
(2015-04-26, 20:47)AppData Wrote: I must be doing something horribly wrong. I can't even get dsplayer to open. dvdplayer opens but not dsplayer. Tried on 2 different operating systems (both 8.1 x64). What am I doing wrong here. (I'm a newbie with Kodi btw)

Did you follow the guide posted on the first page? It contains troubleshooting tips and step-by-step assistance with set-up.

I will take a guess that you installed 64-bit versions of each filter, but who knows.
Reply
No, they're 32. I finally got it working with lav and madvr, I'm still lost on how to get SVP and ffdshow going. - if that's possible.
Reply
  •   
  • 1
  • 20
  • 21
  • 22(current)
  • 23
  • 24
  • 509
  •   
 
Thread Rating:
  • 47 Vote(s) - 4.43 Average



Logout Mark Read Team Forum Stats Members Help
Kodi DSPlayer – DirectShow Player for Windows4.4347
This forum uses Lukasz Tkacz MyBB addons.