Kodi DSPlayer – DirectShow Player for Windows

  Thread Rating:
  • 35 Vote(s) - 4.49 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
MKANET Offline
Senior Member
Posts: 164
Joined: Mar 2015
Reputation: 3
Post: #4861
Kodi still crashes for me on video playback (fullscreen). I actually deleted my entire userdata folder (and Kodi Program Files folder before installing kodi-17.3-Krypton_DSPlayer-x64)...and, configured all my addons again. Kodi still crashes after I start video playback.

This is the first time Ive not been able to get DSPlayer to work at all on my HTPC since I first started using it a couple of years ago. What could be causing this? I'm not even sure where to start troubleshooting. Maybe a LAV Video or MadVR settings are somehow corrupted? The settings I looked correct from what I could tell in their property pages (same way they were configured before).

Thanks in advance. At this point I am willing to try anything except for reinstall my OS.
(This post was last modified: 2017-07-14 04:44 by MKANET.)
find quote
stoolzo Offline
Senior Member
Posts: 286
Joined: Aug 2013
Reputation: 3
Post: #4862
(2017-07-14 04:28)MKANET Wrote:  Kodi still crashes for me on video playback (fullscreen). I actually deleted my entire userdata folder (and Kodi Program Files folder before installing kodi-17.3-Krypton_DSPlayer-x64)...and, configured all my addons again. Kodi still crashes after I start video playback.

This is the first time Ive not been able to get DSPlayer to work at all on my HTPC since I first started using it a couple of years ago. What could be causing this? I'm not even sure where to start troubleshooting. Maybe a LAV Video or MadVR settings are somehow corrupted? The settings I looked correct from what I could tell in their property pages (same way they were configured before).

Thanks in advance. At this point I am willing to try anything except for reinstall my OS.

post your crash log.
find quote
ashlar Offline
Donor
Posts: 2,785
Joined: Mar 2006
Reputation: 48
Post: #4863
(2017-07-11 17:33)RBraverman Wrote:  Let me try to clarify, at this point, I do not want ANY decoder to decode anything BUT AAC. That is the only format that my receiver can not decode, this is why I use ac3filter, it decodes AAC to AC3 and outputs it to the receiver. Same layout only something it can decode. I could decode it and send it out, but I prefer to have a little S/W in between.

Now I understand, from reading (something I do on occasion Rofl) that LAV WILL decode it and send it along, but I can not get it to do so. BUT if there is a way to LAV do as you say it can, would you tell me how?

I have finally gotten the receiver to output the rear channels (too low an output), so I'm closer.

Is there a way to have both (not at the same time) LAV's and madVR's console pop up over the video playback so I can see what's what while the video is playing?

Again thank you.
Does your receiver decode FLAC multichannel? If so, tell me its brand as I'd be curious. In any case... as far as I know there should be no need for anything special.

It should be enough to have LAV Audio configured so as to bitstream everything that's "bitstreamable" and have AC3filter set up the same. If you have bitstreamable format it goes through both LAV and AC3filter untouched, for your decoder to decode it. If it's not bitstreamable, LAV decodes it to PCM, sends it to AC3filter which encodes it to AC3 in realtime and sends it to your receiver.

If this doesn't work... I'm out of ideas.

Edit: these "complications" are what prompted me to upgrade to an HDMI only solution as soon as possible, by the way. Smile

For troubleshooting and bug reporting please make sure you read this first.
(This post was last modified: 2017-07-14 15:11 by ashlar.)
find quote
Warner306 Offline
Posting Freak
Posts: 2,690
Joined: Feb 2014
Reputation: 92
Location: Canada
Post: #4864
(2017-07-13 11:59)mv-- Wrote:  Hi all!

My first post and best regards to everyone working on Kodi and DSPlayer! Best HTPC solution.

--

A question regarding DSPlayer 17.x versions and BDMV - is it supposed to work as is or something should be configured first?

I have a bunch of movies in BDMV structures (scrapper does find them correctly) and when trying to play them with a right click and selecting play main title from the context menu nothing happens.
m2ts files from BDMV stream directory are played correctly when selecting them directly from file browser.

Same behaviour with Kodi DSPlayer x86/x64 17.X versions on Win 8.1 laptop and Win10 CU HTPC. madVR/EVR and DSPlayer options seem to have no effect.

There is no BDMV support. Same with Blu-ray ISO. Have to set these to be played by VideoPlayer.
(This post was last modified: 2017-07-14 22:47 by Warner306.)
find quote
hunky-dory Offline
Junior Member
Posts: 1
Joined: Jul 2017
Reputation: 0
Post: #4865
(2017-03-01 05:49)Sayajin Wrote:  Just a bump to the below post. Any help would be appreciated!

-Sayajin

(2017-02-24 06:19)Sayajin Wrote:  So currently I am not using any Hardware acceleration at all in LAV. "None" is selected.

watch gallery


I have also previously disabled refresh rate switching in Kodi.

Warner, I have updated the display modes previously as well after reading a separate post by you.

watch gallery


Any other suggestions?

Also, regarding your question about refresh rate, I don't know if it is related, however for me to get videos to play in 60fps on the rare occasions they do play, I have to enter windowed mode and then back to full screen. I also still have the problem where about 10% of the right side of my screen is off of the display. Going to windowed mode and back fixes this as well. I have done the screen configuration and scaling options in Kodi with no success to fix this issue. I have added another log file below to show what happened. In this case, the video did play and I just had to go to windowed mode and back to get correct FPS and display scaling.

http://pastebin.com/mg49DcTR


-Sayajin


(2017-02-23 18:08)Warner306 Wrote:  Focus on madVR display modes and turn off refresh rate matching in Kodi. You want to add: 2160p23, 2160p24, 2160p50 and 2160p60.

I had the same problem and I solved it by switching the Windows resolution from "4k x 2k, 4096 x 2160" to "4k x 2k, 3840 x 2160"
find quote
goofer69 Offline
Junior Member
Posts: 7
Joined: Feb 2017
Reputation: 1
Post: #4866
(2017-07-14 22:46)Warner306 Wrote:  
(2017-07-13 11:59)mv-- Wrote:  Hi all!

My first post and best regards to everyone working on Kodi and DSPlayer! Best HTPC solution.

--

A question regarding DSPlayer 17.x versions and BDMV - is it supposed to work as is or something should be configured first?

I have a bunch of movies in BDMV structures (scrapper does find them correctly) and when trying to play them with a right click and selecting play main title from the context menu nothing happens.
m2ts files from BDMV stream directory are played correctly when selecting them directly from file browser.

Same behaviour with Kodi DSPlayer x86/x64 17.X versions on Win 8.1 laptop and Win10 CU HTPC. madVR/EVR and DSPlayer options seem to have no effect.

There is no BDMV support. Same with Blu-ray ISO. Have to set these to be played by VideoPlayer.

This may solve your problem. Go to System>>Settings>>Player>>Discs. In Blu-ray playback mode make sure "Play main movie" is selected. Then just select the movie and it should play w/DSPlayer if that is your default player. Works for me... ;^)
(This post was last modified: 2017-07-14 23:48 by goofer69.)
find quote
MKANET Offline
Senior Member
Posts: 164
Joined: Mar 2015
Reputation: 3
Post: #4867
Kodi Crash Log

EDIT: Here another log doing the same thing using a the default Estuary skin.
Kodi crash log #2

This is the entire log starting from Kodi app execute to playing a TV show file (and crashing)_

Thanks so much for looking into this!

(2017-07-14 11:58)stoolzo Wrote:  
(2017-07-14 04:28)MKANET Wrote:  Kodi still crashes for me on video playback (fullscreen). I actually deleted my entire userdata folder (and Kodi Program Files folder before installing kodi-17.3-Krypton_DSPlayer-x64)...and, configured all my addons again. Kodi still crashes after I start video playback.

This is the first time Ive not been able to get DSPlayer to work at all on my HTPC since I first started using it a couple of years ago. What could be causing this? I'm not even sure where to start troubleshooting. Maybe a LAV Video or MadVR settings are somehow corrupted? The settings I looked correct from what I could tell in their property pages (same way they were configured before).

Thanks in advance. At this point I am willing to try anything except for reinstall my OS.

post your crash log.
(This post was last modified: 2017-07-15 04:58 by MKANET.)
find quote
mv-- Offline
Junior Member
Posts: 2
Joined: Jul 2017
Reputation: 0
Post: #4868
(2017-07-13 21:49)invad3r Wrote:  @mv--
I think this can be solved by changing the default action for playing blurays within Kodi the menu somewhere. It should be something like 'play main movie'. I used to have this problem as well.

(2017-07-14 23:47)goofer69 Wrote:  This may solve your problem. Go to System>>Settings>>Player>>Discs. In Blu-ray playback mode make sure "Play main movie" is selected. Then just select the movie and it should play w/DSPlayer if that is your default player. Works for me... ;^)

Guys, thanks!
DSPlayer does play BD movies now.

How are you playing discs with several titles (e.g. TV shows)?

(2017-07-14 22:46)Warner306 Wrote:  There is no BDMV support. Same with Blu-ray ISO. Have to set these to be played by VideoPlayer.

Actually it seems that it does play BDMV! Only first title is played though but that's quite fine for most of my movies.
Still a pity that simplified Kodi menu with titles selection doesn't work. It would be really great if it will some day. Or maybe there is a way it could be set up with external splitters/filters/...?
find quote
Shogunreaper Offline
Senior Member
Posts: 240
Joined: Jan 2015
Reputation: 2
Post: #4869
does anyone else have a problem resuming video?

i can't get dsplayer to resume at all anymore, it is always starting the videos from the beginning. If i use the default kodi player it resumes perfectly every time though.

i'm using madvr for video renderer, sanear for audio and xysubfilter for subs.

can anyone help me fix this please?
(This post was last modified: 2017-07-16 16:37 by Shogunreaper.)
find quote
alturismo Offline
Senior Member
Posts: 102
Joined: Jul 2009
Reputation: 1
Location: Kaiserslautern, Germany
Post: #4870
Hi, just would like to ask if theres a way to use DSPlayer with EVR with tvheadend as backend server.

Or still only internal DVDPlayer the way to go ...

thanks ahead for a note.
find quote
stoolzo Offline
Senior Member
Posts: 286
Joined: Aug 2013
Reputation: 3
Post: #4871
(2017-07-15 04:46)MKANET Wrote:  Kodi Crash Log

EDIT: Here another log doing the same thing using a the default Estuary skin.
Kodi crash log #2

This is the entire log starting from Kodi app execute to playing a TV show file (and crashing)_

Thanks so much for looking into this!

(2017-07-14 11:58)stoolzo Wrote:  
(2017-07-14 04:28)MKANET Wrote:  Kodi still crashes for me on video playback (fullscreen). I actually deleted my entire userdata folder (and Kodi Program Files folder before installing kodi-17.3-Krypton_DSPlayer-x64)...and, configured all my addons again. Kodi still crashes after I start video playback.

This is the first time Ive not been able to get DSPlayer to work at all on my HTPC since I first started using it a couple of years ago. What could be causing this? I'm not even sure where to start troubleshooting. Maybe a LAV Video or MadVR settings are somehow corrupted? The settings I looked correct from what I could tell in their property pages (same way they were configured before).

Thanks in advance. At this point I am willing to try anything except for reinstall my OS.

post your crash log.

couple of things, dont use the 64 bit version, its buggy, its unnecessary as KODI doesnt need more than 4 gig of ram. Remove the 64 bit versions of LAV and MADVR as well, I'm also using LAV 68.1 still as later versions are a bit crashy, so i'm using:

go full 32 bit.

KODI DS 32 bit
LAV 68.1
MARVR v0.91.10:

smb://192.168.1.2/E$/TV/Fear the Walking Dead/Fear the Walking Dead - S03E07 - The Unveiling HDTV-720p.mkv)

are you playing over a network or locally?
(This post was last modified: 2017-07-17 00:46 by stoolzo.)
find quote
MKANET Offline
Senior Member
Posts: 164
Joined: Mar 2015
Reputation: 3
Post: #4872
Thanks for your help. Last night, my PC's OS was upgraded to the Win10 Creators update. I also updated my Nvidia driver to the latest WHQL driver. After that, I noticed that the issue completely disappeared! I'm not sure what specifically broke; but, it wasn't anything in Kodi. Whatever it was, it didn't affect anything else on the PC; not even MPC-HC using the same madvr settings and DS filters or any of my 3D games.

(2017-07-17 00:42)stoolzo Wrote:  
(2017-07-15 04:46)MKANET Wrote:  Kodi Crash Log

EDIT: Here another log doing the same thing using a the default Estuary skin.
Kodi crash log #2

This is the entire log starting from Kodi app execute to playing a TV show file (and crashing)_

Thanks so much for looking into this!

(2017-07-14 11:58)stoolzo Wrote:  post your crash log.

couple of things, dont use the 64 bit version, its buggy, its unnecessary as KODI doesnt need more than 4 gig of ram. Remove the 64 bit versions of LAV and MADVR as well, I'm also using LAV 68.1 still as later versions are a bit crashy, so i'm using:

go full 32 bit.

KODI DS 32 bit
LAV 68.1
MARVR v0.91.10:

smb://192.168.1.2/E$/TV/Fear the Walking Dead/Fear the Walking Dead - S03E07 - The Unveiling HDTV-720p.mkv)

are you playing over a network or locally?
find quote
stoolzo Offline
Senior Member
Posts: 286
Joined: Aug 2013
Reputation: 3
Post: #4873
(2017-07-17 02:40)MKANET Wrote:  Thanks for your help. Last night, my PC's OS was upgraded to the Win10 Creators update. I also updated my Nvidia driver to the latest WHQL driver. After that, I noticed that the issue completely disappeared! I'm not sure what specifically broke; but, it wasn't anything in Kodi. Whatever it was, it didn't affect anything else on the PC; not even MPC-HC using the same madvr settings and DS filters or any of my 3D games.

(2017-07-17 00:42)stoolzo Wrote:  
(2017-07-15 04:46)MKANET Wrote:  Kodi Crash Log

EDIT: Here another log doing the same thing using a the default Estuary skin.
Kodi crash log #2

This is the entire log starting from Kodi app execute to playing a TV show file (and crashing)_

Thanks so much for looking into this!

couple of things, dont use the 64 bit version, its buggy, its unnecessary as KODI doesnt need more than 4 gig of ram. Remove the 64 bit versions of LAV and MADVR as well, I'm also using LAV 68.1 still as later versions are a bit crashy, so i'm using:

go full 32 bit.

KODI DS 32 bit
LAV 68.1
MARVR v0.91.10:

smb://192.168.1.2/E$/TV/Fear the Walking Dead/Fear the Walking Dead - S03E07 - The Unveiling HDTV-720p.mkv)

are you playing over a network or locally?

thats good news, glad you've got it sorted, i'd defo movie to 32 bit portable though.
find quote
gotham_x Offline
Fan
Posts: 392
Joined: Jun 2014
Reputation: 1
Location: The City of Darkness _@_Italy_@_
Post: #4874
Bad news for those who use MPC-HC as an external player https://mpc-hc.org/2017/07/16/1.7.13-rel...-farewell/
find quote
stoolzo Offline
Senior Member
Posts: 286
Joined: Aug 2013
Reputation: 3
Post: #4875
crap, that really is bad news, hope MPC-BE doesnt go the same way.
find quote
Post Reply