•   
  • 1
  • 53
  • 54
  • 55(current)
  • 56
  • 57
  • 505
  •   
Kodi DSPlayer – DirectShow Player for Windows
Hi,

I've installed the DSplayer of KODI by Helix, version 14.2, and set It to use madVR, which works fine with MPC-HC, but here, when I click a file to play, nothing happens. It doesn't even matter whether I use madVR or EVR - video playback does not initiate, unless I turn DSplayer off.
Reply
(2015-06-27, 14:51)lanzorg Wrote:
Code:
Playlist Player: skipping unplayable item: 0, path [plugin://plugin.video.vimeo/play/?video_id=63892510]
Playlist Player: skipping unplayable item: 0, path [plugin://plugin.video.youtube/play/?video_id=mO42yf0lU1o]

I've got this, there is a problem to play url with "plugin" protocol.
By plugin protocol, does it mean flash player? If yes, how to bind it with dsplayer just like dvdplayer?

have you tried to ad "plugin" to the protocols listed in mediasconfig? probably this will not work but i would try that, sorry i cant help you there...

edit:
it seems it is a "virtual directory" http://mirrors.xbmc.org/docs/python-docs...lugin.html
how does kodi.log looks like if you play the same video with kodis internal dvdplayer?
Reply
(2015-06-27, 17:41)Ed76 Wrote: have you tried to ad "plugin" to the protocols listed in mediasconfig? probably this will not work but i would try that, sorry i cant help you there...

Yes, but it doesn't work.

(2015-06-27, 17:41)Ed76 Wrote: How does kodi.log looks like if you play the same video with kodis internal dvdplayer?

This is with vimeo:

Code:
DVDPlayer: Opening: https://player.vimeo.com/play/157633989?s=63892510_1435430485_1c15cd3661d473b4c5cb8672a52b5673&oauth_token_id=

This is with the youtube live:

Code:
DVDPlayer: Opening: https://manifest.googlevideo.com/api/manifest/hls_playlist/id/mO42yf0lU1o.1/itag/94/source/yt_live_broadcast/requiressl/yes/ratebypass/yes/live/1/cmbypass/yes/gir/yes/dg_shard/bU80MnlmMGxVMW8uMQ.94/hls_chunk_host/r3---sn-cxab5jvh-cg0k.googlevideo.com/gcr/be/pmbypass/yes/playlist_type/DVR/mm/32/mn/sn-cxab5jvh-cg0k/ms/lv/mv/m/pl/16/dover/2/fexp/901816,9407141,9408142,9408420,9408710,9413503,9416137,9416456,952640/upn/iAWxSfqTLs0/rcc/1/sver/3/mt/1435423446/ip/83.134.120.190/ipbits/0/expire/1435445103/sparams/ip,ipbits,expire,id,itag,source,requiressl,ratebypass,live,cmbypass,gir,dg_shard,hls_chunk_host,gcr,pmbypass,playlist_type,mm,mn,ms,mv,pl/signature/5DF00BFAD3C52348E7EFC410D7287544FE77FE11.285A3E7EE898B41BC8C0ADA23A9795C7EBD4464F/key/dg_yt0/playlist/index.m3u8

I don't know why dsplayer use the plugin protocol...
Reply
i really dont know what you can do there. i guess there are changes to dsplayer necessary to get such kinds of internetstreams to work with dsplayer.
Reply
(2015-06-27, 15:22)yonyz Wrote: Hi,

I've installed the DSplayer of KODI by Helix, version 14.2, and set It to use madVR, which works fine with MPC-HC, but here, when I click a file to play, nothing happens. It doesn't even matter whether I use madVR or EVR - video playback does not initiate, unless I turn DSplayer off.

Did you follow the instructions in the set-up guide? You need to install the DSPlayer Starter Kit and go over each filter (particularly, XySubFilter) to ensure it was installed correctly.
Reply
Ok, i've made some tests, and i'm still unable to get the correct audio expected behavior (audio receiver connected to PC by HDMI).
(a) : Supported format by audio receiver send passthroguh by HDMI to be decoded by receiver.
(b) : Unsupported format decoded by PC and send by HMDI to receiver in PCM, with number of channels fitting the number of channel of the file, not the speaker configuration.

I was said to use reclock for that, because when tested without, unable to get (b) working properly.
So, i've used reclock in 'wasapi excluside', because in dvdplayer, it's with 'wasapi' that (a) & (b) work properly.
But, in that case, at least half of my test files generate an 'unsupported audio' error message. I was told to use 'wave out', so, i've tested. The error message indeed disaperead, but the (b) feature is not working. The number of PCM channels are those of the speakers, not the number of channels of the file.

So, my question is : How do i have to configure the dsplayer to have audio behave properly ? Is it even possible ? Because for now, i've the feeling it's not...
Reply
The Trak.TV addon stops working if DSPlayer enabled. Any ideas to get it working again with DSPlayer? I'm pretty sure this is reproducible on other setups.

Specifically, Trak.TV plugin will startup and synch when Kodi starts... however, it won't prompt for rating after a Movie/TV show is completed. The only way to do that is to disable DSPlayer.

PS: I also asked earlier; but, got no response. Where's the setting in DSPlayer to reduce the several second delay when Fullscreen Exclusive is enabled (regardless of the side-effects)?
Reply
(2015-06-29, 00:27)MKANET Wrote: The Trak.TV addon stops working if DSPlayer enabled. Any ideas to get it working again with DSPlayer? I'm pretty sure this is reproducible on other setups.

Specifically, Trak.TV plugin will startup and synch when Kodi starts... however, it won't prompt for rating after a Movie/TV show is completed. The only way to do that is to disable DSPlayer.

PS: I also asked earlier; but, got no response. Where's the setting in DSPlayer to reduce the several second delay when Fullscreen Exclusive is enabled (regardless of the side-effects)?

I also use Trakt. The plugin works fine, but you cannot rate shows after watching them.

I am not sure about Fullscreen exclusive mode. If you have a Doom9 account, I'd ask there. Have you tried toggling the switch refresh rate before playback option under Video -> Playback?
Reply
(2015-06-28, 20:41)jpsdr Wrote: Ok, i've made some tests, and i'm still unable to get the correct audio expected behavior (audio receiver connected to PC by HDMI).
(a) : Supported format by audio receiver send passthroguh by HDMI to be decoded by receiver.
(b) : Unsupported format decoded by PC and send by HMDI to receiver in PCM, with number of channels fitting the number of channel of the file, not the speaker configuration.

I was said to use reclock for that, because when tested without, unable to get (b) working properly.
So, i've used reclock in 'wasapi excluside', because in dvdplayer, it's with 'wasapi' that (a) & (b) work properly.
But, in that case, at least half of my test files generate an 'unsupported audio' error message. I was told to use 'wave out', so, i've tested. The error message indeed disaperead, but the (b) feature is not working. The number of PCM channels are those of the speakers, not the number of channels of the file.

So, my question is : How do i have to configure the dsplayer to have audio behave properly ? Is it even possible ? Because for now, i've the feeling it's not...

Does the behaviour you are looking for work under mpc-hc?
Reply
Ok got all the movies etc bit working with DSPlayer
Can't for the life of me get pvr (from epg) to work with DSPlayer
What should go in the playercorefactory.xml and mediasconfig.xml?

Have added
<rule protocols="pvr" player="DSPlayer" />
to playercorefactory.xml

Also added
<rule protocols="pvr">
<source filter="lavsource" />
<splitter filter="lavsplitter" />
<video filter="lavvideo" />
<audio filter="lavaudio" />
</rule>
to mediasconfig.xml

But as far as I can tell the "pvr" rule is not being invoked
And instead the following catch all rule is being invoked
<rule filetypes=".*">
<source filter="lavsource" />
<splitter filter="lavsplitter" />
<video filter="lavvideo" />
<audio filter="lavaudio" />
</rule>

This is on 14.2

Relevant bits of the log
00:02:04 T:7368 DEBUG: Found audio renderer device "Speakers (LynxTWO-B)" (guid: {E30629D1-27E5-11CE-875D-00608CB78066})
00:02:04 T:7368 DEBUG: Found audio renderer device "ReClock Audio Renderer" (guid: {9DC15360-914C-46B8-B9DF-BFE67FD36C6A})
00:02:04 T:7368 DEBUG: Found audio renderer device "Default DirectSound Device" (guid: {79376820-07D0-11CF-A24D-0020AFD79767})
00:02:04 T:7368 DEBUG: Found audio renderer device "Default WaveOut Device" (guid: {E30629D1-27E5-11CE-875D-00608CB78066})
00:02:04 T:7368 DEBUG: Found audio renderer device "DirectSound: Speakers (LynxTWO-B)" (guid: {79376820-07D0-11CF-A24D-0020AFD79767})
00:02:04 T:7368 INFO: CFGLoader::InsertAudioRenderer Loaded audio renderer list. Elapsed time: 32.44ms
00:02:04 T:7368 INFO: CFGLoader::InsertAudioRenderer Loaded audio renderer from registry. Elapsed time: 40.12ms
00:02:04 T:7368 INFO: CFGLoader::InsertAudioRenderer Added audio renderer to the graph. Elapsed time: 0.36ms
00:02:04 T:7368 NOTICE: CFGLoader::InsertAudioRenderer Successfully added "" to the graph
00:02:04 T:7368 INFO: CFGLoader::LoadFilterRules Loading audio renderer. Elapsed time: 82.09ms
00:02:04 T:7368 DEBUG: CRenderManager::UpdateDisplayLatency - Latency set to 0 msec
00:02:04 T:7368 DEBUG: CFGFilterVideoRenderer::Create Allocator presenter successfully created
00:02:04 T:7368 DEBUG: CFGLoader::InsertVideoRenderer Allocator presenter successfully added to the graph (Renderer: )
00:02:04 T:7368 INFO: CFGLoader::LoadFilterRules Loading video renderer. Elapsed time: 95.63ms
00:02:04 T:7368 DEBUG: CFilterSelectionRule::GetFilters: adding filter: lavsource for rule: un-named
00:02:04 T:7368 DEBUG: CFGFilterFile::Create Successfully loaded external filter (clsid:{B98D13E7-55DB-4385-A33D-09FD1BA26338} path:C:\Program Files (x86)\LAV Filters\x86\LAVSplitter.ax)
00:02:04 T:7368 NOTICE: CFGLoader::InsertFilter Successfully added "LAV Source" to the graph
00:02:04 T:7368 ERROR: CFGLoader::InsertSourceFilter Failed to load file in the splitter/source
00:02:04 T:7368 ERROR: CFGLoader::LoadFilterRules Failed to insert the source filter
00:02:04 T:7368 ERROR: CFGManager::RenderFileXbmc Failed to load filters rules
00:02:04 T:7368 INFO: CDSGraph::SetFile Rendering file. Elapsed time: 217.26ms
00:02:04 T:7368 INFO: CDSPlayer:Tonguerocess Loading file. Elapsed time: 247.84ms
00:02:04 T:7368 ERROR: CDSPlayer:Tonguerocess - Failed creating DS Grap
Reply
you need the other build of DSPlayer. it's a few pages back. The one from this thread doesn't do pvr as it is.
Reply
(2015-06-29, 15:32)spencerjford Wrote: Does the behaviour you are looking for work under mpc-hc?

I don't know. As it's working with dvdplayer, i was expecting it working with dsplayer, as i always thought dsplaye was "more" than dvdplayer, or at least equal.
I'm surprised no one until now never asked for this behavior, or at least it's the feeling i have (maybe i'm wrong). Anyone who have an audio receiver will expect this behavior, for exemple, if audio in source file is 2.0, to have the receiver detect dolby surrond (if there is), and act as expected. This is possible only if 2 channels are send to receiver.
To resume basicaly : Allow/let the audio receiver do all his audio stuff. This is possible only if player behaves like i've described.

If what i'm expecting is unfortunately not possible with dsplayer, so be it...
Reply
(2015-06-29, 20:18)jpsdr Wrote:
(2015-06-29, 15:32)spencerjford Wrote: Does the behaviour you are looking for work under mpc-hc?

I don't know. As it's working with dvdplayer, i was expecting it working with dsplayer, as i always thought dsplaye was "more" than dvdplayer, or at least equal.
I'm surprised no one until now never asked for this behavior, or at least it's the feeling i have (maybe i'm wrong). Anyone who have an audio receiver will expect this behavior, for exemple, if audio in source file is 2.0, to have the receiver detect dolby surrond (if there is), and act as expected. This is possible only if 2 channels are send to receiver.
To resume basicaly : Allow/let the audio receiver do all his audio stuff. This is possible only if player behaves like i've described.

If what i'm expecting is unfortunately not possible with dsplayer, so be it...

Set-up ReClock as below. Make sure Set matching speaker configuration is unchecked for two channel sources. With WASAPI Exclusive enabled, you should get proper audio behavior with all sources.

I would recommend bitstreaming for bit perfect playback, but PCM can be used to eliminate any frame drops due to the slight loss of synchronization that occurs between the different clocks in a computer.

Image
Reply
Thanks. It was almost allready exactly the same configuration i've allready tried, except maybe... the pcm output configuration, which may be the only thing which can explain the "unsupported audio format" error i have on around half of my test files.
Ok, PCM output was "same as input". I think the error message came from this bad setting from my side.
Reply
Ok, i've been able to make more test, all my test files passed ok, except... vfr files.
dvdplayer has an internal algorithm to detect frame rate of video file "on the fly", allowing it to adjust/change the display if the 1rst selected frame rate finaly wasn't the good one (it can happen).
I've personnaly improved this algorithm for the case of vfr (and my pr was allowed in the main branch), locking the player on the highest frame rate detected, which is the better way to properly play this kind of file.
I think this feature is specific to dvdplayer. The test files i've played with dsplayer (video madvr and audio reclock) haven't been able to be displayed properly. I've seen that on reclock you can select an fps when it's unknow, but it's not good enough.
In my test files i've one file with exotic structure : Op/Ed are at 30fps, episode at 24pfs. dvdplayer lock on 30fps and display properly, unable to display properly with dsplayer. The other one is a true vfr file, but based on 29.97fps. dvdplayer lock on 29.97fps, and display properly, unable to display properly with dsplayer.

I know it's exoctic cases (and vfr files are pain in the ass !), and the feature is i think too much internal in dvdplayer and can't probably not be implemented in dsplayer, but unfortunately it's a feature i personnaly need.

Thanks anyway for everyone help, and good luck for the future.
Reply
  •   
  • 1
  • 53
  • 54
  • 55(current)
  • 56
  • 57
  • 505
  •   
 
Thread Rating:
  • 47 Vote(s) - 4.43 Average



Logout Mark Read Team Forum Stats Members Help
Kodi DSPlayer – DirectShow Player for Windows4.4347