•   
  • 1
  • 82
  • 83
  • 84(current)
  • 85
  • 86
  • 495
  •   
Kodi DSPlayer – DirectShow Player for Windows
(2015-08-26, 20:53)bigadevry Wrote: Since it looks like EVR is out (my current config using FFDshow profiles) can someone who knows this new architecture and filter config do a new or current "How To setup" kind of post or document? I like the new improvements, path, and decisions. I am just not familiar with how to setup a proper config. Curerntly, I am at 1080p (use EVR, FFDShow, LAV for non 1080p mostly). I do plan to upgrade my hardware to 4K in the future and not have anything on my server below 720p (some shows only available this way). I feel upscaling anything else is a waste. So, any help is appreciated as I plan my overall upgrade and jump to the new platforms. Thanks again for all the hard work!

I just updated the DSPlayer/madVR set-up guide for this version of DSPlayer. It is very detailed and complex, but it has all the information necessary to set-up the new filters/renderer to your hardware: 222576 (thread).
Reply
(2015-08-27, 23:39)aracnoz Wrote:
(2015-08-26, 21:09)oldpoem Wrote: I'm not sure what's wrong with subtitles add-on. But with this build subtitle download dialog didn't show up when pressed. Video paused but not crashed I can press back button to go back to video. But can't download subtitles (I'm using Subscene & Opensubtitles)

are you able to reproduce this with all the skins? have you tried confluence?

I'm on confluence. Haven't installed other skins lately. I can play file with dvdplayer and download subtitles normally just not with DSplayer.
Reply
Regarding fullscreen exclusive for Kodi, one might want to still use DVDPlayer for DVD ISOs, web streams...

Answering aracnoz's question on why it could be needed. Smile
For troubleshooting and bug reporting please make sure you read this first.
Reply
One thing that I don't know if it could be fixed. If you select "display mode for 4:3 video" as Wide Zoom, subtitles end up being rendered outside the windows (as Kodi stretches the video and madVR complies to the request).
For troubleshooting and bug reporting please make sure you read this first.
Reply
Warner306 ~ Thanks so much for that!! I saw the updated material while I was at work doing some lunch time "research" and formulating my plan. I am currently using the integrated Intel graphics and I am trying to decide / wait on the new generation of UHD HDR compliant video cards. Your guide is awesome and I read it over an over. Thanks again!
Reply
@aracnoz, new debug log, now using new version Isengard dsplayer + dx11.

DSPlayer 15.1 Isengard DX11 - build (20150826-66c524b)

http://pastebin.com/mtZrcq5H

Have same troubles version Jarvis, happen when playing video and come back to home, screen blinking a lot.
MediaBrazil forum Website - Youtube Channel
Aeon MQ8 & Ace2-1.5.1 Skin Team
MarcosQui Website Donate and support us.
Reply
The new one broke my previous configurations, luckily, I backed up the Kodi folder in Roaming. I'll have to wait on a good tutorial to configure the new one, I hope I can use ffdshow so I can use SVP.
Reply
(2015-08-27, 23:39)aracnoz Wrote: there was some problem related to the internal lav splitter i already fixed this, soon i will post a test build to have a confirmation

Thank you so much!
Reply
(2015-08-27, 23:39)aracnoz Wrote: [
(2015-08-27, 15:00)oldpainless Wrote: Great work with DX11 version.

However, if I try to play a file in true fullscreen (with or without MadVR fullscreen exclusive), Kodi crashes and goes to a black screen and I have to reset my machine. Fake fullscreen works.

Also, in the previous version, H.265 content played flawlessly. With the DX11 version the motion is jerky with reported repeated frames (madvr). Going back to the previous Kodi Dsplayer it's fine,

Any thoughts?

win 8.1, GTX 770, latest Madvr.

i don't know about h265 i have not idea at moment on this

i'm able to reproduce the issue with kodi in fullscreen exclusive mode, but my question is, it's really important to have kodi in fullscreen exclusive mode? this will cause only problems because if kodi it's in exclusive mode the madvr's window cannot show up, so for each playstart you should to exit from kodi exclusive mode, change the refresh, then enter in exclusive mode with madvr, this was working with in dx9 i have to check what happens in dx11 but for me have no sense to have kodi in fullscreen exclusive mode if you have no intention to play any video with the internal DVDPlayer

Update - I reinstalled the DX11 version, but on install unticked everything apart from the main Kodi install, and it could be just coincedence but H.265 is now playing back fine. Still have to use fake fullscreen, but as you say, you are looking into it.

Great job.
Sapphire RX 5700 XT (19.9.2)  Ryzen 7 3700x, PRIME X570-Pro, Win 10 x64 (1903), Silverstone LC13B-E, Pioneer SC-LX501 Elite D3, Samsung UE55KS8000, Mission M33i speakers, Kodi Dsplayer 17.6 X64
Reply
(2015-08-28, 01:02)oldpoem Wrote:
(2015-08-27, 23:39)aracnoz Wrote:
(2015-08-26, 21:09)oldpoem Wrote: I'm not sure what's wrong with subtitles add-on. But with this build subtitle download dialog didn't show up when pressed. Video paused but not crashed I can press back button to go back to video. But can't download subtitles (I'm using Subscene & Opensubtitles)

are you able to reproduce this with all the skins? have you tried confluence?

I'm on confluence. Haven't installed other skins lately. I can play file with dvdplayer and download subtitles normally just not with DSplayer.

i need more details because it's really crazy this thing, how do you download the subs? by clicking here?

Image

(2015-08-28, 03:58)Wanilton Wrote: @aracnoz, new debug log, now using new version Isengard dsplayer + dx11.

DSPlayer 15.1 Isengard DX11 - build (20150826-66c524b)

http://pastebin.com/mtZrcq5H

Have same troubles version Jarvis, happen when playing video and come back to home, screen blinking a lot.

Code:
12:07:46 T:1048  NOTICE: Running on Gigabyte Technology Co., Ltd. Z97X-UD3H with Windows 10, kernel: Windows NT x86 64-bit version 10.0
12:07:46 T:1048  NOTICE: Host CPU: Intel(R) Core(TM) i5-4690 CPU @ 3.50GHz, 4 cores available

this is one of my machines and there is no problem using the integrated intel gpu, pls i need that you performs some test and then answer to some question as already said to Warner306

aracnoz Wrote:when the blinking happens it's like a corruption or just like a window that disappear and reappear?

are you able to reproduce with both, madVR presentation dx11(present a frame for every vsync enabled/disabled) and dx9?

can you see if there is any improvement changing the value in madVR rendering windowed mode/ exclusive mode settings "when and how shall the GPU flushed"

you should try to change GPU flush values when the blink occurs not before playback

are you able to reproduce only with the Intel GPU?

maybe you can also try to see if it's relevant the video refresh different from 60hz

the only problem that i have with this build it's with madVR set with the presentation in dx11 in windowed mode and with a refresh different from 60hz, but with this situation i have a lot of presentation glitches, nothing that could be blinking

(2015-08-28, 07:42)AppData Wrote: The new one broke my previous configurations, luckily, I backed up the Kodi folder in Roaming. I'll have to wait on a good tutorial to configure the new one, I hope I can use ffdshow so I can use SVP.

i'm sorry but with the next release the dsplayer databse will updated again because i'm testing a new features to save default settings also for tvshows

Image
Reply
What a good idea the TVShows profiles.
HTPC
Silverstone Grandia GD05 - Intel i5 3570k -Asus H61M-G Micro-ATX - Unidad Blu-ray
MSI GTX970 4GB GDDR5 - 8 GB RAM DDR3 - AVR Denon X3400H Atmos - LG  OLED 55C7V
Reply
(2015-08-28, 07:42)AppData Wrote: The new one broke my previous configurations, luckily, I backed up the Kodi folder in Roaming. I'll have to wait on a good tutorial to configure the new one, I hope I can use ffdshow so I can use SVP.

Okay, I finally figured out the new version and got the ffdshow working again and now have SVP, beautiful picture now!
Reply
(2015-08-28, 00:49)Warner306 Wrote:
(2015-08-27, 22:41)vmax Wrote: Just tried the new version, all works great except for one small detail that I found that really throws my audio out of sync on standard def mkv rips. The lav audio setting Enable Audio Delay can not be removed. I don't see a control in the GUI settings for it, so I take out the check mark with the open the properties sheet link and remove it, but as soon as I run a video it puts it back. There is no way to save the change to remote it.

Other than that this version of Kodi DS Player is BY FAR the BEST version I have ever used!

Thanks for all the programmers involved it bringing us this incredible piece of software!!

The only way I can do it is to set Manage Settings with Kodi set to Never which really defeats the purpose...

If the audio delay is 0, this setting does nothing. I doubt this setting is to blame.

Well, I don't know what to tell you but as soon as I uncheck that option my delay disappears completely. When checked with 0 (default) and I play the video the delay is so great that even using the gui sound setting I can't fix it. But as soon as I uncheck that box, no delay. The weird thing is that it doesn't seem to affect 720 or 1080 encodes...

Anyway I found a work around, I used the other option in the DSPlayer settings (Media rules and filters configuration) and that lets me run without the offending option and all works as it did before with the new features. So all is good, just thought I would mention it, no other issues for me it is very stable.
Reply
(2015-08-28, 23:38)vmax Wrote: Well, I don't know what to tell you but as soon as I uncheck that option my delay disappears completely. When checked with 0 (default) and I play the video the delay is so great that even using the gui sound setting I can't fix it. But as soon as I uncheck that box, no delay. The weird thing is that it doesn't seem to affect 720 or 1080 encodes...

Anyway I found a work around, I used the other option in the DSPlayer settings (Media rules and filters configuration) and that lets me run without the offending option and all works as it did before with the new features. So all is good, just thought I would mention it, no other issues for me it is very stable.

with the current version of DSPlayer the delay settings in LavAudio it's always enabled, also with media rules, so there will be another reason for this strangeness

can you provide a sample of one of these problematic files?
Reply
I have a Problem with the new DSPlayer Version (DX11)
I only got a Playback Window (no Fullscreen Mode) and i have no Control (no OSD, cant Stop it) ... must shut down Playback Window with Taskmanager !

Version 15.1 RC1 works fine ?
Reply
  •   
  • 1
  • 82
  • 83
  • 84(current)
  • 85
  • 86
  • 495
  •   
 
Thread Rating:
  • 46 Vote(s) - 4.41 Average



Logout Mark Read Team Forum Stats Members Help
Kodi DSPlayer – DirectShow Player for Windows4.4146