•   
  • 1
  • 90
  • 91
  • 92(current)
  • 93
  • 94
  • 496
  •   
Kodi DSPlayer – DirectShow Player for Windows
(2015-09-06, 01:25)a5ian300zx Wrote:
(2015-09-05, 12:13)aracnoz Wrote:
(2015-09-05, 08:50)a5ian300zx Wrote: Thanks for that but each time i play anything I just get blank screen with no video or sound until I disable dsplayer which then plays back files but with a stutter on top of the video like a single line.

But plays back fine or the original 15.1 version.

Thanks

i think that you have not http://madshi.net/madVR.zip properly installed on your system, anyway you should provide a debug log, all information on how to do that are at first page under "How to help:"

Ok I went through the manual setup as posted in the quite and still just get blank screen each time I play a media file and I can't do nothing else unless I reboot the system.

That is with dsplayer enabled.

here is the debug log.

Debug log

Many Thanks

In Kodi, system settings, have you selected use fullscreen window?
Sapphire RX 5700 XT (19.9.2)  Ryzen 7 3700x, PRIME X570-Pro, Win 10 x64 (1903), Silverstone LC13B-E, Pioneer SC-LX501 Elite D3, Samsung UE55KS8000, Mission M33i speakers, Kodi Dsplayer 17.6 X64
Reply
(2015-09-06, 01:25)a5ian300zx Wrote: Ok I went through the manual setup as posted in the quite and still just get blank screen each time I play a media file and I can't do nothing else unless I reboot the system.

That is with dsplayer enabled.

here is the debug log.

Debug log

Many Thanks

in this debug log there isn't any attempts to open a file, only videoinfoscanner
there should be

Code:
10:09:30 T:4344   DEBUG: CGUIWindowVideoBase::OnPlayMedia
10:09:30 T:4344  NOTICE: CDSPlayer::OpenFile - DSPlayer: Opening:
10:09:30 T:4344  NOTICE: CDSPlayer::OpenFileInternal - DSPlayer: Opening:

in the case of opening a file by the webserver

Code:
10:12:10 T:6464   DEBUG: webserver: request received for /jsonrpc?Player.Open

but there is nothing in your debug log, if you are sure that this it's the debug.log with all your attemps you should tell me how you are trying to open a file

p.s.

it's better to enable the debug mode directly from the advancedsettings.xml file placed in your %appdata%/kodi/userdata and not from the GUI

Code:
<advancedsettings>
    <loglevel>1</loglevel>
</advancedsettings>
Reply
(2015-09-06, 09:07)oldpainless Wrote:
(2015-09-06, 01:25)a5ian300zx Wrote:
(2015-09-05, 12:13)aracnoz Wrote: i think that you have not http://madshi.net/madVR.zip properly installed on your system, anyway you should provide a debug log, all information on how to do that are at first page under "How to help:"

Ok I went through the manual setup as posted in the quite and still just get blank screen each time I play a media file and I can't do nothing else unless I reboot the system.

That is with dsplayer enabled.

here is the debug log.

Debug log

Many Thanks

In Kodi, system settings, have you selected use fullscreen window?
Yes, it was in the guide. I will try with it off and test again.
TV: Sony  65" A1E Surround: Yamaha RXA-3050 + ORB Audio Mod2 7.1.2 + SVS SB12-NSD Sub Processor: Darbee + DVDO iScan Mini Players: HDI Dune Solo4K + Apple TV4K + Vu+ Ultimo 4K NAS: Qnap TVS 871 Pro i7 16GB Ram 10GBe
Reply
(2015-09-06, 10:17)aracnoz Wrote:
(2015-09-06, 01:25)a5ian300zx Wrote: Ok I went through the manual setup as posted in the quite and still just get blank screen each time I play a media file and I can't do nothing else unless I reboot the system.

That is with dsplayer enabled.

here is the debug log.

Debug log

Many Thanks

in this debug log there isn't any attempts to open a file, only videoinfoscanner
there should be

Code:
10:09:30 T:4344   DEBUG: CGUIWindowVideoBase::OnPlayMedia
10:09:30 T:4344  NOTICE: CDSPlayer::OpenFile - DSPlayer: Opening:
10:09:30 T:4344  NOTICE: CDSPlayer::OpenFileInternal - DSPlayer: Opening:

in the case of opening a file by the webserver

Code:
10:12:10 T:6464   DEBUG: webserver: request received for /jsonrpc?Player.Open

but there is nothing in your debug log, if you are sure that this it's the debug.log with all your attemps you should tell me how you are trying to open a file

p.s.

it's better to enable the debug mode directly from the advancedsettings.xml file placed in your %appdata%/kodi/userdata and not from the GUI

Code:
<advancedsettings>
    <loglevel>1</loglevel>
</advancedsettings>
I did it through the kodi log uploader plug in, but will do it manually and post again.

When I select the movie it's says buffering on the top left corner then screen goes blank.

It's like it does not select the dsplayer. Stupid question but dsplayer is built into the build available on the first page? Or do I need to download and install a seperate external player?

Thanks
TV: Sony  65" A1E Surround: Yamaha RXA-3050 + ORB Audio Mod2 7.1.2 + SVS SB12-NSD Sub Processor: Darbee + DVDO iScan Mini Players: HDI Dune Solo4K + Apple TV4K + Vu+ Ultimo 4K NAS: Qnap TVS 871 Pro i7 16GB Ram 10GBe
Reply
Hi,

here is the new log with manual logging enabled.

i5 Nuc Debug - Blank DSplayer

EDIT: just add dsplayer manually in advance settings advancesettings still the same issue and even tried to fo to the file and pressed C for menu and it says default player dsplayer so tried that and same issue then i tried the dvdplayer and worked fine.

which version of windows are you guys running?

I am on windows 8.1 pro, shall I update to the latest intel drivers from the intel site?

Many Thanks
TV: Sony  65" A1E Surround: Yamaha RXA-3050 + ORB Audio Mod2 7.1.2 + SVS SB12-NSD Sub Processor: Darbee + DVDO iScan Mini Players: HDI Dune Solo4K + Apple TV4K + Vu+ Ultimo 4K NAS: Qnap TVS 871 Pro i7 16GB Ram 10GBe
Reply
Hi guys,

Any one using Next Up add-on with DS player? In Isengard DX11 release I cannot make the script run correctly, it works well with DVDplayer. I think something goes wrong between DS Player or madVR and Kodi when the script is telling to play next or stop playback. Anyways, the author said he'd be happy to help if you wanted to fix this as he's never used DS Player himself so.. I dunno, it's a great add-on, but right now it freezes Kodi when using it. It works up until the point where the next up pop-up ends it's countdown and then plays the next episode(black screen and then freeze).

Here's the link to the add-on thread,
228435 (thread)

Also, if you'd like any logs please let me know. I have no idea if it's DS Player or the script that fails. It would be really sweet to have it working as it's a really, really nice add-on for when watching series.

For the record, I have tried a plethora of different render settings in madVR to avoid this happening.. Different input for DXVA and/or for Presentation, DX11 presentation on/off, windows/exclusive mode.. Delay playback and so on.. It just doesn't work. Either it crashes when selecting to play instant in the add-on or it crashes when it just lets the count down end itself and tells Kodi to play next. So.. It can work like.. Half the time, in each way, lol.

Thanks.
Reply
(2015-09-06, 14:10)a5ian300zx Wrote: Hi,

here is the new log with manual logging enabled.

i5 Nuc Debug - Blank DSplayer

EDIT: just add dsplayer manually in advance settings advancesettings still the same issue and even tried to fo to the file and pressed C for menu and it says default player dsplayer so tried that and same issue then i tried the dvdplayer and worked fine.

which version of windows are you guys running?

I am on windows 8.1 pro, shall I update to the latest intel drivers from the intel site?

Many Thanks

i don't know what you are doing but in these log there is nothing, there is no one attempts to play a file, sorry it should be very easy to catch the moment of the playstart, you can try to rename your folder in %appdata/Kodi
just to recreate a new and clean one to try at least to provide a complete debug log, i see some error with aesink initialization that has nothing to do with dsplayer

p.s.
when you said that with the original kodi 15.1 everything it's fine you mean with dx9 version downloaded from http://www.kodi.tv or the dx11 test version from here 218274 (thread)?

(2015-09-06, 14:18)curael Wrote: Hi guys,

Any one using Next Up add-on with DS player? In Isengard DX11 release I cannot make the script run correctly, it works well with DVDplayer. I think something goes wrong between DS Player or madVR and Kodi when the script is telling to play next or stop playback. Anyways, the author said he'd be happy to help if you wanted to fix this as he's never used DS Player himself so.. I dunno, it's a great add-on, but right now it freezes Kodi when using it. It works up until the point where the next up pop-up ends it's countdown and then plays the next episode(black screen and then freeze).

Here's the link to the add-on thread,
228435 (thread)

Also, if you'd like any logs please let me know. I have no idea if it's DS Player or the script that fails. It would be really sweet to have it working as it's a really, really nice add-on for when watching series.

For the record, I have tried a plethora of different render settings in madVR to avoid this happening.. Different input for DXVA and/or for Presentation, DX11 presentation on/off, windows/exclusive mode.. Delay playback and so on.. It just doesn't work. Either it crashes when selecting to play instant in the add-on or it crashes when it just lets the count down end itself and tells Kodi to play next. So.. It can work like.. Half the time, in each way, lol.

Thanks.

i just quickly tried some file and no problem here, a full debug log could be useful, anyway i already said many times that i cannot guarantee that kodi dsplayer will work 100% with all the plugin because ì'm alone to do this job and it's impossible to me check the entire list of plugin for each brand new version of kodi or madVR
Reply
(2015-09-06, 15:08)aracnoz Wrote: i just quickly tried some file and no problem here, a full debug log could be useful, anyway i already said many times that i cannot guarantee that kodi dsplayer will work 100% with all the plugin because ì'm alone to do this job and it's impossible to me check the entire list of plugin for each brand new version of kodi or madVR

Hi, here is log for DS Player + NextUp add-on, please let me know if you need more, I have never uploaded log before so not sure if there are more levels of logs.

http://xbmclogs.com/pwgfr9zwa

Regards,
CuraeL
Reply
Hi,

Even with the dx11 version from this thread and not using dsplayer everything seems to work with slight vertical video tearing.

If I rename my folder would that effect my plug ins?

Thanks
TV: Sony  65" A1E Surround: Yamaha RXA-3050 + ORB Audio Mod2 7.1.2 + SVS SB12-NSD Sub Processor: Darbee + DVDO iScan Mini Players: HDI Dune Solo4K + Apple TV4K + Vu+ Ultimo 4K NAS: Qnap TVS 871 Pro i7 16GB Ram 10GBe
Reply
(2015-09-06, 17:27)a5ian300zx Wrote: Hi,

Even with the dx11 version from this thread and not using dsplayer everything seems to work with slight vertical video tearing.

If I rename my folder would that effect my plug ins?

Thanks

What kind of files are u trying to play, just curious?
HTPC
Silverstone Grandia GD05 - Intel i5 3570k -Asus H61M-G Micro-ATX - Unidad Blu-ray
MSI GTX970 4GB GDDR5 - 8 GB RAM DDR3 - AVR Denon X3400H Atmos - LG  OLED 55C7V
Reply
. Mkv I will as testing in but also tried avi with same results. It's like dsplayer is not installed.


What do you guys have in the following files.

advancedsettings.xml

playercorefactory.xml

Just so I can compare.

Thanks
TV: Sony  65" A1E Surround: Yamaha RXA-3050 + ORB Audio Mod2 7.1.2 + SVS SB12-NSD Sub Processor: Darbee + DVDO iScan Mini Players: HDI Dune Solo4K + Apple TV4K + Vu+ Ultimo 4K NAS: Qnap TVS 871 Pro i7 16GB Ram 10GBe
Reply
(2015-09-06, 16:39)curael Wrote:
(2015-09-06, 15:08)aracnoz Wrote: i just quickly tried some file and no problem here, a full debug log could be useful, anyway i already said many times that i cannot guarantee that kodi dsplayer will work 100% with all the plugin because ì'm alone to do this job and it's impossible to me check the entire list of plugin for each brand new version of kodi or madVR

Hi, here is log for DS Player + NextUp add-on, please let me know if you need more, I have never uploaded log before so not sure if there are more levels of logs.

http://xbmclogs.com/pwgfr9zwa

Regards,
CuraeL

seems everything correct in your debug log, i see an error that come from the plugin , i don't know if this it's the cause or not

with the next release of DSPlayer there will be an improvements for madVR stability with play/pause/seek/stop etc maybe it could be useful for you or not, as said i'm sorry but i cannot support directly plugins/addons

anyway i can confirm that for me there is no problem, i performed a stress test with multiple file without problems

Code:
16:49:13 T:6040   ERROR: EXCEPTION: Non-Existent Control 3001
16:49:13 T:6040   ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                             - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                            Error Type: <type 'exceptions.RuntimeError'>
                                            Error Contents: Non-Existent Control 3001
                                            Traceback (most recent call last):
                                              File "C:\Users\CloudMedia\AppData\Roaming\Kodi\addons\service.nextup.notification\resources\lib\NextUpInfo.py", line 48, in onInit
                                                self.getControl(3001).setText(overview)
                                            RuntimeError: Non-Existent Control 3001
                                            -->End of Python script error report<--

(2015-09-06, 17:27)a5ian300zx Wrote: Hi,

Even with the dx11 version from this thread and not using dsplayer everything seems to work with slight vertical video tearing.

If I rename my folder would that effect my plug ins?

Thanks

it's just to try with a clean folder without any plugin or previous configuration then you can always rename back the folder to have your original configuration, until now no one has never provided a debug log without any trace of playmedia, open file, etc etc it's like you are doing nothing, the type of the file it's irrelevant because no log mean that you are doing nothing
so you have to try with a clean folder (or maybe starting kodi with portable switch) and try to launch a file better if it's stored locally so that there will be any influence

p.s. the dx11 version it's different from the official one that you can download from the http://www.kodi.tv so why you are experiencing tearing with dvdplayer
Reply
@a5ian300zx - not sure which guide you used but this one by Warner306 is excellent 222576 (thread) apologies if this is the one.

In response to your request for information on advancedsettings and playercorefactory - I have nothing in either which would affect playback of kodi/DSPlayer.

What are you expecting to see - playercorefactory is predominantly for external players - and DSPlayer definitely doesn't come into that category.

EDIT - sorry just read the guide I linked to and it appears playercorefactory is required to play 'streaming' content via DVDPlayer (which is Kodi's internal player). My reply still stands in terms of what is in those files on my system.
Reply
@steelman1991

True, but it is not important just to see if DSPlayer is working or not with local files, as it seems to be his case, so i don't think that will be a problem.
I asked which kind of files he was playing, just cos of that: mean, didn't read the start post, but perhaps he was trying with streaming or some kindda internet content, which he could find may be more problems using DSPlayer. But it seems to be just local MKV files.
HTPC
Silverstone Grandia GD05 - Intel i5 3570k -Asus H61M-G Micro-ATX - Unidad Blu-ray
MSI GTX970 4GB GDDR5 - 8 GB RAM DDR3 - AVR Denon X3400H Atmos - LG  OLED 55C7V
Reply
Ok,

renamed Kodi folder is appdata but even with new one still the same issue, I then uninstalled Kodi and reinstalled your version inc .pub file instruction back and still the same issue.

I have updated the intel gpu drivers drivers and still the same issue.

so I have had enough time messing about with it and wanted to change to Windows 10 any so I am doing a full clean install of Windows 10.

then I will install the version of Kodi on the first thread again and test once its working I will copy my appdata Kodi folder back and test again.

Will report back once I have finished.
TV: Sony  65" A1E Surround: Yamaha RXA-3050 + ORB Audio Mod2 7.1.2 + SVS SB12-NSD Sub Processor: Darbee + DVDO iScan Mini Players: HDI Dune Solo4K + Apple TV4K + Vu+ Ultimo 4K NAS: Qnap TVS 871 Pro i7 16GB Ram 10GBe
Reply
  •   
  • 1
  • 90
  • 91
  • 92(current)
  • 93
  • 94
  • 496
  •   
 
Thread Rating:
  • 46 Vote(s) - 4.41 Average



Logout Mark Read Team Forum Stats Members Help
Kodi DSPlayer – DirectShow Player for Windows4.4146