Kodi DSPlayer – DirectShow Player for Windows
(2015-04-26, 01:12)Warner306 Wrote:
(2015-04-25, 22:35)XTrojan Wrote:
(2015-04-25, 21:53)Warner306 Wrote: Tearing and artifacts are not common to Bicubic image scaling or madVR. I would turn off any video processing that is not done by madVR or Kodi. This includes any processing done by the graphics card from its control panel. I would also try turning off hardware acceleration in LAV Video to see if that fixes the tearing.

Did you try setting Kodi to a true fullscreen and madVR to windowed mode? Also, are you looking at your rendering stats during playback (Cntrl+J)? Those stats will count presentation glitches and dropped frames as they happen. If these counters are not increasing during playback, then madVR is not at fault.
To clarify, i don't use reclöck.It isn't caused by MadVR, It feels like an microstutter or frame drop(even though there's no frames dropped). Could it be that MadVR is not flushing the RAM/Refreshing the RAM or something similar?

I'm using Lanczos 4 and the artifacts only happen on very small places with two colors next to each other like this.

Image

I tried all of what you listed, but one thing i noticed was that Intel graphics was set to "Performance", i changed it to "Quality" and got some improvements but the issues still remain.

MadVR doesn't report anything wrong, i've tried Fullscreen with no effect, i've turned off video processing on both Kodi and the AVR. Software acceleration is on, hardware off.

Edit: I noticed that my audio output is the name of my TV and not my AVR? I'm currently using PC->AVR->TV.

It is difficult to tell what your problem might be. Lanczos4 is a very aggressive scaling algorithm. I would try Lanczos3 instead and see if the artifacts remain. What you are describing might be ringing from over-aggressive scaling. You shouldn't be scaling in linear light either, if that is checked. I would also uncheck all of the trade quality for performance checkboxes except for the one dealing with subtitles.

Try a different refresh rate and see if that is the issue. madVR's version of 3/2 pulldown is not that great, but it hasn't really bothered me. I've heard one person complain about 60hz playback before. Adding ReClock might make the problem better, but I doubt it. Outside of that, I don't know where to direct you. It sounds like you are going over the rendering queue a few times a movie. This has happened to me when 1080p movies don't match the target rectangle. I created a special profile in madVR to address these files as they would dip over 41 ms occasionally. Going over 41 ms will cause a stutter, but madVR will report the dropped frames.

Edit: I noticed you posted in another thread about using LumaSharpen. I would dump LumaSharpen and see if that improves matters. In my experience, artifacts will appear when using sharpening shaders.
I'll try disabling most "trade quality for performance" boxes and change to Lanczos 3.
Rendering isn't an issue as no frames get dropped.

Now that you mentioned 3/2 pulldown, if i always use 60Hz playback won't several frames get dropped since all my movies are 23.976Hz format?
Reply
 
Thread Rating:
  • 47 Vote(s) - 4.43 Average


Messages In This Thread
Lockup on STOP issue resolved! - by MKANET - 2015-04-11, 21:59
RE: Kodi DSPlayer – DirectShow Player for Windows - by XTrojan - 2015-04-26, 02:31
RE: 4G aware patch - by MagikMark - 2015-09-08, 03:27
Alt-F4 no longer quits - by JeffA - 2015-10-31, 20:38