•   
  • 1
  • 24
  • 25
  • 26(current)
  • 27
  • 28
  • 509
  •   
Kodi DSPlayer – DirectShow Player for Windows
(2015-04-28, 15:35)oldpoem Wrote:
(2015-04-28, 14:52)neeto33 Wrote:
(2015-04-28, 14:47)oldpoem Wrote: To be able to use DSplayer with DVD folder (ifo) you need to config dvd navigator as source AND splitter. But then it's not working 100% some dvd won't play so convert iso to mkv seem to be best option.

Yep got dvdnavigator as both source AND splitter.
Any clue on why some work and some don't? anything to do with them being on smb mount on NAS?

It just don't work with some DVD structure even with using other directshow based player (MPC-HC etc.). Since DVD Navigator filter is not in development anymore and no replacement filter for it, that's the end of dvd ifo playback.

Ok here's the answer - it will & does work fine for DVD structures on the local host with the following configs

<rule filetypes="ifo">
<source filter="dvdnavigator" />
<splitter filter="dvdnavigator" />
<video filter="lavvideo" />
<audio filter="lavaudio" />
</rule>

But there is catch - it must be a local structure. If it is on my NAS I get the following:

When I have "ERROR: CFGLoader::InsertSourceFilter Failed loading dvd directory." error, further in the log file is line
ERROR: Playlist Player: skipping unplayable item: 0, path [smb://NAS04/movies/The Very Best of XYZVIDEO_TS/VIDEO_TS.IFO]

I believe this is an error with how this file path is being passed to the filter.
i.e. the "smb:" should not be on the front of the path name.
Reply
It works for some structure not all. I had many that doesn't work right while DVDPlayer plays it fine. Also it should be VIDEO_TS.IFO not VIDEO_TS.INF.

All my media are streaming with SMB protocol so it shouldn't be the problem. My suggestion is convert it and save the hustle, noone develops DVD Navigator filter anymore so can't expect any fixes on that part anytime.
Reply
(2015-04-28, 21:28)eltopo Wrote:
(2015-04-28, 20:53)Warner306 Wrote:
(2015-04-28, 18:20)_Andy_ Wrote: @eltopo yes, i can confirm. In Kodi dvdplayer i use two different sound devices. HDMI for my TV and a headphone. I can switch in the system configuration of Kodi.
If i change the default device in windows to the headphones, dsplayer uses the headphones. If i change the output in dsplayer to use HDMI the audio output is still the headphone.

No matter what i select in the dsplayer configuration, dsplayer always uses the default in windows.

I mentioned my issue two times but no one could give me an answer.

You could use ReClock. Your settings will never change. And I still think it's the best audio renderer. But you do have a point. If you can't adjust the output by remote, some functionality is lost.

The main problem is not that the audio renderer can't be changed by remote. The main problem is that DSPlayer doesn't care about the audio renderer which is selected in the DSPlayer settings, it always uses the Windows default device.

Perhaps aracnoz can change this wrong behaviour in the Isengard release.

fixed for upcoming Isengard DSPlayer
Reply
No internet video. It goes to the sites, but every thing I try to play starts connecting then stops without reason.
Reply
(2015-04-30, 05:26)AppData Wrote: No internet video. It goes to the sites, but every thing I try to play starts connecting then stops without reason.

1992901 (post)
HTPC
Silverstone Grandia GD05 - Intel i5 3570k -Asus H61M-G Micro-ATX - Unidad Blu-ray
MSI GTX970 4GB GDDR5 - 8 GB RAM DDR3 - AVR Denon X3400H Atmos - LG  OLED 55C7V
Reply
i don't know if it's only for my cases but with this rule i can play every video

trailer, youtube or others video addon

Image
Reply
really?, gonna copy that, would be super nice!
HTPC
Silverstone Grandia GD05 - Intel i5 3570k -Asus H61M-G Micro-ATX - Unidad Blu-ray
MSI GTX970 4GB GDDR5 - 8 GB RAM DDR3 - AVR Denon X3400H Atmos - LG  OLED 55C7V
Reply
Hi why can't I select madVR as renderer in DSPlayer options in Kodi?
I have used the install.bat and I got a cmd video telling me just not delete the madVR folder, which I haven't.
Any thoughts?
Reply
I tried on a testcomputer where I got it to select it, but not on my main HTPC. What can the problem be?
Reply
(2015-04-30, 11:04)aracnoz Wrote: i don't know if it's only for my cases but with this rule i can play every video

trailer, youtube or others video addon

Image

Do we need to do anything with the DVDplayer merits so they don't conflict? As I set it up as per your screen shot, and streaming contents is still played (iPlayer) by DVDplayer.

K
Sapphire RX 5700 XT (19.9.2)  Ryzen 7 3700x, PRIME X570-Pro, Win 10 x64 (1903), Silverstone LC13B-E, Onkyo TX-NR686, Philips 55PUS6754/12, Mission M35i speakers, Kodi Dsplayer 17.6 X64
Reply
Have figured it out now.
Reply
(2015-04-30, 10:25)vicmanpergar Wrote:
(2015-04-30, 05:26)AppData Wrote: No internet video. It goes to the sites, but every thing I try to play starts connecting then stops without reason.

1992901 (post)

OK...that's a shame, so, I suppose I could use two separate versions of Kodi, putting one in portable mode for watching the internet streams, the dsplayer for my videos.
Reply
Look this post, have solution for streaming using dsplayer, work great.

1993558 (post)
MediaBrazil forum Website - Youtube Channel
Aeon MQ9-0.3.0 & Ace2 Skin Team
MarcosQui Website Donate and support us.
Reply
(2015-04-29, 14:42)neeto33 Wrote:
(2015-04-28, 15:35)oldpoem Wrote:
(2015-04-28, 14:52)neeto33 Wrote: Yep got dvdnavigator as both source AND splitter.
Any clue on why some work and some don't? anything to do with them being on smb mount on NAS?

It just don't work with some DVD structure even with using other directshow based player (MPC-HC etc.). Since DVD Navigator filter is not in development anymore and no replacement filter for it, that's the end of dvd ifo playback.

Ok here's the answer - it will & does work fine for DVD structures on the local host with the following configs

<rule filetypes="ifo">
<source filter="dvdnavigator" />
<splitter filter="dvdnavigator" />
<video filter="lavvideo" />
<audio filter="lavaudio" />
</rule>

But there is catch - it must be a local structure. If it is on my NAS I get the following:

When I have "ERROR: CFGLoader::InsertSourceFilter Failed loading dvd directory." error, further in the log file is line
ERROR: Playlist Player: skipping unplayable item: 0, path [smb://NAS04/movies/The Very Best of XYZVIDEO_TS/VIDEO_TS.IFO]

I believe this is an error with how this file path is being passed to the filter.
i.e. the "smb:" should not be on the front of the path name.

(2015-04-29, 14:45)oldpoem Wrote: It works for some structure not all. I had many that doesn't work right while DVDPlayer plays it fine. Also it should be VIDEO_TS.IFO not VIDEO_TS.INF.

All my media are streaming with SMB protocol so it shouldn't be the problem. My suggestion is convert it and save the hustle, noone develops DVD Navigator filter anymore so can't expect any fixes on that part anytime.

It's not a DVD Navigator filter issue (well at least regarding DVD structure).
I play all my DVDs with MPC-BE using DVD Navigator, and not one is playing with DSPlayer.

I think neeto33 found the problem : working in local drive, not working on NAS. Systematic, not depending on DVDs.

Aracnoz what's your position on this issue? Is there any way to change the path sent to the filter in order to remove smb: ?

I have a huge amount of DVDs on my NAS, would love to play them with filters support.



EDIT : an idea just popping out in my mind.
Maybe use Coreplayerfactory, to use a BATCH as an external player for IFO's only, and passing it the path with smb: removed, the BATCH calling DSPLAYER Smile
Reply
OK, I was using my own custom playercorefactory xml, finally got the internet stream going, thanks all.
Reply
  •   
  • 1
  • 24
  • 25
  • 26(current)
  • 27
  • 28
  • 509
  •   
 
Thread Rating:
  • 47 Vote(s) - 4.43 Average



Logout Mark Read Team Forum Stats Members Help
Kodi DSPlayer – DirectShow Player for Windows4.4347