•   
  • 1
  • 26
  • 27
  • 28(current)
  • 29
  • 30
  • 506
  •   
Kodi DSPlayer – DirectShow Player for Windows
@Warner306

the problem it's with this your rule

i think was made to use dvdplayer as default player with streaming source but it should be done by playercorefactory.xml, anyway this rule go in conflict with dsplayer rule to play remote file

Code:
<!-- New rule for preferred streaming source filter -->
<rule url="true" filetypes=".*">
  <source filter="internal_ffmpegsource" />
</rule>

p.s.

i think that maybe we have to create a better filtersconfig.xml and mediasconfig.xml for the home folder of dsplayer because now with your starter kit in the list of filter come out some duplication as "Lav Audio" and "Lav Audio Decoder"

the problem it's to do that without create problems for the existing rule of old DSPlayer users


(2015-05-01, 08:20)Warner306 Wrote: ...Can the same be said for Matroska Editions and title selection? I don't have any to test.

yes lav support this too, i fixed something on this the last month
Reply
Hi, I have a strange problem.

When I'm stopping a video, or the video is stopping itlself at the end of it, sometimes (more and more often it seems), Kodi (or at least something in it) is crashing.
I get black screen or frozen screen with parts of the interface.

Logs are talking about "CDXTexture::LoadToGPU - failed to lock texture".

Auto adjust refresh rate was activated in MadVR and not in Kodi.
- If I deactivate it (videos playing at 60Hz), no bug
- If I use DVDPlayer with auto adjust refresh rate activated in Kodi, no bug
==> So the issue has to do with MadVR + autoadjust refresh rate in MadVR
- If I use autoadjust in Kodi and not MadVR, video is launching, but it's very laggy and i get thousands of presentation glitches (?)
==> the option in Kodi to define a pause duration during refresh rate doesn't work (i even tried 20 sec), I think that's why i get presentation glitches : MadVR is launching playback during refresh rate switching

I would like to test the auto adjust kodi option as advised in Warner306 guide, but with the pause option not working, it's impossible.

Any idea? Smile

EDIT : i've just tested that "pause during auto adjust refresh rate" works only with DVDPlayer, not DSPlayer.
Reply
@warner

Gonna try the rule on my system too, i had no time yet.
And AVSplitter was needed to be able to chose the title to play on blu-rays, as far as i remember. This is the only different thing, i think.

Edit:
No, it's not working for me either.... One thing i noticed, don't know if important or not, is, in filtersconfig, i do not have any URL souce declared, but i can find it when creating the rule from the GUI

This is the rule created in mediasconfig

<rule name="Remote URL" protocols="rtsp|http">
<source filter="urlfilesource" />
<splitter filter="lavsplitter" />
<video filter="lavvideo" />
<audio filter="lavaudio" />
</rule>


Edit2:

I took the urlfilesource from an old filterscofig i had,and it is working now. However, not very well.... I can't hear sound, and sometimes it looks like part of the video gets missed out of my screen... lol
The sound issue could be cos i use ReClock....
HTPC
Silverstone Grandia GD05 - Intel i5 3570k -Asus H61M-G Micro-ATX - Unidad Blu-ray
MSI GTX970 4GB GDDR5 - 8 GB RAM DDR3 - AVR Denon X3400H Atmos - LG  OLED 55C7V
Reply
Is there a rule that would make an external player the default for internet videos?
Reply
Yes, use playercorefactory.xml
Reply
I have playercorefactory set for a couple of optional external players, but don't know the setup for internet video, If I can't make an external player default for internet streams, I would like at least a right-click, 'play using' option.
Reply
(2015-05-01, 08:18)Warner306 Wrote:
(2015-05-01, 02:22)Shogunreaper Wrote: anyone figured out how to get rid of the gui lag when opening videos?

No, as stated previously, this lag cannot be completely eliminated due to the frame buffer used by madVR. This is a compromise of this software.

but i'm not using madvr
Reply
(2015-05-02, 00:24)Shogunreaper Wrote:
(2015-05-01, 08:18)Warner306 Wrote:
(2015-05-01, 02:22)Shogunreaper Wrote: anyone figured out how to get rid of the gui lag when opening videos?

No, as stated previously, this lag cannot be completely eliminated due to the frame buffer used by madVR. This is a compromise of this software.

but i'm not using madvr

Then it's likely Kodi's fault. You could be a little more helpful when asking for help. Each post spills out into four or five one line responses that ends in no resolution to your problem. Give some details about what you are doing and what settings are being used in these circumstances.
Reply
(2015-05-01, 12:42)aracnoz Wrote: @Warner306

the problem it's with this your rule

i think was made to use dvdplayer as default player with streaming source but it should be done by playercorefactory.xml, anyway this rule go in conflict with dsplayer rule to play remote file

Code:
<!-- New rule for preferred streaming source filter -->
<rule url="true" filetypes=".*">
  <source filter="internal_ffmpegsource" />
</rule>

p.s.

i think that maybe we have to create a better filtersconfig.xml and mediasconfig.xml for the home folder of dsplayer because now with your starter kit in the list of filter come out some duplication as "Lav Audio" and "Lav Audio Decoder"

the problem it's to do that without create problems for the existing rule of old DSPlayer users


(2015-05-01, 08:20)Warner306 Wrote: ...Can the same be said for Matroska Editions and title selection? I don't have any to test.

yes lav support this too, i fixed something on this the last month

Is it possible for you to create a version of mediasconfig.xml and filtersconfig.xml and post a link here? I would package these files and host them online in the setup guide. You would know best how to configure these files.

Edit: I deleted the rule below and streaming content is now working with DSPlayer:

Code:
<!-- New rule for preferred streaming source filter -->
<rule url="true" filetypes=".*">
  <source filter="internal_ffmpegsource" />
</rule>

I would like to do some tests on the weekend before changing the configuration files posted. I'd still be interested in configuration files created by you if you have them. Overwriting the existing files didn't create any problems as the naming for LAV Filters doesn't seem to be important in the functioning of Internet content. I don't think I can break existing installations by updating the configuration files.
Reply
(2015-05-01, 16:00)djoole Wrote: Hi, I have a strange problem.

When I'm stopping a video, or the video is stopping itlself at the end of it, sometimes (more and more often it seems), Kodi (or at least something in it) is crashing.
I get black screen or frozen screen with parts of the interface.

Logs are talking about "CDXTexture::LoadToGPU - failed to lock texture".

Auto adjust refresh rate was activated in MadVR and not in Kodi.
- If I deactivate it (videos playing at 60Hz), no bug
- If I use DVDPlayer with auto adjust refresh rate activated in Kodi, no bug
==> So the issue has to do with MadVR + autoadjust refresh rate in MadVR
- If I use autoadjust in Kodi and not MadVR, video is launching, but it's very laggy and i get thousands of presentation glitches (?)
==> the option in Kodi to define a pause duration during refresh rate doesn't work (i even tried 20 sec), I think that's why i get presentation glitches : MadVR is launching playback during refresh rate switching

I would like to test the auto adjust kodi option as advised in Warner306 guide, but with the pause option not working, it's impossible.

Any idea? Smile

EDIT : i've just tested that "pause during auto adjust refresh rate" works only with DVDPlayer, not DSPlayer.

I don't think this problem is common. A Kodi debug log would be helpful.
Reply
(2015-05-02, 01:35)Warner306 Wrote:
(2015-05-02, 00:24)Shogunreaper Wrote:
(2015-05-01, 08:18)Warner306 Wrote: No, as stated previously, this lag cannot be completely eliminated due to the frame buffer used by madVR. This is a compromise of this software.

but i'm not using madvr

Then it's likely Kodi's fault. You could be a little more helpful when asking for help. Each post spills out into four or five one line responses that ends in no resolution to your problem. Give some details about what you are doing and what settings are being used in these circumstances.

Well that's because i already said that i'm using the default settings, which is the directshow merits. I haven't changed anything from the way its set up on installation.

You saying that it's likely kodi's fault doesn't make sense seeing as it doesn't happen on the official version, so it would be something done to this one.
Reply
(2015-05-01, 20:45)AppData Wrote: I have playercorefactory set for a couple of optional external players, but don't know the setup for internet video, If I can't make an external player default for internet streams, I would like at least a right-click, 'play using' option.

In my opinion, it is not worth setting up external players for this role. I have managed to play some Internet content with MPC-BE, but seeking forward was unresponsive and performance was not as good as DVDPlayer.
Reply
(2015-05-02, 04:50)Warner306 Wrote:
(2015-05-01, 20:45)AppData Wrote: I have playercorefactory set for a couple of optional external players, but don't know the setup for internet video, If I can't make an external player default for internet streams, I would like at least a right-click, 'play using' option.

In my opinion, it is not worth setting up external players for this role. I have managed to play some Internet content with MPC-BE, but seeking forward was unresponsive and performance was not as good as DVDPlayer.

What about mpv or mpvhq ?
Works perfect with any video stream protocols.
It's just so awesome and it works well with vapoursynth.
Reply
(2015-05-02, 02:46)Warner306 Wrote:
(2015-05-01, 16:00)djoole Wrote: Hi, I have a strange problem.

When I'm stopping a video, or the video is stopping itlself at the end of it, sometimes (more and more often it seems), Kodi (or at least something in it) is crashing.
I get black screen or frozen screen with parts of the interface.

Logs are talking about "CDXTexture::LoadToGPU - failed to lock texture".

Auto adjust refresh rate was activated in MadVR and not in Kodi.
- If I deactivate it (videos playing at 60Hz), no bug
- If I use DVDPlayer with auto adjust refresh rate activated in Kodi, no bug
==> So the issue has to do with MadVR + autoadjust refresh rate in MadVR
- If I use autoadjust in Kodi and not MadVR, video is launching, but it's very laggy and i get thousands of presentation glitches (?)
==> the option in Kodi to define a pause duration during refresh rate doesn't work (i even tried 20 sec), I think that's why i get presentation glitches : MadVR is launching playback during refresh rate switching

I would like to test the auto adjust kodi option as advised in Warner306 guide, but with the pause option not working, it's impossible.

Any idea? Smile

EDIT : i've just tested that "pause during auto adjust refresh rate" works only with DVDPlayer, not DSPlayer.

I don't think this problem is common. A Kodi debug log would be helpful.
I'm convinced that if I could use the option "pause during refresh rate change" I wouldn't have the issue.
Could you please confirm the bug?

Make sure auto adjust frame rate is activated in Kodi, and choose a 15 sec pause.
Now play a video with DVDPlayer (the 15sec pause should be effective).
And play the same video with DSPlayer (if you reproduce the bug, the playback should start at once)

In the meantime I'll get the debug logs.
Reply
@aracnoz - noticed you just slipped in the Isengard beta builds on the first page - great addition and one I've been patiently waiting for - off to test and keep up the excellent work.
Reply
  •   
  • 1
  • 26
  • 27
  • 28(current)
  • 29
  • 30
  • 506
  •   
 
Thread Rating:
  • 47 Vote(s) - 4.43 Average



Logout Mark Read Team Forum Stats Members Help
Kodi DSPlayer – DirectShow Player for Windows4.4347