•   
  • 1
  • 27
  • 28
  • 29(current)
  • 30
  • 31
  • 506
  •   
Kodi DSPlayer – DirectShow Player for Windows
I have a A8-7600 AMD with 384 shaders. My questions are:
1. Should I use same profile for all video?
2. What should my best settings be?
Have tried jinc3 chroma and upscaling, AR filter on both. De interlace if doubt, banding artifacts low and medium, and smooth avoid judder, dithering ordered.
On 720p material I get interval 41,71 Ms and avg stats rendering is approx 30, frame drops keeps going up in hours as I proceed in video and have 4 dropped frames.

I'm using teamviewer to see my stats maybe it has something to say..

What is my recommendation to the 2 questions?
Reply
(2015-05-01, 00:02)aracnoz Wrote: @Warner306

you have to put the list of protocols in "- protocols" no in file types

it's easy to miss this because usually we using the file types

(2015-04-30, 18:25)djoole Wrote:
(2015-04-29, 14:42)neeto33 Wrote: Ok here's the answer - it will & does work fine for DVD structures on the local host with the following configs

<rule filetypes="ifo">
<source filter="dvdnavigator" />
<splitter filter="dvdnavigator" />
<video filter="lavvideo" />
<audio filter="lavaudio" />
</rule>

But there is catch - it must be a local structure. If it is on my NAS I get the following:

When I have "ERROR: CFGLoader::InsertSourceFilter Failed loading dvd directory." error, further in the log file is line
ERROR: Playlist Player: skipping unplayable item: 0, path [smb://NAS04/movies/The Very Best of XYZVIDEO_TS/VIDEO_TS.IFO]

I believe this is an error with how this file path is being passed to the filter.
i.e. the "smb:" should not be on the front of the path name.

(2015-04-29, 14:45)oldpoem Wrote: It works for some structure not all. I had many that doesn't work right while DVDPlayer plays it fine. Also it should be VIDEO_TS.IFO not VIDEO_TS.INF.

All my media are streaming with SMB protocol so it shouldn't be the problem. My suggestion is convert it and save the hustle, noone develops DVD Navigator filter anymore so can't expect any fixes on that part anytime.

It's not a DVD Navigator filter issue (well at least regarding DVD structure).
I play all my DVDs with MPC-BE using DVD Navigator, and not one is playing with DSPlayer.

I think neeto33 found the problem : working in local drive, not working on NAS. Systematic, not depending on DVDs.

Aracnoz what's your position on this issue? Is there any way to change the path sent to the filter in order to remove smb: ?

I have a huge amount of DVDs on my NAS, would love to play them with filters support.



EDIT : an idea just popping out in my mind.
Maybe use Coreplayerfactory, to use a BATCH as an external player for IFO's only, and passing it the path with smb: removed, the BATCH calling DSPLAYER Smile

ok i fixed this issue for the next release, but as has said oldpoem some other things can fails with dvds

Sorry but we're you talking about next DSPlayer release in Helix or Isengard?
Reply
@aracnoz, could you please confirm this issue :

Kodi option "pause during refresh rate change" doesn't work with DSPlayer (but works with DVDPlayer).

Impact : playback with madVR is starting before refresh rate change is finished, and for some videos, randomly, it may lead to presentation glitches (laggy video like 50% frames drops bu no drop) and Kodi crashing when stopping the laggy video.
Reply
(2015-05-01, 00:22)djoole Wrote: Nice!! Thanks very much!
If you need someone to test it I'm there!

Ditto that !!!
Now just need onto getting streaming internet video working via DSPlayer, then live/recorded TV, then....... it's going to be a long night/week/month.....
Reply
(2015-05-02, 13:29)djoole Wrote: Sorry but we're you talking about next DSPlayer release in Helix or Isengard?

isengard dsplayer

(2015-05-02, 13:37)djoole Wrote: @aracnoz, could you please confirm this issue :
Kodi option "pause during refresh rate change" doesn't work with DSPlayer (but works with DVDPlayer).

i already know about this behavior, but it's only with madVR because it's take a bit more time to change the state in "running" at playstart, so when dsplayer try to pause the video at playstart ask to madvr the state, madvr report that the state it's "paused" instead "running" and dsplayer don't pause the videoplayback... maybe i can do something for this but it's not a priority because it's more difficult that what it seems...

anyway i don't think that you can solve all your problem with this feature

just to start, update to latest version madVR v0.87.21, then try to reset your settings on madvr to default with "restore default settings.bat" then you have to ensure that "delay playback unil render queue is full" it's enabled in madvr, manage the change refresh only by kodi
with all my systems that i tryed with madvr + dsplayer never happened that the video start during change refresh with "delay playback unil render queue is full" enabled

for the crash you have to download the related pdb file in the first page rename it in kodi.pdb and put in the kodi dsplayer installation folder... when the crash occurs before to kill the process you have to press CTRL+ALT+SHIFT+PAUSE (on some keyboard it's named as BREAK) after few secs on desktop should be created a madvr freeze report, something useful could be in there

p.s.

@for all

with the current version of isengard dsplayer something it's broke with EVR, kodi seems to call the frame from evr twice, i have to investigate, that irony now dsplayer work only with madVR Big Grin

EDIT

ok i fixed the issue with evr, there is a new build in the first page for isengard
Reply
(2015-05-02, 12:47)Bjur Wrote: I have a A8-7600 AMD with 384 shaders. My questions are:
1. Should I use same profile for all video?
2. What should my best settings be?
Have tried jinc3 chroma and upscaling, AR filter on both. De interlace if doubt, banding artifacts low and medium, and smooth avoid judder, dithering ordered.
On 720p material I get interval 41,71 Ms and avg stats rendering is approx 30, frame drops keeps going up in hours as I proceed in video and have 4 dropped frames.

I'm using teamviewer to see my stats maybe it has something to say..

What is my recommendation to the 2 questions?

1) The same profile for all videos probably wouldn't make sense. Did you read the section on madVR in the set-up guide? Section 5 does a good job of explaining the rationale for each setting. Image Doubling is great if the source is 2x or less of the target resolution. Chroma upscaling can be increased when watching 1080p material while image scaling is reduced because it is not needed. 720p requires a blend of image and chroma scaling settings.

2) Your best settings will depend on what looks best to your eyes. As a middle ground, 720p material should be set to Jinc3 + AR for both chroma and luma. From there, you could upgrade to NNEDI3 chroma scaling, go down to Lanczos scaling, or add 4 taps rather than 3 taps to Jinc or Lanczos. Extra taps will make the image sharper at the cost of increased ringing. The choice of settings all depends on the power of your graphics card.

If your dropped frames counter increases at all during playback, you will have to reduce your settings. You should not have any Presentation Glitches or Dropped Frames. It is possible for these counters to increase even if you are under the average rendering queue.
Reply
I have tested DSPlayer with streaming content from video addons. I have stopped short of reconfiguring the provided DSPlayer Starter Kit because DSPlayer is not very reliable at playing this content.

With some addons, DSPlayer is very capable of playing back Internet video. However, I have encountered a few issues with several addons:

- Some videos will not load with DSPlayer despite being the correct protocol. They are played by DVDPlayer instead.
- Several videos freeze or crash when seeking (pressing up).
- Some videos freeze on load, locking-up the system.

For those willing to give this a try, I provided some instruction on how to get this working in the set-up guide in Other Resources. You will need to update your copy of mediasconfig.xml as the previous version contains a rule that causes DSPlayer to ignore the new rule for supported protocols.
Reply
(2015-05-02, 17:36)aracnoz Wrote:
(2015-05-02, 13:29)djoole Wrote: Sorry but we're you talking about next DSPlayer release in Helix or Isengard?

isengard dsplayer

(2015-05-02, 13:37)djoole Wrote: @aracnoz, could you please confirm this issue :
Kodi option "pause during refresh rate change" doesn't work with DSPlayer (but works with DVDPlayer).

i already know about this behavior, but it's only with madVR because it's take a bit more time to change the state in "running" at playstart, so when dsplayer try to pause the video at playstart ask to madvr the state, madvr report that the state it's "paused" instead "running" and dsplayer don't pause the videoplayback... maybe i can do something for this but it's not a priority because it's more difficult that what it seems...

anyway i don't think that you can solve all your problem with this feature

just to start, update to latest version madVR v0.87.21, then try to reset your settings on madvr to default with "restore default settings.bat" then you have to ensure that "delay playback unil render queue is full" it's enabled in madvr, manage the change refresh only by kodi
with all my systems that i tryed with madvr + dsplayer never happened that the video start during change refresh with "delay playback unil render queue is full" enabled

for the crash you have to download the related pdb file in the first page rename it in kodi.pdb and put in the kodi dsplayer installation folder... when the crash occurs before to kill the process you have to press CTRL+ALT+SHIFT+PAUSE (on some keyboard it's named as BREAK) after few secs on desktop should be created a madvr freeze report, something useful could be in there

I think I might have solved my issue, changing "how many video frames shall be presented in advance" to 1.
Future will say, as the issue was not systematic.

As for DVD support, i guess i have to upgrade to Isengard Smile
Reply
@aracnoz

Where're the rest of the regions and languages on the settings on Isengard? Sad
HTPC
Silverstone Grandia GD05 - Intel i5 3570k -Asus H61M-G Micro-ATX - Unidad Blu-ray
MSI GTX970 4GB GDDR5 - 8 GB RAM DDR3 - AVR Denon X3400H Atmos - LG  OLED 55C7V
Reply
(2015-05-03, 08:49)vicmanpergar Wrote: @aracnoz

Where're the rest of the regions and languages on the settings on Isengard? Sad

Isengard Changelog:
* Addition of language add-ons which allow us to update the User-Interface text outside of regular releases
So, you need to install your language pack addon first.
LG OLED65C8 / Denon AVR-X3200W / KEF E305+ONKYO SKH-410 / Synology DS2415+ / Logitech Harmony Companion / ZOTAC MAGNUS EN1060K (Kodi DSPlayer x64) / LightSpace HTL, DisplayCal, HCFR, Calman / i1D3 OEM Rev.B, i1PRO2 OEM Rev.E
Reply
(2015-05-03, 00:48)Warner306 Wrote: I have tested DSPlayer with streaming content from video addons. I have stopped short of reconfiguring the provided DSPlayer Starter Kit because DSPlayer is not very reliable at playing this content.

With some addons, DSPlayer is very capable of playing back Internet video. However, I have encountered a few issues with several addons:

- Some videos will not load with DSPlayer despite being the correct protocol. They are played by DVDPlayer instead.
- Several videos freeze or crash when seeking (pressing up).
- Some videos freeze on load, locking-up the system.

For those willing to give this a try, I provided some instruction on how to get this working in the set-up guide in Other Resources. You will need to update your copy of mediasconfig.xml as the previous version contains a rule that causes DSPlayer to ignore the new rule for supported protocols.

I made a post the other day suggesting that certain videos that should be being played by DSPlayer are instead being played by DVDPlayer in PleXBMC and couldn't understand why. Do you think this is related? I've not yet worked out a pattern why some are not being played in DSPlayer through Plex when the same videos are fine when loaded directly into Kodi.
(2015-05-01, 12:30)TMDaines Wrote: Does anyone else use PleXBMC with this fork? I'm currently having a couple of issues with it.

For some reason when accessing videos through PleXMBC, only some play in DSPlayer. The others all play in the usual DVDPlayer. When I load the same video library directly in Kodi, everything is being picked up by DSPlayer and plays accordingly. Does anyone have any inklings what might be causing this?
Reply
anyone got a fix for gui lag when stopping video playback?

Doesn't happen when i start videos anymore only when i try to exit out of them, theres a 2-3 second pause before i'm back at the menu.

using default settings.
Reply
Deleted.
Reply
I believe the plex thing is when plex is trancoding it plays with DVDplayer, and when it's direct playing it plays through dsplayer
Reply
(2015-05-03, 11:52)sat4all Wrote:
(2015-05-03, 08:49)vicmanpergar Wrote: @aracnoz

Where're the rest of the regions and languages on the settings on Isengard? Sad

Isengard Changelog:
* Addition of language add-ons which allow us to update the User-Interface text outside of regular releases
So, you need to install your language pack addon first.

Oh, that's a new thing, i had no idea.
Thanks for telling!
HTPC
Silverstone Grandia GD05 - Intel i5 3570k -Asus H61M-G Micro-ATX - Unidad Blu-ray
MSI GTX970 4GB GDDR5 - 8 GB RAM DDR3 - AVR Denon X3400H Atmos - LG  OLED 55C7V
Reply
  •   
  • 1
  • 27
  • 28
  • 29(current)
  • 30
  • 31
  • 506
  •   
 
Thread Rating:
  • 47 Vote(s) - 4.43 Average



Logout Mark Read Team Forum Stats Members Help
Kodi DSPlayer – DirectShow Player for Windows4.4347