19 Nov 2019 - TVDB are still in the process of fixing a number of bugs that have broken the TVDB scraper and any add-on that relies on TVDB data. TVDB are still working to rectify the problems.

Kodi DSPlayer – DirectShow Player for Windows
(2015-05-15, 16:52)aracnoz Wrote: @djoole

you always had error like this in your debug

21:17:34 T:2768 ERROR: CGUIFontTTFDX::CopyCharToTexture: Failed to upload from sysmem to vidmem (0x8876086C)

because stopping by json api (webserver/smatphone etc etc) was performed with a separate thread
the same thing was happening at video complete without stop by remote

so closing dsplayer with a separate thread was the cause of the error on texture, now these things are fixed and without any error in your debug you have this blackscreen :\

now some question

while blackscreen occurs kodi it's running properly? can you hear the sound from the gui if you move to left right etc etc?
if you stop the playback without complete the movie still happens the black screen?

there is some things that i just noticed in your debug log

are you using pulse eight as remote? can you try without this if still happens the problem, because just before to perform the stop somewhere kodi receives a pause command
i don't know why, i don't know if this it's the problem but i cannot reproduce a situation where the pause it's called just before to execute all stop procedure

@oldpoem

i still need an your debug log because i don't know if the problem it's the same of djoole, Warner306 had some problems on stop with some previous build but the causes was different
anyway you said that you can press power button and ok to close kodi... so can you hear the sound from the gui? kodi responds to the commands but the screen it's black?

I think it's the same problem as djoole. I can hear the sound of gui & kodi accept any command through keyboard & remote. The latest build has a little bit different behaviour though, now it most of the time it won't be backscreen part of gui showed up usually some topbar / status bar of skin and when press power button the shutdown menu sometimes popupped but the rest of screen stay black. Seem like not all GUI was restored. I'd try to created debug log next time it happened.

Also I'm not using any other inputs just wireless keyboard & mce remote. Most of the time keyboard stay off and only remote is used.
Reply
 
Thread Rating:
  • 46 Vote(s) - 4.41 Average


Messages In This Thread
Lockup on STOP issue resolved! - by MKANET - 2015-04-11, 21:59
RE: Kodi DSPlayer – DirectShow Player for Windows - by oldpoem - 2015-05-15, 17:02
RE: 4G aware patch - by MagikMark - 2015-09-08, 03:27
Alt-F4 no longer quits - by JeffA - 2015-10-31, 20:38