Kodi DSPlayer – DirectShow Player for Windows
(2015-08-13, 23:23)oldpoem Wrote:
(2015-08-13, 22:41)Cinder Wrote: I can't get this to work with XYSubFilter, I added it to filtersconfig and mediasconfig, and files start up and play with SVP interpolation working correctly, but no subtitles are visible. Not even ones that worked previously with the Kodi internal filter.

Any idea why that might be?

First troubleshooter , press "o" when playing file to see if xysubfilter loaded in active filters list. Then open xysubfilter properties panel and check if it set to always load.

If both checked and still no subtitle displayed. Post your mediaconfig / filtersconfig.

As I said in a previous post my xysubfilter is loaded in the active filters list. However I cannot access any properties panel for xysubfilter.
I use FFDShow RAW since I use SVP for frame interpolation, does this cause a problem with xysubfilter?

My filtersconfig:
Code:
<filtersconfig>
<filters>
<!-- Source -->
  <filter name="lavfsplitter" type="source">
   <guid>{B98D13E7-55DB-4385-A33D-09FD1BA26338}</guid>
   <osdname>LAV Splitter Source</osdname>
  </filter>
  <filter name="avsource" type="source">    
    <guid>{D8980E15-E1F6-4916-A10F-D7EB4E9E10B8}</guid>    
    <osdname>AV Source</osdname>
  </filter>
<!-- Splitters -->
  <filter name="lavf_splitter" type="splitter">
   <guid>{171252A0-8820-4AFE-9DF8-5C92B2D66B04}</guid>
   <osdname>LAV Splitter</osdname>
  </filter>  
  <filter name="avsplitter" type="splitter">
   <guid>{529A00DB-0C43-4F5B-8EF2-05004CBE0C6F}</guid>
   <osdname>AV Splitter</osdname>
  </filter>
<!-- Video -->
   <filter name="lavvideodec" type="videodec">
   <guid>{EE30215D-164F-4A92-A4EB-9D4C13390F9F}</guid>
   <osdname>LAV Video Decoder</osdname>
  </filter>
<!-- Extra -->
  <filter name="ffdraw" type="extra">
     <guid>{0B390488-D80F-4A68-8408-48DC199F0E97}</guid>
     <osdname>FFdshow RAW</osdname>
  </filter>
<!-- Audio -->
  <filter name="lavaudiodec" type="audiodec">
   <guid>{E8E73B6B-4CB3-44A4-BE99-4F7BCB96E491}</guid>
   <osdname>LAV Audio Decoder</osdname>
  </filter>
<!-- Subtitle Filter -->        
  <filter name="xysubfilter" type="subs">
   <guid>{2DFCB782-EC20-4A7C-B530-4577ADB33F21}</guid>
   <osdname>XySubFilter</osdname>
  </filter>    
</filters>
</filtersconfig>

My mediasconfig:
Code:
<mediasconfig>
    <rules>
        <rule filetypes="mkv|avi|mp4|m4v|flv|ts|mts">
            <source filter="lavfsplitter" />
            <splitter filter="lavf_splitter" />
            <video filter="lavvideodec" />
            <audio filter="lavaudiodec" />
            <subs filter="xysubfilter" />
            <extra>
                <extra filter="ffdraw" />
            </extra>
        </rule>
        <rule filetypes="m2ts|bdmv|mpls">
            <source filter="avsource" />
            <splitter filter="avsplitter" />
            <video filter="lavvideodec" />
            <audio filter="lavaudiodec" />
            <subs filter="xysubfilter" />
            <extra>
                <extra filter="ffdraw" />
            </extra>
        </rule>
    </rules>
</mediasconfig>
Reply
 
Thread Rating:
  • 46 Vote(s) - 4.41 Average


Messages In This Thread
Lockup on STOP issue resolved! - by MKANET - 2015-04-11, 21:59
RE: Kodi DSPlayer – DirectShow Player for Windows - by Cinder - 2015-08-15, 12:40
RE: 4G aware patch - by MagikMark - 2015-09-08, 03:27
Alt-F4 no longer quits - by JeffA - 2015-10-31, 20:38