•   
  • 1
  • 444
  • 445
  • 446(current)
  • 447
  • 448
  • 495
  •   
Kodi DSPlayer – DirectShow Player for Windows
(2018-11-03, 17:18)Warner306 Wrote: I don't know why you are always blowing your top over these bug reports. I was just trying to be helpful. You could simplify your explanation to AMD as to what is wrong.

Can you run the following quick tests:
  • Direct3D 11 + madVR (8-bit) + BT.709 + AMD (8-bit) =  normal/not normal
  • Direct3D 11 + madVR (10-bit) + BT.709 + AMD (8-bit) =  normal/not normal
  • Direct3D 11 + madVR (8-bit) + BT.709 + AMD (10-bit) =  normal/not normal
  • Direct3D 11 + madVR (10-bit) + BT.709 + AMD (10-bit) =  normal/not normal

This should tell you whether madVR is involved at all. The media player and GPU will operate independent of each other. 
whos blowing their tops?, I even stated clearly it wasnt your fault, I think you are misreading some of my posts, i'm not angry with you at all, far from it.

here are the results.
  • Direct3D 11 + madVR (8-bit) + BT.709 + AMD (8-bit) =  normal
  • Direct3D 11 + madVR (10-bit) + BT.709 + AMD (8-bit) =  not normal - very red
  • Direct3D 11 + madVR (8-bit) + BT.709 + AMD (10-bit) =  normal
  • Direct3D 11 + madVR (10-bit) + BT.709 + AMD (10-bit) =  not normal - very red


I
I7 / 16GB - LG OLED EF950 - RX580 - DEN X2200
WIN10-1809 - 4K - 444 RGB 60hz AMD 18.11.1
KODI DS - MADVR 92.17 0. - LAV 70.2.15 - FSE / 3D / DIRECT3D11 / 10bit
Reply
I would post those exact results in the Doom9 forum. madVR can't be eliminated because switching to 10-bit output is causing the problem.

It will be simpler to understand if BT.2020 wasn't correcting the problem. The AMD driver might not know what to do with a 10-bit BT.709 SDR source.

I would also add:

Direct3D 11 + madVR (10-bit) + BT.2020 + AMD (10-bit) =  normal (BT.709)
Reply
(2018-10-15, 08:20)Slurm Wrote:
(2018-10-13, 17:14)wints Wrote: Hi, anyone else having sound issues after pausing ? as in the movie plays back fine but with no audio and the only way to get audio back in that movie is to stop and resume? cheers
I've had this problem too with DTS HD. After disabling passthrough for it in the Dsplayer settings it worked.  
 Yeah seems fine if I disable passthrough, but at what expense? I'm I losing sound quality with pcm? cheers still learning sorry guys
Never mind guys just found the difference so it would be better for the AV to do the decoding
9.1 Cinema Room htpc with Kodi Krypton & emby server~Epson EH-TW9300~Homemade 8ft pj screen~AVR~Yamaha RX-A3070~Speakers~Monitor Audio RX6 Fronts & RX Centre~RXFX Surrounds~250's Rears~180's Front Presence~BK XXLS400 Sub~8033C AntiMode~HarmonyOne
 
Reply
(2018-11-03, 19:23)Warner306 Wrote: I would post those exact results in the Doom9 forum. madVR can't be eliminated because switching to 10-bit output is causing the problem.

It will be simpler to understand if BT.2020 wasn't correcting the problem. The AMD driver might not know what to do with a 10-bit BT.709 SDR source.

I would also add:

Direct3D 11 + madVR (10-bit) + BT.2020 + AMD (10-bit) =  normal (BT.709)
Thanks but I've ruled out MADVR if you remember, I've now managed to reproduce it in MPC BE with the standard renderer in DIRECT3D 10 bit output mode, it has to either be Windows 10, DIRECT3D or the AMD driver which is why I logged a ticket to AMD again. I asked MADSHI to pass the issue to any contacts he might have had at AMD but he must be busy as he hasnt been on the forum for a while.

Best MADSHI could do is maybe have a toggle in MADVR for AMD users to fix this problem as he does have workarounds in there for some NVIDA isues I think.
I7 / 16GB - LG OLED EF950 - RX580 - DEN X2200
WIN10-1809 - 4K - 444 RGB 60hz AMD 18.11.1
KODI DS - MADVR 92.17 0. - LAV 70.2.15 - FSE / 3D / DIRECT3D11 / 10bit
Reply
(2018-11-04, 12:24)wints Wrote:
(2018-10-15, 08:20)Slurm Wrote:
(2018-10-13, 17:14)wints Wrote: Hi, anyone else having sound issues after pausing ? as in the movie plays back fine but with no audio and the only way to get audio back in that movie is to stop and resume? cheers
I've had this problem too with DTS HD. After disabling passthrough for it in the Dsplayer settings it worked.   
 Yeah seems fine if I disable passthrough, but at what expense? I'm I losing sound quality with pcm? cheers still learning sorry guys
Never mind guys just found the difference so it would be better for the AV to do the decoding 
The audio is still digital and hasn't been decoded yet, so there is no loss of quality with PCM output.
Reply
(2018-11-04, 16:17)mclingo Wrote:
(2018-11-03, 19:23)Warner306 Wrote: I would post those exact results in the Doom9 forum. madVR can't be eliminated because switching to 10-bit output is causing the problem.

It will be simpler to understand if BT.2020 wasn't correcting the problem. The AMD driver might not know what to do with a 10-bit BT.709 SDR source.

I would also add:

Direct3D 11 + madVR (10-bit) + BT.2020 + AMD (10-bit) =  normal (BT.709)
Thanks but I've ruled out MADVR if you remember, I've now managed to reproduce it in MPC BE with the standard renderer in DIRECT3D 10 bit output mode, it has to either be Windows 10, DIRECT3D or the AMD driver which is why I logged a ticket to AMD again. I asked MADSHI to pass the issue to any contacts he might have had at AMD but he must be busy as he hasnt been on the forum for a while.

Best MADSHI could do is maybe have a toggle in MADVR for AMD users to fix this problem as he does have workarounds in there for some NVIDA isues I think.   
 You could simplify your explanation of the problem to AMD like this:

When using madVR for video playback, BT.709 SDR content is not being passed through to the display with the correct color.

To reproduce:

 (madVR - general settings) use Direct3D 11 for presentation (Windows 7 and newer) + (madVR) 8-bit + (madVR - calibration -> this display is already calibrated -> primaries) BT.709 + (AMD) 8-bit = normal (BT.709)

(madVR - general settings) use Direct3D 11 for presentation (Windows 7 and newer) + (madVR) 8-bit + (madVR - calibration -> this display is already calibrated -> primaries) BT.709 + (AMD) 10-bit = normal (BT.709)

(madVR - general settings) use Direct3D 11 for presentation (Windows 7 and newer) + (madVR) 10-bit + (madVR - calibration -> this display is already calibrated -> primaries) BT.709 + (AMD) 8-bit = not normal - oversaturated

(madVR - general settings) use Direct3D 11 for presentation (Windows 7 and newer) + (madVR) 10-bit + (madVR - calibration -> this display is already calibrated -> primaries) BT.709 + (AMD) 10-bit = not normal - oversaturated

(madVR - general settings) use Direct3D 11 for presentation (Windows 7 and newer) + (madVR) 10-bit + (madVR - calibration -> this display is already calibrated -> primaries) BT.2020 + (AMD) 8-bit/10-bit = normal (BT.709)

Summary: 10-bit SDR output from the media player with Direct3D 11 presentation enabled is producing the wrong colors. 

I would also mention the other media player with the same problem and attach the image that showed the corrupt color.
Reply
thanks, soon as a AMD tech guy gets back to me i'll provide him with this.
I7 / 16GB - LG OLED EF950 - RX580 - DEN X2200
WIN10-1809 - 4K - 444 RGB 60hz AMD 18.11.1
KODI DS - MADVR 92.17 0. - LAV 70.2.15 - FSE / 3D / DIRECT3D11 / 10bit
Reply
(2018-11-04, 17:57)Warner306 Wrote:
(2018-11-04, 12:24)wints Wrote:
(2018-10-15, 08:20)Slurm Wrote: I've had this problem too with DTS HD. After disabling passthrough for it in the Dsplayer settings it worked.   
 Yeah seems fine if I disable passthrough, but at what expense? I'm I losing sound quality with pcm? cheers still learning sorry guys
Never mind guys just found the difference so it would be better for the AV to do the decoding  
The audio is still digital and hasn't been decoded yet, so there is no loss of quality with PCM output.Thank you for the that Warner
9.1 Cinema Room htpc with Kodi Krypton & emby server~Epson EH-TW9300~Homemade 8ft pj screen~AVR~Yamaha RX-A3070~Speakers~Monitor Audio RX6 Fronts & RX Centre~RXFX Surrounds~250's Rears~180's Front Presence~BK XXLS400 Sub~8033C AntiMode~HarmonyOne
 
Reply
What's good my DSfreaks. Hope you're all doing well. I got an RTX 2080 and cranked a lot of the settings to max and boy, does it run good. Except for at 60fps 1080p. My question is.. Profiles. Can I VideoPlayer Merit a rule to 60hz? I'd be fine with that since all I use 60 for in Kodi is Twitch streams. OR can I in anyway configure a settings profile in MadVR around 60Hz? Sorry, I poked around a little but I couldn't really get to the bottom of this, neither with the help of Google. If any one has any ideas how I can handle this I'd appreciate it. 4K 23 and 24 and 30 runs just fine so I can'tvreally merit on the res here. The hertz is the only thing that separates these video streams.

Appreciate it. Smile

/CuraeL
Reply
I have it sometimes that after a uhd movie, kodi is coming back on the screen minimized. 
the only way to bring it back in fullscreen is to restart kodi complete.

any solution?
Reply
few things that could be, do you have full screen windowed ticked in KODI DS and do you KODI DS GUI set to the same res as your PC desktop?

Also if you have both 1080p and 2160p display modes in MADVR that can cause it, try using KODI DS refresh rate switching instead.

turn on FSE in MADVR also as a test.

One of these issues may solve this.
I7 / 16GB - LG OLED EF950 - RX580 - DEN X2200
WIN10-1809 - 4K - 444 RGB 60hz AMD 18.11.1
KODI DS - MADVR 92.17 0. - LAV 70.2.15 - FSE / 3D / DIRECT3D11 / 10bit
Reply
(2018-11-06, 01:12)curael Wrote: What's good my DSfreaks. Hope you're all doing well. I got an RTX 2080 and cranked a lot of the settings to max and boy, does it run good. Except for at 60fps 1080p. My question is.. Profiles. Can I VideoPlayer Merit a rule to 60hz? I'd be fine with that since all I use 60 for in Kodi is Twitch streams. OR can I in anyway configure a settings profile in MadVR around 60Hz? Sorry, I poked around a little but I couldn't really get to the bottom of this, neither with the help of Google. If any one has any ideas how I can handle this I'd appreciate it. 4K 23 and 24 and 30 runs just fine so I can'tvreally merit on the res here. The hertz is the only thing that separates these video streams.

Appreciate it. Smile

/CuraeL
Try adding this rule under scaling algorithms and create two profiles: 1080p60 and one for everything else (Other):

if (deintFps > 30) and ((srcWidth > 1280) and (srcWidth <= 1920)) "1080p60"
else if (deintFps > 30) and ((srcWidth <= 1280) and (srcHeight > 720) and (srcHeight <= 1080)) "1080p60"
else "Other"
Reply
I know DSPlayer doesn't support Tvheadend as a PVR back-end. I've just tried this PlayerCoreFactory rule that forces Kodi to use the normal DVDPlayer for live TV:

<playercorefactory>
    <rules action="prepend">
        <rule protocols="daap|rtv|rtmp|http|https|rtmpe|mms|rtp|rtsp|htsp" player="DVDPlayer" />
    </rules>
</playercorefactory>

For some reason, this correctly forces Kodi to use DVDPlayer when choosing a channel from the "Recently played channels" section, but if I try to choose a channel via the "Channels" or "Guide" section, it tries to use DSPlayer and fails. Does anyone know what am I missing in this rule?
Reply
4K display
windows 10; Kodi using DS Player/madvr

Am i correct in saying the video card should be expected to work it's hardest when the source is 480i video and work its least when the source is 4K?
Reply
(2018-11-07, 20:04)DragonQ Wrote: I know DSPlayer doesn't support Tvheadend as a PVR back-end. I've just tried this PlayerCoreFactory rule that forces Kodi to use the normal DVDPlayer for live TV:

<playercorefactory>
    <rules action="prepend">
        <rule protocols="daap|rtv|rtmp|http|https|rtmpe|mms|rtp|rtsp|htsp" player="DVDPlayer" />
    </rules>
</playercorefactory>

For some reason, this correctly forces Kodi to use DVDPlayer when choosing a channel from the "Recently played channels" section, but if I try to choose a channel via the "Channels" or "Guide" section, it tries to use DSPlayer and fails. Does anyone know what am I missing in this rule?
The only protocol I can see you are missing is pvr. Try adding it.

Add maybe try adding a </rule> in there: 

</rule>
</rules>

If you are using 17.6, it is no longer "DVDPlayer" but "VideoPlayer."
Reply
  •   
  • 1
  • 444
  • 445
  • 446(current)
  • 447
  • 448
  • 495
  •   
 
Thread Rating:
  • 46 Vote(s) - 4.41 Average



Logout Mark Read Team Forum Stats Members Help
Kodi DSPlayer – DirectShow Player for Windows4.4146