[REQUEST] Addon for bigstar.tv

  Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Alexsource Offline
Senior Member
Posts: 161
Joined: Jul 2014
Reputation: 1
Post: #1
http://www.bigstar.tv/
This seems to be a legal site from what I could tell, it is not listed in http://wheretowatch.com/where-to-watch , but they do have apps for a lot of devices, including IOs ones --> https://itunes.apple.com/us/app/movies-y...23315?mt=8 . IF it happens to not be a legal site, then you can disregard this thread altogether.

It has a bunch of b-movies, documentaries, shorts and such. It has 2 plans: free with ads, or premium (monthly subscription). I'm just interested on the free stuff.
Some of the stuff there seems to also be at snagfilms, but on bigstar it's available for my region while at snagfilms it's not always available.

It also uses JWPlayer ads edition.
find quote
Alexsource Offline
Senior Member
Posts: 161
Joined: Jul 2014
Reputation: 1
Post: #2
I've just found out bigstar now has a new design of their webpage in beta stage which uses an html5 player --> http://preview.bigstar.tv/ . For anyone interested, from there you can right-click your way to the video url and save it to a file kodi can interpret ( Internet_video_and_audio_streams (wiki) ).
Also, I've tryed sending the url to kodi with the Send to XBMC firefox addon, and it seems to work.

Just bare in mind the new site design is in beta stage and kinda buggy, so be patient Tongue and it'll work.
(This post was last modified: 2016-01-31 15:38 by Alexsource.)
find quote
MetalChris Online
Fan
Posts: 658
Joined: Jan 2014
Reputation: 34
Location: U.S.A.
Post: #3
Thanks for the info. I wrote a simple add-on for BigStar a few months ago, if you're interested you can give it a try:


EDIT: Link removed. Download the latest version from post 21.

Looks like I may need to do an update in the near future.

XBMC Gotham (13.2) on ThinkPad T400 Ubuntu 12.04.5 | Kodi Jarvis (16.1) on HTPC Lubuntu 14.04 | My Add-ons | My Repo
(This post was last modified: 2016-02-08 06:52 by MetalChris.)
find quote
Alexsource Offline
Senior Member
Posts: 161
Joined: Jul 2014
Reputation: 1
Post: #4
Nice! I'll give your addon atry! Big Grin
find quote
Alexsource Offline
Senior Member
Posts: 161
Joined: Jul 2014
Reputation: 1
Post: #5
It seems to work well. The only weird thing I've noticed is some movie descriptions have issues with special characters, like '. I'm using Jarvis rc2 btw.
find quote
MetalChris Online
Fan
Posts: 658
Joined: Jan 2014
Reputation: 34
Location: U.S.A.
Post: #6
(2016-02-01 14:24)Alexsource Wrote:  It seems to work well. The only weird thing I've noticed is some movie descriptions have issues with special characters, like '. I'm using Jarvis rc2 btw.

The issue with the special characters is caused by an encoding issue due to the way I'm getting the info from the site. I'm sure I can work this out for a future release, but -

I'm not having any luck getting the add-on to work with the beta preview. Sad

I'll keep trying though, hopefully I'll have a breakthrough soon. For now, enjoy the add-on as-is.

XBMC Gotham (13.2) on ThinkPad T400 Ubuntu 12.04.5 | Kodi Jarvis (16.1) on HTPC Lubuntu 14.04 | My Add-ons | My Repo
find quote
Alexsource Offline
Senior Member
Posts: 161
Joined: Jul 2014
Reputation: 1
Post: #7
I'm cool with a little enconding issue Wink keep up the good work!
find quote
MetalChris Online
Fan
Posts: 658
Joined: Jan 2014
Reputation: 34
Location: U.S.A.
Post: #8
I've updated the add-on to version 0.0.3 which fixes the encoding issue. If I followed the instructions correctly, and you have auto updates enabled, you should be running version 0.0.3 now. If the add-on did not update for you, use the link below to get the latest version.


EDIT: Link removed. Download the latest version from post 21.

Also, I've had the breakthrough I was hoping for, and should be able to keep the add-on working with the new site design. Big Grin

XBMC Gotham (13.2) on ThinkPad T400 Ubuntu 12.04.5 | Kodi Jarvis (16.1) on HTPC Lubuntu 14.04 | My Add-ons | My Repo
(This post was last modified: 2016-02-08 06:52 by MetalChris.)
find quote
Alexsource Offline
Senior Member
Posts: 161
Joined: Jul 2014
Reputation: 1
Post: #9
Nice! I'll give it a whirl when I get back home.
find quote
Eye in the sky Offline
Fan
Posts: 391
Joined: Apr 2011
Reputation: 10
Location: Germany
Post: #10
I get an error message "dependencies not met" with v 0.0.3.
find quote
Alexsource Offline
Senior Member
Posts: 161
Joined: Jul 2014
Reputation: 1
Post: #11
Yeah. me too: "The dependency on script.module.beautifulsoup version 4.3.2 could not be satisfied"

But, I do have it installed...
find quote
MetalChris Online
Fan
Posts: 658
Joined: Jan 2014
Reputation: 34
Location: U.S.A.
Post: #12
(2016-02-05 15:59)Eye in the sky Wrote:  I get an error message "dependencies not met" with v 0.0.3.

(2016-02-06 00:22)Alexsource Wrote:  Yeah. me too: "The dependency on script.module.beautifulsoup version 4.3.2 could not be satisfied"

But, I do have it installed...

Sorry, not sure why I changed the requirement in the addon.xml file, but I changed it back to match the requirements in the version 0.0.2 addon.xml. Try downloading from the link below.


EDIT: Link removed. Download the latest version from post 21.

If the previous version was working for you, version 0.0.3 should now work too. Let me know if there are still any problems.

XBMC Gotham (13.2) on ThinkPad T400 Ubuntu 12.04.5 | Kodi Jarvis (16.1) on HTPC Lubuntu 14.04 | My Add-ons | My Repo
(This post was last modified: 2016-02-08 06:53 by MetalChris.)
find quote
Alexsource Offline
Senior Member
Posts: 161
Joined: Jul 2014
Reputation: 1
Post: #13
It seems to still have the dependency problems. Same message only it says version 4.2.0 now instead of 4.3.2.
find quote
MetalChris Online
Fan
Posts: 658
Joined: Jan 2014
Reputation: 34
Location: U.S.A.
Post: #14
Argh. Sometimes BeautifulSoup drives me nuts. An older add-on had similar issues - the module was installed, but the add-on wasn't seeing it for some reason. I finally tried downloading and re-installing the module and things started working. The link below is from the Kodi Isengard mirror. Try downloading and re-installing and let me know if that works.

BeautifulSoup 4.3.2

This won't be an issue with the version I'm developing to work with the new site design on BigStar as I'm using JSON, which is easier to work with, and seems to be much faster.

XBMC Gotham (13.2) on ThinkPad T400 Ubuntu 12.04.5 | Kodi Jarvis (16.1) on HTPC Lubuntu 14.04 | My Add-ons | My Repo
find quote
Alexsource Offline
Senior Member
Posts: 161
Joined: Jul 2014
Reputation: 1
Post: #15
I've tryed like you said, but it still shows the dependency message. Huh
find quote
Post Reply