[REQUEST] Addon for bigstar.tv
#16
(2016-02-06, 02:40)Alexsource Wrote: I've tryed like you said, but it still shows the dependency message. Huh

Hmm, this is getting weird. Have you tried re-starting Kodi, or a complete reboot?

If that doesn't work, try downloading from the link below. I've removed the BeautifulSoup requirement from the addon.xml file. I'm not positive, but I think if the module is already installed, the add-on doesn't really need to import it again during installation, it only needs to access it when running.

EDIT: Link removed. Download the latest version from post 21.
Kodi Krypton (17.6) on ThinkPad T400 Lubuntu 18.04 | Kodi Krypton (17.6) on HTPC Lubuntu 16.04 | My Add-ons | My Repo
Reply
#17
Well I'll give it a better try tommorrow, but I've tryed 0.0.3a and this is what the log has to say:
Code:
22:33:52 T:8060   ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                             - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                            Error Type: <type 'exceptions.ImportError'>
                                            Error Contents: No module named bs4
                                            Traceback (most recent call last):
                                              File "C:\Users\Alexis\AppData\Roaming\Kodi\addons\plugin.video.bigstar\addon.py", line 8, in <module>
                                                from bs4 import BeautifulSoup
                                            ImportError: No module named bs4
                                            -->End of Python script error report<--
22:33:52 T:8040   ERROR: XFILE::CDirectory::GetDirectory - Error getting plugin://plugin.video.bigstar/
22:33:52 T:8040   ERROR: CGUIMediaWindow::GetDirectory(plugin://plugin.video.bigstar/) failed
22:33:58 T:8040   ERROR: Unable to activate the previous window
Reply
#18
Well, I gave another go just in case, I went and added the following line to 0.0.3a's addon.xml
Code:
<import addon="script.module.beautifulsoup4" version="4.3.2"/>
And now the addon starts Huh I've even tryeda random movie and it started playing Wink
Reply
#19
(2016-02-06, 03:53)Alexsource Wrote: Well, I gave another go just in case, I went and added the following line to 0.0.3a's addon.xml
Code:
<import addon="script.module.beautifulsoup4" version="4.3.2"/>
And now the addon starts Huh I've even tryeda random movie and it started playing Wink

Wow, like I said, sometimes BeautifulSoup drives me nuts. You basically just added what I had removed. Huh

Appreciate your persistence, and glad you got it working!

I'm making some pretty good progress getting the add-on to work with the new site design, just have to get the TV Episodes working. Might even be able to release it tomorrow. Stay tuned...
Kodi Krypton (17.6) on ThinkPad T400 Lubuntu 18.04 | Kodi Krypton (17.6) on HTPC Lubuntu 16.04 | My Add-ons | My Repo
Reply
#20
I guess it was somewhat "sensitive" about the version number Tongue
Just in case, bigstar sister sites seem to already be using the new site design. I only took a peek at then, and they seem to be sub-sets of what is available in bigstar, except maybe for their bollywood site ( http://www.bestbollywood.tv ). Not interested about this sister sites, but I thought it might be useful for you to know Wink
Reply
#21
Thanks for the info, didn't realize there were any sister sites. They do look to be just smaller components of what makes up the BigStar site.

I've finished the re-write for the new site design. Re-creating a working Search function held me up a bit from releasing the new version. The Search option on the main listing will search for movies only. I actually had to create a separate function, which is available inside the TV Episodes menu, to search the TV shows. I'd prefer to have a unified Search function for all videos, but with the way the results are returned this was the best I could come up with - for now.

I've darkened the default fanart for the add-on a bit to make it easier to read the listings, and this version also has fanart specific to the selected movie or TV show. Image availability for the the TV shows seems to be somewhat spotty though. Links exist, but no image is returned in some instances. Not sure if this is due to the site design still being in the beta stages or not, but since the links provided don't work in a browser either I know the add-on is not at fault. This in no way affects the ability to play the videos though, so I'll take a wait and see approach and perhaps look into this further once the beta site design becomes final.

No BeautifulSoup in this version, but the simplejson module is required.

Download the latest version of the add-on from the link below:

EDIT: Link removed. Please download the latest version from post #23 below.

It might be best to uninstall any existing versions before installing the latest version. If you're having any issues with the add-on, please post a log (wiki).
Kodi Krypton (17.6) on ThinkPad T400 Lubuntu 18.04 | Kodi Krypton (17.6) on HTPC Lubuntu 16.04 | My Add-ons | My Repo
Reply
#22
Hey, I've just updated and it seems to work fine Smile
Reply
#23
Oops, just discovered a bug... Seems I was re-constructing the same link for all episodes of a TV show, so the add-on ended up streaming the first episode in the list no matter which episode was selected.

Sorry 'bout that. Confused

EDIT: Please download from post #45, or install my repo from the link in my signature.

It might be best to uninstall any existing versions before installing the latest version. If you're having any issues with the add-on, please post a log (wiki).
Kodi Krypton (17.6) on ThinkPad T400 Lubuntu 18.04 | Kodi Krypton (17.6) on HTPC Lubuntu 16.04 | My Add-ons | My Repo
Reply
#24
Hey, I gave it a go yesterday and it seems to be fine Wink
Reply
#25
(2016-02-10, 18:10)Alexsource Wrote: Hey, I gave it a go yesterday and it seems to be fine Wink

Excellent! Thanks for the feedback.
Kodi Krypton (17.6) on ThinkPad T400 Lubuntu 18.04 | Kodi Krypton (17.6) on HTPC Lubuntu 16.04 | My Add-ons | My Repo
Reply
#26
There seems to be some troubles, the playback skips some frames. Maybe something changed in the website? I'had updated to 16.1 recently, no sure if it happened before that.
Reply
#27
(2016-05-04, 00:55)Alexsource Wrote: There seems to be some troubles, the playback skips some frames. Maybe something changed in the website? I'had updated to 16.1 recently, no sure if it happened before that.

As far as I can tell, there's been no changes to the website. In fact, they still have not completed the changeover to the new site layout. There's still a link to the 'Beta' site.

Had you noticed this on multiple videos or just one? I just watched the third episode of 'Devil's Brigade' and playback was smooth as usual. I don't have a system running Jarvis, so can't rule out something being caused by your recent update. Let me know what you were watching when this occurred and I'll try to see if I get the same result.
Kodi Krypton (17.6) on ThinkPad T400 Lubuntu 18.04 | Kodi Krypton (17.6) on HTPC Lubuntu 16.04 | My Add-ons | My Repo
Reply
#28
I tryed 2 different flicks: Spolier and Death Race 2000, and both seem to have this issue. I'll try to get a log file when i get home.
Reply
#29
Weird, I tryed playing a different flick, for the sake of variety, El Robot Magnos. It skipped frames.
thenm I went and played Devils Brigade ep 3 and it was working fine. So did Spoiler and Death Race.
So I went back to Magnos and it played fine as well!!!

Might be somehting on my machine hogging either cpu or some such. I'll test some more before uploading a log.
Reply
#30
(2016-05-06, 02:01)Alexsource Wrote: Weird, I tryed playing a different flick, for the sake of variety, El Robot Magnos. It skipped frames.
thenm I went and played Devils Brigade ep 3 and it was working fine. So did Spoiler and Death Race.
So I went back to Magnos and it played fine as well!!!

Might be somehting on my machine hogging either cpu or some such. I'll test some more before uploading a log.

OK, thanks for the update. Seems like you could be on to something there. I've got Death Race 2000 playing now, and so far no problems.
Kodi Krypton (17.6) on ThinkPad T400 Lubuntu 18.04 | Kodi Krypton (17.6) on HTPC Lubuntu 16.04 | My Add-ons | My Repo
Reply
 
Thread Rating:
  • 1 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
[REQUEST] Addon for bigstar.tv51