•   
  • 1
  • 5
  • 6
  • 7
  • 8
  • 9(current)
[Windows] KODI4SMARTIE - Kodi DLL for LCD Smartie
I will take a look at it in the next few days and let you know what I find. It sounds like the connection to KODI is no succeeding.
Reply
ok thankx
Reply
I started up Kodi 17.5 and lcd smartie and am having no issues connecting to Kodi and receiving events. Perhaps you can turn on logging in the config file and see what it shows. What does your config file look like?
Reply
Hello.
I really, really like this plugin and it works very good with just 1 annoying bug..hope it could be fixed...

I'm from Germany and got the "ä, ö, ü" letters. If i write some text directly in lcd-smartie the letters works as they should but it seems that kodi or the plugin doesn't.
Look my screenshot:
Image

both should be correctly called "Bluträcher" instead of the chinese thing.
Same happens if i'm at the mainmenu which is called "Hauptmenü" -> the "ü" is again replaced by this chinese character

my code:
Code:
$dll(if,1,$dll(kodi4smartie,7,XBMC.GetInfoLabels,Player.Title)#,$dll(kodi4smartie,7,XBMC.GetInfoLabels,System.CurrentWindow)#$dll(if,1,$dll(kodi4smartie,7,XBMC.GetInfoLabels,MusicPlayer.Artist)#,#$dll(kodi4smartie,7,XBMC.GetInfoLabels,MusicPlayer.Artist) - )$dll(kodi4smartie,7,XBMC.GetInfoLabels,Player.Title)$dll(if,1,$dll(kodi4smartie,7,XBMC.GetInfoLabels,MusicPlayer.Album)#,# [$dll(kodi4smartie,7,XBMC.GetInfoLabels,MusicPlayer.Album)])                    )

$dll(if,1,$dll(kodi4smartie,7,XBMC.GetInfoLabels,Player.Title)#,$dll(kodi4smartie,7,XBMC.GetInfoLabels,System.CurrentControl)#$dll(kodi4smartie,7,XBMC.GetInfoLabels,Player.Time(h:mm:ss))$dll(if,1,$dll(kodi4smartie,7,XBMC.GetInfoLabels,Player.Duration)#,#/$dll(kodi4smartie,7,XBMC.GetInfoLabels,Player.Duration(h:mm:ss)))

$dll(Kodi4smartie,2,,)

$dll(Kodi4smartie,1,,)            $CustomChar(1,0,14,21,23,17,14,0,0)$Chr(176)$Time(hh:nn)
Reply
ok i try to put on logging in the config file of the plugin, ill post it later today
Reply
update: after instal off kodi 17.6 i have now kodi for smartie working again? tv channel are displayed, but movies are displayed as unknow
im on kodi4smartie 2.0.2a2 version
i use in smartie the follow lines:
$dll(kodi4smartie,1,,)
$dll(kodi4smartie,2,,)
this is my config:
//
// kodi4smartie configuration file
//
// Lines beginning with // are ignored.

//
//ConfigItems
//
//logging, 1=enabled.  All notifications are logged.
//logging=1

// create a new file each time 
//newfile=0

// TCP port
//port=9090

 Character LCD width
lcd_width=16

 Use graphical bars to display progress values, if zero then show value as text
use_bars=0

// Use character bars. 
// Some LCDs dont handle the normal bars right.
// mode 0: use graphical bars
// mode 1: >>>>    
// mode 2: >>>>----
// mode 3: --->----
//bar_mode=0

 Delay (in second) before returning to welcome screen after hitting stop.
reset_delay=3

//application to monitor for before connecting (case sensitive)
//might need to be kodi.exe for windows 10 app version
//kodiexe=Kodi.exe

// Number of seconds to wait before connect after detection of the kodiexe
//connect_delay=1

// Format of the time/date. See http://www.delphibasics.co.uk/RTL.asp?Na...atDateTime    
time_format=dd/mm/yy hh:nn

//When using function 7 & 8 to retreive the state. If the state is none and the idle_timer time has passed
//the the state will be set to idle(11). Set to zero to disable the idle timer. Use function 10 to cancel
//the idle timer.
//idle_timer=5

//
//Strings. override these to localize
//
welcome=Kodi HTPC
stop_str=Stop
//track_str=Track
//channel_str=Channel
//ff_str=Fast-Forward
//rewind_str=Rewind
//volume_str=Volume
//knf_str=Kodi not found
//unknown_title=Unknown Title

//
// Modify title using regular expresions. Can declare multiple regular expression
//
//regex=match,replace
//
// remove formating [color blue] etc
regex=\^\ (wiki)*\],
//character replacements.
//regex=ø,oe
//regex=å,aa
//regex=æ,ae


All i want was like before show channels of tv line 1 time playing line2
and when movie plays line 1: moviename
line 2: time played and time remain (time movie)
Reply
any news how we can display movie title that is playing, now it says Unknown title, my tvchanels are displayed good : channel 1 NPO1 ect,ect
Only movies and series show Unknown?
Reply
no answer yet, not found the problem?
hope you can fix it

gtrz ed
Reply
(2017-11-12, 22:05)skite2001 Wrote: Hello.
I really, really like this plugin and it works very good with just 1 annoying bug..hope it could be fixed...

I'm from Germany and got the "ä, ö, ü" letters. If i write some text directly in lcd-smartie the letters works as they should but it seems that kodi or the plugin doesn't.
Look my screenshot:
Image

both should be correctly called "Bluträcher" instead of the chinese thing.
Same happens if i'm at the mainmenu which is called "Hauptmenü" -> the "ü" is again replaced by this chinese character

my code:
Code:
$dll(if,1,$dll(kodi4smartie,7,XBMC.GetInfoLabels,Player.Title)#,$dll(kodi4smartie,7,XBMC.GetInfoLabels,System.CurrentWindow)#$dll(if,1,$dll(kodi4smartie,7,XBMC.GetInfoLabels,MusicPlayer.Artist)#,#$dll(kodi4smartie,7,XBMC.GetInfoLabels,MusicPlayer.Artist) - )$dll(kodi4smartie,7,XBMC.GetInfoLabels,Player.Title)$dll(if,1,$dll(kodi4smartie,7,XBMC.GetInfoLabels,MusicPlayer.Album)#,# [$dll(kodi4smartie,7,XBMC.GetInfoLabels,MusicPlayer.Album)])                    )

$dll(if,1,$dll(kodi4smartie,7,XBMC.GetInfoLabels,Player.Title)#,$dll(kodi4smartie,7,XBMC.GetInfoLabels,System.CurrentControl)#$dll(kodi4smartie,7,XBMC.GetInfoLabels,Player.Time(h:mm:ss))$dll(if,1,$dll(kodi4smartie,7,XBMC.GetInfoLabels,Player.Duration)#,#/$dll(kodi4smartie,7,XBMC.GetInfoLabels,Player.Duration(h:mm:ss)))

$dll(Kodi4smartie,2,,)

$dll(Kodi4smartie,1,,)            $CustomChar(1,0,14,21,23,17,14,0,0)$Chr(176)$Time(hh:nn)
You probably need to enable something in the config file. Try the following section. You might need to turn on logging, reproduce your issue and see what is shown in the log file in order to display the correct character. I only can display what is given to me.

//character replacements.
//regex=ø,oe
//regex=å,aa
//regex=æ,ae
Reply
(2017-12-01, 18:46)eddedrukker Wrote: no answer yet, not found the problem?
hope you can fix it

gtrz ed
 For some reason I did not get an update in my email for your response. The problem is that kodi is not passing the title to me. It used to. It got broken somewhere in an early 17.x release. I was trying to write up a bug but didnt have the time  to figure out how to do it. Once day once I get sometime I will write up a bug to see if it can get fixed.
Reply
(2017-12-04, 23:14)Jakester34 Wrote:
(2017-12-01, 18:46)eddedrukker Wrote: no answer yet, not found the problem?
hope you can fix it

gtrz ed
 For some reason I did not get an update in my email for your response. The problem is that kodi is not passing the title to me. It used to. It got broken somewhere in an early 17.x release. I was trying to write up a bug but didnt have the time  to figure out how to do it. Once day once I get sometime I will write up a bug to see if it can get fixed. 
 ok we wait thankx for the answer
Reply
I see that the CodePlex site is now read only, and the source code has been moved to GitHub.  Just wondering if there is somewhere I can download the latest compiled .DLL?  I see that a "timeout" value has been added to the config file, but it must be after version 2.0.2a2.  Thanks.
Reply
Anyone found a fix for special characters?

Im using spanish and every á, é, í, ó, ú show a weird graphic.

Also, there is a proper command or configurarion to see the folder you are navigating? I can see the main categories, movies, music, but as soon as you enter a sub menu inside music, nothing show on screen. Text appears again when you are navigating music files, but when still navigating through subfolders, nothing show till you get inside the folder with music.

Thanks
Reply
  •   
  • 1
  • 5
  • 6
  • 7
  • 8
  • 9(current)
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
KODI4SMARTIE - Kodi DLL for LCD Smartie00