•   
  • 1
  • 20
  • 21
  • 22(current)
  • 23
  • 24
  • 89
  •   
OpenELEC Testbuilds for RaspberryPi (Kodi 15.0) Part 2
Hi guys,

here is the debug log from the crash.

the file is an 4 gb mkv file dvd copy. after 13 or so minutes it crashes.

suddenly the cpu goes to 100% and the movie stops, then after a few seconds crashes.

The movie also crashes on android. but at a different time.

http://xbmclogs.com/pbjnlrbgj

hope it helps !!
(2015-04-30, 20:58)OurJermain Wrote: Hi guys,

here is the debug log from the crash.

So Kodi isn't crashing, it's just playback that is stopping?

If Kodi is crashing, please upload your /storage/.kodi/temp/kodi_crashlog_<date/time>.log file. If Kodi isn't crashing, please use the correct terminology when reporting an issue. Smile

According to your log, you're getting a read error:
Code:
20:49:45 843.389709 T:1609561152   ERROR: ffmpeg[5FEFF440]: [matroska,webm] Read error at pos. 561196769 (0x21732ee1)

which might suggest your MKV has an issue (encoding issue, or maybe just corrupt file?)
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2015-04-30, 20:58)OurJermain Wrote: http://xbmclogs.com/pbjnlrbgj

I assume the file is corrupt. Does it play correctly on any player or on any platform?
Thank you guys, I am re-download the file. Will report tomorrow. And thanks for explaining I should not say crash but the file stopped playing instead.
Latest builds are still rockin and rollin for me using only mmal. I mostly watch mpeg2 streams from pvr.mythtv, both live and recorded and h264 encoded videos via nfs.
(2015-04-29, 21:17)doveman2 Wrote:
(2015-04-29, 19:55)rterblanche Wrote: Check your hdmi cable. If you gave her a new cable it might not be CEC capable.

The cable said High Speed HDMI with Ethernet, so I thought it should work but I had another one which says the same and that seems to work better. I don't get the error popup anymore but still the remote does nothing and I can't see in the log that the RPi is registering any key presses http://pastebin.com/GN8pVtMS

I installed OE 5.0.8 to check whether it was any different and with that I do see a popup about registering the TV CEC after XBMC loads, which I don't see with #418 but still the remote has no effect and I'm not seeing any keypresses registering in the log http://pastebin.com/iiAETsqP

Try plugging the RPi into another HDMI port on the TV. CEC might only work on port 1. If you are plugging into an AV receiver then that will go in HDMI 1 on the TV and the RPi should go into HDMI 1 on the AV receiver. I looked up this unit and I didn't see any mention of CEC capability but most manufactures don't mention it anymore or re-brand it. A call to the vendor of the TV might confirm that CEC is available.
New OpenELEC Isengard build #0430: RPi / RPi2
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 4.0.0 #1 Fri May 1 06:40:29 BST 2015 armv6l GNU/Linux

# vcgencmd version
Apr 28 2015 18:46:46
Copyright (c) 2012 Broadcom
version f33c3f25a8bdb3522ba6b47871e15897acc223da (clean) (release)

# lsb_release
OpenELEC (Milhouse) - Version: devel-20150501063937-#0430-g774f426 [Build #0430]

# vcdbg log msg 2>&1 | grep DTOK
001545.834: Kernel trailer DTOK property says yes

# Kernel device tree status: Enabled

Based on tip of OpenELEC master (774f4262, changelog) and tip of XBMC master (282bc13d, changelog) with the following modifications: Build Highlights:
  1. Temporarily revert upstream dcadec due to performance issues, continue with original patch from previous builds
  2. Temporarily revert upstream kernel 4.0.1 until rpi-4.0.y bump
  3. Add pvr.vbox and pvr.stalker addons to build
  4. newclock4 - even more screensavers!
  5. Add "CONFIG_DMA_BCM2708_LEGACY=y" to linux.arm.conf as this now seems to be required for some reason
Build Details:
  1. OpenELEC:
    • Include libvcsm.so in RPi/RPi2 builds - needed by upcoming firmware (PR:4116, 1 commit, 1 file changed)
    • [build] add BUILD_SUFFIX to the IMAGE_NAME, too. (PR:4052, 1 commit, 1 file changed)
    • ccache: update to ccache-3.2.1 (16ca2949)
    • new package: add package 'dcadec' (78787437)
    • libevdev: update to libevdev-1.4.2 (6b86c6b2)
    • ffmpeg: add upstream dcadec support (02ffc575)
    • kodi: add patch to support dcadec (75dd5a44)
    • linux: update to linux-4.0.1 (31bc4c7d)
    • libass: update to libass-0.12.1 (91b72b21)
    • distributions/OpenELEC/options: cleanup (c1cad68f)
    • pcre: update to pcre-8.37 (0bdca6ea)
    • new addon: pvr.stalker (e80dcbbf)
  2. XBMC:
    • ActiveAE: slightly reduce buffer size (PR:7035, 1 commit, 1 file changed)
    • [seekhandler] fix wrong seek step processing if no delay is configured (PR:7031, 4 commits, 2 files changed)
    • emulate fputs to fix curl warning (PR:7004, 1 commit, 1 file changed)
    • [pvr] Improve PVR startup time (PR:6246, 1 commit, 1 file changed)
    • [pvr] Add new pvr.stalker add-on (PR:7036, 1 commit, 2 files changed)
    • [mmalrenderer] Fix initialisation of m_format in init_vout (PR:7021, 1 commit, 1 file changed)
    • update splash image for beta (b153f6c5)
  3. newclock4:
    • New commits in this build:
      • fixup: leave lock (adc2226d)
      • squash: warp: less wild zooming (6332f129)
      • squash: Make screensavers use a generic framework. Add a couple more (aaa7643d)
    • Commits no longer in build:
      • [mmalcodec] Fix initialisation of m_format in init_vout (8d0e0f30)
      • ActiveAE: slightly reduce buffer size (592ca69b)
  4. Additional commits/pull requests/changes not yet merged upstream:
    • Added: patch: Fix GLES screensaver build
    • Added: patch: Add dcadec package for DTS HD-MA support
    • Updated: patch: Enable sdhost driver
    • Updated: patch: Enable audiodecoder, audioencoder, pvr and visualization addons
    • Reverted: 02ffc575: ffmpeg/dcadec (performance issue)
    • Reverted: 75dd5a44: kodi/dcadec (performance issue)
    • Reverted: 78787437: dcadec package (performance issue)
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2015-04-30, 15:56)popcornmix Wrote:
(2015-04-30, 13:03)Gregoire Wrote:
(2015-04-30, 12:15)popcornmix Wrote: If you have had hangs or stuttery video with dvd playback then please test latest build.

I've had the same issue. It was worse with MMAL enabled.

Can you provide a sample file that is stuttery with latest build?

Installed the last build 430 and stuttering is gone. Plays as smooth as I've ever seen.
(2015-04-23, 14:41)hdmkv Wrote: Curious as to how the ISO support is coming along?

I hope it should be there within the next few days; I'm afraid I've been quite unwell this month, which has delayed it.
I just tried 0430 and see two new PVR addons added. Unfortunately, they are enabled on updating to 0430 and it temporarily borks things if you have another PVR addon (hts, in my case). I think they should come disabled by default. Is this a Kodi issue, OE issue, or OE testbuild issue?

I'll test the new (old?) dcadec DTS-MA tonight (movie night)!

Love the build so far.
Wink 
(2015-05-01, 14:17)deborah_c Wrote:
(2015-04-23, 14:41)hdmkv Wrote: Curious as to how the ISO support is coming along?

I hope it should be there within the next few days; I'm afraid I've been quite unwell this month, which has delayed it.

WoHoo.. Big Grin Big Grin Big Grin
Most likely this is the wrong thread so feel free to point me to the correct location. I got troubles with the new FULL HD framepacking 3D over HDMI feature on my Raspberry PI 2. I tested it using those three 1 minute mkv samples from another thread here ("Gravity", "The Hobbit - Desolation of Smaug", "Thor 2") aswell as using a MakeMKV rip of "Frozen" and some HSBS samples.
With "Settings -> Acceleration -> Use Full HD HDMI modes for 3D" activated all videos play in 2D mode on my TV. If I disable it the HSBS samples trigger the 3D mode automatically and everything works as desired. The FULL HD MVC mkv files keep playing in 2D though.

So far I was just shrugging my shoulders telling myself the TV (LG 55LB650V) is crap and plainly doesn't support FULL HD 3D frame packing as HDMI input. What makes me wonder now is that playing 3D BluRays with the PS3 works. Isn't the PS3 sending the very same HDMI stream (except HDCP) to the TV when playing a 3D BluRay? I guess I'm missing some detail here that everyone else knows, just like usual ;-).
See what tv modes are supported with the tvservice command.
If I have helped you or increased your knowledge, click the 'thumbs up' button to give thanks :) (People with less than 20 posts won't see the "thumbs up" button.)
(2015-05-01, 18:24)doug Wrote: I just tried 0430 and see two new PVR addons added. Unfortunately, they are enabled on updating to 0430 and it temporarily borks things if you have another PVR addon (hts, in my case). I think they should come disabled by default. Is this a Kodi issue, OE issue, or OE testbuild issue?

Strange, they're disabled on my systems (but then I don't have PVR enabled at all). Not sure why they would be enabled by default.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2015-05-02, 00:44)Milhouse Wrote:
(2015-05-01, 18:24)doug Wrote: I just tried 0430 and see two new PVR addons added. Unfortunately, they are enabled on updating to 0430 and it temporarily borks things if you have another PVR addon (hts, in my case). I think they should come disabled by default. Is this a Kodi issue, OE issue, or OE testbuild issue?

Strange, they're disabled on my systems (but then I don't have PVR enabled at all). Not sure why they would be enabled by default.

I had to disable as well. I use PVR.WMC.
  •   
  • 1
  • 20
  • 21
  • 22(current)
  • 23
  • 24
  • 89
  •   



Logout Mark Read Team Forum Stats Members Help
OpenELEC Testbuilds for RaspberryPi (Kodi 15.0) Part 214
This forum uses Lukasz Tkacz MyBB addons.