PVR.TVH Crashing
#1
Just setup TVheadend on Kodibuntu (Helix 14.0) and am having problems with Kodi crashing whenever i start the live TV. This doesn't seem to be an issue with TVHeadend itself as I have a RapberryPI client running openelec in a different room connected to the same TVHeadend backend with no issues.

Sometimes the crash happens as soon as I start live TV sometimes it happens after watching for a few seconds, sometimes as soon as I switch channels. But I haven't been able to watch live TV without Kodi crashing for more than a minute. This also seems to happen when I start watching a recorded episode.

Running the following:
HTS Tvheadend 3.9.2679~g995aaf8~trusty
PVR.TVH 0.9.8

Below is a link to the Kodi log when the crash happens. If anyone has any ideas or can maybe point me in the right direction, that would be a huge help!

Seems to be something with ERROR: ffmpeg[7F33B59B0700]: [mpeg2video] Invalid frame dimensions 0x0.
18:10:17 T:139860066895616 ERROR: Decode - avcodec_decode_video returned failure

http://paste.ubuntu.com/10795259/
Reply
#2
Just upgraded to Helix 14.2 Git:7cc53a9. Same problem.
Reply
#3
I appear to have figured out my issue. I dug a little deeper and noticed in my syslog that I was seeing the following error everytime the crash occurred.

DVDPlayerVideo[8577]: segfault at 7faae8703000 ip 00007faaea67e8bb sp 00007faa94f25490 error 6 in r600_dri.so[7faaea3af000+808000]

Looks like it was an issue with the Radeon drivers I was using. I updated to the newest version of drivers and Mesa but still the same issues. I then switched over to an old Geforce 8800 video card I had and everything seems to be working great now.
Reply
#4
There seems to be a bug in tvheadend which is partially the reason you're seeing this crash. I'll see what I can do about it.
Reply
#5
Great thanks negge.
Reply



Logout Mark Read Team Forum Stats Members Help
PVR.TVH Crashing0
This forum uses Lukasz Tkacz MyBB addons.