Here is a simple fix (and some other tips) for most HDMI audio issues. (Pin 19)
#1
Hello Community,

So, a while back I ran into some infuriatingly annoying issues related to HDMI audio from my HTPC to my Onkyo Receiver, and in some ways every device connected. The primary purpose of this thread is to spread some advice I received after tinkering with different solutions for about a month.This surprisingly works, but is apparently not common knowledge. I've seen threads about Kodi/XBMC switching audio devices from WASAPI to DirectSound, and the recommendations have been to buy HDMI splitters or some other device to 'fool' the HDMI handshake. Sure, that solution does work, and may even be a good route to go for some situations, but for I have an easier/cheaper option.

So, the underlying cause of all of these HDMI issues is the Handshake between the receiver and the HTPC. Now, I have an evga Nvidia GTX 970, so I'm certainly not using old hardware. That being said, even top end video cards these days are pitiful when it comes to HDMI audio. So, if you want to know who to blame for these frustrations, there you go. I'm sure M$ is somewhat to blame here as well, but I'm not sure. For example, the $35 Raspberry pi supports a feature called HDMI-CEC, yet these $500 video cards dont. It's ridiculous.

So, when you turn your TV off, Windows goes a bit wonky, and assumes that your audio device has been fully disconnected, not just turned off. This is why things get strange when turning your TV/receiver back on in terms of your audio. So the goal of this fix is to forcibly fool the system into thinking it's still connected.

This is the "Pin 19 fix", and it is called that because what you will need to do is cover up pin 19 on your HDMI cable. I can not see why it would matter which end of the cable (where it plugs into the receiver, or where it plugs into the HTPC) is covered, but I personally cover pin 19 on the end that plugs into my HTPC. A tiny sliver of electrical tape, like the image (from a Microsoft blog) shown below, should suffice.


Image


Once you cover up pin 19 you'll want to go ahead and restart your computer. After that, you'll be good to go!

All this does is block the Hot Plug detection, as seem in the image below.

Image


Well, I hope that this information proves to be helpful to others out there who have run into these annoyances.
Reply
#2
This post is informative. I have a Nvidia card that also drops its connection now and again and I lose audio. I would suggest dumping the information in the second half of the post (delete it all because it is only useful for specific gear) and request to have this thread moved to Tips & Tricks by a forum moderator.

The HDMI pin trick is its own guide. The rest is a little off-track.
Reply
#3
Thanks for the suggestions!. I've made the modifications you advised.
Reply
#4
Hi does the tape have to go into the plug or just over the front of the pin? cheers for posting this
9.1 Cinema Room htpc with Kodi Krypton & emby server~Epson EH-TW9300~Homemade 8ft pj screen~AVR~Yamaha RX-A3070~Speakers~Monitor Audio RX6 Fronts & RX Centre~RXFX Surrounds~250's Rears~180's Front Presence~BK XXLS400 Sub~8033C AntiMode~HarmonyOne
 
Reply
#5
I don't see how this will help, by blocking pin 19 you kill off hpd, most HDMI source devices need it, that said some use an undocumented feature called receiver sense which relies on the termination voltage of the tmds clock line. I would suggest shorting pin 18 and 19 together on the sink side of the cable if you want to force always video on, but even this could be dangerous
https://www.pulse-eight.com/ - HDMI-CEC products for Kodi
Reply
#6
(2015-04-12, 17:08)RavynDarkcraft Wrote: Hello Community,

So, a while back I ran into some infuriatingly annoying issues related to HDMI audio from my HTPC to my Onkyo Receiver, and in some ways every device connected. The primary purpose of this thread is to spread some advice I received after tinkering with different solutions for about a month.This surprisingly works, but is apparently not common knowledge. I've seen threads about Kodi/XBMC switching audio devices from WASAPI to DirectSound, and the recommendations have been to buy HDMI splitters or some other device to 'fool' the HDMI handshake. Sure, that solution does work, and may even be a good route to go for some situations, but for I have an easier/cheaper option.

So, the underlying cause of all of these HDMI issues is the Handshake between the receiver and the HTPC. Now, I have an evga Nvidia GTX 970, so I'm certainly not using old hardware. That being said, even top end video cards these days are pitiful when it comes to HDMI audio. So, if you want to know who to blame for these frustrations, there you go. I'm sure M$ is somewhat to blame here as well, but I'm not sure. For example, the $35 Raspberry pi supports a feature called HDMI-CEC, yet these $500 video cards dont. It's ridiculous.

So, when you turn your TV off, Windows goes a bit wonky, and assumes that your audio device has been fully disconnected, not just turned off. This is why things get strange when turning your TV/receiver back on in terms of your audio. So the goal of this fix is to forcibly fool the system into thinking it's still connected.

This is the "Pin 19 fix", and it is called that because what you will need to do is cover up pin 19 on your HDMI cable. I can not see why it would matter which end of the cable (where it plugs into the receiver, or where it plugs into the HTPC) is covered, but I personally cover pin 19 on the end that plugs into my HTPC. A tiny sliver of electrical tape, like the image (from a Microsoft blog) shown below, should suffice.


Image


Once you cover up pin 19 you'll want to go ahead and restart your computer. After that, you'll be good to go!

All this does is block the Hot Plug detection, as seem in the image below.

Image


Well, I hope that this information proves to be helpful to others out there who have run into these annoyances.

I wonder if this will cure the problem I have with a Humax PVR. Basically, if I switch the off the TV but leave the PVR on, then a while later power up the TV, I have no sound. The only cure is to put the PVR into standby (wait for the HDD to spin down and then power up). This happens occasionally when I had a 9 year old Sony TV connected (which died this weekend) and it happens almost ever time with a now connected Small (non-smart) Samsung...
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Here is a simple fix (and some other tips) for most HDMI audio issues. (Pin 19)00