•   
  • 1
  • 14
  • 15
  • 16
  • 17
  • 18(current)
Release Library Node Editor
Please let me know if this is the add-on I need.  I am using Kodi 19 on a RaspberryPi (LibreElec 10) with the Estuary skin.  On the main screen, when Movies are selected, there is a set of category widgets on the top row (Recently added, Genres, Titles, etc.).  I want to add a new category widget called “4K” that only shows titles from one source.  Will this add-on do that?

I have read the add-on page instructions and made a lot of attempts, but I can’t get a new category widget to appear.  In Settings->Interface->Skin->Estuary->Configure skin…->Main menu items->Movies->Edit categories->Video Library->Movies, I added a new parent node called “4K” and Start with defaults=Movies.  I opened the node and added a rule “Path - starts with - Browse for value” and selected my source with 4K content.  I’d now expect to see a new category widget appear on the Movies screen along with the existing ones, but I do not.

What am I doing wrong?
Reply
(2021-12-24, 12:35)Paul Crook Wrote: I want to add a new category widget called “4K” that only shows titles from one source.  Will this add-on do that?
Yes, this addon will do exactly what you want. I have the same feature set-up on Estuary using Kodi 19.3, although I did things slightly differently.
My 4K Movie node is set-up as follows:-
Content: Movies
Order: Title (ascending)
Rule: Video Resolution is greater than 1080

Works like a charm. I guess you could also set a max resolution as well, if you only 4K (might come in handy when 8K media becomes more popular).
Just create another rule where video resolution is less than 2160.
Hope this helps
Reply
(2021-12-26, 20:40)Dumyat Wrote: Yes, this addon will do exactly what you want.
Thanks for responding.  I think I now know why my new category node didn’t show up.  It appears that the add-on writes to a config file but Kodi doesn’t know the file has changed, and it keeps running with the old config.  Whenever I make an edit, I have to reboot Kodi before I see the results.  That isn’t mentioned in the add-on page, so maybe it’s a bug.  Otherwise the instructions should be changed to reflect this requirement.

I kept the rule based on the path (instead of resolution) since my 4K content is all in one folder.  Now, my new category widget appears and clicking it sends me directly to a list of 4K titles.  The only thing I did that was different from the instructions was to make the new node a leaf node rather than a parent node.

Thanks for the help.  Letting me know that the add-on should do what I wanted gave me the motivation to keep trying stuff.
Reply
Ahh yeah, I didn't think to mention that happens.
As far as I remember, the same thing also occurs when you select to move the position of a node, ie the new position won't be visible until you exit and re-start Kodi.
Glad you sussed it out in the end.
Reply
I've tried to have a look into the "change order" issue but cannot reproduce. This is something that is only happening on windows right? Store or regular version?
Cheers
Reply
@enen92 
Rather ironically, I tried moving the position of a TV show category node yesterday, but was unable to do so using the Estuary skin on 19.3 as every time I open the dialog select window, none of the nodes are shown there. Also the the confirmation 'OK' button is not displayed.
Was going to post yesterday, but slipped my mind. Seeing your post just now reminded me.
Not sure if anybody else has reported this. Yes, I was using Windows 11. I'll try the same action using the shield later on and report back.
Let me know if you need a debug log, screen shot or both.
Reply
Debug log would be nice (and confirmation in works - or not - on the shield too). Although I have seen similar debug logs and while it's easy to find the error (the list of nodes is empty and crashes on the operation on the empty list) it doesn't help figuring out the root cause (why it's empty in the first place).
I have a dual boot setup at home so I might be able to run test this on windows at some point next week.

Are you running just a normal installation? portable mode? installed from Windows store?
Reply
Both Windows and Shield are normal installations direct from the Kodi download page.
Windows is using 19.3 and Shield is using 19.2.
Screen shot below is of my Windows install when I tried to move the position of the 'Genre' node for TV shows:-

Image

Once this screen appears, my remote control also stopped giving any focus. Had to use a mouse to click on 'cancel' button.
Debug log capturing of me attempting this action is here: azefeyocev.kodi (paste)
First mention of 'Library node editor' is from line 3255. Seems to be a few errors mentioned a bit further down. Hopefully these will mean something to you  Wink

On the shield, I was able to move the same node and no issue with the dialog select window. Whilst the node does move position on the dialog select, it doesn't on the home screen, ie you still have to exit and restart for the position to change. Dialog select window is also missing the 'OK' confirmation label.
Think that's everything you wanted.
Hope it helps.
Reply
Question 
Hey there, I have a quick question about calling plugins and scripts from a node directly:
I know and use a lot of this structure:
<?xml version='1.0' encoding='UTF-8'?>
<node order="150" type="folder">
<label>someLabel</label>
<path>plugin://plugin.video.somePlugin</path>
<icon>/home/me/logosnicons/1542453496.png</icon>
</node>
Now im wondering if I could use scripts or more specific the “play random video” script in much the same way. I tried variations of this:
<path>RunScript(script.playrandomvideos,&quot;smb://DISC/folder1/TVEpisodes/&quotWink</path>
But it doesn’t work. It would be great if you could help me out.
Cheers
Reply
I'm not sure it's possible.
I tried doing exactly the same thing 2-3 years ago using a random playlist.
Whilst the playlist would create random playback when the playlist was added as a favourite, unfortunately it didn't start any playback when I added the same playlist as a node. As I recall, one of the Kodi team members said that such a feature could probably be added, but wasn't possible at that particular time.
Maybe things have changed since then, but if your script is not working then maybe the feature has still not been implemented....
Reply
(2022-01-04, 14:27)Dumyat Wrote: I'm not sure it's possible.
I tried doing exactly the same thing 2-3 years ago using a random playlist.
Whilst the playlist would create random playback when the playlist was added as a favourite, unfortunately it didn't start any playback when I added the same playlist as a node. As I recall, one of the Kodi team members said that such a feature could probably be added, but wasn't possible at that particular time.
Maybe things have changed since then, but if your script is not working then maybe the feature has still not been implemented....

I agree with you. I have been trying several different ways of implementing it but none of them worked. So i guess you're right and this function hasnt been implemented(yet).
However i ended up taking a different approach and used SuperFavourites for this. SF can handle RunScript(), playRandomVideo scripts and it can also be added to the menu as a Library Node. Works for me as node parent (with multiple children triggering different scripts) as well as being directly integrated as a node.
Reply
@enen92 
Did you by any chance get a chance to review the log in post #263 that you asked me to provide?
Reply
Is the ability to match all rules something that "Recently Added" doesn't support? I'm trying to setup custom parent nodes for all of my different content, but for whatever reason, Recently Added is not respecting the rules I have, even if I keep it simple and focus on only one rule, it's adding all recently added (in this case) movies. This is what I currently have, and it's including things that should have been removed:


<node order="10" type="folder">
    <label>20382</label>
    <icon>DefaultRecentlyAddedMovies.png</icon>
    <path>videodb://recentlyaddedmovies/</path>
    <rule field="path" operator="contains">
        <value>COMPLETE.UHD</value>
    </rule>
</node>

This, however, is including things such as Movie.1978.1080p.BluRay.x264-GROUP, Movie.2021.1080p.BluRay.x264-GROUP, and Movie.2021.HDR.2160p.WEB.H265-GROUP. How can I get the Recently Added category to properly exclude those things that i do not want? I've tried including


    <rule field="path" operator="doesnotcontain">
        <value>2160p</value>
    </rule>
    <rule field="path" operator="doesnotcontain">
        <value>hd</value>
    </rule>

However that doesn't work, and if I add <match>all</match> then I get an error message in the Library Node Editor.
Reply
I too had issues with the recently add not working correctly with custom nodes.

Want I did was create a new node within the parent node which I named "New". Then added a 'days added' rule in that node and then changed my menu to point to the "New" node. That solved the problem for me.
"When the going gets weird, the weird turn pro." - Hunter S. Thompson
Using: Windows 10 Pro | Kodi 18.9 + Aeon MQ7 Multi-Mod 1.0.5.4 | Kodi 19.4 + Aeon Madnox v21.12.12+m | Kodi 19.4 + Aeon MQ7 Multi-Mod 1.0.2.3 
Reply
I have a weird issue that has come about after pasting the Music & Video libraries (from another build) into org.xbmc.kodi/files/.kodi/userdata/library.

I now have all parent nodes duplicated as nodes and appearing as widgets. Any ideas guys?
Reply
  •   
  • 1
  • 14
  • 15
  • 16
  • 17
  • 18(current)



Logout Mark Read Team Forum Stats Members Help
Library Node Editor3
This forum uses Lukasz Tkacz MyBB addons.