•  Previous
  • 1
  • 2
  • 3
  • 4(current)
  • 5
  • 6
  • 25
  • Next 
 
Thread Rating:
  • 5 Vote(s) - 4 Average
Work in Progress - Media importing and library integration (UPnP, Emby, ...)
#46
Updated April 22 OpenELEC builds:

RPi: http://milhouse.openelec.tv/builds/wipup...229a9c.tar
RPi2: http://milhouse.openelec.tv/builds/wipup...229a9c.tar
Generic: http://milhouse.openelec.tv/builds/wipup...229a9c.tar

(2015-04-21, 20:15)rterblanche Wrote: Which url must be used with the openelec dev update. I configured a new path based on the above but keep on getting an Pi2.arm release not found error message.

Leopold has updated his addon to v4.7.0 (thanks @Leopold)

Create a custom source with url "http://milhouse.openelec.tv/builds/wipupnp/RPi2" (for RPi2 builds) and set the build type to "Milhouse"
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
#47
@Milhouse: Thanks for providing the OpenELEC test builds so fast. And feel free to edit my "release" posts and fill in the links directly if you want.
Always read the online manual (wiki), FAQ (wiki) and search the forum before posting.
Do not e-mail Team Kodi members directly asking for support. Read/follow the forum rules (wiki).
Please read the pages on troubleshooting (wiki) and bug reporting (wiki) before reporting issues.
Reply
#48
I don't appear to have permission to edit anyone else's posts...
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
#49
Hm OK I thought every team member has moderation rights. I at least can edit your posts.
Always read the online manual (wiki), FAQ (wiki) and search the forum before posting.
Do not e-mail Team Kodi members directly asking for support. Read/follow the forum rules (wiki).
Please read the pages on troubleshooting (wiki) and bug reporting (wiki) before reporting issues.
Reply
#50
I'm trying to access my server at the moment, but for some reason it's listed as "inactive" when it is very clearly active, as I just went and played around with it, watched some youtube vids, etc. Is there any way to force Kodi to double check or something?

edit: Further, if I try to browse the UPnP library from Windows File Explorer, it browses fine.
edit 2: I'd grab a debug log, but I'm honest not sure what to grab and where from. It definitely appears to be a server-side issue, because both my Windows and my Android clients are listing it as inactive.
edit 3: All of a sudden, my Android client seems to have found the provider. The Windows client still doesn't see it.
Reply
#51
Yeah I've seen issues with the detection of UPnP servers but they aren't specific to the media import stuff. Sometimes when I was debugging something and restarted the client a lot sometimes it simply wouldn't see the server and I'd have to restart the client again to be able to see it.
Always read the online manual (wiki), FAQ (wiki) and search the forum before posting.
Do not e-mail Team Kodi members directly asking for support. Read/follow the forum rules (wiki).
Please read the pages on troubleshooting (wiki) and bug reporting (wiki) before reporting issues.
Reply
#52
I am still having some issues with the watch status updating not consistently. Trying to reproduce it with the log files enabled.

1. When I watch an episode of media hosted on the main windows instance on the Pi, I see the watched check box appear and the immediately disappear.

2. When I select play on a series level the watched episodes are also never marked. (strangely mark as watched works)

3. Watching something on the main windows instance the episode is marked as watched. I go to the pi and do a full sync and the episode isn't marked as watched. Even sometimes has the episode marked as unwatched on the main instance. Strangely watch position syncs correctly.

Will try and get more detailed debug logs.
Reply
#53
(2015-04-24, 20:20)rterblanche Wrote: I am still having some issues with the watch status updating not consistently. Trying to reproduce it with the log files enabled.

1. When I watch an episode of media hosted on the main windows instance on the Pi, I see the watched check box appear and the immediately disappear.
Since we don't constantly synchronise with the backend this might be unrelated but I'll look into it. With had some similar issues in the usual nightly builds a while ago.

(2015-04-24, 20:20)rterblanche Wrote: 2. When I select play on a series level the watched episodes are also never marked. (strangely mark as watched works)

3. Watching something on the main windows instance the episode is marked as watched. I go to the pi and do a full sync and the episode isn't marked as watched. Even sometimes has the episode marked as unwatched on the main instance. Strangely watch position syncs correctly.

Will try and get more detailed debug logs.
It sounds like something is very odd. I only tried mark as watched/unwatched and that worked perfectly fine on both the client and the server (with instant synchronisation from the client to the server (but not the other way around).
I'll try to play something and see if / why it behaves differently.
Always read the online manual (wiki), FAQ (wiki) and search the forum before posting.
Do not e-mail Team Kodi members directly asking for support. Read/follow the forum rules (wiki).
Please read the pages on troubleshooting (wiki) and bug reporting (wiki) before reporting issues.
Reply
#54
This is *really* a great feature!

I never was a great fond of the MySQL shared library; I'd rather support the n-tier approach. This in conjunction with the headless kodi are in my perspective the first step to this goal.

Any thought about the availability of this request? Might it be included in Isengard?

I will test this feature once I get some free time for sure!
Reply
#55
(2015-04-27, 13:59)FuN_KeY Wrote: Any thought about the availability of this request? Might it be included in Isengard?

Isengard is already in feature freeze so that certainly won't happen. And I don't really have a timeline because there are a lot of things missing (like music library support), a lot of bugs and I never know how much time I'll have to work on this. It also can't replace MySQL just yet because this e.g. doesn't support profiles so your client always syncs with the profile that is currently running on the media provider. That's also a problem that needs to be fixed for the headless approach as it needs to be able to provide information and data for multiple profiles.
Always read the online manual (wiki), FAQ (wiki) and search the forum before posting.
Do not e-mail Team Kodi members directly asking for support. Read/follow the forum rules (wiki).
Please read the pages on troubleshooting (wiki) and bug reporting (wiki) before reporting issues.
Reply
#56
Anyone know why my media import starts up and dies immediately? I see the notification popup to say its processing movies for a split second and nothing ever synchronizes.
Reply
#57
(2015-05-01, 01:52)joeweb Wrote: Anyone know why my media import starts up and dies immediately? I see the notification popup to say its processing movies for a split second and nothing ever synchronizes.

Debug Log (wiki)?
Always read the online manual (wiki), FAQ (wiki) and search the forum before posting.
Do not e-mail Team Kodi members directly asking for support. Read/follow the forum rules (wiki).
Please read the pages on troubleshooting (wiki) and bug reporting (wiki) before reporting issues.
Reply
#58
(2015-04-27, 08:16)Montellese Wrote:
(2015-04-24, 20:20)rterblanche Wrote: 2. When I select play on a series level the watched episodes are also never marked. (strangely mark as watched works)

3. Watching something on the main windows instance the episode is marked as watched. I go to the pi and do a full sync and the episode isn't marked as watched. Even sometimes has the episode marked as unwatched on the main instance. Strangely watch position syncs correctly.

Will try and get more detailed debug logs.
It sounds like something is very odd. I only tried mark as watched/unwatched and that worked perfectly fine on both the client and the server (with instant synchronisation from the client to the server (but not the other way around).
I'll try to play something and see if / why it behaves differently.

Figured out what was wrong. It only affected the update of playcount when actually having played an imported item. That's why it behaved differently than marking as watched.
Always read the online manual (wiki), FAQ (wiki) and search the forum before posting.
Do not e-mail Team Kodi members directly asking for support. Read/follow the forum rules (wiki).
Please read the pages on troubleshooting (wiki) and bug reporting (wiki) before reporting issues.
Reply
#59
Just checking and not rushing. I haven't missed any new builds since the last on the thread
Reply
#60
Sorry I've been rather busy lately.

Latest test builds: May 12 2015:
Changelog
  • Fixed saving file state of watched videos and updating the changes on the media provider
Always read the online manual (wiki), FAQ (wiki) and search the forum before posting.
Do not e-mail Team Kodi members directly asking for support. Read/follow the forum rules (wiki).
Please read the pages on troubleshooting (wiki) and bug reporting (wiki) before reporting issues.
Reply
  •  Previous
  • 1
  • 2
  • 3
  • 4(current)
  • 5
  • 6
  • 25
  • Next 



Media importing and library integration (UPnP, Emby, ...)45