•   
  • 1
  • 35
  • 36
  • 37(current)
  • 38
  • 39
  • 86
  •   
WIP Media importing and library integration (UPnP, Emby, Plex, ...)
(2019-12-23, 05:48)LongMan Wrote: Edit: Playback checkins does work after i restarted the computer. Not sure what happened there but, this morning it shows in the server web page. Nice.
There was a bug in the mediaimporter.emby add-on which resulted in the python script that executed the playback checkins to crash if the media provider was not properly configured (which is always the case when the media provider is originally discovered). I've fixed this now and also fixed the music video issue. The latter will require a new test-build of Kodi. I'm still looking into the "Browse" issue for tv shows.
Always read the online manual (wiki), FAQ (wiki) and search the forum before posting.
Do not e-mail Team Kodi members directly asking for support. Read/follow the forum rules (wiki).
Please read the pages on troubleshooting (wiki) and bug reporting (wiki) before reporting issues.
Reply
There seems to been a problem if I remove a provider when it is missing/offline. Kodi just hangs. I have to kill it from the task manager.
 
  • I wanted to return to LibreELEC on a small zotac machine I keep on my desk to listen music and radio etc. I didn't need another windows install anymore since you fixed the problem that was causing the crash. I would just install Jellyfin in Docker on LibreELEC.
  • However, I didn't remove the Jellyfin provider before making the switch. I know that removing a provider works because I did it a few times before. However, now with the server offline, Kodi hangs. The logs are attached.
https://drive.google.com/file/d/1VCmN-HJ...sp=sharing

That reminds me, in a previous iteration of MediaImport, I remember a Welcome/Status  Message for each provider on startup. I think it was when it was all C++.

Edit: Maybe it was when i tried to play an item from a missing provider that the message was there previously. Not sure
Reply
(2019-12-23, 14:54)LongMan Wrote:
  • TV show from Jellyfin,
    • use Video info Dialog choose "Browse",
      • Error: One or more items fail to play. Check the log for more information about this message.
        • Looks like the tried to play instead of browse.
  • TV show from Emby,
    • Use Video Info Dialog,
      • same error as with Jellyfin
This is / was a bug in Kodi core which has probably been there forever but almost never surfaces. I've fixed it in my media import branch.
Always read the online manual (wiki), FAQ (wiki) and search the forum before posting.
Do not e-mail Team Kodi members directly asking for support. Read/follow the forum rules (wiki).
Please read the pages on troubleshooting (wiki) and bug reporting (wiki) before reporting issues.
Reply
(2019-12-26, 16:21)LongMan Wrote: There seems to been a problem if I remove a provider when it is missing/offline. Kodi just hangs. I have to kill it from the task manager.
There seems to have been a bug in both mediaimporter add-ons which I've fixed in the master branch but it should not result in Kodi hanging. I just tried it with my Emby server and removing the whole media provider worked perfectly fine.

(2019-12-26, 16:21)LongMan Wrote: That reminds me, in a previous iteration of MediaImport, I remember a Welcome/Status  Message for each provider on startup. I think it was when it was all C++.

Edit: Maybe it was when i tried to play an item from a missing provider that the message was there previously. Not sure 
Yes it's still there if you try to play a video item from an inactive media provider.
Always read the online manual (wiki), FAQ (wiki) and search the forum before posting.
Do not e-mail Team Kodi members directly asking for support. Read/follow the forum rules (wiki).
Please read the pages on troubleshooting (wiki) and bug reporting (wiki) before reporting issues.
Reply
(2019-12-27, 01:16)Montellese Wrote: There seems to have been a bug in both mediaimporter add-ons which I've fixed in the master branch but it should not result in Kodi hanging. I just tried it with my Emby server and removing the whole media provider worked perfectly fine.
Yes it's still there if you try to play a video item from an inactive media provider.

You're right I did not describe it properly. Maybe hang is not the right word.
Kodi has a message "Preparing..." with the spinning circle to indicate an action in progress.
However, nothing further occurs there. Kodi is still functional until I click the power button and chosse Exit. Kodi does not close.
After a while there is the windows dialog, "Kodi is not reponding, >Close the program or >Wait for the program to respond. That closes it.
Since I had it more than once, I don't wait for windows dialog, I just kill it from the Task Manager.

Hope that helps.

Edit: I saw that you had a new Test Build up so, I gave it a go.
  • The hanging problem is gone.
  • The Browse problem with TV shows is gone too.
  • The music video checkins is still there but i suspect you haven't gotten around to that one yet.

Great stuff.
Reply
(2019-12-27, 02:15)LongMan Wrote:  I saw that you had a new Test Build up so, I gave it a go.
  • The hanging problem is gone.
  • The Browse problem with TV shows is gone too.
  • The music video checkins is still there but i suspect you haven't gotten around to that one yet.
 
Yes there are new test builds for WIN64, OSX and Android. OSX still has a build issue in the unit tests which I need to address.
I had to change the database layout of MyVideosXXX.db so be sure to remove a previous MyVideos117.db version.

@LongMan the change in the video database is most likely the reason why music video checkins still didn't work for you. They are working fine for me now.
Always read the online manual (wiki), FAQ (wiki) and search the forum before posting.
Do not e-mail Team Kodi members directly asking for support. Read/follow the forum rules (wiki).
Please read the pages on troubleshooting (wiki) and bug reporting (wiki) before reporting issues.
Reply
Quote:@LongMan the change in the video database is most likely the reason why music video checkins still didn't work for you. They are working fine for me now.
Yes. That did the trick. Checkins appears almost instantly on the server too.
Also the "Processing media items... " string is fixed too.

I have made a post in the server forums. Waiting for some feedback.
Reply
While writing the instructions to post in the server forums, i noticed something. On the dialog where we choose what to import, there two tabs , Emby and Synchronization. For the tab with Emby, I think either Imports, Libraries, Sources or the media type, eg TV Shows, would be a better label.
What do you think?

Cheers,
LongMan
Reply
Hello there,

i could not connect with plex, with jellyfin i could and imported library, i can stream movies but i cannot use any subtitles that i have on jellyfin, fortunately, i can use one subtitle addon with kodi, others i can´t because i can´t install the rar and archive addons, i can´t install one dependency which is needed.

here is my log https://paste.kodi.tv/udemohatoc.kodi

and thank you for compiling for android.

if there's anything you want me to try, tell me.
Current setup: SONY XG8096
Previous setup: Mecool KM9 PRO - Kodi Leia 18.5 | xiaomi mibox 3 - kodi Leia 18.3 | MXIII - Some Kodi version - LibreELEC | Raspberry Pi 2 & 3 - Pipplware - LibreELEC
Reply
@Norin_Radd,
External subtitles are not yet supported, only internal ones.
With regards to Plex, I haven't tested it. Hopefully Montellese can help you there.

Cheers,
LongMan
Reply
(2019-12-29, 17:06)LongMan Wrote: @Norin_Radd,
External subtitles are not yet supported, only internal ones.
With regards to Plex, I haven't tested it. Hopefully Montellese can help you there.

Cheers,
LongMan

I am ok with jellyfin, I just tested the two options and wanted to share my really really basic functionality test.

for now iam happy, i can stream my library without a crash, i was annoying everybody with that, its simpler to use plex, emby or jellyfin as a backend and kodi, which way more cooler and better with is nice features as a frontend.

would love to see this work implemented on matrix release, i looked into the news blog, whit rough times it will be difficult but lets hope for the best.

cheers Wink
Current setup: SONY XG8096
Previous setup: Mecool KM9 PRO - Kodi Leia 18.5 | xiaomi mibox 3 - kodi Leia 18.3 | MXIII - Some Kodi version - LibreELEC | Raspberry Pi 2 & 3 - Pipplware - LibreELEC
Reply
@Montellese,
I am not sure if you are aware of this PR,

https://github.com/xbmc/xbmc/pull/14972

The authors seems to have disappeared. Is there a way to get it merged?
Reply
(2019-12-28, 22:58)LongMan Wrote: While writing the instructions to post in the server forums, i noticed something. On the dialog where we choose what to import, there two tabs , Emby and Synchronization. For the tab with Emby, I think either Imports, Libraries, Sources or the media type, eg TV Shows, would be a better label.
What do you think?

Cheers,
LongMan
Sure I'm always open for better wording / terms.
Always read the online manual (wiki), FAQ (wiki) and search the forum before posting.
Do not e-mail Team Kodi members directly asking for support. Read/follow the forum rules (wiki).
Please read the pages on troubleshooting (wiki) and bug reporting (wiki) before reporting issues.
Reply
(2019-12-29, 04:47)Norin_Radd Wrote: Hello there,

i could not connect with plex, with jellyfin i could and imported library, i can stream movies but i cannot use any subtitles that i have on jellyfin, fortunately, i can use one subtitle addon with kodi, others i can´t because i can´t install the rar and archive addons, i can´t install one dependency which is needed.

here is my log https://paste.kodi.tv/udemohatoc.kodi

and thank you for compiling for android.

if there's anything you want me to try, tell me.
Thanks for the feedback and the log. I noticed the following things:
  • Concerning Plex I only see a few log messages indicating that authentication fails. Did you try MyPlex PIN login or local access?
  • Concerning Jellyfin
    • Is it possible that you first tried to play a video while the Jellyfin server was not reachable? There are a few timeouts while trying to open a stream.
    • I saw lots of warnings / errors concerning the responses for playback checkins. Maybe the Jellyfin API for /Sessions/Playing, /Sessions/Playing/Progress and /Sessions/Playing/Stopped differ from the ones Emby provides? Did playback checkins show up on the Jellyfin server?
    • I see the error that Jellyfin does not support the newly added endpoint to update userdata (playcount, lastplayed, ...) of a media item on the server. This is a known issue. I need to figure out if there's a way to identify that the server is Jellyfin and not Emby then I could try to react accordingly.
Thanks for taking the time to test this and report back! This is much appreciated.
Always read the online manual (wiki), FAQ (wiki) and search the forum before posting.
Do not e-mail Team Kodi members directly asking for support. Read/follow the forum rules (wiki).
Please read the pages on troubleshooting (wiki) and bug reporting (wiki) before reporting issues.
Reply
Just noticed that the same errors concerning playback checkins appear with an Emby server. I'll fix that in the Emby mediaimporter add-on.
Always read the online manual (wiki), FAQ (wiki) and search the forum before posting.
Do not e-mail Team Kodi members directly asking for support. Read/follow the forum rules (wiki).
Please read the pages on troubleshooting (wiki) and bug reporting (wiki) before reporting issues.
Reply
  •   
  • 1
  • 35
  • 36
  • 37(current)
  • 38
  • 39
  • 86
  •   



Logout Mark Read Team Forum Stats Members Help
Media importing and library integration (UPnP, Emby, Plex, ...)10
This forum uses Lukasz Tkacz MyBB addons.