XIMETA NetDisk (NDAS) support

I have a couple of questions that I hope someone here could help me out with:

1) I assume that xbox/xbmc does not have support for XIMETA's NetDisk (NDAS) protocol?

2) Does anyone know if someone out there is trying to add NDAS support for the XBOX. Is this possible to do at all?

3) Is it possible to write custom device drivers for the xbox as things stand at the moment? If so does someone know how one would go about doing this, i.e. where can one get the DDK etc.


Viktor Godaly

Ximeta has external hard drive cases with NDAS support. NDAS is different than NAS, each client needs to run a driver kind of software to access the NDAS storage disk. Ximeta engineers have posted the driver source code for linux.

Can this source code be ported to XBMC to support accessing Ximeta NDAS disks? This may be a great addition to networking capabilities of XBMC.

seems like a stupid design, is it USB or Ethernet ?

And why don't you even include a link where I could findout about this myself ?
Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.

[Image: badge.gif]
It has both USB and ethernet interfaces. Only one can be used at a time. They claim their transfer speeds are much faster than NAS. The drive is not assigned an IP address unlike NAS drives. There is a unique key per Ximeta enclosure and each client PC configures the key in the Ximeta driver to access the drive.

The link to the product is:


The link for the source code on linux to access Ximeta NDAS devices is:

Thumbs Down 
Don't hold your breath, we are not big fans of proprietary protocols.
...why XIMETA just don't just support SMB as well is beyond me Stare


Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
I'm a major adversary to proprietary protocols as well; however...

In this case, it's a justified feature and the company has done a great job signing up partners, and delivering ubiquitous code.

You’re probably familiar with the inherent shortcomings of NAS and the overhead of IP file sharing. You have a few options, iSCSI being one. This is the poor-man’s iSCSI, and the beauty of it – it could be argued that it’s more secure than IP file sharing, it’s MUCH faster, it’s easier and has less overhead, and relevant to our discussion here: it’s got an amazing DVD/CD virtualization technology for media jukeboxes, which is absolutely huge.

I feel that before it’s dismissed, it would be worth reconsidering – or at least keeping it on a list for consideration/research, particularly since the source is available.
virtualization is irrelevant to XBMC, which can already use disc image files without issue.
Catchy Signature Here
I have an NDAS drive and I think it would be great if it were supported in XBMC.
hello xbmc forum,

Thanks to XBMC team for great job and for support time in this forum.
I've been using xbmc for many years and it is great.Nod

Back to NDAS :
It is true, available NDAS hard drives are much faster than nas drives.
If you are using XBMC on a linux platform, xbmc as application doesn't need support NDAS.
You have only to install the driver on your system and register ndas device with id and key (you find them on your ndas drive) and enable it.
The device apears as block device like the internal hard drive(as virtual device).
Now XBMC can access to new ndas device like to normal internal hard drive.

Find more in a current README in this tarball

I'm not use such devices because of this unsupported feature:
- Hibernation, standby are not supported


I hope this post helps to NDAS users.
I'm using NDAS SVN along with windows 7, and I'm not able to connect to the remote device, which is shown as offline always.

The device is a IAMM NTD-38N below a link to it:


The connection is thru wireless. Using a router comtrend CT-5365

Form the device (NTD-38N) point of view, it's connected to the wireless, but when I install the NDAS and registered the device, then after is always shown as offline.

I have deleted the device from NDAS, couple of times and registered again but it doesn't work.

What can I do? Sad

Many thanks for your advises.

Kind rgds
So what if it's fast? Any regular NAS with SMB is more than fast enough to serve up HD streams.

Why doesn't NDAS just add SMB support?
I have used the NDAS utility to mount with read write with my Mac, but I try to write to the Netdisk and it doesn't work. when I look at permissions in the utility it is fine but the netdisk shows read only. frustrating... what's going on? Stare
I am in a mixed environment but only my Mac is mounted with write at this point.
I have a XIMETA Netdisk NDAS that I bought a few years ago and worked Ok with Windows Server 2003. I just tried to use it with Windows 7 64 bit and it indicates Offline when on network but Online if USB. I hate proprietary network protocols that are unresponsive to standard utilities.
Thread Rating:
  • 0 Vote(s) - 0 Average

Logout Mark Read Team Forum Stats Members Help
XIMETA NetDisk (NDAS) support00