synology access outside network
#1
Hi everyone

i have a family member who lives else where and would like to access my synology nas remotely using kodi just wondering whats the best way to do this and what people have done to get this to work thanks
Reply
#2
I have made this to work. I actually verified this by taking my kodi box to some other house, hooked up on wifi and then streamed off my synology which is in my house. Works quite brilliantly.

Do the following:
1) in your synology, register the ddns serivce that synology provides. U have to pick some id, which is then used by synology to create a url. For instance, if ur id is "RemoteLib", synology gives you this url: remotelib.synology.me. The ddns service of synology ensures this url always points to the IP address ur inet provider assigned to ur modem
2) on your kodi box, go to FILES and then ADD VIDEOS
3) in the box that pops up, choose browse, then go to the option ADD NETWORK LOCATION (prob d last in the list)
4) in the next popup box, select option "WEBDAV SERVER (HTTP)". Then enter your url "remotelib.synology.me", remote path should be ur video folder, port 5005 (thats quite standard) and finally the username / pw to connect to ur synology (i created a user XBMC for this purpose)

For the rest, it is pretty much same as creating any other library in your kodi box

Hope this works for you. Let me know

Regards
Miguix
Reply
#3
Before i forget - make sure you have port forwarding in your (provider's) modem/router for all ports synology uses (5000/5001/5005/5006 at least). Your synology doc should explain.

In synology FAQ #299 all relevat ports are listed

Also, you need to make sure that user you use to connect to your nas (as per my previous post) is authorised to use webdav in your nas, as well as read/write access to your movie/tvshow libs (it needs write access if you want to download subs while watching)

Furthermore, it occurred to me that sometimes movies seem to play irregulary (stops or timeouts) when playing at home using the url as lib id. This was easily resolved in my "outermost" router (i have two behind each other) by defining the url in the routers own dns table.

Still, streaming from outside my house worked excellently.

Updating your lib is best done from wothin your own lan, especially if you have a large movie set

Good luck
Miguix
Reply
#4
Miquix, I think this is the solution I need.
I followed your steps above with the exceptions of port forwarding and defining the url in my router dns table - I have no idea how to do either of those Sad
I did run the Synology EZ-Internet Wizard which is supposed to handle the port forwarding automatically but maybe not?
I am getting this Remote Share error after creating the link "Could not connect to network server".
This is what the source path looks like: "dav://*****.synology.me:5005/video" with ****** being my user info.

Does that look correct?
Reply
#5
ItsBoaz,
That looks pretty much correct. I assume ur ddns url for synology is ok. The dialog in ur syn nas should indicate if the url is ok and recognised by synology.

Double checks:
- u did create a user "kodi" (or whatever) with read/write access on ur nas disks / shared folders? I gave rw access on both videos and tv shows. For streaming the "r" should be ok, but i think u need the "w" if ur gona download subs from kodi
- u did enter this user name / pw in the dialog box where u defined ur vid source to connect thru debdav?
- did u authorise this user in your synology to use webdav?

The url entered in ur router's local dns is not compulsory. I did that to fix a freeze problem when streaming in local lan with Full url. For some reason my (outermost) router messed that up.

That leaves the port forwarding. I know synology has a kind of wizard for that which u seem to have used. I dont know how that works. I used the UI of my linksys (innermost) router which provides a screen for that. Assuming your router is recent enough (not more than cpl years old) it should have that functionality. U just log in to the router, and find the page/screen that has the port forwarding. Manual should point this out.

If case you have two routers behind each other (like me) there should be some extra port forwarding. I have an outermost router from my provider, which i only use for internet connectivity. Everything else is switched off or unused. Behind that is ONLY my innermost router (to wchich all my switches hosts etc are connected). If you have the same setup, odds are synolog only set up ur innermost router. Your outermost router should have all ports forwarded to your innermost router's ip (should be fixed ip). Your innermost router should have all ports forwarded to ip of your nas (which is best tomalso have fixed). Virtually all routers allow you to fix an ip addy in their UI.


Some questions i have:
- do you get the connect error when trying to connect from outside your house? Or also from within your lan?
- can u get ur kodi box to connect if u use ip rather than url, but still using webdav?

To check if your port forwarding is working, try to connect to ur synology with dsvideo or dsfile app from smartphone or tablet. If that works, also from outside your home/lan, port forwarding is ok. You should then probably be looking at correct uname/pw in the source definition box in kodi, and the user authorisations in your as i described above.

Hope this helps!

Miguix
Reply
#6
The DDNS URL works as I've used it to connect to my Synology remotely at work for example so good there.
The User does have read/write access, check.
Yes, your instructions were easy to follow (thank you) and I entered the credentials properly (and tested the credentials logging in remotely with the DS Video app on my phone).
I did need to authorize the user for webdav as that was not checked - done.

My router (only one) definitely has the functionality but I am just not technical enough to follow the on-screen prompts - there are some assumptions you know what your doing which I don't Smile However, I think I'm ok as I can get to the Synology with PC's and phones - just can't figure out how to create the link from Kodi.

I've only tried connecting from inside the house - I have not removed to try outside my LAN.
I have not tried connecting via the IP in webdav - is that using the external IP address of my Synology? I like the URL path as my IP address gets changed by Comcast and then I'd have to figure out how to update remotely which is way above my ability...

I will try and take another run at the user tonight using my Admin logon which has full read/write to all - that should identify if it is the username/pw/authorizations.

Thank you Miguix!
Reply
#7
Keep me posted please. When i said try connect the webdav thru ip instead of url, i meant internal lan ip. That is to make sure u can actually connect thru webdav not having to rely on port forwarding.
Did u fix the IP addy in your router? Normally it shld remain the same but it can change

As for the login to router, u dont need to be really techy
I will google for the manual of ur router see how it works
Reply
#8
Oh it doesnt mention ur router model. Which is it?
Reply
#9
Oh (2)
It shldnt have to be ur admin level. I connect on a normal user on my nas for remote access and no prob
Will go thru setting see if i missed anything
Reply
#10
Ok, changed connection to LAN IP which now looks like this: dav://10.0.0.22:5005/media/movies/ (and I am connected here at the house on LAN).
So here are my new share settings:
Protocol = WebDAV server (HTTP)
Server address = 10.0.0.22
Remote path = media/movies
Port = 5005
Username = *****
Password = *****
Still says unable to connect so maybe not a webdav issue?
My router is: http://setuprouter.com/router/arris/tg862g-ct/ provided by Comcast.
I wish this was easier!
Reply
#11
Link to screenshot of port forwarding setup on my router: http://imgur.com/4gh4yQH
Reply
#12
Believe me - i struggled for a cpl days before i got it right. But it will work.

As for you connect attempt. If you connect to the local 10.0.0.22 ip addy, u should leave out the port nr. Port nr is only to be used if you want the traffic from outside ur router (wan side) to travel through the router to lan side. That is what happens if u use the ....synology.me url (because that url points to the wan side ip of your router). If you connect inside lan, just drop the ":5005" port number.

Pls try the webdav connect to ur ip addy without the port nr. If u get that to work, ur webdav setup is ok. That is a prerequisite for connecting thru the url

As for your screen dump. The good news is - your router does support it.
In the field on that screen it asks for a begin and end port of a range. Just provide 5000-5001 and 5005-5006 as beg/end points (so you should be defining two ranges). As ip addy, provide ur fixed internal ip, i think that was 10.0.0.22. What you do with this, is to tell ur router that all traffic that is sent to ur routers WAN address, is forwarded to ur ....22 addy in ur lan, as long as the traffic mentions any of these four port numbers. Thats how external access requests to ur nas can actually arrive there (ur internal lan ip addy is invisible / meaningless on wan side).

Hope this brings u another step further :-)
Reply
#13
Ok here is Kodi link with IP vs URL: dav://*****:*****@10.0.0.22/media/movies (where **** = user/pw obviously): picture here: http://imgur.com/5CmUHX9
Protocol = WebDAV server (HTTP)
Server address = 10.0.0.22
Remote path = media/movies
Port =
Still says can not connect to network so maybe that is a clue to get us closer lol Huh

Here is screenshot of port forwarding so I think this one is covered now right? http://imgur.com/yU9zk9g (blanked out ipv6 not sure if that is sensitive info or not).
Reply
#14
Weird.....

As for port forward, wot if u only forward to the ipv4 addy (10.....22)? I never use the ipv6 myself

Rest looks like it shld be ok. Only diff with wot i have, is that i dont have 2 layer fokders. So i have dav://url/videos, not dav://url/media/videos

Will give it sm more thought
Coz i am sure it works (ive used it that way)
Reply
#15
I was just toying w my kodi box and reorganising the lib and i think i found it.

Summary: try the connect string with only one level folder, so 10.0.0.22/media, instead of 10.0.0.22/media/video.

I tried to define a double layer folder, and it refused to connect. One layer works. Still, if you need two layers there is a workaround i think. Just try to connect with one layer only. Lets get that to work. Am praying for you now haha.

Cheerio
Reply
 
Thread Rating:
  • 1 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
synology access outside network51