Problem with audio
#1
I have a problem in executing succesfully a game through kodi.
I am using the 14.2 stable version with Wasapi audio settings. All the games are working just perfect through advanced launcher so are the movies and tv shows, with no problems.
I am using a delay of 7 seconds so that Wasapi will be free. One specific game The Wicther 3 start ok with music but at sometime when I go to the menu no speech or music is heard. This game utisde KODi runs just perfect

I have found in the logs the following

00:55:11 T:4300 WARNING: CActiveAE::ActiveAE::CActiveAE::StateMachine - signal: 0 from port: OutputControlPort not handled for state: 6
00:55:12 T:2068 ERROR: CAESinkWASAPI::InitializeExclusive: IsFormatSupported failed (AUDCLNT_E_UNSUPPORTED_FORMAT) - trying to find a compatible format
00:55:16 T:4496 ERROR: ActiveAE::ActiveAE::CActiveAE::Resume - failed to init
00:55:57 T:4300 WARNING: CActiveAE::ActiveAE::CActiveAE::StateMachine - signal: 0 from port: OutputControlPort not handled for state: 6
00:56:02 T:4856 ERROR: ActiveAE::ActiveAE::CActiveAE::Resume - failed to init
00:56:03 T:1320 NOTICE: Thread LanguageInvoker start, auto delete: false
00:56:03 T:2068 ERROR: CAESinkWASAPI::InitializeExclusive: IsFormatSupported failed (AUDCLNT_E_UNSUPPORTED_FORMAT) - trying to find a compatible format

It seems that sometimes a compatible format is found and sometimes not.
Any thoughs? Is this a bug of Wasapi?

PS IF I increase the time in advanced launcher to 12 seconds the problem seems to be resolved.
Reply



Logout Mark Read Team Forum Stats Members Help
Problem with audio0
This forum uses Lukasz Tkacz MyBB addons.