•   
  • 1
  • 7
  • 8
  • 9(current)
  • 10
  • 11
  • 18
  •   
TMDB Movie Scraper not working
Impacted as well, was wondering what went wrong (I was rebuilding my setup and scanned all the library again, only to see it completely disappear). Was weirded out but since I had a backup, I just went back to it, tried again… and saw the same thing happen once more. Then looked around for help and found this thread.

Scraping in FR-fr, on a Raspberry Pi 2 running the current built of OSMC.

Edit: switching to Universal Movie Scraper works, but all descriptions are now in English instead of French (addon is set to fr, movie titles are in fr); I'm guessing it's falling back to IMDb instead of TMDb.
Edit: oh well, https://www.themoviedb.org/talk/56446d00...0a3f0051fb
Reply
yep it's a change on their end
Reply
could be off base here since I haven't gotten positive results but it looks like tmdb is wanting + instead of . or space in their search query. Unfortunately the scraper uses regexen, which are not good at search and replace. The input strings appear to come from the binary.
Reply
Has anyone posted a debug report
doesn't look like it http://trac.kodi.tv/report/25
If I have helped you or increased your knowledge, click the 'thumbs up' button to give thanks :) (People with less than 20 posts won't see the "thumbs up" button.)
Reply
devs are on it: https://github.com/xbmc/repo-scrapers/pull/20
Do not PM or e-mail Team-Kodi members directly asking for support.
Always read the Forum rules, Kodi online-manual, FAQ, Help and Search the forum before posting.
Reply
Thanks Ronie.
If I have helped you or increased your knowledge, click the 'thumbs up' button to give thanks :) (People with less than 20 posts won't see the "thumbs up" button.)
Reply
(2015-11-13, 01:58)ronie Wrote: devs are on it: https://github.com/xbmc/repo-scrapers/pull/20

Tested these changes locally - works like a charm for me.
Reply
I take it back, it looks like the json coming back is in a different order
Reply
damn, the dev beat me to it. oh well at least I know how the scrapers work now Smile
Reply
(2015-11-13, 02:46)petersmith Wrote:
(2015-11-13, 01:58)ronie Wrote: devs are on it: https://github.com/xbmc/repo-scrapers/pull/20

Tested these changes locally - works like a charm for me.

Can you please explain how you downloaded fix from Github? I'm a newbie. Did u download updated file some how or did you manually copy and past xml changes?
Reply
Actually, I think the output order from the regex is still wrong - the year is not resolving correctly
Reply
(2015-11-13, 03:25)DAlba Wrote: Can you please explain how you downloaded fix from Github? I'm a newbie. Did u download updated file some how or did you manually copy and past xml changes?

Yeah, I went with the low-tech approach of manually applying the changes from the github diff to my local file
Reply
(2015-11-13, 01:58)ronie Wrote: devs are on it: https://github.com/xbmc/repo-scrapers/pull/20

have to take it back that these work like a charm; the scraper now picks up results in general, but tags my files as different, incorrect movies
Reply
I think y'all want this instead:

Code:
<GetSearchResults dest="8">
                <RegExp input="$$3" output="&lt;results&gt;\1&lt;/results&gt;" dest="8">
                        <RegExp input="$$1" output="&lt;entity&gt;&lt;title&gt;\4&lt;/title&gt;&lt;id&gt;\2&lt;/id&gt;&lt;year&gt;\1&lt;/year&gt;&lt;url cache=&quot;tmdb-$INFO[language]-\1.json&quot;&gt;http://api.tmdb.org/3/movie/\2?api_key=57983e31fb435df4df77afb854740ea9&amp;amp;language=$INFO[language]&lt;/url&gt;&lt;/entity&gt;" dest="3">
                                <expression repeat="yes">&quot;overview&quot;:.*?,&quot;release_date&quot;:&quot;([0-9]+)-.*?,&quot;id&quot;:([0-9]*),&quot;original_title&quot;:&quot;([^&quot;]*)&quot;,&quot;original_language&quot;:&quot;[^&quot;]*&quot;,&quot;title&quot;:&quot;([^&quot;]*)</expression>
                        </RegExp>
                        <RegExp input="$$1" output="&lt;entity&gt;&lt;title&gt;\3&lt;/title&gt;&lt;id&gt;\2&lt;/id&gt;&lt;year&gt;\1&lt;/year&gt;&lt;url cache=&quot;tmdb-$INFO[language]-\1.json&quot;&gt;http://api.tmdb.org/3/movie/\1?api_key=57983e31fb435df4df77afb854740ea9&amp;amp;language=$INFO[language]&lt;/url&gt;&lt;/entity&gt;" dest="3+">
                                <expression repeat="yes">&quot;overview&quot;:.*?,&quot;release_date&quot;:&quot;([0-9]+)-,&quot;id&quot;:([0-9]*),&quot;original_title&quot;:&quot;([^&quot;]*)&quot;,&quot;original_language&quot;:&quot;[^&quot;]*&quot;</expression>
                        </RegExp>
                        <RegExp input="$$1" output="&lt;entity&gt;&lt;title&gt;\2&lt;/title&gt;&lt;id&gt;\1&lt;/id&gt;&lt;url cache=&quot;tmdb-$INFO[language]-\1.json&quot;&gt;http://api.tmdb.org/3/movie/\1?api_key=57983e31fb435df4df77afb854740ea9&amp;amp;language=$INFO[language]&lt;/url&gt;&lt;/entity&gt;" dest="3+">
                                <expression repeat="yes">&quot;overview&quot;:.*?,&quot;release_date&quot;:null,&quot;id&quot;:([0-9]*),&quot;original_title&quot;:&quot;([^&quot;]*)&quot;,&quot;original_language&quot;:&quot;[^&quot;]*&quot;</expression>
                        </RegExp>
                        <expression noclean="1" />
                </RegExp>
        </GetSearchResults>
Reply
I updated the thread at github
Reply
  •   
  • 1
  • 7
  • 8
  • 9(current)
  • 10
  • 11
  • 18
  •   



Logout Mark Read Team Forum Stats Members Help
TMDB Movie Scraper not working5
This forum uses Lukasz Tkacz MyBB addons.