v14 IPTV - Dolby Digital+ playback problems and FFMPEG missing packets
#1
Hi there Smile

First of all i'd like to say, that iptv simple client works surprisingly well for me. I didn't believe it would be that easy, to watch the Channels provided by my IPTV Provider using Kodi on my RPi2 instead of the STB.

But unfortunately two Problems are left so far:

1.) Dolby Digtal + / EAC3 Problems
Some of the Channels are only provided with EAC3/DD+ sound with no chance of switching to stereo or standard ac3. Every single DD+ Channel shows me a video playback which is green most of the time and full of pixels. Sound doesn't even appear.

2.) Sometimes Video/Audio Asynchronity
Sometimes after switching channels Video and Audio aren't synchronous any more. This happens independent from a channel or the Video or Audio Codec the Channel provides. And if there is asynchronity on one channel, directly switching the channel again doesn't help. In this case the others are asynchronous too and only stopping playback and restarting playback again helps ... sometimes ... sometimes i even have to restart PVR or the RPi itself

Kodi Version: Kodi 14.2 Helix
Hardware: RPi 2 on HDMI
IPTV Client: IPTV Simple Client

Playlist looks like:
Code:
#EXTINF:-1 tvg-id="a1tv.tv.609" tvg-num="1" tvg-name="ORFeins" tvg-logo="609.png" group-title="A1 TV" radio=false,ORFeins
rtp://@239.2.16.1:8208
#EXTINF:-1 tvg-id="a1tv.tv.625" tvg-num="2" tvg-name="ORF 2 W" tvg-logo="625.png" group-title="A1 TV" radio=false,ORF 2 W
rtp://@239.2.16.2:8208
#EXTINF:-1 tvg-id="a1tv.tv.671" tvg-num="3" tvg-name="ATV" tvg-logo="671.png" group-title="A1 TV" radio=false,ATV
rtp://@239.2.16.3:8208

...

I hope somebody can give advice
thanks Smile
-------------------------------------------------------------------------------------------------------------------

EDIT:

Whenever the channel is getting asynchronous, the log is writing those lines:

21:46:40 T:1295508544 DEBUG: ffmpeg[4D37E440]: RTP: missed 28 packets
21:46:40 T:1295508544 DEBUG: ffmpeg[4D37E440]: RTP: missed 32 packets
21:46:40 T:1295508544 DEBUG: ffmpeg[4D37E440]: RTP: missed 26 packets


and so on ....

Could there be a way to prevent missing packets?
Reply
#2
Doesn't anyone have an idea? Sad

Push ... I hope pushing is allowed ^^
Reply
#3
Without me being able to reproduce this, it will be hard to diagnose. If you see the same issue with a recording and can upload a sample file, that would help.

Otherwise, try changing the video/acceleration settings and see if any help.
Try a nightly Milhouse build and see if the problem is still present.
Reply
#4
Thank you for your hints, i'll try that Smile

Maybe i shout also add, that the asynchronity only appears on IPTV Live - Streams ... I never ever had any issue like that on local or network attached files or static sources from the internet like youtube and so on ...

I'll report as soon as possible, thanks once more Smile

edit:

i activated debug logging and and checked for different log outputs whenever a IPTV Stream is getting asynchronous.
And there is one difference ... one repeating line:

Code:
21:46:39 T:1295508544   ERROR: ffmpeg[4D37E440]: [h264] decode_slice_header error
21:46:39 T:1295508544   ERROR: ffmpeg[4D37E440]: [h264] no frame!
21:46:39 T:1295508544   DEBUG: ffmpeg[4D37E440]: [h264] Increasing reorder buffer to 1
21:46:40 T:1295508544   DEBUG: ffmpeg[4D37E440]: [h264] Increasing reorder buffer to 2
21:46:40 T:1295508544   DEBUG: ffmpeg[4D37E440]: RTP: missed 20 packets
21:46:40 T:1295508544   DEBUG: ffmpeg[4D37E440]: RTP: missed 35 packets
21:46:40 T:1295508544   DEBUG: ffmpeg[4D37E440]: RTP: missed 29 packets
21:46:40 T:1295508544   DEBUG: ffmpeg[4D37E440]: RTP: missed 28 packets
21:46:40 T:1295508544   DEBUG: ffmpeg[4D37E440]: [rtp] PES packet size mismatch
21:46:40 T:1295508544   DEBUG: ffmpeg[4D37E440]: RTP: missed 23 packets
21:46:40 T:1295508544   DEBUG: ffmpeg[4D37E440]: RTP: missed 28 packets
21:46:40 T:1295508544   DEBUG: ffmpeg[4D37E440]: RTP: missed 32 packets
21:46:40 T:1295508544   DEBUG: ffmpeg[4D37E440]: RTP: missed 26 packets
21:46:40 T:1295508544   DEBUG: ffmpeg[4D37E440]: [rtp] PES packet size mismatch
21:46:40 T:1295508544   DEBUG: Previous line repeats 1 times.
21:46:40 T:1295508544   DEBUG: ffmpeg[4D37E440]: RTP: missed 17 packets
21:46:40 T:1295508544   DEBUG: ffmpeg[4D37E440]: RTP: missed 31 packets
21:46:40 T:1295508544   DEBUG: ffmpeg[4D37E440]: [rtp] PES packet size mismatch
21:46:40 T:1295508544   DEBUG: Previous line repeats 1 times.
21:46:40 T:1295508544   DEBUG: Open - av_find_stream_info finished

Whenever the channel is getting asynchronous, the log is writing those lines:

21:46:40 T:1295508544 DEBUG: ffmpeg[4D37E440]: RTP: missed 28 packets
21:46:40 T:1295508544 DEBUG: ffmpeg[4D37E440]: RTP: missed 32 packets
21:46:40 T:1295508544 DEBUG: ffmpeg[4D37E440]: RTP: missed 26 packets


and so on ....

Could there be a way to prevent missing packets?
Reply



Logout Mark Read Team Forum Stats Members Help
IPTV - Dolby Digital+ playback problems and FFMPEG missing packets0
This forum uses Lukasz Tkacz MyBB addons.