No Sound with Pulseaudio anymore
#61
Setting the PULSE_LATENCY_MSEC variable was a fix I sometimes applied to Wine to get rid of crackling, but for Kodi it has no effect.
Regarding libcec2, I don't have an official package here. There's one in the user repository, but do I really need it? I don't have an IR remote.
Reply
#62
Just try it, package is called libcec - and we try to load that module.

I got another arch user testing ... and everything works as it should ... had two PA devs review the code once more -> also everything fine. All ideas you have tested.

Edit: One thing comes to my mind: did you compile PA with a different compiler than kodi?
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#63
I'll try.
And yes, I probably compiled Kodi with a different compiler (clang) than Pulseaudio (gcc I guess, didn't compile it myself), but since I only compile Kodi at all to apply your patches, I guess it shouldn't be the root cause. For normal daily use I use the pre-compiled binaries from the repos for both PA and Kodi.
Reply
#64
Compiled Kodi and Pulse with the same compliler just now, no patches applied, same issue. Acer V5-573G laptop, i5-4200U, Intel onboard HDA sound.

Kodi log: http://xbmclogs.com/pdbgsylyi
pactl list: http://xbmclogs.com/pikoql802

ALSA works fine.

Edit: this is on vanilla Arch testing (not Chakra)

Edit2: compiler info:
Using built-in specs.
COLLECT_GCC=gcc
COLLECT_LTO_WRAPPER=/usr/lib/gcc/x86_64-unknown-linux-gnu/5.1.0/lto-wrapper
Target: x86_64-unknown-linux-gnu
Configured with: /build/gcc-multilib/src/gcc-5-20150519/configure --prefix=/usr --libdir=/usr/lib --libexecdir=/usr/lib --mandir=/usr/share/man --infodir=/usr/share/info --with-bugurl=https://bugs.archlinux.org/ --enable-languages=c,c++,ada,fortran,go,lto,objc,obj-c++ --enable-shared --enable-threads=posix --enable-libmpx --with-system-zlib --with-isl --enable-__cxa_atexit --disable-libunwind-exceptions --enable-clocale=gnu --disable-libstdcxx-pch --disable-libssp --enable-gnu-unique-object --enable-linker-build-id --enable-lto --enable-plugin --enable-install-libiberty --with-linker-hash-style=gnu --enable-gnu-indirect-function --enable-multilib --disable-werror --enable-checking=release --with-default-libstdcxx-abi=c++98
Thread model: posix
gcc version 5.1.0 (GCC)

Edit3: I'll try to be on IRC as much as I can and maybe dig through the source code a bit tomorrow.
Reply
#65
@K900: Yeah, looks absolutely the same.

As already stated yesterday I have no idea. The other Arch users (JackWinter in #pulseaudio channel) made tests for me, without any problems.Please also provide the pulseaudio -vvv logs.

From what I see - the transition from kodi to PA goes fully wrong.

Btw. the difference I see is very clear, on Ubuntu I get:

Quote:[email protected]:~$ pactl list sinks |grep -i fragment
device.buffering.fragment_size = "32768"
device.buffering.fragment_size = "32768"
[email protected]:~$ pactl list sinks |grep -i buffer_size
device.buffering.buffer_size = "65536"
device.buffering.buffer_size = "65536"

This is 10 times more than you have with default config. Any idea, why? Is this some "low latency" mode?

Edit: Can you both try without kde, please?

E.g. just start Xserver and pulseaudio and then see what you get with kodi?

Edit2: Here is my pulseaudio --dump-conf http://sprunge.us/BSLA

Can you compare with yours?

Edit2: Forget about the buffer stuff. I added tsched=0 on my setup and now I get _your_ numbers, but kodi is still working.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#66
Please recompile arch's pulseaudio with this patch: http://xbmclogs.com/pm2q2y6fd

That way we can see what is happening under the hood, thx much in advance.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#67
Diffed my Pulse configuration with yours: this is all I have:
Code:
-deferred-volume-safety-margin-usec = 1 (yours)
+deferred-volume-safety-margin-usec = 8000 (mine)

Going to try the patch now.
Reply
#68
We found out on IRC, that setting PULSE_LATENCY_MSEC is the culprit. Running with: PULSE_LATENCY_MSEC=scheisshaus ./kodi.bin should make it work for you.
scheisshaus <- just something that cannot be parsed to an integer
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#69
Not setting it at all is also a valid option.
Reply
#70
Hi, sorry that I haven't answered this thread for a few days. I was very busy.
I tried setting PULSE_LATENCY_MSEC to a bullshit value and it worked. Simply not setting it at all didn't work, but "scheisshaus" did the job. Do you still want me to try on a stick Ubuntu? If so, I'll hopefully be able to do that over the weekend.
Reply
#71
Nope. Thx much. This gets fixed by upstream PA.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#72
Great.
Thanks again for all your help and effort.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
No Sound with Pulseaudio anymore00