• 1
  • 2(current)
  • 3
  • 4
  • 5
  • 9
AMLogic - try and fix your Audio and Video playback problems.
I'm honestly not sure, other than I know Koying has/had some Rockchip specific tweaks in SPMC (wiki). I thought those were just audio tweaks, but maybe they have refresh rate switching as well.
I have Amlogic s805 and followed directions for Rockchip devices initial.d and test shows I have initial.d support but the problem is I see no difference fps on the box Before and after I was getting reading of about average 27 to 31 fps I am using Kodi 14.2 as 15.0 and 15.2 are out of sync audio and video Possibly i'm looking at the wrong reading or not understanding Thanks in advance for listening hoping to hear from you soon By the way I don't even know if it's a rockchip box
Glad to say although I saw no difference in fps I decided to try 15.2. Again and Hey Presto perfect So thanks very much That code for rockchip was dead on as I had tried that other code and it did'nt work Thanks again
(2015-09-16, 23:59)tomtomtoo Wrote: Glad to say although I saw no difference in fps I decided to try 15.2. Again and Hey Presto perfect So thanks very much That code for rockchip was dead on as I had tried that other code and it did'nt work Thanks again

Which 15.2 was it? Where did you get it and was it some magical patch?
No magical patch Code #!/system/bin/sh
chmod 666 /sys/class/display/display0.HDMI/mode( coupled with Initial.d)
Sorry I got 15.2 a couple of weeks ago Had it in downloads
Sorry to say when I opened it this morning it was back to square one audio and video not syncing and had to delete to get 14.2 up and running again Sorry for being an upstart but it looked great last night Thanks I'm very disappointed but that's life
i tried this fix and this is the result:

the x265 720p video no longer pixelates that much (about 1 percent of the whole video - video lasts 45 minutes, les than 30 seconds was pixelating) the only issue is that the audio is not in sync most of the time,

video starts fast forwarding until it gets caught up with the audio but then it starts with sync issues again. if i rewind the video about 15 seconds it gets fixed, but then again audio sync issues appear.

file is aproxx 200 mb x265 720p.

my box is a mygica atv 582 Amlogic S802B with Octa Core Mali-450 GPU, all codecs are enabled, and it does show the change of frame rate on the tv from 60 hz to 24 hz on some videos (depends on the frame rate of the video).

edit: forgot to mention that mx player plays the video great!!, doesn't have issues but it is software decoding (i dont mind that)

edit 2: forgot to mention, i have latest rc2 kodi (15.2 shows on the screen i think)
I decided to try 15.2 again it works perfect until I reboot and it's back to non sync of audio and video I was able to watch two Bluray movies am I missing something else Do I have to adjust the three codecs Thanks in advance
Have you saved the script ?
I have not used this in a long while, but you would definitely have to save the script somehow using the Universal App.

Thanks for posting this wrxtasy.

I ran the suggested command via a terminal emulator and have noticed an improvement in playback in Kodi 15.2. I haven't loaded the script yet as I found that even after a reboot that playback was still good, so it seems that the command has stuck. Is that even possible? I also tried SPMC after a reboot and the popup during loading said that it had been granted SU permissions to the /sys/class/display/mode directory.

Anyway I might load the script just in case.

Should I also grant permissions to the following, which I saw posted in a separate thread on this forum?

chmod 666 /sys/class/display/mode
chmod 666 /dev/amvideo
chmod 666 /dev/amstream*
chmod 666 /sys/class/video/axis
chmod 666 /sys/class/video/screen_mode
chmod 666 /sys/class/video/disable_video
chmod 666 /sys/class/tsync/pts_pcrscr
chmod 666 /sys/class/audiodsp/digital_raw
chmod 666 /sys/class/ppmgr/ppmgr_3d_mode
chmod 666 /sys/devices/system/cpu/cpu0/cpufreq/scaling_min_freq
chmod 666 /sys/devices/system/cpu/cpu0/cpufreq/scaling_max_freq
chmod 666 /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor

Looks like the script has been saved to the correct location by Universal init.d then.
Yes its all safe with those commands, all you are doing with chmod 666 is giving the files R/W permissions.

Sometimes this script takes a little while after bootup to execute if I remember correctly too.

What I mean is that I haven't used Universal init.d yet. I ran the command in a terminal emulator window just to test it and then restarted the box expecting to have to do it again, but it seems fine. So it seems it survives after a reboot. Strange.
I've been reading all about the Amlogic issue back over in another post on the forum:

Just got an M8S, Amlogic S812 Android box and this came installed with Anroid 4.4.2 and Kodi 14.2. All working great. I played back some HEVC h.265 content via other video player apps and they utilised the s812 Amlogic hardware for decoding just perfectly, however Kodi 14.2 does not, only hardware h.264 support as per the Kodi release notes.

So to get HEVC h.265 in Kodi I installed Kodi 15.2 as release notes detail it support HEVC h.265 and for Amlogic S812 that's upto 8bit 4K no 10 bit. Just finished testing today and all working perfectly hardware decoding within Kodi 15.2 utilising Amlogic hardware for of h.264 HD, HEVC h.265 HD and UHD. See screen shots below from Kodi Smile

I should add this M8S box is not rooted and thus no changes to permissions have been done, it just worked as in....am I one of the luck ones, has something changed in the 15.2 build?

I have absolutely no idea why/how this is working on this Android box with Amlogic S812. Here re some screen grabs of the details.

[Image: IMG_3345.png]

[Image: IMG_3346.jpg]

[Image: IMG_3347.jpg]
So does this sort the 23p problem? My MXQ box (android KK) allows the auto refresh rate switch from Kodi but I still can't get 100% smooth 24p playback unless it's a true 24p vid file. I've considered that these boxes just haven't got the processing power but I'm living in hope!

As I do live in hope I've tried to set the chmod file up, I'm not that techie so couldn't figure out how to copy the text file I created for the hacked permissions to the relevant folder. Wouldn't it be simple for some one to recompile the apk so the default file is the permissions hack?

So is there any more news about this fix or are most of us stuck with a box that can't do smooth playback, well at least 23p files.
  • 1
  • 2(current)
  • 3
  • 4
  • 5
  • 9
Thread Rating:
  • 3 Vote(s) - 4.67 Average

Logout Mark Read Team Forum Stats Members Help
AMLogic - try and fix your Audio and Video playback problems.4.673