•  Previous
  • 1
  • 2
  • 3(current)
  • 4
  • 5
  • 9
  • Next 
 
Thread Rating:
  • 3 Vote(s) - 4.67 Average
AMLogic - try and fix your Audio and Video playback problems.
#31
(2015-12-10, 15:55)PatrickJB Wrote: So does this sort the 23p problem? My MXQ box (android KK) allows the auto refresh rate switch from Kodi but I still can't get 100% smooth 24p playback unless it's a true 24p vid file. I've considered that these boxes just haven't got the processing power but I'm living in hope!

As I do live in hope I've tried to set the chmod file up, I'm not that techie so couldn't figure out how to copy the text file I created for the hacked permissions to the relevant folder. Wouldn't it be simple for some one to recompile the apk so the default file is the permissions hack?

So is there any more news about this fix or are most of us stuck with a box that can't do smooth playback, well at least 23p files.
If you have not got the preferred modified AMLogic Linux Kernel that does what is called Frame Rate Automation for smooth 23.976fps video output when your TV switches to its 24p movie mode, then you need a Firmware update. Same for dynamic refresh rate switching.
If that is not available easily, or you are in over your head, then you need to head over to Freaktab to search for alternative fixed Firmware:
http://freaktab.com/forum/tv-player-supp...tv-players

That is the only solution. Team Kodi are not in the business of fixing or installing new Firmware for the millions of cheap Android devices that flood the market.
Reply
#32
OK Thanks. I did get the chmod thingy to work but it hasn't made any difference so I figure the box was already modified as it already did the refresh rate switching.

So there definitely are hacked versions that will sort the 23.976fps problem? Now I suppose I'll have to go through the process of finding a rom that will work with my box. I did wonder if Amlogic were going to release an Android patch but I imagine that's doubtful as the chip-set is getting pretty long in the tooth!

Anyway thanks again.
Reply
#33
(2015-12-10, 18:07)wrxtasy Wrote: If you have not got the preferred modified AMLogic Linux Kernel that does what is called Frame Rate Automation for smooth 23.976fps video output when your TV switches to its 24p movie mode, then you need a Firmware update. Same for dynamic refresh rate switching.
By the way, if anybody is interested, my box is running kernel version: 3.10.33 with android 4.4.2 API level 19,. Build 109k4, Amlogic Meson8B

Yes does refresh rate switching but still get the 40 second judder on 23p playback. I'm wondering if the chmod fix hasn't taken effect or is perhaps being over ridden by some hard coded fix on my rom for the refresh rate switch? Remember the refresh thing worked before I applied the chmod.

Also my TV can turn 24p on and off even when being feed 23p or 24p makes no difference still get judder ever 40 seconds.
Reply
#34
Its simple...
Quote:..you have not got the preferred modified AMLogic Linux Kernel that does what is called Frame Rate Automation for smooth 23.976fps video output when your TV switches to its 24p movie mode, you will need a Firmware update with this much preferred modified Kernel.
This is why I keep banging on about Firmware being everything with Android Kodi devices. You really do get what you pay for.
Reply
#35
I understand where you are coming from on the various device firmware but on my specific device (Xtremer Wonder) with the Amlogic S812 Kodi 15.1 works just fine with the Amlogic hardware acceleration in use but when I go up to Kodi 15.2, 16 beta 1, 2, or 3 it leaves the video in a small box in the upper left hand corner of the screen. When you uncheck the Amlogic hardware acceleration you get full screen video but any file over 720p is very choppy and out of sync with the audio.

So I find it hard to believe that is a firmware issue with the device since the only thing changed was the Kodi version. If I go back to kodi 15.1 everything works just fine again.
Reply
#36
Sorry to be the bearer of bad news, but...

Firmware is the exact issue !

You have not got the correct file permissions written into the devices Firmware to allow anything above Kodi 15.1 to work properly.
This was a decision made by the Kodi devs from Kodi 15.2 going forwards. Android device manufacturers either get with the Kodi way of doing things or devices will not function properly. This is the risk with buying some unknown Android device from Amazon or Ebay. User are left without support and need to go to the Freaktab website and DIY.

You will have to fix your own file permissions as per the instructions on Page #1 if you want Kodi to work properly from this point onwards. Even then it may not be the full fix. The alternative is to run OpenELEC from a SD card if you can find a distribution. Again visit Freaktab.
Reply
#37
Mostly use my S805 device for UK TV viewing.
While watching Live TV the stream/picture will pause sometimes, and continues after few seconds.

Kodi 14.2 works fine will pause and continue with no issues all day long.

Kodi 15.2 sometimes resumes with no audio and picture stutter after such a pause.
Kodi 16.0 beta 4 Jarvis does the same no audio and picture stutter after a pause.

http://www.xbmclogs.com/p1g3jqas7
http://pastebin.com/raw/yKZkYb4Y

all chmod 666 permissions enabled.

Video clips show what happens.
https://www.youtube.com/watch?v=rUZ62llF...e=youtu.be

https://www.youtube.com/watch?v=f7YcP_jL...e=youtu.be
Reply
#38
To add to the above post

1.Kodi 16.0 beta 4
2.This time tested with amcodec disabled. Same thing happens.

Basically will pause then resume `without audio` plus `jittery video`.

http://www.xbmclogs.com/pxibslls3
http://pastebin.com/raw/DpkDu0kT

Box is Original Mk808b plus, tested previous firmware 109k 111k and latest 112k.
Same issue across all firmware.
Reply
#39
PatrickJB. you should see if perhaps your audio settings are causing your choppy video playback issues....


i had to uncheck the 3 hardware accelleration options and then put them back in for video playback to occur in full screen( was at top left corner only before)

also, had to change audio to 2.0 setting for audio to work
having it as 5.1 caused choppy video / no audio


also , everything worked properly on my toshiba tv (1080 / audio)
but had to mess with above stuff when plugged into a different brand tv (insignia) only got 720 no audio
=== > Dollar Shave Club <==== try it today
Reply
#40
Hi all and sorry for my bad English. For Christmas my brother buy me a new victsing Mxiii tv box. With amcodec on all 2D 1080p films work very well but the problem for me is to see my collection of 3D view in monoscopic mode. With amcodec on I see not in Monoscopic, and I hope you can help me to find a fix for this issue. I try other codec and all give me same problem, for example MediaCodec show me good 2D films and 3D in monoscopic but in precise moment all became blocked , I lost av sync video blocked and the audio continue. All films 2D stopped between minutes 50-54 and 3D between 20-27 minutes from start. Is possible use amcodec on and resolve the issue of monoscopic? Or is more simple resolve the issue of the mediacodec frame skipHuh
Thanks and I hope you can give me a possible fix Smile...
Reply
#41
Someone just answer this bs I got the android tv system had Cody on it but nothing would work cleared my cache by accident and lost all root streaming site etc how do I get the helix and Jarvis codes back in so I have sites again .
Reply
#42
(2016-01-09, 03:00)Green14 Wrote: Someone just answer this bs I got the android tv system had Cody on it but nothing would work cleared my cache by accident and lost all root streaming site etc how do I get the helix and Jarvis codes back in so I have sites again .

Kodi forum doesn't condone pirate streaming addon links in Kodi.
Ask the manufacturer or seller of your box for help.
Reply
#43
Not sure if this is right thread for this question .anyways i need a fix for this. When i watch live sports/tv and it buffers then plays but only audio is playing and video freezes . I messed with acceleration and it kind of helped but if i pause then play same thing .any suggestions?
Reply
#44
(2016-01-06, 20:32)[email protected] Wrote: Hi all and sorry for my bad English. For Christmas my brother buy me a new victsing Mxiii tv box. With amcodec on all 2D 1080p films work very well but the problem for me is to see my collection of 3D view in monoscopic mode. With amcodec on I see not in Monoscopic, and I hope you can help me to find a fix for this issue. I try other codec and all give me same problem, for example MediaCodec show me good 2D films and 3D in monoscopic but in precise moment all became blocked , I lost av sync video blocked and the audio continue. All films 2D stopped between minutes 50-54 and 3D between 20-27 minutes from start. Is possible use amcodec on and resolve the issue of monoscopic? Or is more simple resolve the issue of the mediacodec frame skipHuh
Thanks and I hope you can give me a possible fix Smile...

not sure how you can say its working good when ALL videos just randomly stop playing at some point during them.. lol

that box just came with crap software, the hardware is decent.

if it was me i would ditch android and install Openelec, sorry i cant help you with how to do that but if you google "Kerber Openelec" maybe you can sort it out.
Main System - HTPC - Intel I3 6300 - Asrock z170 - 16 GB DDR4 - 128gb SSD - 65" UHD HDR Sony Android TV - Pioneer VSX 1130-K - 7.2.2 speakers
Other devices currently in use - 55" 3D UHD LG TV - 2 Fire TV's - Nexus Player - MiniMX s905 - Voyo Vmac Mini
Ubuntu Server - 12 TB NAS - MYSQL - Torrent Box
Reply
#45
Hi I just wanted to say that when I upgraded to Kodi 15.2 I had major audio/video sync issues. I am running amlogic s812 on kitkat 4.4.2. I followed instructions on page 1 and now my issues are gone. I went from having at least +225ms off sync, each video being different to now having full audio/video sync on 15.2. I now see the value in purchasing from a company that will supply firmware upgrades. A Big big big thanks for posting that code!!
Reply
  •  Previous
  • 1
  • 2
  • 3(current)
  • 4
  • 5
  • 9
  • Next 



AMLogic - try and fix your Audio and Video playback problems.4.673